TESTERS WANTED for ATAng preview 2

2003-08-16 Thread Soeren Schmidt
The story continues with Preview 2 - from the README: Now the functionality is almost equal to that of stock ATA, I'm getting close to being ready to expose this on the -current users, so please give this a go to shake out the last nasties. I've fixed alot of minor issue that testers have

Re: TESTERS WANTED for ATAng preview 2

2003-08-16 Thread Soeren Schmidt
It seems Andrew Kenneth Milton wrote: linking kernel ata-all.o: In function `ata_identify_devices': ata-all.o(.text+0x107e): undefined reference to `ad_attach' ata-all.o(.text+0x1116): undefined reference to `ad_attach' I'm guessing this is because I have; device ata

Re: TESTERS WANTED for ATAng preview 1

2003-08-14 Thread Soeren Schmidt
It seems Gavin Atkinson wrote: On Wed, 13 Aug 2003, Soeren Schmidt wrote: It seems Gavin Atkinson wrote: With the new ATA code, the boot now hangs. I now get on a verbose bootup: ata1-master: FAILURE - ATAPI_IDENTIFY status=1ERROR error=0 Okies, what if you make that CDROM a slave

Re: driver maintainers, please help

2003-08-14 Thread Soeren Schmidt
It seems Lukas Ertl wrote: Hi there, this is a call for help from the various driver maintainers. In a recent discussion on -doc it has come out that several manpages are not in sync with what's listed in the 5.1 Hardware Notes, and I'm currently trying to update those manpages.

Re: TESTERS WANTED for ATAng preview 1

2003-08-14 Thread Soeren Schmidt
It seems Jason Dambrosio wrote: On Fri, Aug 08, 2003 at 09:55:11PM +0200, Soeren Schmidt wrote: The first preview release of ATAng is now available on: ftp://ftp.deepcore.dk/pub/ATAng I cvsup'd to HEAD and applied the conf-patch and put in your new ATA source, but when I

TESTERS WANTED for ATAng preview 1

2003-08-14 Thread Soeren Schmidt
The first preview release of ATAng is now available on: ftp://ftp.deepcore.dk/pub/ATAng From the README there: ATAng preview 1 release Before these rather radical changes to the ATA driver hits the tree, here is the opportunity to test them out, give usefull feedback and for the depending

Re: ATAng

2003-08-14 Thread Soeren Schmidt
It seems Matt Douhan wrote: [ PGP not available, raw data follows ] -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 I cvsup'd current src today and applied the conf-patch and replaced the /usr/src/sys/dev/ata/* now in my dmesg output I see this, Waiting (max 60 seconds) for system

Re: TESTERS WANTED for ATAng preview 1

2003-08-14 Thread Soeren Schmidt
It seems Gavin Atkinson wrote: I'm using ATAng-20030809-1.tgz on top-of-tree current on hardware detected with the old ATA code as: atapci0: Intel ICH5 UDMA100 controller port 0xffa0-0xffaf,0-0x3,0-0x7,0-0x3,0-0x7 at device 31.1 on pci0 ata0: at 0x1f0 irq 14 on atapci0 ata1: at 0x170 irq

Re: driver maintainers, please help

2003-08-14 Thread Soeren Schmidt
It seems Lukas Ertl wrote: On Wed, 13 Aug 2003, Soeren Schmidt wrote: *) ata(4) - what are the supported UDMA levels for SiS 652, 751, and 752? { ATA_SIS652, 0x00, SIS_SOUTH, 0, ATA_UDMA6, SiS 652 } { ATA_SIS751, 0x00, SIS_SOUTH, 0, ATA_UDMA6, SiS 751 } { ATA_SIS752

if_xl borked in current!!

2003-08-14 Thread Soeren Schmidt
Upgraded laptop from 5.1 to -current was as usual a bad idea, this time the xl driver broke (and wi is still useless BTW) leaving me with no networks working :( CURRENT: xl0: 3Com 3c575C Fast Etherlink XL port 0x1000-0x107f mem 0x88002000-0x8800207f,0x88002080-0x880020ff irq 11 at device 0.0 on

Re: TESTERS WANTED for ATAng preview 1

2003-08-14 Thread Soeren Schmidt
It seems Gavin Atkinson wrote: On Wed, 13 Aug 2003, Soeren Schmidt wrote: It seems Gavin Atkinson wrote: ata1: spurious interrupt - status=0x7f error=0x7f reason=0x7f ad0: 19881MB Maxtor 6E020L0 [40395/16/63] at ata0-master UDMA100 acd0: CDROM SAMSUNG CD-ROM SC-152A at ata1-slave PIO4

Re: VIA 82C686B UDMA100 controller port 0xd800-0xd80f at device7.1on pci0

2003-08-05 Thread Soeren Schmidt
It seems Doug White wrote: On Sun, 3 Aug 2003, ryan chris wrote: with dma enabled, a sysinstall will only work under the minimal install, and after a certain point, apparently using too much hard drive space (showed up with a tar -xvf ports.tar) causes a panic with anic errors Have

Re: dma error

2003-08-03 Thread Soeren Schmidt
It seems ryan chris wrote: versions this happened on: 4.8-release, 5.1-release, 5.1-current with dma enabled, panics with anic errors occur left and right during intensive hdd i/o... examples are during a non-minimal sysinstall, and during a tar -xvf of the entire ports collection this

Re: sil3112 controller

2003-08-02 Thread Soeren Schmidt
It seems Petri Helenius wrote: Should there be an option to run atacontrol in sysinstall? hmm, maybe... So that drives could be assigned to a mirror / stripe set before installing without having to build the mirror on another machine first? (in this case the BIOS does not help) You cant

Re: sil3112 controller

2003-08-01 Thread Soeren Schmidt
It seems Petri Helenius wrote: Just saw the support for the controller go in. Does the driver support any RAID1 style mirroring? Only our own ATA RAID (see atacontrol).. I do have an Adaptec 1210 that has RAID capabilities and I have deciphered their RAID config info, but support is not

Re: questions on S-ATA and ICH5 (now owns hardware :)

2003-07-24 Thread Soeren Schmidt
It seems John Reynolds wrote: Hi all, a few weeks back I had asked whether -current supported ICH5's S-ATA and Søren stated that he'd put code in to detect it and it should work but there wasn't a lot of feedback yet from users. Well, I have some feedback. I just got a new spiffy 120Gb Seagate

Re: ata tagged queuing support question

2003-07-24 Thread Soeren Schmidt
It seems mitrohin a.s. wrote: ata-disk.c /* use tagged queueing if allowed and supported */ #if 0 /* disable tags for now */ if (ata_tags ad_tagsupported(adp)) { adp-num_tags = atadev-param-queuelen; adp-flags |= AD_F_TAG_ENABLED; adp-device-channel-flags |=

Re: ata tagged queuing support question

2003-07-24 Thread Soeren Schmidt
It seems mitrohin a.s. wrote: On Thu, Jul 24, 2003 at 04:08:01PM +0200, Marcin Dalecki wrote: tagged queueing broken in -current? i have IBM ICxAV drives and want to use this feature. can i enable this block? Don't. It's very frequently broken by *hardware* and not worth the trouble

Re: HPT372 bug summary [was: RE: escalation stage 2]

2003-07-18 Thread Soeren Schmidt
It seems Harald Schmalzbauer wrote: I also think the RAID configuration is stored on the disks since when I create a non-DOS compatible slice (starting at 0 not 63) the RAID configuration vanishes. Yes the Highpoint BIOS uses sector 9 to hold the RAID config, so if you use that for other

Re: errors using wi driver in -CURRENT

2003-07-16 Thread Soeren Schmidt
It seems Bruce Cran wrote: Just to chime in here, I've spent 2 weeks of various trial and errors to get two Lucent Wavelan's (one 4.8, one -current) to talk to each other. Dispite my more or less futile experiments this would not work no matter what (even asking on -mobile and trying what came up

Re: Silicon Image SiI 3112 Serial ATA controller support?

2003-07-06 Thread Soeren Schmidt
It seems Arjan van Leeuwen wrote: Hi, Is the Silicon Image SiI 3112 Serial ATA controller supported in -CURRENT, or is anybody working on support? I have one here (on a Asus A7N8X mainboard), but the controller is not recognized at boot. If I can help anyone with information about the

Re: Promise SX6000 - error 128 lba 0

2003-07-06 Thread Soeren Schmidt
It seems Gorm J. Siiger wrote: I have installed FreeBSD 5.1 from CD onto a machine with a Promise SX6000 controller with a RAID5 on 360GB. The installation went very well, but when the machine start to boot from the disk, the console shows: You cant boot from a sx6000 controller, our

Re: Promise SX6000 - error 128 lba 0

2003-07-06 Thread Soeren Schmidt
It seems Gorm J. Siiger wrote: You cant boot from a sx6000 controller, our bootblocks does something stupid that the sx6000 BIOS doesn't understand... Damn, can I put the bootblock on another device ? CD for example. Sure, you can mount the pst devices as soon as the kernel is running,

Re: features of ICH5/ICH5-R supported in -current or 5.1-RELEASE?

2003-07-02 Thread Soeren Schmidt
It seems John Reynolds wrote: Hi all, I'm wondering if some of the features of the ICH5 found in the springdale and canterwood platforms (i865/i875) are currently supported in either 5.1-RELEASE or -CURRENT? I've read through some of the ATA code commits and see a few comments related to

Re: Heads up: checking in change to ata-card.c

2003-06-27 Thread Soeren Schmidt
It seems Bill Paul wrote: In message [EMAIL PROTECTED], M. Warner Losh writes: Here's a better patch, basesd on wpaul's input. Bill, can you try it an see if it works for you? If so, i would be better to commit this one. If not, I'll work with you to fix it. FYI, I have a no-name

Re: Heads up: checking in change to ata-card.c

2003-06-26 Thread Soeren Schmidt
I do have problems with the wording you use in the comments in that patch mentioned below, I will even say that I will remove that as soon as it appears *and* shoot the committer so it doesn't happen again to use your choice of wording.. Now, I dont think this way is productive at all, and would

Re: problem installing 4.7/4.8, etc

2003-06-25 Thread Soeren Schmidt
It seems Thomas Dickey wrote: I'm setting up a new machine, and none of the current *BSD's install on it. Linux works. The *BSD's choke during the device identification. Perhaps someone on this list knows why. Attaching a copy of dmesg output from one of the Linux's I installed. The *BSD's

Re: problem installing 4.7/4.8, etc

2003-06-25 Thread Soeren Schmidt
It seems Hideyuki KURASHINA wrote: From your attached dmesg, PCI: Using IRQ router SIS [1039/0008] at 00:02.0 [...] SIS5513: IDE controller on PCI bus 00 dev 15 PCI: Found IRQ 5 for device 00:02.5 SIS5513: chipset revision 0 SIS5513: not 100% native mode: will probe irqs later

Re: ATA DMA broken/kernel panic with 5.1-R/5.1-C and VIA 82C586B

2003-06-17 Thread Soeren Schmidt
It seems Nicolai E M Plum wrote: Hi I installed 5.1-RELEASE from the CD images, and have problems using DMA on my ATA discs. I get the same problem on several discs, both several years old and brand new, across several vendors. 4.6-RELEASE handles the discs fine. Relevant excepts from the

Re: interesting problem

2003-06-06 Thread Soeren Schmidt
It seems David Leimbach wrote: So... I have this nice SATA drive and controller which I believe is supported by FreeBSD but not in the default build for releases. What is the best way to cross-build a version of FreeBSD's release ISOs that will include drivers not included in the default

Re: interesting problem

2003-06-06 Thread Soeren Schmidt
It seems dave wrote: It seems David Leimbach wrote: So... I have this nice SATA drive and controller which I believe is supported by FreeBSD but not in the default build for releases. What is the best way to cross-build a version of FreeBSD's release ISOs that will include

Re: Flushing CD-ROM?

2003-06-05 Thread Soeren Schmidt
It seems Sergey Matveychuk wrote: Why 5.1 flush acd0 on shutdown? - syncing disk, buffers remaining... done Uptime ... acd0: timeout waiting for cmd=e7 s=01 e=04 acd0: flushing device failed The operating system has halted. - Well, it's cd-writer really, but there is no

Re: ATA broken on alpha?

2003-03-30 Thread Soeren Schmidt
It seems Peter Wemm wrote: Do you need more details or is that enough of a clue? I can see what the problem is, I'll have to look to find the reason... -Søren ___ [EMAIL PROTECTED] mailing list

Re: Broken DMA devices

2003-03-25 Thread Soeren Schmidt
It seems The Anarcat wrote: On Tue Mar 25, 2003 at 08:16:28AM +0100, Soeren Schmidt wrote: It seems The Anarcat wrote: Can't the ata drivers detect that condition or recognize the set of drives that are broken instead of penalizing everyone else? ATAPI DMA is more likely to be broken

Re: Broken DMA devices

2003-03-24 Thread Soeren Schmidt
It seems The Anarcat wrote: hw.ata.atapi_dma=1# Run the CD-ROM/DVD in DMA mode to /boot/loader.conf. This should be in almost EVERY /boot/loader.conf. The default is 0 (PIO) because DMA is broken on at least a few early CD readers, but it is very rare to have it fail. (I've never

Re: [acpi-jp 2106] RE: ACPI-CA import/new diff?

2003-03-21 Thread Soeren Schmidt
It seems Takanori Watanabe wrote: Would you try it? http://people.freebsd.org/~takawata/acpi-20030321.diff http://people.freebsd.org/~takawata/acpica-freebsd-20030321.tar.gz Just did here, ASUS P4S8X board, With the CVS version power off doesnt work, it prints the power system off using

Re: SiS5591(?) ATA

2003-03-16 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: On 15-Mar-2003 Soeren Schmidt wrote: atapci0: SiS 961 UDMA100 controller port 0xff00-0xff0f at device 2.5 on pci0 ata0: at 0x1f0 irq 14 on atapci0 ata1: at 0x170 irq 15 on atapci0 ad0: DMA limited to UDMA33, non-ATA66 cable or device ad0: 78533MB

Re: SiS5591(?) ATA

2003-03-15 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: jmmr# dmesg | egrep '(ad0|ata|ATA)' pci0: mass storage, ATA at device 2.5 (no driver attached) ata0 at port 0x3f6,0x1f0-0x1f7 irq 14 on isa0 ata1 at port 0x376,0x170-0x177 irq 15 on isa0 ad0: 38166MB ST340823A [77545/16/63] at ata0-master PIO4 acd0: CDROM

Re: SiS5591(?) ATA

2003-03-15 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: On 15-Mar-2003 Soeren Schmidt wrote: Please make sure that ata-chipset.c is rev 1.14 which corrected a bug in the chip ident function... ata-chipset.c 1.14 was checked in on March 12 my kernel is from two days after. So I guess it is included. I

Re: SiS5591(?) ATA

2003-03-15 Thread Soeren Schmidt
It seems FUJITA Kazutoshi wrote: become better. but still it does't work in UDMA100. atapci0: SiS 961 UDMA100 controller port 0xff00-0xff0f at device 2.5 on pci0 ata0: at 0x1f0 irq 14 on atapci0 ata1: at 0x170 irq 15 on atapci0 ad0: DMA limited to UDMA33, non-ATA66 cable or device ad0:

Re: ATA CS5530 (cyrix) driver panic (ata_cyrix_setmode())

2003-03-09 Thread Soeren Schmidt
It seems Bruce R. Montague wrote: I'll look into it, thanks for reporting! Hi, the current -current ata driver panics at boot when using the CS5530 (National GX1, ex-cyrix). This driver worked in the past on -current, likely up until the major rework that appears to be underway as of

Re: ATA CS5530 (cyrix) driver panic (ata_cyrix_setmode())

2003-03-09 Thread Soeren Schmidt
It seems Bruce R. Montague wrote: Routine ata_cyrix_setmode() in ata-chipset.c appears to be assuming that channel-dma has a valid pointer to a struct ata_dma_funcs, and that channel-r_bmio is a valid bus resource id. This is not the case, both channel-dma and channel-r_bmio (bus master

Re: ATA CS5530 (cyrix) driver panic (ata_cyrix_setmode())

2003-03-09 Thread Soeren Schmidt
It seems Bruce R. Montague wrote: /* is busmastering supported ? */ if ((cmd (PCIM_CMD_PORTEN | PCIM_CMD_BUSMASTEREN)) == (PCIM_CMD_PORTEN | PCIM_CMD_BUSMASTEREN)) { failed because cmd was 0x01 instead of 0x05 (the PORTEN | BUSMASTEREN is 0x05). The 5530 datasheet (well, SC1200

Re: Big IDE drive + little IDE controller + freebsd

2003-03-08 Thread Soeren Schmidt
It seems James Satterfield wrote: Hmm there is a workaround in -current for using 48bit access to the old promises, however it should only engage when you access areas beyond 137G on the drives. However using 48bit modes on older controllers are not really a good idea as they tend to do wierd

Re: ATA MODE_SENSE_BIG timeout

2003-03-04 Thread Soeren Schmidt
It seems David Xu wrote: (snip snap) acd1: read data overrun 34/0 acd1: MODE_SENSE_BIG command timeout - resetting ata1: resetting devices .. done acd1: CD-RW SONY CD-RW CRX140E at ata1-slave PIO4 Hmm, can you use the acd1 device normally or does it fail (how) ? -Søren

Re: ATA problems

2003-03-04 Thread Soeren Schmidt
It seems Dag-Erling Smorgrav wrote: Dag-Erling Smorgrav [EMAIL PROTECTED] writes: No tags, like you said. Previously, with a tags-capable kernel, enabling tags would cause a continuous stream of timeouts and resets on both disks. Just for kicks, I removed the #if 0 in ata-disk.c and got

Re: ATA problems

2003-03-04 Thread Soeren Schmidt
It seems Dag-Erling Smorgrav wrote: Scotty [EMAIL PROTECTED] writes: ad0: READ command timeout tag=0 serv=0 - resetting ata0: resetting devices .. Disable tags (add hw.ata.tags=0 to /boot/loader.conf). Never worked for me either (ASUS P5A, ALi M1543 southbridge, IBM DTTA and IC35L

Re: ATA MODE_SENSE_BIG timeout

2003-03-03 Thread Soeren Schmidt
It seems David Xu wrote: (snip snap) acd1: read data overrun 34/0 acd1: MODE_SENSE_BIG command timeout - resetting ata1: resetting devices .. done acd1: CD-RW SONY CD-RW CRX140E at ata1-slave PIO4 Hmm, can you use the acd1 device normally or does it fail (how) ? -Søren To Unsubscribe:

Re: Me Too: HPT372 UDMA detection problem on current (was Re: High %interrupt when building world)

2003-03-01 Thread Soeren Schmidt
It seems Shizuka Kudo wrote: --- Bruce Cran [EMAIL PROTECTED] wrote: Just to add to this, when I run the above 'dd' command, I see top reporting 35-40% interrupt usage on the drive on the RAID controller, while it's 3-5% for the drive on the VIA controller, and the drive itself is:

Re: HPT372 UDMA detection problem on current

2003-03-01 Thread Soeren Schmidt
It seems Akinori MUSHA wrote: Hi, Using the latest CURRENT on my box, the ata driver fails to enable UDMA for the ATA133 disks connected to an on-board HPT372 controller. Besides, UDMA is not enabled for the CD/DVD-ROM drive which is capable of UDMA4 either, but this may be a feature or a

Re: Yet another ATA-related Kernel trap 12 :-(

2003-02-27 Thread Soeren Schmidt
It seems Terry Lambert wrote: Vladimir Kushnir wrote: Setup: Fujitsu MPG3409AT E disk on external CMD649 controller (the only HD). Kernel trap while booting with timeout for ad0 device. Setting hw.ata.ata_dma=0 solves the problem. Sources last cvsupped last night (after the last

Re: Sis chipset

2003-02-26 Thread Soeren Schmidt
It seems Martin Blapp wrote: Hi, Is there a chance to get the built in 100MBit network adapter in the chipset working somehow? I thought I've fixed the support so it should work ? If not, do you have a pciconf -lv output for me ? It works on -current for me... -Søren To Unsubscribe: send

Re: Sis chipset

2003-02-26 Thread Soeren Schmidt
It seems Christoph P. Kukulies wrote: I have two network cards plugged in. But board has the builtin 100MBit, Soeren, it's the same board I sent to you. I will lookup in the bios (later) if I have disabled the on board NIC inadvertently (if that's possible) but at present make world is

Re: UDMA66 vs ATAPI_DEVICE(atadev)?

2003-02-26 Thread Soeren Schmidt
It seems Andrew Gallatin wrote: After recent ATA commits, my Promise UDMA66 controller is now running its drives in PIO4 mode. Previously, UDMA66 was working fine. Here's a dmesg snippet: atapci0: Promise UDMA66 controller port 0xdf00-0xdf3f,0xdfe0-0xdfe3,0xdfa8-0xd

Re: Yet another ATA-related Kernel trap 12 :-(

2003-02-26 Thread Soeren Schmidt
It seems Vladimir Kushnir wrote: Setup: Fujitsu MPG3409AT E disk on external CMD649 controller (the only HD). Kernel trap while booting with timeout for ad0 device. Setting hw.ata.ata_dma=0 solves the problem. Sources last cvsupped last night (after the last ATA-related commits). Dmesg output

Re: the ata driver is broken

2003-02-25 Thread Soeren Schmidt
It seems Takahashi Yoshihiro wrote: I got the following error. The kernel config has no pci device but ATA_NOPCI option. Fixed. I just completely forgot that ISA only systems exists... -Søren To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the

Re: ATA problems

2003-02-25 Thread Soeren Schmidt
It seems Wesley Morgan wrote: This morning I booted a kernel built last night, and it panicked when trying to mount the root filesystem after this: ad0: READ command timeout tag=0 serv=0 - resetting ata0: resetting devices .. ad0: removed from configuration done cvsup'd, built a new

Re: Mounting Root fails with error 22 (EINVAL)

2003-02-24 Thread Soeren Schmidt
It seems Alexander Leidinger wrote: On Sun, 23 Feb 2003 17:41:07 +0100 (CET) Soeren Schmidt [EMAIL PROTECTED] wrote: It seems that I managed to break the tagged queueing support somehow, so please disable tags while I look hunt for the problem.. For some of us it is broken since long

Re: cc: Internal error: Illegal instruction (program as)

2003-02-24 Thread Soeren Schmidt
It seems Paul A. Howes wrote: All; These two kernel options seem to have solved the problem. Builds now run smoothly and error-free. I read the comments in NOTES about these options and something clicked: I recall that most Pentium processors will only deal with 4 kB pages. Aren't 4

Re: cc: Internal error: Illegal instruction (program as)

2003-02-24 Thread Soeren Schmidt
It seems leafy wrote: Try this: DON'T remove /usr/obj before doing a buildworld, just let it accumulate. It will show up someday (it's not deterministic). Even sh(1) can die during the build a long with make(1) and as and gcc. My P4 never showed such behaviour if I properl y remove /usr/obj

Re: cc: Internal error: Illegal instruction (program as)

2003-02-24 Thread Soeren Schmidt
It seems Paul A. Howes wrote: Soren, I have a machine that uses a SiS 648, but it has other problems... I'm one of the unlucky individuals who bought the ASUS implementation of this board, and ended up with a flaky P.O.S. Uhm the board here is and ASUS P4S8X and it works like a charm

Re: cc: Internal error: Illegal instruction (program as)

2003-02-24 Thread Soeren Schmidt
It seems leafy wrote: Doesn't make any difference, the only way I (so far) has been able to reproduce this is by severely overclocking the CPU and RAM... -Søren I didn't believe it either at first. But I had kernel #54 before I first got thi s weird behavior. Ever since I have only kernel #0.

Re: cc: Internal error: Illegal instruction (program as)

2003-02-24 Thread Soeren Schmidt
It seems Terry Lambert wrote: Soeren Schmidt wrote: It seems Paul A. Howes wrote: I have a machine that uses a SiS 648, but it has other problems... I'm one of the unlucky individuals who bought the ASUS implementation of this board, and ended up with a flaky P.O.S. Uhm the board

Re: Mounting Root fails with error 22 (EINVAL)

2003-02-23 Thread Soeren Schmidt
It seems Michael Class wrote: Hello Soeren, I am sorry, but the last demsg output I have sent was not complete. I had captured that from /var/log/messages which does not seem to contain everything... Enclosed is a new one done with a serial console. Here I think the culprit can be

Re: Mounting Root fails with error 22 (EINVAL)

2003-02-23 Thread Soeren Schmidt
It seems that I managed to break the tagged queueing support somehow, so please disable tags while I look hunt for the problem.. I'll commit a disable tags patch to -current in a few... -Søren To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the

HEADS UP! ATA driver updates...

2003-02-23 Thread Soeren Schmidt
I have corrected a number of problems on Serverworks ALI chipsets and it has been committed to -current. There is an outstanding problem with having tags enabled on ATA disks, and I have temporarily disabled tags support until I nail that nasty problem. So please update your sources and let me

Re: Mounting Root fails with error 22 (EINVAL)

2003-02-22 Thread Soeren Schmidt
It seems Anders Andersson wrote: On Sat, Feb 22, 2003 at 01:02:33PM +0100, [EMAIL PROTECTED] wrote: If you say int broke in the 20feb timeframe I think sos' ATA megacommit is the main suspect... Yes, sos ATA commit is what broke my sparc64 also (already informed sos in private mail), but

HEADS UP! ATA driver changes committed.

2003-02-20 Thread Soeren Schmidt
The first round of ATA updates/fixes has been committed, please let me know if you find any problems with it... The commitlog say: This moves all chipset specific code to a new file 'ata-chipset.c'. Extensive use of tables and pointers to avoid having the same switch on chipset type in several

ATA PATCH updated!!

2003-02-14 Thread Soeren Schmidt
For those with ALI and ICH problems please try the updated patch: ftp://freebsd.dk/pub/ATA/ata-ng-diff-030214-1.gz Thanks! -Søren To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

PLEASE TEST - ATA driver patch (ATANG)...

2003-02-13 Thread Soeren Schmidt
I've prepared a patch that brings the ATA driver to the next level. This is mainly to prepare for other platforms which demanded some changes to the driver infrastructure. It also fixes lots of outstanding problems and adds support several new chipsets including SiS (thanks to Christoph

Re: PLEASE TEST - ATA driver patch (ATANG)...

2003-02-13 Thread Soeren Schmidt
It seems Sheldon Hearn wrote: On (2003/02/13 14:00), Soeren Schmidt wrote: I've prepared a patch that brings the ATA driver to the next level. You've brought ata in under cam? ;-) That wouldn't be forward moving now would it ? Sorry, couldn't resist. Ditto. -Søren To Unsubscribe

Re: PLEASE TEST - ATA driver patch (ATANG)...

2003-02-13 Thread Soeren Schmidt
It seems David Schultz wrote: Thus spake Soeren Schmidt [EMAIL PROTECTED]: I've prepared a patch that brings the ATA driver to the next level. This is mainly to prepare for other platforms which demanded some changes to the driver infrastructure. It also fixes lots of outstanding

Re: kern/43345: Support for the SiS 651 ATA controller

2003-02-12 Thread Soeren Schmidt
It seems Aaron D. Gifford wrote: Then on one of the messages, I noticed a link to Patrick Bihan-Faou's problem report, read it, and tried out his patch under 5.0-CURRENT (having completed my install of 5.0-RELEASE and updated to -CURRENT). Of course the line numbers were a bit different,

Re: The cbus driver for pc98

2003-02-09 Thread Soeren Schmidt
It seems Takahashi Yoshihiro wrote: I have made the cbus driver for pc98 based on i386 isa driver. This completely removes that PC98 depends on isa driver and also corrects directory layouts (pc98/i386 - pc98/pc98 and pc98/pc98 - pc98/cbus). Soeren, please review the ata part.

SiS pciconf's request ending :)

2003-02-06 Thread Soeren Schmidt
Thanks to all those that replied with pciconf output from various SiS chipsets (and thanks to those that sent from other systems as well :) ). I now have a significant amount of data to use for the SiS chipset support, and am working on it over the next days.. -Søren To Unsubscribe: send mail

Re: ATA code is buggy and slower

2003-02-06 Thread Soeren Schmidt
It seems Dong Lin wrote: My 5.0R kernel complains about READ timeout and resetting when I try to dd the disk. But everything *works* if I boot the same equipment with 4.5R and 4.7R. It seems that the error can occur on any sector I pick as long as I keep reading it inside a loop, a sign

Request for info from SiS chipset owners

2003-02-01 Thread Soeren Schmidt
I'm currently in the midst of an ATA chipset support mega rewrite/update, and the last item on the list is SiS support. That where _you_ come into the picture, I need a pciconf -l from your SiS based system! Just reply to this message with the output from pciconf -l and you have helped me sort

Re: ata0: resetting device - ASUS P4S8X

2003-02-01 Thread Soeren Schmidt
It seems Christoph Kukulies wrote: I bought new hardware for a server today, an ASUS P4S8X with an 1.8 GHZ P4 CPU, nothing fancy I would say, which has an onboard RAID controller (Promise) but I'm not using it for the moment. I attached an IBM 60GB Deskstar ATA/IDE disk to the IDE 1 port.

Re: ATA seems to lock up the system at boot (KT133A)

2003-01-13 Thread Soeren Schmidt
It seems Alexander Leidinger wrote: On Sun, 12 Jan 2003 20:35:41 +0100 (CET) Soeren Schmidt [EMAIL PROTECTED] wrote: Could your Zip disk be missing or bad? Usually I don't have a zip disk in the drive at boot time... I give it a try (tomorrow). I've tried both here, works

Re: ATA seems to lock up the system at boot (KT133A)

2003-01-13 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: posted is also that you are running the atapi ZIP-drive as master and Soeren as slave, so maybe this could be a hint that something goes wrong with initialisation when atapi floppy-drives are attached as masters. That makes no difference I still cant get it to

Re: ATA seems to lock up the system at boot (KT133A)

2003-01-12 Thread Soeren Schmidt
It seems Alexander Leidinger wrote: On Sun, 12 Jan 2003 06:49:18 -0800 walt [EMAIL PROTECTED] wrote: Could your Zip disk be missing or bad? Usually I don't have a zip disk in the drive at boot time... I give it a try (tomorrow). I've tried both here, works just fine on a newly compiled

Re: mirrored root fs?

2003-01-09 Thread Soeren Schmidt
It seems Nate Lawson wrote: On Tue, 7 Jan 2003, Soeren Schmidt wrote: For those that are brave enough to play with this I just created the following small change to ata-raid.c. Now it will always rebuild the array on creation, using the first disk as the master image. This allows you

Re: mirrored root fs?

2003-01-07 Thread Soeren Schmidt
It seems Soeren Schmidt wrote: It should work on 4.7 forward, but its been a while since I played with it. Another thing is that its a pain to make a mirror on an already running system (which is often wanted), so I plan to add an option to atacontrol to tell where to get the master from

Re: mirrored root fs?

2003-01-07 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: Søren, This is a real temptation. Let me be sure that I'm understanding correctly. I have an old machine, but running today's current, with only one disk, ad0. Could I do the following? o- Add ad2 o- run atacontrol create RAID1 ad0 ad2 source ad0

Re: mirrored root fs?

2003-01-07 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: | Doing stuff to your root filesystems is always dangerous, so you | have been warned :) Thanks, Søren. Indeed I have:-) I'll give it a try over the coming weekend after backing up everything:). Will this patch be committed to the tree, before then?

Re: mirrored root fs?

2003-01-07 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: | man atacontrol :) I did that but it sounded too easy :) It actually is :) | However if you want to use RAID1+0 and you want to be able to | boot from it you *need* a RAID capable controller BIOS, there is | no way to make a stock BIOS boot from a

Re: mirrored root fs?

2003-01-06 Thread Soeren Schmidt
It seems Nate Lawson wrote: I'd like to have a mirrored root partition. I tried ccd(4) but the boot blocks couldn't find the fs. Any idea how much work it would take to enable booting a ccd root? Also, does vinum already support this? If you use ATA drives you can use atacontrol to make the

Re: mirrored root fs?

2003-01-06 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: On Mon, Jan 06, 2003 at 07:29:51PM +0100, Soeren Schmidt wrote: It seems Nate Lawson wrote: I'd like to have a mirrored root partition. I tried ccd(4) but the boot blocks couldn't find the fs. Any idea how much work it would take to enable booting

Re: mirrored root fs?

2003-01-06 Thread Soeren Schmidt
It seems [EMAIL PROTECTED] wrote: if `atacontrol rebuild` would work... Is there simple way, i.e. without copying the content of the array to a temporary location, to recover from disk-failures when doing raid1 on non-raid controllers ? The problem is that if its the drive that on

Re: Cordless Keyboard + Mouse

2003-01-06 Thread Soeren Schmidt
It seems Daren Desjardins wrote: Has anyone been able to get the Logitech Cordless Elite Duo, or any cordless kb/mouse combos to work? I have the Cordless Elite Duo however the system only detects my keyboard, and I have to use a corded mouse. I have been searching around and yet to find

Re: mirrored root fs?

2003-01-06 Thread Soeren Schmidt
It seems Andrew P. Lentvorski, Jr. wrote: Probably your best choice right now if you have a real RAID controller on your motherboard. The BIOS takes care of most of the nasty booting details. If you don't have a real RAID controller on the motherboard, stop now. Rebuilds don't work

Re: mirrored root fs?

2003-01-06 Thread Soeren Schmidt
It seems Andrew P. Lentvorski, Jr. wrote: On Tue, 7 Jan 2003, Soeren Schmidt wrote: Not true, you can boot off a broken mirror on a non-RAID ATA controller, and then rebuild on the fly with atacontrol once the system is up Is this new (ie. since August 22, 2002)? I attempted to do

Re: Panic during ata_resume (sound)

2003-01-01 Thread Soeren Schmidt
It seems Gavin Atkinson wrote: This looks like a problem in the sound system, as the ATA driver prints the last 'done' line it has finished its resume code, and the trace points at the mixer_reinit func... That the ATA driver then locks in the dump code can have lots of reasons, difficult to

Re: SIS 962 chipset, problems ...

2002-12-23 Thread Soeren Schmidt
It seems Martin Blapp wrote: --- sys/dev/ata/ata-dma.c.origMon Dec 23 14:44:39 2002 +++ sys/dev/ata/ata-dma.c Mon Dec 23 15:49:20 2002 @@ -632,7 +632,9 @@ ata_find_dev(parent, 0x06351039, 0) || /* SiS 635 */ ata_find_dev(parent, 0x06401039, 0) || /*

Re: ata driver

2002-12-17 Thread Soeren Schmidt
It seems Takahashi Yoshihiro wrote: In article [EMAIL PROTECTED] [EMAIL PROTECTED] writes: Is it only for ATA/IDE disks ? Does it depend on the size of the disks ? Only for the internal IDE controller. The internal IDE controller on pc98 uses the fixed geometry which is 8 heads and 17

Re: ATACD issues slowly coming back...

2002-12-09 Thread Soeren Schmidt
It seems Vadim Belman wrote: Bruce Cran wrote: Your CD drive should indeed support UDMA33 - my DVD drive supports UDMA33, and my CDRW supports multi-word DMA, even though my BIOS only ever configures it for PIO4, and my DVD for UDMA33. FreeBSD only ever configures them for PIO

Re: Link failure in ata driver

2002-12-06 Thread Soeren Schmidt
It seems Kris Kennaway wrote: ata-all.o: In function `ata_boot_attach': ata-all.o(.text+0x1590): undefined reference to `ata_raid_attach' ata-all.o(.text+0x1594): undefined reference to `ata_raid_attach' Yes, I've seen it there is two other issues I'd like to fix also, I'll ask re@ for

Re: Another INVARIANTS panic with ata driver

2002-12-06 Thread Soeren Schmidt
It seems Andrew Gallatin wrote: Kris Kennaway writes: I got this on one of the gohan machines overnight. These machines have failing disks -- I get a lot of hard read errors, but the INVARIANTS panic could better be replaced by something else. I reported another instance of

Re: ATACD issues slowly coming back...

2002-12-06 Thread Soeren Schmidt
It seems Cliff L. Biffle wrote: I mentioned earlier on the list that the ATA issues I'd been having with 4.7 had disappeared since installing 5.0. They're still much less frequent -- i.e. I can burn CDs now -- but I just got one of the old messages and wanted to submit it for your perusal.

Re: panic: ata_dmasetup: transfer active on this device!

2002-12-04 Thread Soeren Schmidt
It seems Ian Dowse wrote: Hi Søren, I get the above panic every few days when resuming, especially if the disk was active while the laptop was suspending - it's easy to reproduce by starting some disk-intensive activity and then hitting the suspend button. I see that IWASAKI-san posted

  1   2   >