Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Ruslan Ermilov
On Sun, Dec 01, 2002 at 11:11:29AM -0700, M. Warner Losh wrote: In message: [EMAIL PROTECTED] Daniel C. Sobral [EMAIL PROTECTED] writes: : There I go reply to all... sigh : : IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the : *latest* version in the 3.x series.

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread David O'Brien
On Sun, Dec 01, 2002 at 05:03:03PM +0200, Ruslan Ermilov wrote: Index: Makefile.inc1 === RCS file: /home/ncvs/src/Makefile.inc1,v retrieving revision 1.312 diff -u -r1.312 Makefile.inc1 --- Makefile.inc1 14 Nov 2002 19:24:50

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Ruslan Ermilov
On Mon, Dec 02, 2002 at 12:28:50AM -0800, David O'Brien wrote: On Sun, Dec 01, 2002 at 05:03:03PM +0200, Ruslan Ermilov wrote: Index: Makefile.inc1 === RCS file: /home/ncvs/src/Makefile.inc1,v retrieving revision 1.312 diff

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread M. Warner Losh
In message: [EMAIL PROTECTED] Ruslan Ermilov [EMAIL PROTECTED] writes: : Um, why? I can even cross-build any of our supported arches on the : 4.0-RELEASE i386 box. This happens almost automatically, as part : of the cross-arch work tasks. I think that there are some build tools that

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Doug Barton
On Sun, 1 Dec 2002, Daniel C. Sobral wrote: IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here. While I can't put a lot of time into supporting ru's efforts, and I agree that the policy should be

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Doug Barton
On Sun, 1 Dec 2002, Ruslan Ermilov wrote: [ current@ Cc:'ed because it'll be useful to a number of upgraders. dougb@ Cc:'ed to be aware of possible mergemaster(8) problems. Thanks. 1. smmsp user was missing from /etc/passwd and /etc/group 2. installed 4.0 kernel did not have the

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Terry Lambert
Doug Barton wrote: On Sun, 1 Dec 2002, Daniel C. Sobral wrote: IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here. While I can't put a lot of time into supporting ru's efforts, and I agree that

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Ruslan Ermilov
On Mon, Dec 02, 2002 at 01:15:39AM -0800, Doug Barton wrote: On Sun, 1 Dec 2002, Daniel C. Sobral wrote: IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here. While I can't put a lot of time

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Terry Lambert
Doug Barton wrote: On Sun, 1 Dec 2002, Ruslan Ermilov wrote: I've attempted to overcome 1) as suggested by UPDATING, by running the ``mergemaster -p'' (from src/usr.sbin/mergemaster/). This did not work well because mergemaster(8) attempted to use stat(1) which is not present in 4.0.

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Doug Barton
On Mon, 2 Dec 2002, Terry Lambert wrote: Doug Barton wrote: On Sun, 1 Dec 2002, Ruslan Ermilov wrote: I've attempted to overcome 1) as suggested by UPDATING, by running the ``mergemaster -p'' (from src/usr.sbin/mergemaster/). This did not work well because mergemaster(8) attempted to

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread Kirill Ponomarew
Hi! On Mon, Dec 02, 2002 at 01:19:17AM -0800, Doug Barton wrote: DB I'm not sure how to solve this problem non-invasively. One way to deal DB with it would be to include the instructions to install stat(1) if needed DB in UPDATING, but then if the upgrade fails for whatever reason, the user DB

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-02 Thread David O'Brien
On Mon, Dec 02, 2002 at 10:34:32AM +0200, Ruslan Ermilov wrote: Please indent the last line either 4 spaces or a tab. It is a continued line. It's already indented, and we don't indent multiple times like this: Blah, mis-read the patch. Please forget I responed before. To Unsubscribe:

[REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread Ruslan Ermilov
[ current@ Cc:'ed because it'll be useful to a number of upgraders. dougb@ Cc:'ed to be aware of possible mergemaster(8) problems. imp@ Cc:'ed to be aware of incorrect UPDATING instruction. peter@ Cc:'ed to LOL about foot-shooting with anti-foot-shooting. re@ Cc:'ed to consider approving the

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread Daniel C. Sobral
There I go reply to all... sigh IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here. Ruslan Ermilov wrote: [ current@ Cc:'ed because it'll be useful to a number of upgraders. dougb@ Cc:'ed to be

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread Ruslan Ermilov
[Cc: to re@ dropped to avoid unnecessary load] On Sun, Dec 01, 2002 at 01:15:00PM -0200, Daniel C. Sobral wrote: There I go reply to all... sigh IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here.

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread Jake Burkholder
Apparently, On Sun, Dec 01, 2002 at 01:15:00PM -0200, Daniel C. Sobral said words to the effect of; There I go reply to all... sigh IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here.

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread Robert Watson
On Sun, 1 Dec 2002, Jake Burkholder wrote: Apparently, On Sun, Dec 01, 2002 at 01:15:00PM -0200, Daniel C. Sobral said words to the effect of; There I go reply to all... sigh IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series.

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread M. Warner Losh
In message: [EMAIL PROTECTED] Daniel C. Sobral [EMAIL PROTECTED] writes: : There I go reply to all... sigh : : IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the : *latest* version in the 3.x series. I sure hope we adopt the same policy : here. ru@ has stepped up to

Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT

2002-12-01 Thread M. Warner Losh
Hey ru! These patches are only one '/' different from what I build on my 4.3, 4.5 and 4.6.2 systems w/o a new make being installed. All built perfectly! Thanks! Warner To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

Patches reviewed [was: Re: [REPORT] Upgrade from 4.0-RELEASE to 5.0-CURRENT]

2002-12-01 Thread Marcel Moolenaar
On Sun, Dec 01, 2002 at 12:12:36PM -0500, Robert Watson wrote: There I go reply to all... sigh IIRC, we never supported upgrade to 4.0 or 4.1 from anybut but the *latest* version in the 3.x series. I sure hope we adopt the same policy here. Agree, I don't see any use in