Re: AHCI/ADA regression?

2016-05-25 Thread Kenneth D. Merry
On Wed, May 25, 2016 at 14:36:59 +0200, Gary Jennejohn wrote: > On Wed, 25 May 2016 08:15:11 +0200 > Gary Jennejohn wrote: > > > On Tue, 24 May 2016 15:10:41 -0400 > > "Kenneth D. Merry" wrote: > > > > > Can you send full dmesg output from the working

Re: AHCI/ADA regression?

2016-05-25 Thread Gary Jennejohn
On Wed, 25 May 2016 08:15:11 +0200 Gary Jennejohn wrote: > On Tue, 24 May 2016 15:10:41 -0400 > "Kenneth D. Merry" wrote: > > > Can you send full dmesg output from the working kernel? > > > > I'll give it a try and hope that the mail server doesn't

Re: AHCI/ADA regression?

2016-05-24 Thread Kenneth D. Merry
On Tue, May 24, 2016 at 20:00:51 +0200, Gary Jennejohn wrote: > On Tue, 24 May 2016 10:41:25 -0400 > "Kenneth D. Merry" wrote: > > > > The question in my mind is - why are "empty" multiplier ports being > > > probed with the new code but not with the old code? > > > > If the

Re: AHCI/ADA regression?

2016-05-24 Thread Gary Jennejohn
On Tue, 24 May 2016 10:41:25 -0400 "Kenneth D. Merry" wrote: > > The question in my mind is - why are "empty" multiplier ports being > > probed with the new code but not with the old code? > > If the HBA says that it supports port multipliers, the kernel should always > look

Re: AHCI/ADA regression?

2016-05-24 Thread Kenneth D. Merry
On Tue, May 24, 2016 at 15:58:28 +0200, Gary Jennejohn wrote: > On Mon, 23 May 2016 13:51:05 -0400 > "Kenneth D. Merry" wrote: > > > On Sat, May 21, 2016 at 10:09:49 +0200, Gary Jennejohn wrote: > > > There appears to be a regression in AHCI/ADA behavior since r300207. > > > >

Re: AHCI/ADA regression?

2016-05-24 Thread Gary Jennejohn
On Mon, 23 May 2016 13:51:05 -0400 "Kenneth D. Merry" wrote: > On Sat, May 21, 2016 at 10:09:49 +0200, Gary Jennejohn wrote: > > There appears to be a regression in AHCI/ADA behavior since r300207. > > > > Starting a test kernel at r300293 results in extremely long timeouts >

Re: AHCI/ADA regression?

2016-05-23 Thread Kenneth D. Merry
On Sat, May 21, 2016 at 10:09:49 +0200, Gary Jennejohn wrote: > There appears to be a regression in AHCI/ADA behavior since r300207. > > Starting a test kernel at r300293 results in extremely long timeouts > probing ahcich2 for non-existent multiplier ports. > > Here some kernel output: Is this

AHCI/ADA regression?

2016-05-21 Thread Gary Jennejohn
There appears to be a regression in AHCI/ADA behavior since r300207. Starting a test kernel at r300293 results in extremely long timeouts probing ahcich2 for non-existent multiplier ports. Here some kernel output: ahci0: port 0xff00-0xff07,0xfe00-0xfe03,0xfd00-0xfd07,0xfc00-0xfc03,