Re: kernel config question

2019-01-04 Thread John Baldwin
On 1/3/19 10:40 PM, Kevin Oberman wrote: > On Wed, Jan 2, 2019 at 5:02 PM Robert Huff wrote: > >> >> John Baldwin writes: >> >>> -[8] In order to have a kernel that can run the 4.x binaries needed >> to >>> -do an installworld, you must include the COMPAT_FREEBSD4 option in >>> -

Re: kernel config question

2019-01-03 Thread Kevin Oberman
On Wed, Jan 2, 2019 at 5:02 PM Robert Huff wrote: > > John Baldwin writes: > > > -[8] In order to have a kernel that can run the 4.x binaries needed > to > > -do an installworld, you must include the COMPAT_FREEBSD4 option in > > -your kernel. Failure to do so may leave you with

Re: kernel config question

2019-01-02 Thread Robert Huff
John Baldwin writes: > -[8] In order to have a kernel that can run the 4.x binaries needed to > -do an installworld, you must include the COMPAT_FREEBSD4 option in > -your kernel. Failure to do so may leave you with a system that is > -hard to boot to recover. A similar

Re: kernel config question

2019-01-02 Thread John Baldwin
On 1/2/19 1:31 PM, Robert Huff wrote: > > John Baldwin writes: > >> >> [8] In order to have a kernel that can run the 4.x binaries >> >> needed to do an installworld, you must include the >> >> COMPAT_FREEBSD4 option in your kernel. [...] >> >> > No, COMPAT_FREEBSD4 is not needed. Maybe

Re: kernel config question

2019-01-02 Thread Robert Huff
John Baldwin writes: > >> [8] In order to have a kernel that can run the 4.x binaries > >> needed to do an installworld, you must include the > >> COMPAT_FREEBSD4 option in your kernel. [...] > > > No, COMPAT_FREEBSD4 is not needed. Maybe COMPAT_FREEBSD11 is needed. > > Yes, that

Re: kernel config question

2019-01-02 Thread John Baldwin
On 1/2/19 12:02 PM, Kurt Jaeger wrote: > Hi! > >> FreeBSD 12.0-CURRENT #0 r331659: Thu Mar 29 12:31:36 EDT 2018 amd64 >> >> to CURRENT (as of last midnight. >> Does this, in src/UPDATING: >> >> [8] In order to have a kernel that can run the 4.x binaries >> needed to do an

Re: kernel config question

2019-01-02 Thread Kurt Jaeger
Hi! > FreeBSD 12.0-CURRENT #0 r331659: Thu Mar 29 12:31:36 EDT 2018 amd64 > > to CURRENT (as of last midnight. > Does this, in src/UPDATING: > > [8] In order to have a kernel that can run the 4.x binaries > needed to do an installworld, you must include the >

kernel config question

2019-01-02 Thread Robert Huff
I'm updating a machine from: FreeBSD 12.0-CURRENT #0 r331659: Thu Mar 29 12:31:36 EDT 2018 amd64 to CURRENT (as of last midnight. Does this, in src/UPDATING: [8] In order to have a kernel that can run the 4.x binaries needed to do an installworld, you