Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Baptiste Daroussin
On Sat, Dec 06, 2014 at 05:12:12AM -0800, Jeffrey Bouquet wrote:
 
 On 12/06/14 04:40, Baptiste Daroussin wrote:
  Hi,
 
  We have released a new 1.4.0 rc2 version of pkg (available in
  ports-mgmt/pkg-devel) since first beta it has received tons of bug fixes and
  should be now way more reliable and able to handle ootb without mistakes
  upgrades like the gettext one and the perl one.
 
  All reported issues should have been fixed since.
 
  Please test that new version I would like to make it the final release if
  possible.
 
  Best regards,
  Bapt
 The upgrade of pkg-devel went slightly more without problems.  Did not test
 a direct deinstall/reinstall though.
 
 OTOH pkg install xorriso xombrero still wants to remove w3m-img , install
 w3m, guile 1.8, x246,  along with the reinstall of those two.
 
 For which I n and
 pkg delete xorriso xombrero
 cd ../cache/pkg
 pkg clean
 pkg install xorr[tab] xomb[tab] to complete and install manually
 Works, but a few more commands in the way.
 
 I seem to have no guile installed (was using v2 for mcron) and libx264
 installed.
 Just ignoring guile for now probably.

Sounds like a port problem that pkg is showing I'll dig into it.

regards,
Bapt


pgp86MPk5dm5O.pgp
Description: PGP signature


Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Jeffrey Bouquet

On 12/06/14 04:40, Baptiste Daroussin wrote:
 Hi,

 We have released a new 1.4.0 rc2 version of pkg (available in
 ports-mgmt/pkg-devel) since first beta it has received tons of bug fixes and
 should be now way more reliable and able to handle ootb without mistakes
 upgrades like the gettext one and the perl one.

 All reported issues should have been fixed since.

 Please test that new version I would like to make it the final release if
 possible.

 Best regards,
 Bapt
The upgrade of pkg-devel went slightly more without problems.  Did not test
a direct deinstall/reinstall though.

OTOH pkg install xorriso xombrero still wants to remove w3m-img , install
w3m, guile 1.8, x246,  along with the reinstall of those two.

For which I n and
pkg delete xorriso xombrero
cd ../cache/pkg
pkg clean
pkg install xorr[tab] xomb[tab] to complete and install manually
Works, but a few more commands in the way.

I seem to have no guile installed (was using v2 for mcron) and libx264
installed.
Just ignoring guile for now probably.
___
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to freebsd-current-unsubscr...@freebsd.org


Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Baptiste Daroussin
On Sat, Dec 06, 2014 at 05:12:12AM -0800, Jeffrey Bouquet wrote:
 
 On 12/06/14 04:40, Baptiste Daroussin wrote:
  Hi,
 
  We have released a new 1.4.0 rc2 version of pkg (available in
  ports-mgmt/pkg-devel) since first beta it has received tons of bug fixes and
  should be now way more reliable and able to handle ootb without mistakes
  upgrades like the gettext one and the perl one.
 
  All reported issues should have been fixed since.
 
  Please test that new version I would like to make it the final release if
  possible.
 
  Best regards,
  Bapt
 The upgrade of pkg-devel went slightly more without problems.  Did not test
 a direct deinstall/reinstall though.
 
 OTOH pkg install xorriso xombrero still wants to remove w3m-img , install
 w3m, guile 1.8, x246,  along with the reinstall of those two.

Right so the is a problem in the way ports express dependencies and can only be
solved with some provides/requires we do not know yet how to express with the
ports tree :(

Regards,
Bapt


pgp56FNINKiTW.pgp
Description: PGP signature


Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Hans Petter Selasky

Hi,

Just a simple question:

Does pkg upgrade automatically lock packages which are not available 
or cannot be built?


I recently did a pkg upgrade and found myself without a working 
libreoffice ... 9-stable amd64



--HPS
___
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to freebsd-current-unsubscr...@freebsd.org


Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Baptiste Daroussin
On Sat, Dec 06, 2014 at 04:15:45PM +0100, Marc UBM wrote:
 On Sat, 6 Dec 2014 13:40:29 +0100
 Baptiste Daroussin b...@freebsd.org wrote:
 
  Hi,
  
  We have released a new 1.4.0 rc2 version of pkg (available in
  ports-mgmt/pkg-devel) since first beta it has received tons of bug fixes and
  should be now way more reliable and able to handle ootb without mistakes
  upgrades like the gettext one and the perl one.
  
  All reported issues should have been fixed since.
  
  Please test that new version I would like to make it the final release if
  possible.
  
  Best regards,
  Bapt
 
 Unfortunately, installing / upgrading pkg-devel still fails with:
 
  Compressing man pages (compress-man)
 ===  Installing for pkg-1.4.0.b2
 ===  Checking if pkg already installed
 pkg-static: sqlite error while executing DROP INDEX
 packages_unique;CREATE UNIQUE INDEX packages_unique ON packages(name);
 in file pkgdb.c:2245: UNIQUE constraint failed: packages.name *** Error
 code 74
 
 Stop.
 make[1]: stopped in /usr/ports/ports-mgmt/pkg-devel
 *** Error code 1
 
 Stop.
 make: stopped in /usr/ports/ports-mgmt/pkg-devel
 
 Any new ideas?
 
 Bye
 Marc
 
 ___
 freebsd-current@freebsd.org mailing list
 http://lists.freebsd.org/mailman/listinfo/freebsd-current
 To unsubscribe, send any mail to freebsd-current-unsubscr...@freebsd.org

You are trying to install beta2 not rc2

Plus be aware that your setup has outdated packages as you should not anymore
have duplicated package names for around a year, but pkg rc2 will be able to
handle it anyway :)

regards,
Bapt


pgpxkViA_k0ef.pgp
Description: PGP signature


Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Baptiste Daroussin
On Sat, Dec 06, 2014 at 06:23:21PM +0100, Hans Petter Selasky wrote:
 Hi,
 
 Just a simple question:
 
 Does pkg upgrade automatically lock packages which are not available 
 or cannot be built?
 
 I recently did a pkg upgrade and found myself without a working 
 libreoffice ... 9-stable amd64

Nope it does not and will be very very hard to do it properly, the problem was
that some libraries are now dropping (upstream) support for gcc 4.2 which
resulted in libreoffice not being built, he said libraries was reverted to the
ancient version so next package build should have libreoffice again.

regards,
Bapt


pgpYZ7_N4NeOx.pgp
Description: PGP signature


Re: [CFT] pkg 1.4.0 rc2

2014-12-06 Thread Willem Jan Withagen
On 6-12-2014 13:40, Baptiste Daroussin wrote:
 Hi,
 
 We have released a new 1.4.0 rc2 version of pkg (available in
 ports-mgmt/pkg-devel) since first beta it has received tons of bug fixes and
 should be now way more reliable and able to handle ootb without mistakes
 upgrades like the gettext one and the perl one.
 
 All reported issues should have been fixed since.
 
 Please test that new version I would like to make it the final release if
 possible.

I missed the previous announcement, but this is bothering me for some
time already

I'm using this simple cronic script to reduce traffic from scripts with
nothing serious to report. But pkg still triggers:
-
# sudo cronic pkg audit -F
Cronic detected failure or error output for the command:
pkg audit -F

RESULT CODE: 0

ERROR OUTPUT:
pkg: vulnxml file up-to-date
--

And I wonder why this informational message is reported on STDERR, and
other real problems on STDOUT...

--
sudo cronic pkg audit
Cronic detected failure or error output for the command:
pkg audit

RESULT CODE: 1

ERROR OUTPUT:

STANDARD OUTPUT:
phpMyAdmin-4.2.13 is vulnerable:
phpMyAdmin -- XSS and DoS vulnerabilities
CVE: CVE-2014-9219
CVE: CVE-2014-9218
WWW: http://portaudit.FreeBSD.org/c9c46fbf-7b83-11e4-a96e-6805ca0b3d42.html

1 problem(s) in the installed packages found.
--

I would atleast to have case 1) also write to STDOUT.
And perhaps have case 2) report on STDERR.

--WjW



___
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to freebsd-current-unsubscr...@freebsd.org