Re: ucom_free Fatal trap on shutdown / module unload

2014-07-01 Thread Lundberg, Johannes
Hi Hans Thanks for the uhso patch. That did the trick. Now reboot and kldunload works fine. -- Johannes Lundberg BRILLIANTSERVICE CO., LTD. On Tue, Jul 1, 2014 at 2:33 PM, Hans Petter Selasky h...@selasky.org wrote: Hi, Try the attached patch. Does it make any difference? --HPS --

Re: ucom_free Fatal trap on shutdown / module unload

2014-07-01 Thread Hans Petter Selasky
Hi, Try the attached patch. Does it make any difference? --HPS === uhso.c == --- uhso.c (revision 268059) +++ uhso.c (local) @@ -559,8 +559,6 @@ mtx_init(sc-sc_mtx, uhso, NULL, MTX_DEF); ucom_ref(sc-sc_super_ucom); -

Re: ucom_free Fatal trap on shutdown / module unload

2014-07-01 Thread Hans Petter Selasky
Hi Johannes, Thank you for your patience! http://svnweb.freebsd.org/changeset/base/268078 --HPS ___ freebsd-current@freebsd.org mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-30 Thread Lundberg, Johannes
Hi Hans Thanks for the tips. I tried both adding them in kernel config and the patch (not simultaneously) but no effect. Still crash on unload/reboot. -- Johannes Lundberg BRILLIANTSERVICE CO., LTD. On Mon, Jun 30, 2014 at 1:13 PM, Hans Petter Selasky h...@selasky.org wrote: On 06/30/14

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-29 Thread Lundberg, Johannes
As I mention in earlier mail, it is when I comment out following lines it works # For full debugger support use (turn off in stable branch): options DDB # Support DDB. options GDB # Support remote GDB. options DEADLKRES

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-29 Thread Hans Petter Selasky
On 06/30/14 06:01, Lundberg, Johannes wrote: As I mention in earlier mail, it is when I comment out following lines it works # For full debugger support use (turn off in stable branch): options DDB # Support DDB. options GDB # Support

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-23 Thread Hans Petter Selasky
On 06/23/14 07:34, Lundberg, Johannes wrote: I added some logging to see what is going on and this is what I got (none of the proposed solution solved the problem) uhso_detach gets called 7 times (for oid 0-6). It crashes the 2nd time on the call usbd_transfer_unsetup(sc-sc_xfer, 3); Hi,

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-23 Thread Lundberg, Johannes
Hi Well I'm running the snaphot memstick image from June of 11-CURRENT amd64, with newcons. The device is embedded in the laptop and I can not remove it easily so I don't know what would happen if I do. I'm sending you the screenshots separately in direct mail so we don't have to wait for large

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-22 Thread Lundberg, Johannes
Hi I tried replacing DRIVER_MODULE(uhso, uhub, uhso_driver, uhso_devclass, uhso_driver_loaded, 0); with DRIVER_MODULE_ORDERED(uhso, uhub, uhso_driver, uhso_devclass, uhso_driver_loaded, 0, SI_ORDER_ANY); but makes no difference.. Don't know if its relevant but with ucom debug on I get a message

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-22 Thread Hans Petter Selasky
On 06/23/14 03:30, Lundberg, Johannes wrote: Hi I tried replacing DRIVER_MODULE(uhso, uhub, uhso_driver, uhso_devclass, uhso_driver_loaded, 0); with DRIVER_MODULE_ORDERED(uhso, uhub, uhso_driver, uhso_devclass, uhso_driver_loaded, 0, SI_ORDER_ANY); but makes no difference.. Don't know if its

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-22 Thread Lundberg, Johannes
I added some logging to see what is going on and this is what I got (none of the proposed solution solved the problem) uhso_detach gets called 7 times (for oid 0-6). It crashes the 2nd time on the call usbd_transfer_unsetup(sc-sc_xfer, 3); -- Johannes Lundberg BRILLIANTSERVICE CO., LTD. On

Re: ucom_free Fatal trap on shutdown / module unload

2014-06-20 Thread Hans Petter Selasky
On 06/20/14 04:25, Lundberg, Johannes wrote: Hi I'm getting this error on 11-CURRENT amd64 (snapshot from June). (see attached image) Worked fine with 10 I think.. The ucom module is loaded as a dependency by the uhso module. Any clues? -- Johannes Lundberg [image: Inline image 1] Hi,