Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-22 Thread Wojciech A. Koszek
On Mon, Dec 19, 2005 at 02:24:04PM -0500, John Baldwin wrote: On Friday 16 December 2005 05:19 pm, Wojciech A. Koszek wrote: On Fri, Dec 16, 2005 at 11:14:12AM -0500, John Baldwin wrote: On Friday 16 December 2005 04:10 am, Peter Jeremy wrote: On Thu, 2005-Dec-15 22:37:45 +, Wojciech

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-22 Thread Wojciech A. Koszek
On Fri, Dec 16, 2005 at 11:14:12AM -0500, John Baldwin wrote: On Friday 16 December 2005 04:10 am, Peter Jeremy wrote: On Thu, 2005-Dec-15 22:37:45 +, Wojciech A. Koszek wrote: abort2(const char *why, int nargs, void **args); why is reason of program abort, nargs is number of

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-19 Thread John Baldwin
On Friday 16 December 2005 05:19 pm, Wojciech A. Koszek wrote: On Fri, Dec 16, 2005 at 11:14:12AM -0500, John Baldwin wrote: On Friday 16 December 2005 04:10 am, Peter Jeremy wrote: On Thu, 2005-Dec-15 22:37:45 +, Wojciech A. Koszek wrote: abort2(const char *why, int nargs, void

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-16 Thread Peter Jeremy
On Fri, 2005-Dec-16 00:17:14 +0100, Václav Haisman wrote: I would like to comment on FreeBSD style(9) a bit. That is a different bikeshed. If, taking into account the other comments in this thread, you believe that you can justify changes to style(9), please start a new thread - probably in

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-16 Thread Peter Jeremy
On Thu, 2005-Dec-15 22:37:45 +, Wojciech A. Koszek wrote: abort2(const char *why, int nargs, void **args); why is reason of program abort, nargs is number of arguments passed in args. Both why and args (with %p format) will be printed via log(9). Sample output: [..] pid 3004 abort2

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-16 Thread John Baldwin
On Friday 16 December 2005 04:10 am, Peter Jeremy wrote: On Thu, 2005-Dec-15 22:37:45 +, Wojciech A. Koszek wrote: abort2(const char *why, int nargs, void **args); why is reason of program abort, nargs is number of arguments passed in args. Both why and args (with %p format) will be

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-16 Thread Wojciech A. Koszek
On Fri, Dec 16, 2005 at 08:10:57PM +1100, Peter Jeremy wrote: On Thu, 2005-Dec-15 22:37:45 +, Wojciech A. Koszek wrote: abort2(const char *why, int nargs, void **args); why is reason of program abort, nargs is number of arguments passed in args. Both why and args (with %p format)

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-16 Thread Wojciech A. Koszek
On Fri, Dec 16, 2005 at 11:14:12AM -0500, John Baldwin wrote: On Friday 16 December 2005 04:10 am, Peter Jeremy wrote: On Thu, 2005-Dec-15 22:37:45 +, Wojciech A. Koszek wrote: abort2(const char *why, int nargs, void **args); why is reason of program abort, nargs is number of

[CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Wojciech A. Koszek
(discussed task was picked from Poul-Henning Kamp's TODO list) Hackers, I've implemented abort2() system call. Works just like abort(3), but delivers signal reliably. Here is a prototype: abort2(const char *why, int nargs, void **args); why is reason of program abort, nargs is number of

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Václav Haisman
Wojciech A. Koszek wrote: [...] Comments are welcome! As for the patch, the use of do {} while(0) instead of goto looks odd to me. I would like to comment on FreeBSD style(9) a bit. Why does not mention or even encourage C99 style // comments? They are nice when one wants to comment out bigger

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread joerg
On Fri, Dec 16, 2005 at 12:17:14AM +0100, Václav Haisman wrote: I would like to comment on FreeBSD style(9) a bit. Why does not mention or even encourage C99 style // comments? They are nice when one wants to comment out bigger chunks of code with /**/ comment. Use #if 0 ... #endif for that.

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Warner Losh
I would like to comment on FreeBSD style(9) a bit. Why does not mention or even encourage C99 style // comments? They are nice when one wants to comment out bigger chunks of code with /**/ comment. Too new. /**/ comment out is bogus anyway. #if 0 ... #endif is better. On the similar note,

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Poul-Henning Kamp
In message [EMAIL PROTECTED], Warner Losh writes: On the similar note, the ability to move declarations closer to the point of use in code is IMO nice feature, too. The style(9) doesn't mention this either. C doesn't allow it, or didn't until recently. That style tends to lead to really

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Václav Haisman
[EMAIL PROTECTED] wrote: On Fri, Dec 16, 2005 at 12:17:14AM +0100, Václav Haisman wrote: I would like to comment on FreeBSD style(9) a bit. Why does not mention or even encourage C99 style // comments? They are nice when one wants to comment out bigger chunks of code with /**/ comment. Use

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Václav Haisman
Poul-Henning Kamp wrote: In message [EMAIL PROTECTED], Warner Losh writes: On the similar note, the ability to move declarations closer to the point of use in code is IMO nice feature, too. The style(9) doesn't mention this either. C doesn't allow it, or didn't until recently. That style

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Warner Losh
Also, it tends to make it harder to judge the amount of stackspace a function uses, something which is not entirely uninteresting in kernel programming. While it might be harder to get estimate of stack space allocation I suspect it could actually lower the allocation. Maybe, maybe not.

Re: [CALL FOR TESTERS] New system call: abort2()

2005-12-15 Thread Wojciech A. Koszek
On Fri, Dec 16, 2005 at 12:17:14AM +0100, Václav Haisman wrote: Wojciech A. Koszek wrote: [...] Comments are welcome! As for the patch, the use of do {} while(0) instead of goto looks odd to me. This can be changed easily in final version of the patch if needed. I would like to comment