Re: Cisco shows LACP not enabled on 11.1U2, BCM 57810S-t, 2960X IOS 15.2

2018-03-13 Thread Eugene Grosbein
14.03.2018 1:28, Rob Hutton wrote:

> Trying to get to a LACP Trunk config working on FreeNAS, but I'm not sure
> if this is an upstream issue.  First step is just LACP bundle in edge mode
> (no vlans) and bundle will not form.  The FreeNAS side shows it as being
> active.  The switch is reporting that LACP is not enabled on the individual
> ports.  We have tried multiple versions of IOS from 15.0 to 15.2(6)E1.  I
> have about 10 windows servers with the same NICs on the same switch that
> are negotiating LACP successfully as well as tagging vlans, so the hardware
> pieces seem to be OK.  I have tried configuring from both the GUI and the
> CL with the same result.
> 
> Cisco 2960X
> 
> switch config:
> interface Port-channel10
> switchport access vlan 1900
> switchport mode access
> !
> interface GigabitEthernet1/0/27
> switchport access vlan 1900
> switchport mode access
> channel-group 10 mode active
> !
> interface GigabitEthernet1/0/28
> switchport access vlan 1900
> switchport mode access
> channel-group 10 mode active
> 
> logs from switch:
> Mar 13 17:38:09.626: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/27,
> changed state to up
> Mar 13 17:38:09.665: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/28,
> changed state to up
> Mar 13 17:38:15.753: %EC-5-L3DONTBNDL2: Gi1/0/28 suspended: LACP currently
> not enabled on the remote port.
> Mar 13 17:38:16.005: %EC-5-L3DONTBNDL2: Gi1/0/27 suspended: LACP currently
> not enabled on the remote port.
> 
> Switch#sh etherc summ
> Flags:  D - down P - bundled in port-channel
> I - stand-alone s - suspended
> H - Hot-standby (LACP only)
> R - Layer3   S - Layer2
> U - in use   N - not in use, no aggregation
> f - failed to allocate aggregator
> 
> M - not in use, minimum links not met
> m - not in use, port not aggregated due to minimum links not met
> u - unsuitable for bundling
> w - waiting to be aggregated
> d - default port
> 
> A - formed by Auto LAG
> 
> 
> Number of channel-groups in use: 1
> Number of aggregators:1
> 
> Group  Port-channel  Protocol Ports
> --+-+---+---
> 10  Po10(SD) LACP   Gi1/0/27(w) Gi1/0/28(w)
> 
> Switch#sh int gi1/0/27
> GigabitEthernet1/0/27 is up, line protocol is down (notconnect)
> 
> Switch#sh int gi1/0/28
> GigabitEthernet1/0/28 is up, line protocol is down (notconnect)
> 
> 
> FreeNAS
> ifconfig
> 
> bxe0: flags=8843 metric 0 mtu 1500
>options=527bb M,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
>ether 00:0e:1e:86:7c:70
>hwaddr 00:0e:1e:86:7c:70
>nd6 options=9
>media: Ethernet autoselect (10Gbase-T )
>status: active
> 
> bxe1: flags=8843 metric 0 mtu 1500
>options=527bb M,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
>ether 00:0e:1e:86:7c:70
>hwaddr 00:0e:1e:86:7c:72
>nd6 options=9
>media: Ethernet autoselect (10Gbase-T )
>status: active
> 
> lagg0: flags=8843 metric 0 mtu 1500
>options=527bb M,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
>ether 00:0e:1e:86:7c:70
>nd6 options=9
>media: Ethernet autoselect
>status: active
>groups: lagg
>laggproto lacp lagghash l2,l3,l4
>laggport: bxe0 flags=0<>
>laggport: bxe1 flags=0<>
> 
> Last edited: 12 minutes ago

See also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213606

In short: bxe(4) driver fails to setup hardware so it would receive incoming
multicast LACP frames unless switched to promisc. mode.

For now, replace the NIC with one from distinct manufacturer (Intel etc.)

___
freebsd-net@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscr...@freebsd.org"


Re: Cisco shows LACP not enabled on 11.1U2, BCM 57810S-t, 2960X IOS 15.2

2018-03-13 Thread Ryan Stone
Unfortunately, this is a known issue with the bxe driver.  I was under
the impression that QLogic had committed a fix to -head, but I just
checked and it hasn't seen any updates from QLogic in over a year,
unfortunately.
___
freebsd-net@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscr...@freebsd.org"


Cisco shows LACP not enabled on 11.1U2, BCM 57810S-t, 2960X IOS 15.2

2018-03-13 Thread Rob Hutton
Trying to get to a LACP Trunk config working on FreeNAS, but I'm not sure
if this is an upstream issue.  First step is just LACP bundle in edge mode
(no vlans) and bundle will not form.  The FreeNAS side shows it as being
active.  The switch is reporting that LACP is not enabled on the individual
ports.  We have tried multiple versions of IOS from 15.0 to 15.2(6)E1.  I
have about 10 windows servers with the same NICs on the same switch that
are negotiating LACP successfully as well as tagging vlans, so the hardware
pieces seem to be OK.  I have tried configuring from both the GUI and the
CL with the same result.

Cisco 2960X

switch config:
interface Port-channel10
switchport access vlan 1900
switchport mode access
!
interface GigabitEthernet1/0/27
switchport access vlan 1900
switchport mode access
channel-group 10 mode active
!
interface GigabitEthernet1/0/28
switchport access vlan 1900
switchport mode access
channel-group 10 mode active

logs from switch:
Mar 13 17:38:09.626: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/27,
changed state to up
Mar 13 17:38:09.665: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/28,
changed state to up
Mar 13 17:38:15.753: %EC-5-L3DONTBNDL2: Gi1/0/28 suspended: LACP currently
not enabled on the remote port.
Mar 13 17:38:16.005: %EC-5-L3DONTBNDL2: Gi1/0/27 suspended: LACP currently
not enabled on the remote port.

Switch#sh etherc summ
Flags:  D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3   S - Layer2
U - in use   N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators:1

Group  Port-channel  Protocol Ports
--+-+---+---
10  Po10(SD) LACP   Gi1/0/27(w) Gi1/0/28(w)

Switch#sh int gi1/0/27
GigabitEthernet1/0/27 is up, line protocol is down (notconnect)

Switch#sh int gi1/0/28
GigabitEthernet1/0/28 is up, line protocol is down (notconnect)


FreeNAS
ifconfig

bxe0: flags=8843 metric 0 mtu 1500
   options=527bb
   ether 00:0e:1e:86:7c:70
   hwaddr 00:0e:1e:86:7c:70
   nd6 options=9
   media: Ethernet autoselect (10Gbase-T )
   status: active

bxe1: flags=8843 metric 0 mtu 1500
   options=527bb
   ether 00:0e:1e:86:7c:70
   hwaddr 00:0e:1e:86:7c:72
   nd6 options=9
   media: Ethernet autoselect (10Gbase-T )
   status: active

lagg0: flags=8843 metric 0 mtu 1500
   options=527bb
   ether 00:0e:1e:86:7c:70
   nd6 options=9
   media: Ethernet autoselect
   status: active
   groups: lagg
   laggproto lacp lagghash l2,l3,l4
   laggport: bxe0 flags=0<>
   laggport: bxe1 flags=0<>

Last edited: 12 minutes ago
___
freebsd-net@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscr...@freebsd.org"


[Bug 7556] [ppp] sl_compress_init() will fail if called anything else than -1 or >MAX_STATE

2018-03-13 Thread bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=7556

Alex Kozlov  changed:

   What|Removed |Added

 Resolution|Overcome By Events  |---
 Status|Closed  |Open

--- Comment #6 from Alex Kozlov  ---
This function is used in ng_vjc(4) and sppp(4). The issue described in this bug
is still exist.

-- 
You are receiving this mail because:
You are the assignee for the bug.
___
freebsd-net@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscr...@freebsd.org"


[Bug 7556] [ppp] sl_compress_init() will fail if called anything else than -1 or >MAX_STATE

2018-03-13 Thread bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=7556

Eugene Grosbein  changed:

   What|Removed |Added

 CC||eu...@freebsd.org
 Status|In Progress |Closed
 Resolution|--- |Overcome By Events

--- Comment #5 from Eugene Grosbein  ---
sl(4) was removed from FreeBSD before 8.0-RELEASE.

-- 
You are receiving this mail because:
You are the assignee for the bug.
___
freebsd-net@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscr...@freebsd.org"