Expensive timeout(9) function: 0x9ffc000000b59d80(0) 0.060724954 s

2013-10-10 Thread Anton Shterenlikht
I see on the console: lock order reversal: 1st 0xe00012c58a28 ufs (ufs) @ /usr/src/sys/fs/nullfs/null_vnops.c:620 2nd 0x9ffc00c32360 allproc (allproc) @ /usr/src/sys/kern/kern_descrip.c:2780 KDB: stack backtrace: db_trace_self(0x9ffc000c9ec0) at db_trace_self+0x40

gpart weirdness: diskid/DISK-3EV0P4PZ00007250010X GPT (17G)

2013-10-09 Thread Anton Shterenlikht
# gpart show = 34 35566411 da1 GPT (17G) 34 35566411 - free - (17G) = 34 35566411 diskid/DISK-3EV0P4PZ7250010X GPT (17G) 34 35566411- free - (17G) = 34 35566411 da2 GPT (17G) 34 35566411 -

Re: gpart weirdness: diskid/DISK-3EV0P4PZ00007250010X GPT (17G)

2013-10-09 Thread Anton Shterenlikht
From: Mark Felder f...@freebsd.org To: freebsd-questions@freebsd.org Subject: Re: gpart weirdness: diskid/DISK-3EV0P4PZ7250010X GPT (17G) Date: Wed, 09 Oct 2013 06:56:17 -0500 On Wed, Oct 9, 2013, at 4:33, Anton Shterenlikht wrote: # gpart show = 34 35566411 da1 GPT (17G

Re: where to start with PGP/GPG?

2013-08-16 Thread Anton Shterenlikht
From cpgh...@cordula.ws Thu Aug 15 20:20:49 2013 On 08/15/13 14:16, Anton Shterenlikht wrote: I never needed to use pgp till now. So I'm not sure where to start. Is security/gnupg the way to go? Any other advice? security/gnupg + security/pinentry is the way to go. I wonder if pinentry

where to start with PGP/GPG?

2013-08-15 Thread Anton Shterenlikht
I never needed to use pgp till now. So I'm not sure where to start. Is security/gnupg the way to go? Any other advice? Thanks Anton ___ freebsd-questions@freebsd.org mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-questions To

Re: where to start with PGP/GPG?

2013-08-15 Thread Anton Shterenlikht
From tr...@fagskolen.gjovik.no Thu Aug 15 13:28:22 2013 On Thu, 15 Aug 2013 13:16+0100, Anton Shterenlikht wrote: I never needed to use pgp till now. So I'm not sure where to start. Is security/gnupg the way to go? Any other advice? Consider the use of security/pinentry for entering

Re: where to start with PGP/GPG?

2013-08-15 Thread Anton Shterenlikht
From mexas Thu Aug 15 13:16:09 2013 To: freebsd-questions@freebsd.org Subject: where to start with PGP/GPG? Reply-To: me...@bris.ac.uk I never needed to use pgp till now. So I'm not sure where to start. Is security/gnupg the way to go? Any other advice? Answering my own question, this guide

Re: learn

2013-08-01 Thread Anton Shterenlikht
From: Teymur.Rahimzade teymur.rahimz...@gmail.com To: questi...@freebsd.org Subject: learn Date: Thu, 1 Aug 2013 16:35:57 +0500 Hi. Please help me to learn freebsd unix. Many thanks. RTFM: http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/index.html

Re: learn

2013-08-01 Thread Anton Shterenlikht
Date: Thu, 1 Aug 2013 14:29:25 +0200 From: herbert langhans w...@langhans.com.pl To: freebsd-questions@freebsd.org Subject: Re: learn The handbook is a monster, even technically interested people get lost there. You know that, corebug. I completely disagree. The handbook is of excellent quality

LC_CTYPE=fr_FR.ISO8859-1 with xterm - still French accented characters are corrupted

2013-07-17 Thread Anton Shterenlikht
I tried, in tcsh: % setenv |grep FR XTERM_LOCALE=fr_FR.ISO8859-1 LC_CTYPE=fr_FR.ISO8859-1 but the accented French characters are corrupted, e.g. in /usr/ports/french/aster/pkg-descr. I built xterm with % make -C /usr/ports/x11/xterm showconfig === The following configuration options are

SOLVED [WAS: Re: LC_CTYPE=fr_FR.ISO8859-1 with xterm - still French accented characters are corrupted

2013-07-17 Thread Anton Shterenlikht
Date: Wed, 17 Jul 2013 22:57:34 +0200 From: Polytropon free...@edvax.de To: Elimar Riesebieter riese...@lxtec.de Subject: Re: LC_CTYPE=fr_FR.ISO8859-1 with xterm - still French accented characters are corrupted On Wed, 17 Jul 2013 15:38:53 +0200, Elimar Riesebieter wrote: * Anton Shterenlikht

tor browser?

2013-07-16 Thread Anton Shterenlikht
Anybody is using the Tor Browser? I started using security/tor. In addition to this, the tor folk insist on using the tor browser: https://www.torproject.org/download/download#warning which is a part of the tor bundle: https://www.torproject.org/projects/torbrowser-details.html.en#build Now,

highest nice(1) -n increment value?

2013-07-08 Thread Anton Shterenlikht
It is not clear from the nice(1) man page, i.e. for /usr/bin/nice, not a shell built-in nice, what is the highest increment value nice will accept. It seems it is limited to 20. I tried $ /usr/bin/nice -n 100 portmaster -a But all processes spawned by the portmaster have the nice value of only

Re: X client without X server

2013-07-03 Thread Anton Shterenlikht
Date: Wed, 3 Jul 2013 10:55:48 +0700 (ICT) From: Olivier Nicole olivier.nic...@cs.ait.ac.th To: freebsd-questions@freebsd.org Subject: X client without X server Hi, Is there a way to install an X client without automatically install an X

Re: X client without X server

2013-07-03 Thread Anton Shterenlikht
From olivier2...@gmail.com Wed Jul 3 13:09:25 2013 Anton, On Wed, Jul 3, 2013 at 5:47 PM, Anton Shterenlikht me...@bris.ac.uk wrote: Date: Wed, 3 Jul 2013 10:55:48 +0700 (ICT) From: Olivier Nicole olivier.nic...@cs.ait.ac.th

Re: X client without X server

2013-07-03 Thread Anton Shterenlikht
Date: Wed, 3 Jul 2013 08:26:09 -0700 (PDT) From: Bill Tillman btillma...@yahoo.com Subject: Re: X client without X server xterm may not require it [xorg-server], but one of xterm's dependencies may. This is simply not true. xterm does not require

Re: What compiler is used to build a port

2013-07-01 Thread Anton Shterenlikht
Date: Mon, 1 Jul 2013 15:36:46 +0700 (ICT) From: Olivier Nicole olivier.nic...@cs.ait.ac.th To: freebsd-questions@freebsd.org Subject: What compiler is used to build a port Hi, I have a strange situation: 2 machines, 9.1 p4, on the first machine,

Re: What compiler is used to build a port

2013-07-01 Thread Anton Shterenlikht
From olivier.nic...@cs.ait.ac.th Mon Jul 1 12:12:08 2013 I have a strange situation: 2 machines, 9.1 p4, on the first machine, graphicslibfpx build with the stock compiler: $ make === Fetching all distfiles required

installing a kernel under a custom location, not /boot/kernel?

2013-06-17 Thread Anton Shterenlikht
I think there is an option for this. But I cannot find it under 9.5. Building and Installing a Custom Kernel http://www.freebsd.org/doc/handbook/kernelconfig-building.html I need to keep several kernels installed, not just the current and the previous. How to achive this? Thaknks Anton

incomplete PLIST for devel/liblangtag [WAS Re: libchk issue]

2013-06-11 Thread Anton Shterenlikht
On my system (9.1-RELEASE-p3 on amd64), libchk reports: Unresolvable link(s) found in: /usr/local/lib/liblangtag-gobject.so.2 liblangtag.so.1 'pkg which' informs me that: /usr/local/lib/liblangtag-gobject.so.2 was not found in the database

Re: X breaks sound

2013-05-15 Thread Anton Shterenlikht
On Tue, 2013-05-14 at 21:20 +0100, Anton Shterenlikht wrote: Briefly, the sound works fine until X starts. As soon as X starts, sound doesn't work until a reboot. Assumed pulseaudio should be installed, this likely is the culprit, if so, remove

bwn0: RX decryption attempted (old 0 keyidx 0x2)

2013-05-14 Thread Anton Shterenlikht
I have this wireless chip: siba_bwn0@pci0:48:0:0: class=0x028000 card=0x1371103c chip=0x431214e4 rev=0x02 hdr=0x00 vendor = 'Broadcom Corporation' device = 'BCM4311 802.11a/b/g' class = network I use bwn(4) for it: siba_bwn0: Broadcom BCM4312 802.11a/b/g Wireless mem

X breaks sound

2013-05-14 Thread Anton Shterenlikht
Briefly, the sound works fine until X starts. As soon as X starts, sound doesn't work until a reboot. This is HP Compaq 6715s laptop. I'm running current r250633. I have this sound device: hdac0@pci0:0:20:2: class=0x040300 card=0x30c2103c chip=0x43831002 rev=0x00 hdr=0x00 vendor =

Re: Kernel Modules Documentation?

2013-04-30 Thread Anton Shterenlikht
I have a list of about 220 kernel modules and would like to find out what they do, or are for (none has a man page). I suspect that many of them are drivers for particular devices. Is there any resource or documentation available? Thanks. P.S.

Re: Operation timed out with smtp.gmail.com - please help

2013-03-30 Thread Anton Shterenlikht
Date: Fri, 29 Mar 2013 15:36:19 -0400 From: Jerry je...@seibercom.net To: FreeBSD freebsd-questions@freebsd.org Subject: Re: Operation timed out with smtp.gmail.com - please help On Fri, 29 Mar 2013 18:32:34 GMT Anton Shterenlikht articulated

Re: Operation timed out with smtp.gmail.com - please help

2013-03-30 Thread Anton Shterenlikht
Date: Sat, 30 Mar 2013 07:49:19 -0400 From: Jerry je...@seibercom.net To: FreeBSD freebsd-questions@freebsd.org Subject: Re: Operation timed out with smtp.gmail.com - please help On Sat, 30 Mar 2013 10:49:45 + Matthew Seaman articulated:

Operation timed out with smtp.gmail.com - please help

2013-03-29 Thread Anton Shterenlikht
Please help debug sendmail / smtp.gmail config. My University just switched to gmail (dickheads) and I'm trying to figure out how to set it up. It used to work ok with the University smtp auth server. Now I get in /var/log/maillog: sm-mta[72300]: r2TI0vQc072134: to=me...@bris.ac.uk,

Re: stupid portmaster question

2013-03-25 Thread Anton Shterenlikht
How do I tell portmaster -ad to ignore certain ports because they are broken such as editors/libreoffice is currently marked as (I am sure this will change soon) -x avoid building or updating ports that match this pattern. Can be specified more than once.

USB host controllers on a server that does not use USB devices?

2013-03-20 Thread Anton Shterenlikht
This is on an ia64 server. Do I need these devices in kernel: device ehci# EHCI host controller device ohci# OHCI PCI-USB interface device uhci# UHCI PCI-USB interface if I don't ever attach any usb devices to it? Thanks Anton

how to forbid a process to use swap?

2013-03-09 Thread Anton Shterenlikht
I run a program that uses large arrays. I don't want it to use swap, because it's too slow. I want the program to fail when there's not enough RAM, rather than using swap. How to do this? Is it something to do with these kernel variables: kern.dfldsiz: 34359738368 kern.dflssiz: 8388608

Re: how to forbid a process to use swap?

2013-03-09 Thread Anton Shterenlikht
From m.e.sanlit...@gmail.com Sun Mar 10 00:25:27 2013 On Sat, Mar 9, 2013 at 3:55 PM, Anton Shterenlikht me...@bristol.ac.ukwrote: I run a program that uses large arrays. I don't want it to use swap, because it's too slow. I want the program to fail

Re: fetchmail/sendmail: Domain of sender address does not exist

2013-03-08 Thread Anton Shterenlikht
From free...@edvax.de Fri Mar 8 07:50:06 2013 On Thu, 7 Mar 2013 21:55:57 GMT, Anton Shterenlikht wrote: And Matthias already helped me sort it out. Could you write to the list how you solved the problem? http://lists.freebsd.org/pipermail/freebsd-ports/2013

fetchmail/sendmail: Domain of sender address does not exist

2013-03-07 Thread Anton Shterenlikht
I'm running sendmail, and using fetchmail to fetch my mail from the university IMAP server. I sometimes see fetchmail complain: fetchmail: SMTP error: 553 5.1.8 ad...@system.mail... Domain of sender address ad...@system.mail does not exist And this is doubled in /var/log/maillog:

process eating up all memory - what should happen next?

2013-03-07 Thread Anton Shterenlikht
I have a process that eats up al memory, in my case science/paraview if I try to analyse a large model. What should FreeBSD do when a process tries to use all RAM or more? I my case I get a complete freeze, can't even login from the console, and requiring a cold reboot. I guess this is not

Re: fetchmail/sendmail: Domain of sender address does not exist

2013-03-07 Thread Anton Shterenlikht
Date: Thu, 7 Mar 2013 13:48:45 -0700 From: Chad Perrin per...@apotheon.com To: freebsd-questions@freebsd.org Subject: Re: fetchmail/sendmail: Domain of sender address does not exist On Thu, Mar 07, 2013 at 09:40:47AM +, Anton Shterenlikht wrote

Re: cannot ssh into a box with DHCP assigned IP address

2013-02-20 Thread Anton Shterenlikht
From m...@my.gd Wed Feb 20 10:11:12 2013 Run this on your server: tcpdump -ni wlan0 ip and port 22 Then try to ssh to the box, see if SYN packets arrive, see if your box sends SYN/ACK back. 172.21.220.12 is the ssh server 137.222.187.241 is the

Re: cannot ssh into a box with DHCP assigned IP address

2013-02-20 Thread Anton Shterenlikht
From m...@my.gd Wed Feb 20 10:28:54 2013 Ok I think you've got a DNS resolution problem here, so when you try to establish the connection, SSHD tries to resolve your client's hostname. It fails and times out, however your ssh login gracetime is already

Re: cannot ssh into a box with DHCP assigned IP address

2013-02-20 Thread Anton Shterenlikht
: freebsd-questions@freebsd.org On Feb 20, 2013, at 10:28 AM, Anton Shterenlikht me...@bristol.ac.uk wrote: I have a laptop with FreeBSD -current, with ip address assigned via DHCP. The laptop has neither a static ip

Re: cannot ssh into a box with DHCP assigned IP address

2013-02-20 Thread Anton Shterenlikht
From m...@my.gd Wed Feb 20 14:39:34 2013 On Feb 20, 2013, at 2:55 PM, Anton Shterenlikht me...@bristol.ac.uk wrote: From feenb...@nber.org Wed Feb 20 13:39:28 2013 From: Fleuriot Damien m...@my.gd To: me

daily otput: rejected mail hosts?

2013-02-14 Thread Anton Shterenlikht
I see in the daily output: Checking for rejected mail hosts: 172 553 check_mail system.mail exist 129 553 check_mail tsvpt014.vpt.co.uk exist 43 553 check_mail unix.dedicated.com.tr exist 43 553 check_mail ubs.net exist 43 553 check_mail localhost.localdomain exist 43 553 check_mail

Re: which X driver for NVIDIA Quadro FX 570M?

2013-02-11 Thread Anton Shterenlikht
From: paranormal paranor...@isgroup.com.ua Subject: Re: which X driver for NVIDIA Quadro FX 570M? To: freebsd-questions@freebsd.org Date: Wed, 06 Feb 2013 03:23:40 +0200 I have t61p with mentioned card. x11/nvidia-driver works well for me (at least

Re: which X driver for NVIDIA Quadro FX 570M?

2013-02-11 Thread Anton Shterenlikht
From smi...@nimnet.asn.au Mon Feb 11 13:49:38 2013 On Mon, 11 Feb 2013 10:41:31 GMT, Anton Shterenlikht wrote: From: paranormal paranor...@isgroup.com.ua Subject: Re: which X driver for NVIDIA Quadro FX 570M? To: freebsd-questions

Re: which X driver for NVIDIA Quadro FX 570M?

2013-02-11 Thread Anton Shterenlikht
From smi...@nimnet.asn.au Mon Feb 11 16:59:49 2013 On Mon, 11 Feb 2013 14:28:30 GMT, Anton Shterenlikht wrote: From smi...@nimnet.asn.au Mon Feb 11 13:49:38 2013 On Mon, 11 Feb 2013 10:41:31 GMT, Anton Shterenlikht wrote

building custom kernel on -current: unknown option COMPAT_LINUX

2013-02-09 Thread Anton Shterenlikht
This is on amd64 r246552 I added options COMPAT_43 options COMPAT_LINUX options COMPAT_LINUX32 to the kernel config, following sys/amd64/conf/NOTES On buildkernel I get: unknown option COMPAT_LINUX What am I missing? Thanks Anton ___

Re: building custom kernel on -current: unknown option COMPAT_LINUX

2013-02-09 Thread Anton Shterenlikht
From free...@edvax.de Sun Feb 10 00:29:36 2013 On Sun, 10 Feb 2013 00:18:06 GMT, Anton Shterenlikht wrote: This is on amd64 r246552 I added options COMPAT_43 options COMPAT_LINUX options COMPAT_LINUX32

Re: building custom kernel on -current: unknown option COMPAT_LINUX

2013-02-09 Thread Anton Shterenlikht
From free...@edvax.de Sun Feb 10 00:42:11 2013 On Sun, 10 Feb 2013 00:31:44 GMT, Anton Shterenlikht wrote: From free...@edvax.de Sun Feb 10 00:29:36 2013 On Sun, 10 Feb 2013 00:18:06 GMT, Anton Shterenlikht wrote

mount: /dev/da0p1: Invalid argument

2013-02-08 Thread Anton Shterenlikht
I need to transfer some files from sparc64 -current box onto amd64 9.1-RELEASE laptop. The amd64 laptop has no network connection yet, so I'm trying to achive this with a USB flash drive. The problem is that I always end up with # mount /dev/da0p1 /mnt/ mount: /dev/da0p1: Invalid argument #

Re: mount: /dev/da0p1: Invalid argument

2013-02-08 Thread Anton Shterenlikht
From kostik...@gmail.com Fri Feb 8 12:25:21 2013 On Fri, Feb 08, 2013 at 12:01:41PM +, Anton Shterenlikht wrote: I need to transfer some files from sparc64 -current box onto amd64 9.1-RELEASE laptop. The amd64 laptop has no network connection yet

Re: mount: /dev/da0p1: Invalid argument

2013-02-08 Thread Anton Shterenlikht
From ch...@monochrome.org Fri Feb 8 13:27:48 2013 On Fri, 8 Feb 2013, Anton Shterenlikht wrote: [ snip ] So what is the advice for transferring data via USB in such cases? Any other gpart partition I could use? I've always used

Re: mount: /dev/da0p1: Invalid argument

2013-02-08 Thread Anton Shterenlikht
From bon...@mail.r-bonomi.com Fri Feb 8 13:27:49 2013 From: Anton Shterenlikht me...@bristol.ac.uk Subject: Re: mount: /dev/da0p1: Invalid argument From kostik...@gmail.com Fri Feb 8 12:25:21 2013 On Fri, Feb 08, 2013 at 12:01:41PM

Re: mount: /dev/da0p1: Invalid argument

2013-02-08 Thread Anton Shterenlikht
From jnagyjr1...@gmail.com Fri Feb 8 14:47:22 2013 On 02/08/13 07:38, Anton Shterenlikht wrote: From ch...@monochrome.org Fri Feb 8 13:27:48 2013 On Fri, 8 Feb 2013, Anton Shterenlikht wrote: [ snip

which X driver for NVIDIA Quadro FX 570M?

2013-02-03 Thread Anton Shterenlikht
I'm considering buying this Thinkpad T61p laptop: http://www.ebay.co.uk/itm/321063105251 It lists this graphics card: NVIDIA Quadro FX 570M I'm not sure what driver, if any, will support it. There seems to be the official Nvidia FreeBSD driver provided for it:

powerd(8), cpufreq(4) only available on amd64/i386?

2013-01-07 Thread Anton Shterenlikht
I recently installed 9.1-release on a sparc64 box. One of the options in bsdinstall was to use the cpu power control. I chose to use it. So I've got # grep power /etc/rc.conf powerd_enable=YES # which doesn't seem to work: root: /etc/rc: WARNING: failed to start powerd Is the following dmesg

Re: do I need agp(4) on my amd64 laptop

2012-11-25 Thread Anton Shterenlikht
From ill...@gmail.com Sat Nov 24 16:09:29 2012 On 22 November 2012 06:19, Anton Shterenlikht me...@bristol.ac.uk wrote: It is not clear for me from the agp(4) man page, whether I need this device in the kernel or not. The pciconf -lv output is below

Re: do I need agp(4) on my amd64 laptop

2012-11-25 Thread Anton Shterenlikht
From ill...@gmail.com Sat Nov 24 16:09:29 2012 On 22 November 2012 06:19, Anton Shterenlikht me...@bristol.ac.uk wrote: It is not clear for me from the agp(4) man page, whether I need this device in the kernel or not. The pciconf -lv output is below

do I need agp(4) on my amd64 laptop

2012-11-22 Thread Anton Shterenlikht
It is not clear for me from the agp(4) man page, whether I need this device in the kernel or not. The pciconf -lv output is below. Or do I need to show dmesg? Please advise Thanks Anton hostb0@pci0:0:0:0: class=0x06 card=0x30c2103c chip=0x79101002 rev=0x00 hdr=0x00 vendor =

Re: csup to svn

2012-11-21 Thread Anton Shterenlikht
Date: Wed, 21 Nov 2012 11:10:28 -0500 From: Fbsd8 fb...@a1poweruser.com I use packages for all my ports. But some times I have to use ports make files because I need to change the default configuration. I use a custom csup script to just download

Re: csup to svn

2012-11-21 Thread Anton Shterenlikht
From fb...@a1poweruser.com Wed Nov 21 17:57:51 2012 Anton Shterenlikht wrote: Date: Wed, 21 Nov 2012 11:10:28 -0500 From: Fbsd8 fb...@a1poweruser.com I use packages for all my ports. But some times I have to use

Re: BIOS update saga - the end

2012-11-13 Thread Anton Shterenlikht
From lenzi.ser...@gmail.com Tue Nov 13 16:17:49 2012 That is one of the reasons I stop buying HP products specially laptops.. and sony vaio as well.. the last one I have is a z6000 that is still working very well with FreeBSD10. HP notebooks are

BIOS update saga - the end

2012-11-04 Thread Anton Shterenlikht
I can't find my original thread, so starting a new one. So I bought a spare laptop disk, installed freedos on it, made a usb memstick with HP BIOS updating executable, and booted from it, only to stop at: The BIOS on your notebook PC can not be updated. Refer to HP Customer Advisory C01457784

Re: laptop with no BIOS? or BIOS reflash pain

2012-11-01 Thread Anton Shterenlikht
Date: Tue, 30 Oct 2012 21:28:22 +0100 Subject: Re: laptop with no BIOS? or BIOS reflash pain From: Idwer Vollering vid...@gmail.com To: freebsd-questions@freebsd.org, flash...@flashrom.org Another approach is to use an external SPI programmer:

Re: laptop with no BIOS? or BIOS reflash pain

2012-10-30 Thread Anton Shterenlikht
Date: Mon, 29 Oct 2012 15:44:19 -0700 (PDT) From: Jakub Lach jakub_l...@mailplus.pl To: freebsd-questions@freebsd.org Subject: Re: laptop with no BIOS? or BIOS reflash pain More civilised notebook manufactures usually provide also self booting (CD)

how to disable page breaks in line printer

2012-10-30 Thread Anton Shterenlikht
I need to print some text on a continuous paper with no page breaks. How to do this? I've epson lq-550 matrix printer attached via a parallel cable, and lp|local line printer:\ :sh:\ :lp=/dev/lpt0:\ :sd=/var/spool/output/lpd:\ :lf=/var/log/lpd-errs:\

Re: how to disable page breaks in line printer

2012-10-30 Thread Anton Shterenlikht
From at...@sohara.org Tue Oct 30 11:54:11 2012 I thought from reading printcap(5) that pl sets page length is lines, so if I make it long enough, I should see no page breaks. Still, I get empty space at the bottom of the physical page

Re: laptop with no BIOS? or BIOS reflash pain

2012-10-25 Thread Anton Shterenlikht
From cpgh...@cordula.ws Thu Oct 25 03:40:28 2012 Heh... ;-) (U)EFI is nothing new for us old farts: we've had OpenBoot[1] on Sun hardware for ages, and even though it didn't limit us w.r.t. the OS you wanted to boot (that's why you can install

Re: laptop with no BIOS? or BIOS reflash pain

2012-10-25 Thread Anton Shterenlikht
From br...@cran.org.uk Thu Oct 25 09:22:33 2012 On 25 Oct 2012, at 08:52, Anton Shterenlikht me...@bristol.ac.uk wrote: I'm probably missing something here. ia64 uses EFI, but there's nothing about checking for non-signed code. I can boot VMS

laptop with no BIOS? or BIOS reflash pain

2012-10-19 Thread Anton Shterenlikht
I've HP compaq 6715s laptop. It's all right with 10-current. I've got wireless and at one point I even managed to get flash working. My problem is with BIOS. Apparently it's wrong and John Baldwin provided me with a pci.c patch to get it to boot. There is an updated BIOS version, but so far I

Re: Info 2 Release

2012-10-10 Thread Anton Shterenlikht
From: andrew clarke m...@ozzmosis.com PS. This is an English-speaking mailing list. What's the problem? If there are non-english posts and non-english helpful replies, who suffers? You and me can just ignore those, like we ignore OT, right? Anton

suggest pdf viewer for pdf version 1.6 with annotations

2012-10-03 Thread Anton Shterenlikht
I got sent a pdf file, version 1.6, with annotations. xpdf can view the file, but not the annotations. Please suggest a pdf viewer from ports that might help. Thanks Anton ___ freebsd-questions@freebsd.org mailing list

Re: suggest pdf viewer for pdf version 1.6 with annotations

2012-10-03 Thread Anton Shterenlikht
From erichfreebsdl...@ovitrap.com Wed Oct 3 09:53:17 2012 Hi, On Wed, 3 Oct 2012 08:50:16 +0100 (BST) Anton Shterenlikht me...@bristol.ac.uk wrote: I got sent a pdf file, version 1.6, with annotations. xpdf can view the file

where is all terminal output sent if the controlling terminal is closed?

2012-08-30 Thread Anton Shterenlikht
I occasionally build ports with extra logs enabled. When I then launch such programs from, say xterm on the background (), I get lots of output on the controlling terminal. If I then close the terminal, where does all the output goes? I presume it's still being sent to the PID of the parent xterm.

reduce priority of large port builds, e.g. firefox, gcc4x

2012-08-29 Thread Anton Shterenlikht
Is it possible to reduce priority of port building processes with something like nice +19 make (tcsh syntax)? Here's a typical scenario for a large build (actually building gcc-4.7 and firefox in parallel): last pid: 54736; load averages: 5.27, 5.38, 5.11up

Re: reduce priority of large port builds, e.g. firefox, gcc4x

2012-08-29 Thread Anton Shterenlikht
From owner-freebsd-questi...@freebsd.org Wed Aug 29 16:52:53 2012 Is it possible to reduce priority of port building processes with something like nice +19 make (tcsh syntax)? Sure, I do it all the time. ok, thanks. I'll try it next time. Anton

mail, mpack and aliases

2012-08-24 Thread Anton Shterenlikht
I'm trying to use converters/mpack to send attachments. It doesn't seem to know anything about mail(1) aliases. I tried to save mpack output to a file with -o option, and then read this file into a mail message, e.g. with ~r. However, this doesn't seem to work. The attachment is not recognised as

subvertion treat PostScript files as binary?

2012-08-22 Thread Anton Shterenlikht
Why does subversion treats PostScript files as binary? I changed the bounding box in a text editor, but can't use svn diff: TZAV svn diff rep-room-mises-mesh.ps Index: rep-room-mises-mesh.ps === Cannot display: file marked as a

mail(1) ~R and REPLYTO

2012-08-20 Thread Anton Shterenlikht
mail(1) man page says: ~R string Use string as the Reply-To field. However, this doesn't seem to work for me. Hitting ~R doesn't have any effect at all. The man page also has: REPLYTO If set, will be used to initialize the Reply-To field for outgo- ing

Mail Reference Manual?

2012-07-31 Thread Anton Shterenlikht
mail(1) man page mentions the Mail Reference Manual. The only one I can find is here: docs.freebsd.org/44doc/usd/07.mail/paper.pdf Is this the one? The URL isn't that definitive. It seems to be in troff. Anybody got the sources of this document? Anyway, the description of the save command in this

Re: mail(1) save command does not work as in the man page

2012-07-26 Thread Anton Shterenlikht
From bon...@mail.r-bonomi.com Thu Jul 26 02:58:29 2012 Date: Wed, 25 Jul 2012 19:37:47 -0500 (CDT) From: Robert Bonomi bon...@mail.r-bonomi.com To: freebsd-questions@freebsd.org, me...@bristol.ac.uk Subject: Re: mail(1) save command does not work as in the

mail(1) save command does not work as in the man page

2012-07-25 Thread Anton Shterenlikht
According to the man mail(1): save(s) Takes a message list and a filename and appends each message in turn to the end of the file. The filename in quotes, followed by the line count and character count is echoed on the user's terminal. However, it

Re: how to speed up port make??

2012-07-25 Thread Anton Shterenlikht
is it possible to speed up port make ?? i want to install openbox and xorg on a Pentium 4 and 2gb ram, compiling xorg takes about 2 hours 2 hours only?? Try lang/gcc46 or 47 or science/paraview This will keep your electronic helper busy for a day.

fetchmail ssl error

2012-07-23 Thread Anton Shterenlikht
and usually is available, DER is another one; you can convert between both using the openssl(1) utility's x509 sub-mode). *end quote* So, I'm not sure if I need to convert my certificate to PEM format or not? Please advise Many thanks -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept

zfs tuning on ia64

2012-07-19 Thread Anton Shterenlikht
vm.kmem_size_scale: 4 vm.kmem_size_max: 0 vm.kmem_size_min: 0 vm.kmem_size: 1578090496 # Do the vm.kmem tunables look reasonable? Thanks -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423

how to preserve local modifications to /usr/local/share/texmf/web2c/texmf.cnf

2012-07-16 Thread Anton Shterenlikht
to inimfmp TZAV but this doesn't help. Please advise -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423 ___ freebsd-questions@freebsd.org

where is LOCALBASE actually defined?

2012-07-15 Thread Anton Shterenlikht
$ cat Makefile all: echo $(LOCALBASE) $ $ make echo $ What do I need to do to use LOCALBASE in my makefiles? Thanks -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423

Re: where is LOCALBASE actually defined?

2012-07-15 Thread Anton Shterenlikht
On Sun, Jul 15, 2012 at 03:06:14PM -0700, Eitan Adler wrote: On 15 July 2012 14:47, Anton Shterenlikht me...@bristol.ac.uk wrote: $ cat Makefile all: echo $(LOCALBASE) $ $ make echo easier way to test is make -V LOCALBASE What do I need to do to use LOCALBASE in my

ati, radeon, dri (drm) confusion

2012-07-15 Thread Anton Shterenlikht
.html -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423 ___ freebsd-questions@freebsd.org mailing list http://lists.freebsd.org/mailman

Re: profiling library smaller than non-profiling, while it contains more symbols. Why?

2012-07-13 Thread Anton Shterenlikht
On Thu, Jul 12, 2012 at 09:12:32PM -0500, Robert Bonomi wrote: From owner-freebsd-questi...@freebsd.org Thu Jul 12 17:34:12 2012 Date: Thu, 12 Jul 2012 23:31:31 +0100 From: Anton Shterenlikht me...@bristol.ac.uk To: freebsd-questions@freebsd.org Subject: profiling library smaller than

Re: profiling library smaller than non-profiling, while it contains more symbols. Why?

2012-07-13 Thread Anton Shterenlikht
aa.f *skip ~1400 other files* gfortran46 -fpic -DPIC -O -Wl,-rpath=/usr/local/lib/gcc46 -o zwrsk.So -c zwrsk.f building shared library libslatec.so.1 -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944

profiling library smaller than non-profiling, while it contains more symbols. Why?

2012-07-12 Thread Anton Shterenlikht
17885 # Using diff I can confirm that the only difference between the 2 libs is the .mcount symbol for each object file in the profiling library. So how can the profiling library be smaller? -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk

Re: profiling library smaller than non-profiling, while it contains more symbols. Why?

2012-07-12 Thread Anton Shterenlikht
On Thu, Jul 12, 2012 at 11:31:31PM +0100, Anton Shterenlikht wrote: While updating my port (math/slatec) to use the new OPTIONS framework, I did some experiments with the profiling library. I don't know much about this, so what surprised me is that the profiling library is smaller: # ls

X broken - top quarter of the screen not updated by *some* programs - EXA/XAA issue?

2012-06-20 Thread Anton Shterenlikht
extended input device Keyboard0 (type: KEYBOARD) -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423 ___ freebsd-questions@freebsd.org mailing

Re: can't kill -9 Xorg

2012-06-12 Thread Anton Shterenlikht
On 11-Jun-2012, at 5:01 PM, Anton Shterenlikht wrote: My X is unusable since the recent png update. This is r236740M on HP Compaq 6715s amd64 laptop. I've no hal installed (if this matters). # pkg info -x xorg linux-f10-xorg-libs-7.4_1 Xorg libraries (Linux Fedora 10

Re: can't kill -9 Xorg

2012-06-12 Thread Anton Shterenlikht
On Tue, Jun 12, 2012 at 09:13:06AM +0100, Anton Shterenlikht wrote: On Tue, Jun 12, 2012 at 12:07:06AM +0530, Subhro Sankha Kar wrote: Hello What happens if you run without a xorg.conf? Xorg has become pretty good at guessing correct settings these days. No change. I removed /etc

Re: can't kill -9 Xorg

2012-06-12 Thread Anton Shterenlikht
On Tue, Jun 12, 2012 at 02:13:17PM +0200, Hans Ottevanger wrote: On 06/12/12 10:24, Anton Shterenlikht wrote: On Tue, Jun 12, 2012 at 09:13:06AM +0100, Anton Shterenlikht wrote: On Tue, Jun 12, 2012 at 12:07:06AM +0530, Subhro Sankha Kar wrote: Hello What happens if you run without

can't kill -9 Xorg

2012-06-11 Thread Anton Shterenlikht
recover is reboot. Please advise. -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423 ___ freebsd-questions@freebsd.org mailing list

Re: MK_CLANG_IS_CC mis-formed when compiling ports

2012-06-01 Thread Anton Shterenlikht
SENDMAIL_LDADD+=-lsasl2 PERL_VERSION=5.14.2 WITH_PKGNG=yes #CC=clang #CXX=clang++ #CPP=clang-cpp GEN8 I have no problems when building bwn-firmware-kmod. -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117

netstat: kvm_read: Bad address

2012-06-01 Thread Anton Shterenlikht
On ia64 r231193 I get: # netstat -r netstat: kvm_read: Bad address What's the problem? Thanks -- Anton Shterenlikht Room 2.6, Queen's Building Mech Eng Dept Bristol University University Walk, Bristol BS8 1TR, UK Tel: +44 (0)117 331 5944 Fax: +44 (0)117 929 4423

Re: netstat: kvm_read: Bad address

2012-06-01 Thread Anton Shterenlikht
On Fri, Jun 01, 2012 at 01:30:37PM +0300, Volodymyr Kostyrko wrote: Anton Shterenlikht wrote: On ia64 r231193 I get: # netstat -r netstat: kvm_read: Bad address What's the problem? Thanks For jail environment this means that /dev is not mounted. I'm sure I've got /dev mounted

Re: mercurial (hg) transaction abort!

2012-05-31 Thread Anton Shterenlikht
On Wed, May 30, 2012 at 01:40:00PM +0100, Anton Shterenlikht wrote: On Wed, May 30, 2012 at 01:08:07PM +0200, uki wrote: Did you try to hg clone -U and than update? Mozilla repo is quite big, and that _might_ be the reason, splitting the work in 2 parts will help if that was the cause

Re: mercurial (hg) transaction abort!

2012-05-31 Thread Anton Shterenlikht
On Thu, May 31, 2012 at 09:47:06AM +0100, Anton Shterenlikht wrote: On Wed, May 30, 2012 at 01:40:00PM +0100, Anton Shterenlikht wrote: On Wed, May 30, 2012 at 01:08:07PM +0200, uki wrote: Did you try to hg clone -U and than update? Mozilla repo is quite big, and that _might_

  1   2   3   4   5   6   >