Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-03 Thread Lucas (a.k.a T-Bird or bsdfan3)

I will try reflashing the BIOS with the latest ROMpaq.

[EMAIL PROTECTED] wrote:

On 01/06/07, Lucas (a.k.a T-Bird or bsdfan3) [EMAIL PROTECTED] 
wrote:



Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5
state, shutdown -r or -p).  How do I fix this?



In my experience most of the stuff built around the
AMD k6 junk (circa 1998) had horrible ACPI support,
nonstandard and incomplete, where possible.  I have
a lurking suspicion that they advertised these things
as only working correctly under winders (Optimised
for Windows 98! Now with nearly intel compliant MMX!).
A bios upgrade _might_ solve it.
A lot of those older machines (supposedly) support apm,
so fiddling with apm(8) might give some answers.
You might have to load the module or uncomment the
device apm line and recompile your kernel.


___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-03 Thread Lucas (a.k.a T-Bird or bsdfan3)
Well, turning securelevel completely off in /etc/rc.conf fixed X, or 
sort of.   X will start up in 800x600 (which is the LCD's native 
resolution) using the vesa driver; but, when I try the trident driver, 
it refuses to run at 800x600 and tries 640x480 instead, which the LCD 
doesn't like.  Results: a black screen.  Any idea on how to fix this one?


magikman wrote:


Lucas (a.k.a T-Bird or bsdfan3) wrote:


Securelevel == 1 and thanks for the answer to the fourth question

magikman wrote:


Lucas (a.k.a T-Bird or bsdfan3) wrote:


Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5 
state, shutdown -r or -p).  How do I fix this?
2) X gives me errors about not being able to open /dev/mem and 
/dev/io such as Operation not allowed.  This occurs both when X 
is started directly as root and from xdm run from /etc/ttys.  
Again, how do I fix this?
3) Does anyone know if this machine supports S4BIOS?  It lists S4 
as a supported sleep state, but the hw.acpi.s4bios sysctl prints as 0.

4) How do you set sysctl tunables at boot time?

Please CC me, as I am not subscribed to the list.
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]



1) I am not sure.
2) What secure you need to check your secure level.
3) I am not sure.
4) /etc/sysctl.conf





___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]


Drop the level down to 0.



___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-02 Thread [EMAIL PROTECTED]

On 01/06/07, Lucas (a.k.a T-Bird or bsdfan3) [EMAIL PROTECTED] wrote:

Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5
state, shutdown -r or -p).  How do I fix this?


In my experience most of the stuff built around the
AMD k6 junk (circa 1998) had horrible ACPI support,
nonstandard and incomplete, where possible.  I have
a lurking suspicion that they advertised these things
as only working correctly under winders (Optimised
for Windows 98! Now with nearly intel compliant MMX!).
A bios upgrade _might_ solve it.
A lot of those older machines (supposedly) support apm,
so fiddling with apm(8) might give some answers.
You might have to load the module or uncomment the
device apm line and recompile your kernel.

--
--
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-01 Thread magikman

Lucas (a.k.a T-Bird or bsdfan3) wrote:

Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5 
state, shutdown -r or -p).  How do I fix this?
2) X gives me errors about not being able to open /dev/mem and /dev/io 
such as Operation not allowed.  This occurs both when X is started 
directly as root and from xdm run from /etc/ttys.  Again, how do I fix 
this?
3) Does anyone know if this machine supports S4BIOS?  It lists S4 as a 
supported sleep state, but the hw.acpi.s4bios sysctl prints as 0.

4) How do you set sysctl tunables at boot time?

Please CC me, as I am not subscribed to the list.
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]

1) I am not sure.
2) What secure you need to check your secure level.
3) I am not sure.
4) /etc/sysctl.conf


___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-01 Thread Lucas (a.k.a T-Bird or bsdfan3)

Securelevel == 1 and thanks for the answer to the fourth question

magikman wrote:


Lucas (a.k.a T-Bird or bsdfan3) wrote:


Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5 
state, shutdown -r or -p).  How do I fix this?
2) X gives me errors about not being able to open /dev/mem and 
/dev/io such as Operation not allowed.  This occurs both when X is 
started directly as root and from xdm run from /etc/ttys.  Again, how 
do I fix this?
3) Does anyone know if this machine supports S4BIOS?  It lists S4 as 
a supported sleep state, but the hw.acpi.s4bios sysctl prints as 0.

4) How do you set sysctl tunables at boot time?

Please CC me, as I am not subscribed to the list.
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]


1) I am not sure.
2) What secure you need to check your secure level.
3) I am not sure.
4) /etc/sysctl.conf





___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-01 Thread magikman

Lucas (a.k.a T-Bird or bsdfan3) wrote:

Securelevel == 1 and thanks for the answer to the fourth question

magikman wrote:


Lucas (a.k.a T-Bird or bsdfan3) wrote:


Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5 
state, shutdown -r or -p).  How do I fix this?
2) X gives me errors about not being able to open /dev/mem and 
/dev/io such as Operation not allowed.  This occurs both when X is 
started directly as root and from xdm run from /etc/ttys.  Again, 
how do I fix this?
3) Does anyone know if this machine supports S4BIOS?  It lists S4 as 
a supported sleep state, but the hw.acpi.s4bios sysctl prints as 0.

4) How do you set sysctl tunables at boot time?

Please CC me, as I am not subscribed to the list.
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]


1) I am not sure.
2) What secure you need to check your secure level.
3) I am not sure.
4) /etc/sysctl.conf





___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]

Drop the level down to 0.
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Multiple issues (FreeBSD 6.2 RELEASE)

2007-06-01 Thread Lucas (a.k.a T-Bird or bsdfan3)
I tried changing securelevel to 0 in /etc/rc.conf and init changed it to 
1 against my will. :(


Relevant error/warning messages:
(WW) checkDevMem: failed to open /dev/mem (Operation not permitted)
(WW) xf86EnableIO: Failed to open /dev/io for extended I/O ((at two 
different points))

then finally
(EE) No devices detected

magikman wrote:


Lucas (a.k.a T-Bird or bsdfan3) wrote:


Securelevel == 1 and thanks for the answer to the fourth question

magikman wrote:


Lucas (a.k.a T-Bird or bsdfan3) wrote:


Hardware: Compaq Presario 1200-XL118
AMD K6-2 500MHz
64MB of RAM
Trident CyberBlade i7 video with 4MB shared RAM
6GB ATA66 HD
Linksys 10/100 PCCard Ethernet (using ed driver)

OS: FreeBSD 6.2-RELEASE using GENERIC kernel

Issues:
1) The machine will not turn off when I try to soft-off it (ACPI S5 
state, shutdown -r or -p).  How do I fix this?
2) X gives me errors about not being able to open /dev/mem and 
/dev/io such as Operation not allowed.  This occurs both when X 
is started directly as root and from xdm run from /etc/ttys.  
Again, how do I fix this?
3) Does anyone know if this machine supports S4BIOS?  It lists S4 
as a supported sleep state, but the hw.acpi.s4bios sysctl prints as 0.

4) How do you set sysctl tunables at boot time?

Please CC me, as I am not subscribed to the list.
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]



1) I am not sure.
2) What secure you need to check your secure level.
3) I am not sure.
4) /etc/sysctl.conf





___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to 
[EMAIL PROTECTED]


Drop the level down to 0.



___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]