Re: Spamassassin not working after update of Perl

2011-06-24 Thread Jos Chrispijn

Hi Damien,

What I don't understand is that if I already are on 15.4 and there is an 
update to 15.4.1 I have to perform always a 'portupgrade -fr perl' to 
have this work?
Normally this only goes for 15.3 to 15.4 (full version upgrade) or do I 
miss something here?


Thanks for your help
Jos Chrispijn

Damien Fleuriot:

On 6/23/11 3:51 PM, Jos Chrispijn wrote:

I have updated my Perl version yesterday but now my Spamd doesn't work
anymore.
Can someone hint me how to solve this?

thanks,
Jos Chrispijn

Pls see output:

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamassassin line 80.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.
ClamAV update process started at Thu Jun 23 15:43:00 2011
main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder:
sven)
daily.cld is up to date (version: 13231, sigs: 130699, f-level: 60,
builder: arnaud)
bytecode.cld is up to date (version: 143, sigs: 40, f-level: 60,
builder: edwin)
spamd not running? (check /var/run/spamd/spamd.pid).
Starting spamd.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamd line 85.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamassassin line 80.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.

--- cut ---
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to
freebsd-questions-unsubscr...@freebsd.org





Just to make really sure, did you check for any 

Re: Spamassassin not working after update of Perl

2011-06-24 Thread Jos Chrispijn
So true. I have processed as you suggested and will follow that + the 
UPDATING suggestion as well in future.
Just got on wrong track that this scenario should be used with 5.14 to 
5.14.x as well.


FYI:
After running

sa-update -D
sa-update --nogpg
spamassassin --lint -D
freshclam

I got at the end a warning, saying:
warn: Use of uninitialized value $opt{syslog-socket} in lc at 
/usr/local/bin/spamd line 44


Found out that this is a minor thing and fixed *in* 3.3.2 and *in* trunk.

BR,
Jos Chrispijn

Damien Fleuriot:

Normally, any special care to be taken while upgrading your port should
be noted in UPDATING.

However, it's always prudent to rebuild dependencies when upgrading a
port, because you never know what changed (unless you take the time to
check the changelog + source code).


On 6/24/11 12:33 PM, Jos Chrispijn wrote:

Hi Damien,

What I don't understand is that if I already are on 15.4 and there is an
update to 15.4.1 I have to perform always a 'portupgrade -fr perl' to
have this work?
Normally this only goes for 15.3 to 15.4 (full version upgrade) or do I
miss something here?

Thanks for your help
Jos Chrispijn

Damien Fleuriot:

On 6/23/11 3:51 PM, Jos Chrispijn wrote:

I have updated my Perl version yesterday but now my Spamd doesn't work
anymore.
Can someone hint me how to solve this?

thanks,
Jos Chrispijn

Pls see output:

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamassassin line 80.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line
80.
ClamAV update process started at Thu Jun 23 15:43:00 2011
main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder:
sven)
daily.cld is up to date (version: 13231, sigs: 130699, f-level: 60,
builder: arnaud)
bytecode.cld is up to date (version: 143, sigs: 40, f-level: 60,
builder: edwin)
spamd not running? (check /var/run/spamd/spamd.pid).
Starting spamd.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamd line 85.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.
Compilation failed in 

Re: Spamassassin not working after update of Perl

2011-06-24 Thread Jos Chrispijn
So true. I have processed as you suggested and will follow that + the 
UPDATING suggestion as well in future.
Just got on wrong track that this scenario should be used with 5.14 to 
5.14.x as well.


FYI:
After running

sa-update -D
sa-update --nogpg
spamassassin --lint -D
freshclam

I got at the end a warning, saying:
warn: Use of uninitialized value $opt{syslog-socket} in lc at 
/usr/local/bin/spamd line 44


Found out that this is a minor thing and fixed *in* 3.3.2 and *in* trunk.

BR,
Jos Chrispijn

Damien Fleuriot:

Normally, any special care to be taken while upgrading your port should
be noted in UPDATING.

However, it's always prudent to rebuild dependencies when upgrading a
port, because you never know what changed (unless you take the time to
check the changelog + source code).


On 6/24/11 12:33 PM, Jos Chrispijn wrote:

Hi Damien,

What I don't understand is that if I already are on 15.4 and there is an
update to 15.4.1 I have to perform always a 'portupgrade -fr perl' to
have this work?
Normally this only goes for 15.3 to 15.4 (full version upgrade) or do I
miss something here?

Thanks for your help
Jos Chrispijn

Damien Fleuriot:

On 6/23/11 3:51 PM, Jos Chrispijn wrote:

I have updated my Perl version yesterday but now my Spamd doesn't work
anymore.
Can someone hint me how to solve this?

thanks,
Jos Chrispijn

Pls see output:

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamassassin line 80.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line
80.
ClamAV update process started at Thu Jun 23 15:43:00 2011
main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder:
sven)
daily.cld is up to date (version: 13231, sigs: 130699, f-level: 60,
builder: arnaud)
bytecode.cld is up to date (version: 143, sigs: 40, f-level: 60,
builder: edwin)
spamd not running? (check /var/run/spamd/spamd.pid).
Starting spamd.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamd line 85.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
line 25.
Compilation failed in 

Re: Spamassassin not working after update of Perl

2011-06-23 Thread Damien Fleuriot
On 6/23/11 3:51 PM, Jos Chrispijn wrote:
 I have updated my Perl version yesterday but now my Spamd doesn't work
 anymore.
 Can someone hint me how to solve this?
 
 thanks,
 Jos Chrispijn
 
 Pls see output:
 
 Can't locate Net/DNS.pm in @INC (@INC contains:
 /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
 /usr/local/lib/perl5/site_perl/5.14.1/mach
 /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
 /usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
 BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.
 
 Can't locate Net/DNS.pm in @INC (@INC contains:
 /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
 /usr/local/lib/perl5/site_perl/5.14.1/mach
 /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
 /usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
 BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.
 
 Can't locate NetAddr/IP.pm in @INC (@INC contains:
 /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
 /usr/local/lib/perl5/site_perl/5.14.1/mach
 /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
 /usr/local/lib/perl5/5.14.1) at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
 
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
 Compilation failed in require at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
 Compilation failed in require at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
 Compilation failed in require at /usr/local/bin/spamassassin line 80.
 BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.
 ClamAV update process started at Thu Jun 23 15:43:00 2011
 main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder:
 sven)
 daily.cld is up to date (version: 13231, sigs: 130699, f-level: 60,
 builder: arnaud)
 bytecode.cld is up to date (version: 143, sigs: 40, f-level: 60,
 builder: edwin)
 spamd not running? (check /var/run/spamd/spamd.pid).
 Starting spamd.
 
 Can't locate NetAddr/IP.pm in @INC (@INC contains:
 /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
 /usr/local/lib/perl5/site_perl/5.14.1/mach
 /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
 /usr/local/lib/perl5/5.14.1) at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
 
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
 Compilation failed in require at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
 Compilation failed in require at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
 Compilation failed in require at /usr/local/bin/spamd line 85.
 BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.
 
 Can't locate NetAddr/IP.pm in @INC (@INC contains:
 /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
 /usr/local/lib/perl5/site_perl/5.14.1/mach
 /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
 /usr/local/lib/perl5/5.14.1) at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
 
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
 Compilation failed in require at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
 Compilation failed in require at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
 BEGIN failed--compilation aborted at
 /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
 Compilation failed in require at /usr/local/bin/spamassassin line 80.
 BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.
 
 --- cut ---
 ___
 freebsd-questions@freebsd.org mailing list
 http://lists.freebsd.org/mailman/listinfo/freebsd-questions
 To unsubscribe, send any mail to
 freebsd-questions-unsubscr...@freebsd.org





Just to make really sure, did you check for any notes in UPDATING
regarding perl ?

Also, have you run perl-after-update ?
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To 

Re: Spamassassin not working after update of Perl

2011-06-23 Thread Matthew Seaman
On 23/06/2011 14:55, Damien Fleuriot wrote:
 I have updated my Perl version yesterday but now my Spamd doesn't work
 anymore.
 Can someone hint me how to solve this?

You need to reinstall all perl modules if you upgrade perl from 5.10.x
or 5.12.x to 5.14.1.  This is explained in UPDATING.

If you do it right, there should be pretty much nothing left in
/usr/local/lib/perl5/5.X.Y where 5.X.Y is the version you're upgrading
from.  Specifically reinstall p5-NetAddr-IP and p5-Net-DNS

Cheers,

Matthew

-- 
Dr Matthew J Seaman MA, D.Phil.   7 Priory Courtyard
  Flat 3
PGP: http://www.infracaninophile.co.uk/pgpkey Ramsgate
JID: matt...@infracaninophile.co.uk   Kent, CT11 9PW



signature.asc
Description: OpenPGP digital signature


Re: Spamassassin not working after update of Perl

2011-06-23 Thread Damien Fleuriot
On 23 Jun 2011, at 21:37, Matthew Seaman m.sea...@infracaninophile.co.uk 
wrote:

 On 23/06/2011 14:55, Damien Fleuriot wrote:
 I have updated my Perl version yesterday but now my Spamd doesn't work
 anymore.
 Can someone hint me how to solve this?
 
 You need to reinstall all perl modules if you upgrade perl from 5.10.x
 or 5.12.x to 5.14.1.  This is explained in UPDATING.
 
 If you do it right, there should be pretty much nothing left in
 /usr/local/lib/perl5/5.X.Y where 5.X.Y is the version you're upgrading
 from.  Specifically reinstall p5-NetAddr-IP and p5-Net-DNS
 
Cheers,
 
Matthew
 
 -- 
 Dr Matthew J Seaman MA, D.Phil.   7 Priory Courtyard
  Flat 3
 PGP: http://www.infracaninophile.co.uk/pgpkey Ramsgate
 JID: matt...@infracaninophile.co.uk   Kent, CT11 9PW
 


You're totally misquoting me as I'm not the OP but I'll live 
;)___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to freebsd-questions-unsubscr...@freebsd.org


Re: Spamassassin not working

2007-05-22 Thread Chris Slothouber
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

On 2007-05-22 06:45, [EMAIL PROTECTED] wrote:
 I have installed Spamaassassin along with amavisd-new to filter spam, but
 I don't think it is working. I am getting a bunch of spam and spamassassin
 is not tagging it as spam. I have the score set at 3.0. It worked before
 on my old box but when I installed it on a new box using the same
 procedure I used on the old box it is not working. Anyone have any ideas?

What MTA are you using?  What method are you using to forward messages
between the MTA and amavisd-new?

Have you copied the appropriate plug-in .cf files for SA into
`/usr/local/etc/mail/spamassassin`?  Are the plugins being loaded in
`/usr/local/etc/mail/spamassassin/init.pre`?

- --
Chris Slothouber ([EMAIL PROTECTED]) -=- Mercenary Sysadmin
BIZ: http://www.hier7.com -=- building.better.ideas
PGP: 7A83 F021 5AC3 4BD7 6738 21D8 B348 0B16 79C0 C27F
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGUtm3s0gLFnnAwn8RAhd1AJ4q3O9+soBroig7IIQX/JZcV1rjgwCgtIwQ
Q8xnkFNKMoxCoJAtEIwrBcU=
=jkdF
-END PGP SIGNATURE-
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Spamassassin not working

2007-05-22 Thread betts
What MTA are you using?
Postfix

What method are you using to forward messages
between the MTA and amavisd-new?
This is part of the main.cf

smtp-amavis unix -  -   y   -   2  smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes
-o disable_dns_lookups=yes
-o max_use=20

127.0.0.1:10025 inet n  -   n   -   -  smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_delay_reject=no
-o smtpd_client_restrictions=permit_mynetworks,reject
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,reject
-o smtpd_data_restrictions=reject_unauth_pipelining
-o smtpd_end_of_data_restrictions=
-o mynetworks=127.0.0.0/8
-o smtpd_error_sleep_time=0
-o smtpd_soft_error_limit=1001
-o smtpd_hard_error_limit=1000
-o smtpd_client_connection_count_limit=0
-o smtpd_client_connection_rate_limit=0

Have you copied the appropriate plug-in .cf files for SA into
`/usr/local/etc/mail/spamassassin`?  Are the plugins being loaded in
`/usr/local/etc/mail/spamassassin/init.pre`?

I don't see any plugins in that directory. Where would I find those
plugins or do I need to reinstall spamassassin with amavis-new?

Thanks



___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]


Re: Spamassassin not working

2007-05-22 Thread Olivier Nicole
 I have installed Spamaassassin along with amavisd-new to filter spam, but
 I don't think it is working. I am getting a bunch of spam and spamassassin
 is not tagging it as spam. I have the score set at 3.0. It worked before
 on my old box but when I installed it on a new box using the same
 procedure I used on the old box it is not working. Anyone have any ideas?

I have about 1000 of ideas, so we need to narrow down the problem.

First thing would be to tell us if SpamAssassin is working at all or
not: are the messages tagged by SA but all are under 3.0 or they are
not tagged at all?

Did you try to run a message throught SA by hand, using the command
spamassassin? Are you running SA daemon, do you have spamd running?
Did you try to feed a message to spand?

Olivier
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [EMAIL PROTECTED]