Re: freebsd 10.0 not work carp protocol on Hyper-v

2014-03-04 Thread Mark Felder
Did you try to enable spoofing of MAC Addresses in HyperV? http://vbry21.wordpress.com/2012/07/03/fixed-in-a-tick-solving-mulicast-issues-in-hyper-v-vms/ ___ freebsd-virtualization@freebsd.org mailing list

Re: freebsd 10.0 not work carp protocol on Hyper-v

2014-03-04 Thread Giovanni Mattera
Yes i test it but not work The CARP protocolol remain in state INIT. - Messaggio originale - Da: Mark Felder f...@freebsd.org A: Maurizio Marini maurizio.mar...@cost.it, Julian Elischer jul...@freebsd.org Cc: FreeBSD Net n...@freebsd.org, Manuel Martini po...@manuelmartini.it,

RE: freebsd 10.0 not work carp protocol on Hyper-v

2014-03-04 Thread Abhishek Gupta (LIS)
Hi Giovanni, Sorry to come late to the thread. Have you integrated the Hyper-V drivers yet or are relying on emulated mode? Let's start from there and we shall see if the problem can be resolved. Thanks, Abhishek Gupta PM, BSD Integration Services Microsoft Corporation

Re: freebsd 10.0 not work carp protocol on Hyper-v

2014-03-04 Thread Mark Felder
On Mar 4, 2014, at 11:43, Maurizio Marini maurizio.mar...@cost.it wrote: But shouldn't the CARP state go to master anyway, even if it couldn't find a live partner due to network/Hyper-V problems? this is the question, forget network/Hyper-V problems, CARP should go MASTER anyway I will

Re: freebsd 10.0 not work carp protocol on Hyper-v

2014-03-04 Thread Maurizio Marini
On Tue, 4 Mar 2014 18:00:55 + Abhishek Gupta (LIS) abgu...@microsoft.com wrote: Hi Giovanni, Sorry to come late to the thread. Have you integrated the Hyper-V drivers yet or are relying on emulated mode? Let's start from there and we shall see if the problem can be resolved. Thanks,

Problem with ZFS userboot changes r262331 and VM with mixed partitions

2014-03-04 Thread Craig Rodrigues
Hi, I encountered problems with the new changes to userboot to boot ZFS. About a month ago, I created a FreeBSD 10 VM with the following layout: = 34 419430333 md0 GPT (200G) 341281 freebsd-boot (64K) 16220971522 freebsd-ufs (1.0G) 2097314

Re: Problem with ZFS userboot changes r262331 and VM with mixed partitions

2014-03-04 Thread Craig Rodrigues
On Tue, Mar 4, 2014 at 2:24 PM, Peter Grehan gre...@freebsd.org wrote: Hi Craig, ZFS: i/o error - all block copies unavailable I don't fully understand all this logic. Is there a bug that can be fixed here? Yes - a flag needs to be passed to userboot to tell it to ignore ZFS

Re: Problem with ZFS userboot changes r262331 and VM with mixed partitions

2014-03-04 Thread Peter Grehan
Hi Craig, Can this flag be passed via bhyveload, and if so, how? It can't yet: the API to userboot has to be changed to allow this to be passed through. later, Peter. ___ freebsd-virtualization@freebsd.org mailing list

Re: [Hyper-V][camlock] storvsc driver panics during boot with patches from camlock project

2014-03-04 Thread Oleg Sidorkin
That's great! Thanks a lot. On Tue, Mar 4, 2014 at 3:06 PM, Alexander Motin m...@freebsd.org wrote: Oleg, It was found that real problem is not there. You do not need manual scanning. You should remove it. All you really need is to properly report bus to CAM: @@ -1147,7 +1062,7 @@