Re: Heads up: AR7241 + PCIe and AR9287 on-board stuff works

2012-09-18 Thread Johann Hugo
On Wednesday 05 September 2012 01:20:10 Adrian Chadd wrote: On 28 August 2012 21:00, Adrian Chadd adr...@freebsd.org wrote: The default (most things as modules) kernel build is still ~ 3.5mb. That's rather large for a board with 16MB of RAM. Additionally, I can't load the ath device

Re: Performance of AR9287

2012-09-22 Thread Johann Hugo
address. It's quite useful to see what's actually going on. :-) Adrian On 22 September 2012 01:20, Johann Hugo jh...@meraka.csir.co.za wrote: On Saturday 22 September 2012 02:05:23 Derrick Edwards wrote: Thanks again for looking into this. My main concern was the range

misc/172955: [ath] 11n does not work in adhoc mode

2012-10-22 Thread Johann Hugo
The following reply was made to PR kern/172955; it has been noted by GNATS. From: Johann Hugo jh...@meraka.csir.co.za To: bug-follo...@freebsd.org Cc: Adrian Chadd adr...@freebsd.org, jh...@meraka.csir.co.za Subject: misc/172955: [ath] 11n does not work in adhoc mode Date: Mon, 22 Oct 2012 21:19

Re: kern/173636: [ath] ath1: bad series0 hwrate 0x0, tries 1 ts_status 0x0

2012-11-18 Thread Johann Hugo
On Sunday 18 November 2012 23:05:44 adr...@freebsd.org wrote: Synopsis: [ath] ath1: bad series0 hwrate 0x0, tries 1 ts_status 0x0 State-Changed-From-To: open-closed State-Changed-By: adrian State-Changed-When: Sun Nov 18 21:04:51 UTC 2012 State-Changed-Why: This was fixed in r243047,

Re: [ath] Degraded throughput - adhoc mode

2012-12-12 Thread Johann Hugo
On Sunday, December 09, 2012 04:18:45 PM Adrian Chadd wrote: Ok, I've just taught the aggressive mode logic about IBSS. It's pretty dirty - I may cop some hate for enabling aggressive mode for IBSS as each IBSS node doesn't know about the overall voice/video data rates. That's how it works in

Re: 11n in adhoc mode

2012-12-12 Thread Johann Hugo
On Wednesday, December 12, 2012 01:58:38 AM Adrian Chadd wrote: Here's what I have trimmed this down to so far: http://people.freebsd.org/~adrian/ath/20121212-11n-ibss-and-other-stuff-3.di ff Please disable ampdu for now (ifconfig wlanX -ampdu) as it just plain doesn't work. I'll figure

Re: So, which IEEE-Frequency mappings should we be all using?

2013-07-24 Thread Johann Hugo
Which vendors are you talking about. Are you planing to add support for any of them. We have a UHF wifi pilot project and was thinking of doing a frequency down convert to UHF. Johann On Monday 22 July 2013 10:35:27 Adrian Chadd wrote: Well, the UHF stuff is available now and vendors are

Atheros 5413 + half/quarter width

2014-01-31 Thread Johann Hugo
Hi Is half/quarter width working for Atheros 5413 (looks like it) ? https://wiki.freebsd.org/dev/ath_hal(4)/HalfQuarterRate Will the output of ifconfig -v wlan2 show if it is supported ? Is it supported in FreeBSD 9.0 or do I need to upgrade to CURRENT ? Do I need compile time flags/options

Atheros 9220 in 11a mode

2014-07-29 Thread Johann Hugo
Hi Are there any special settings needed to operate a 11n adapter in 11a mode ? e.g. dev.ath.0.rxantenna I've managed to get it into 11a mode, but for some reason more that 80% of all big packets are dropped, small packets works fine. mesh-6c9a:~ # uname -a FreeBSD mesh-6c9a 11.0-CURRENT

Ath - clients with weak signals not working after upgrade to FreeBSD 11.0

2014-07-31 Thread Johann Hugo
Hi After an upgrade from FreeBSD 9.0 to 11.0 I'm losing comms to some of the wifi clients that worked when I was using FreeBSD 9.0 (long distance links in mesh) On CURRENT the devices are still showing with list sta, but the idle counter keeps growing + no comms to them. FreeBSD 9.0-STABLE

Re: Ath - clients with weak signals not working after upgrade to FreeBSD 11.0

2014-07-31 Thread Johann Hugo
1012 rx0 [1] tx0 rx13114 The RSSI's look fine. So there's likely something else odd going on -a On 31 July 2014 13:00, Johann Hugo jh...@meraka.csir.co.za wrote: Hi After an upgrade from FreeBSD 9.0 to 11.0 I'm losing comms to some of the wifi clients

Re: Ath - clients with weak signals not working after upgrade to FreeBSD 11.0

2014-07-31 Thread Johann Hugo
beacons received 28 average rssi (beacons only) Antenna profile: [0] tx 641 rx3 [1] tx0 rx 8487 -a On 31 July 2014 14:14, Johann Hugo jh...@meraka.csir.co.za wrote: On Thursday 31 July 2014 13:43:34 Adrian Chadd wrote: I think the idle counter

Re: Ath - clients with weak signals not working after upgrade to FreeBSD 11.0

2014-07-31 Thread Johann Hugo
and not on older ones with an Atheros 5413 chipset. -a On 31 July 2014 14:14, Johann Hugo jh...@meraka.csir.co.za wrote: On Thursday 31 July 2014 13:43:34 Adrian Chadd wrote: I think the idle counter there is the receive idle counter. Ie, it's not hearing frames from them

Re: Ath - clients with weak signals not working after upgrade to FreeBSD 11.0

2014-08-01 Thread Johann Hugo
0 0 0 12 0 0 28 6M 201 0 0 0 0 15 0 0 29 6M 400 0 0 0 0 28 0 0 27 6M On Thursday 31 July 2014 16:01:56 Adrian Chadd wrote: On 31 July 2014 14:56, Johann

Re: Ath - clients with weak signals not working after upgrade to FreeBSD 11.0

2014-08-20 Thread Johann Hugo
Chadd wrote: Well, step #1 would be to run the freebsd-9 ath(4) driver in the later freebsd version. If you're able to shoehorn that in, let's see if that's the case. -a On 1 August 2014 02:20, Johann Hugo jh...@meraka.csir.co.za wrote: Hi Is it possible to disable ANI ? How should we go