Re: [FUG-BR] Erro durante a i nstalação: Read_DMA UDMA ICRC

2006-03-15 Por tôpico Marcelo/Porks
Po galera, valeu pelas respostas.

Só para dar um feedback para a lista: Enchi o saco disso tudo e troquei o
HD+FLAT, funcionou que é uma beleza!
O outro vou deixar como slave (se der né...)

Valeu a todos, abraços!


On 3/14/06, Nilton Jose Rizzo [EMAIL PROTECTED] wrote:

 On Tue, 14 Mar 2006 17:10:02 -0300, Gustavo Fukao wrote
  
   Não consegui achar muita coisa pelo google ou no handbook (por isso
 estou
   aqui incomodando :D), mas eu vi alguns lugares falando algo de
 desabilitar
   ou fazer algo com o DMA... Também vi algo falando que o problema pode
 estar
   com a geometria do disco, mas não sei como posso mudar isso. Alguém ai
 tem
   alguma idéia sobre essas coisas?
  
   A máquina que uso é:
   Pentium 4 1.5GHZ
   512MB de Ram
   placa mãe Soyo (SDy-P4VSA --
   http://www.soyo.com.tw/products/proddesc.php?id=109)
   HD Samsung SV2011H
  
   Enfim, se alguém tiver alguma idéia do que está acontecendo e como
   solucionar esse problema eu ficarei agradecido!
  
   Valeu pela atenção...

 Rapaz tive o mesmo problema com um HD desses e uma PCChips 810 ou algo
 semelhante ..não lembro diretio o modelo da placa mas tinha um Duron Pro
 Soldado diretamente na placa ... É de um cliente

 Ele tinha um HD de 6G funcionando perfeito em UDMA, mas o novo HD
 não funcionou nem amarrado :) nem com XP nem com o Free nem com o Open
 so passando ele para PIO 4 ele ficou ok, e o computador firou uma carroça
 :(
 Ainda tentei utilizar os cabos rounded para ATA133 mas não adiantou
 Decepicionante ... :(

 Rizzo

   ___
   freebsd mailing list
   freebsd@fug.com.br
   http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br
  
 
  Voce pode tentar adicionando as linhas abaixo
 
  = /boot/loader.conf 
  hw.ata.ata_dma=0
  ==
 
  = /etc/rc.local +==
  atacontrol mode 0 udma1 udma1
  ==
 
  Mais informacoes
 
  http://lists.freebsd.org/pipermail/freebsd-stable/2005-July/017121.html
 
 

 http://groups-beta.google.com/group/mailing.freebsd.stable/browse_thread/thread/267a66ec7573c465/fc61ccf7b4272072?lnk=stq=freebsd+quality+atarnum=1hl=en
 
  Att
 
  --
  
  Gustavo FukaoEngenharia da Computacao
  CEL: 14 9163 5798
  FreeBSD user: 51175
  ICQ: 51266435 MSN: gustavofukao[at]hotmail.com
 
 --
  ___
  freebsd mailing list
  freebsd@fug.com.br
  http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br


 --
 Nilton José Rizzo
 805 Informatica
 021 2413 9786

 ___
 freebsd mailing list
 freebsd@fug.com.br
 http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br

___
freebsd mailing list
freebsd@fug.com.br
http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br


Re: [FUG-BR] Erro durante a i nstalação: Read_DMA UDMA ICRC

2006-03-14 Por tôpico Rodrigo Graeff
On 3/14/06, Marcelo/Porks [EMAIL PROTECTED] wrote:
 Senhores,

 Sou estou começando a usar o FreeBSD agora e já na minha primeira instalação
 me dei mal (hehehe). Então se vocês tiverem a paciência de ler esse email
 gigante e se alguém tiver alguma luz para me dar eu ficarei agradecido.

 O que acontece é o seguinte:
 Com o a instalação do FreeBSD 6.0 eu digo para ela usar todo o disco (20GB),
 e aceito as partições padrão do Sysinstall.

 Então após passar pelo passo de escolher a midia onde estão os arquivos de
 instalação (no meu caso um CD-ROM) o Sysinstall vai fazer as alterações no
 disco (fazer as divisões do HD) e neste momento surge a mensagem:

 Error: Unable to write data to disk ad0!

 Olhando no outro console (alt + f2) aparecem mensagens como:

 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0

 Entretanto... se eu fizer a mesma instalação porém no momento que eu dou o
 boot com o cd de instalação eu escolho a opção 3 (Safe Mode) a instalação é
 feita sem nenhum problema. O chato é que depois que o sistema está instalado
 no HD, se eu for tentar bootar normalmente ele volta a dar erro, com a
 mensagem:

 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 trying to mount root from ufs:/dev/ad0s1a

 e ai só resta rebootar a máquina...

 Se bootar com a opção Safe mode funciona normalmente o sistema (pelo menos é
 o que eu acho, já que sou novo nisso tudo).

 O 'engraçado' é que tentei instalar o OpenBSD 3.8 também e dá o mesmo tipo
 de erro e não deixa instalar. O Debian (Sarge) instala normal mas dá também
 erros desse tipo durante todo o boot.

 Tá.. eu sei que está meio que óbvio que o problema é o HD, mas o que me
 chama a atenção é que em Safe Mode o FreeBSD funciona e antes estava
 instalado o Windows 2003 Server (a máquina era nosso servidor de banco de
 dados) e nunca deu problema. Eu também passei uma ferramentinha para zerar o
 HD inteiro e testar se há problemas e ela não retornou nenhum problema.

 Não consegui achar muita coisa pelo google ou no handbook (por isso estou
 aqui incomodando :D), mas eu vi alguns lugares falando algo de desabilitar
 ou fazer algo com o DMA... Também vi algo falando que o problema pode estar
 com a geometria do disco, mas não sei como posso mudar isso. Alguém ai tem
 alguma idéia sobre essas coisas?

 A máquina que uso é:
 Pentium 4 1.5GHZ
 512MB de Ram
 placa mãe Soyo (SDy-P4VSA --
 http://www.soyo.com.tw/products/proddesc.php?id=109)
 HD Samsung SV2011H

 Enfim, se alguém tiver alguma idéia do que está acontecendo e como
 solucionar esse problema eu ficarei agradecido!


   Eu ja passei por isso amigo, infelizmente consegui resolver
retirando o UDMA da bios e colocando o HD (os HDs que no caso eu tinha
uns 4 na maquina) a trabalhar em PIO mode pois o BSD nao se dava bem
com o chipset VIA da interface IDE. Apos resolver isso, usei o
atacontrol para ajustar no sistema operacional tambem os HDs para PIO,
eu sei que a performance fica comprometida porem era a unica maneira
de eu utilizar o BSD nessa maquina, eu esperava que no 6.x isso fosse
resolvido, pelo jeito nao foi ainda, existe um projeto paralelo que li
na epoca de uma pessoa re-escrevendo os drivers de IDE do BSD para
suportar genericamente barramentos 66/100 que no caso dao pau com
alguns chipsets VIA.

Abracos,

--
Rodrigo Graeff
delphus
___
freebsd mailing list
freebsd@fug.com.br
http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br


Re: [FUG-BR] Erro durante a i nstalação: Read_DMA UDMA ICRC

2006-03-14 Por tôpico Gustavo Fukao
On 3/14/06, Marcelo/Porks [EMAIL PROTECTED] wrote:
 Senhores,

 Sou estou começando a usar o FreeBSD agora e já na minha primeira instalação
 me dei mal (hehehe). Então se vocês tiverem a paciência de ler esse email
 gigante e se alguém tiver alguma luz para me dar eu ficarei agradecido.

 O que acontece é o seguinte:
 Com o a instalação do FreeBSD 6.0 eu digo para ela usar todo o disco (20GB),
 e aceito as partições padrão do Sysinstall.

 Então após passar pelo passo de escolher a midia onde estão os arquivos de
 instalação (no meu caso um CD-ROM) o Sysinstall vai fazer as alterações no
 disco (fazer as divisões do HD) e neste momento surge a mensagem:

 Error: Unable to write data to disk ad0!

 Olhando no outro console (alt + f2) aparecem mensagens como:

 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0

 Entretanto... se eu fizer a mesma instalação porém no momento que eu dou o
 boot com o cd de instalação eu escolho a opção 3 (Safe Mode) a instalação é
 feita sem nenhum problema. O chato é que depois que o sistema está instalado
 no HD, se eu for tentar bootar normalmente ele volta a dar erro, com a
 mensagem:

 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA UDMA ICRC Error (retrying request) LBA=0
 ad0: Warning Read_DMA status=51 READ,DSC,ERROR error=84 ICRC,ABORTED
 LBA=0
 trying to mount root from ufs:/dev/ad0s1a

 e ai só resta rebootar a máquina...

 Se bootar com a opção Safe mode funciona normalmente o sistema (pelo menos é
 o que eu acho, já que sou novo nisso tudo).

 O 'engraçado' é que tentei instalar o OpenBSD 3.8 também e dá o mesmo tipo
 de erro e não deixa instalar. O Debian (Sarge) instala normal mas dá também
 erros desse tipo durante todo o boot.

 Tá.. eu sei que está meio que óbvio que o problema é o HD, mas o que me
 chama a atenção é que em Safe Mode o FreeBSD funciona e antes estava
 instalado o Windows 2003 Server (a máquina era nosso servidor de banco de
 dados) e nunca deu problema. Eu também passei uma ferramentinha para zerar o
 HD inteiro e testar se há problemas e ela não retornou nenhum problema.

 Não consegui achar muita coisa pelo google ou no handbook (por isso estou
 aqui incomodando :D), mas eu vi alguns lugares falando algo de desabilitar
 ou fazer algo com o DMA... Também vi algo falando que o problema pode estar
 com a geometria do disco, mas não sei como posso mudar isso. Alguém ai tem
 alguma idéia sobre essas coisas?

 A máquina que uso é:
 Pentium 4 1.5GHZ
 512MB de Ram
 placa mãe Soyo (SDy-P4VSA --
 http://www.soyo.com.tw/products/proddesc.php?id=109)
 HD Samsung SV2011H

 Enfim, se alguém tiver alguma idéia do que está acontecendo e como
 solucionar esse problema eu ficarei agradecido!

 Valeu pela atenção...
 ___
 freebsd mailing list
 freebsd@fug.com.br
 http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br


Voce pode tentar adicionando as linhas abaixo

= /boot/loader.conf 
hw.ata.ata_dma=0
==

= /etc/rc.local +==
atacontrol mode 0 udma1 udma1
==

Mais informacoes

http://lists.freebsd.org/pipermail/freebsd-stable/2005-July/017121.html

http://groups-beta.google.com/group/mailing.freebsd.stable/browse_thread/thread/267a66ec7573c465/fc61ccf7b4272072?lnk=stq=freebsd+quality+atarnum=1hl=en


Att

--

Gustavo FukaoEngenharia da Computacao
CEL: 14 9163 5798
FreeBSD user: 51175
ICQ: 51266435 MSN: gustavofukao[at]hotmail.com
--
___
freebsd mailing list
freebsd@fug.com.br
http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br