[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-22 Thread pepeto

Update of bug #14556 (project freeciv):

  Status:None = Fixed  
 Assigned to:None = pepeto 
 Open/Closed:Open = Closed 


___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-21 Thread Marko Lindqvist

Follow-up Comment #5, bug #14556 (project freeciv):

 In trunk we can simply bump the requirement as done with
 attached patch.

After I got same error from build with *latest* cygwin, I consider gtk+ 2.12
too high a requirement even in trunk.

However, we should be aware that staying with lower requirement than we
actually have any reason to just causes unnecessary maintenance work and less
than ideal implementations as we duplicate features of newer requirement
libraries in our own code.

___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-21 Thread pepeto

Follow-up Comment #6, bug #14556 (project freeciv):

 However, we should be aware that staying with lower requirement
 than we actually have any reason to just causes unnecessary
 maintenance work and less than ideal implementations as we
 duplicate features of newer requirement libraries in our own
 code.

I totally agree with that.  And applying my patch would fix the problem
without requesting any requirement more.


___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-20 Thread pepeto

Follow-up Comment #4, bug #14556 (project freeciv):

Version 2, do it in #rrggbb mode, like described in the header instead of
#.  We don't need a such precision.


(file #7041)
___

Additional Item Attachment:

File name: trunk_S2_2_gdk_color_to_string2.diff Size:2 KB


___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-19 Thread Marko Lindqvist

URL:
  http://gna.org/bugs/?14556

 Summary: gdk_color_to_string() used, but only gtk+ 2.4
required
 Project: Freeciv
Submitted by: cazfi
Submitted on: Monday 10/19/2009 at 16:44
Category: client-gtk-2.0
Severity: 3 - Normal
Priority: 1 - Later
  Status: None
 Assigned to: None
Originator Email: 
 Open/Closed: Open
 Release: 
 Discussion Lock: Any
Operating System: None
 Planned Release: None

___

Details:

Compilation with older systems fail due to gdk_color_to_string() usage.
Documentation states that gdk_color_to_string() was added in 2.12.




___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-19 Thread Marko Lindqvist

Update of bug #14556 (project freeciv):

 Planned Release:None = 2.2.0  

___

Follow-up Comment #1:

In trunk we can simply bump the requirement as done with attached patch.

In S2_2 I'd like to support gtk+ 2.8 at least (version in Ubuntu Dapper)


(file #7034)
___

Additional Item Attachment:

File name: ReqGtk212_14556.diff   Size:1 KB


___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-19 Thread pepeto

Follow-up Comment #2, bug #14556 (project freeciv):

This is my mistake... I didn't notice that.  I should check gtk 2.4
documentation instead of my local one.  I don't know any replacement of this
function yet...  I hope I will find something, or I will probably my own
version...


___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #14556] gdk_color_to_string() used, but only gtk+ 2.4 required

2009-10-19 Thread pepeto

Follow-up Comment #3, bug #14556 (project freeciv):

gdk_color_to_string replacement attached.


(file #7035)
___

Additional Item Attachment:

File name: trunk_S2_2_gdk_color_to_string.diff Size:2 KB


___

Reply to this item at:

  http://gna.org/bugs/?14556

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev