[Freeciv-Dev] [bug #15973] libfreeciv should be linked against libm

2010-05-08 Thread Jacob Nevins
Update of bug #15973 (project freeciv): Status:None = Ready For Test Assigned to:None = jtn Planned Release: = 2.2.1

[Freeciv-Dev] [bug #15973] libfreeciv should be linked against libm

2010-05-08 Thread Jacob Nevins
Update of bug #15973 (project freeciv): Status: Ready For Test = Fixed Open/Closed:Open = Closed ___ Reply to this item at:

[Freeciv-Dev] [bug #15973] libfreeciv should be linked against libm

2010-04-30 Thread anonymous
URL: http://gna.org/bugs/?15973 Summary: libfreeciv should be linked against libm Project: Freeciv Submitted by: None Submitted on: Friday 04/30/2010 at 21:12 CEST Category: None Severity: 3 - Normal

[Freeciv-Dev] [bug #15973] libfreeciv should be linked against libm

2010-04-30 Thread Jacob Nevins
Follow-up Comment #1, bug #15973 (project freeciv): Don't suppose this patch would also fix bug #15400, would it? ___ Reply to this item at: http://gna.org/bugs/?15973 ___ Message sent

[Freeciv-Dev] [bug #15973] libfreeciv should be linked against libm

2010-04-30 Thread anonymous
Follow-up Comment #2, bug #15973 (project freeciv): It will help, but from the error log on 15400, it looks like there are two other places which need -lm flags as well. I'll submit a separate patch for 15400. JKL ___ Reply to this item

[Freeciv-Dev] [bug #15973] libfreeciv should be linked against libm

2010-04-30 Thread Jonathan Landis
Follow-up Comment #3, bug #15973 (project freeciv): Here is a better patch. This one sets up some autoconf variables for the common and utility libs. 1. It sets up a COMMON_LIBS autoconf variable, which is used as an extra LIBADD for libfreeciv. 2. It sets up a UTILTITY_LIBS autoconf