[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2012-03-15 Thread Marko Lindqvist
Update of bug #16429 (project freeciv):

  Status:  Ready For Test = Fixed  
 Assigned to:None = cazfi  
 Open/Closed:Open = Closed 


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2012-03-04 Thread Jacob Nevins
Follow-up Comment #25, bug #16429 (project freeciv):

Not sure if this patch could explain my original symptom (comment #0).

The unit involved (Engineers id=4105) definitely changed hands with its city
(Muza id=501), from the Himyarites to a new Arab player (who I'm assuming is
the result of a civil war), at around the time the message was emitted.

But both nations know Railroad (and known techs will always be the same for a
civil war, I think). So unless this is some transitory state where the unit is
checked while it has *no* owner (so knowledge of Railroad can't be looked
up)...?

I agree with separating out one ticket per fix, given that this bug is so
slippery.

There were suggestions that tech loss could be implicated, but we have plenty
of occurrences where that can't be the case. There was one tech loss fix in
bug #16767, but there was another in comment #21 that hasn't obviously been
laid to rest yet.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2012-03-04 Thread Marko Lindqvist
Follow-up Comment #26, bug #16429 (project freeciv):

 There were suggestions that tech loss could be implicated, but
 we have plenty of occurrences where that can't be the case.

Note that due to bug #19487 the fact that ruleset has not enabled tech_upkeep
is not alone proving that tech loss is not part of problem.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2012-02-26 Thread Marko Lindqvist
Follow-up Comment #23, bug #16429 (project freeciv):

I've got another reproducible case, and it's not about tech loss (this time).
I run with several patches applied. While I don't think those patches
contribute to the patch, it's probably reproducible from my autogame without
those patches.

So far I know:

Georgian Settler id 639 is trying to build Railroad on Forest / River.
Georgians have no Railroad tech, and never had. There has been unit with id
639 for a long time, owned by Abkhazians. It seems that unit_change_owner()
was not recently (since my last check it belongs to Abkhazians) called for
this unit. There was civil war recently, which may, or may not, be related.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2012-02-26 Thread Marko Lindqvist
Update of bug #16429 (project freeciv):

  Status:   Confirmed = Ready For Test 
 Planned Release:2.3.0, 2.4.0 = 2.2.8, 2.3.2, 2.4.0,
2.5.0

___

Follow-up Comment #24:

As reports differ, we might be dealing with several bugs. Attached patch fixes
one I were experiencing today - when cities are transfered to new owner, unit
activities are not checked (or if some function called has such a check, it
happens before owner actually gets set) This might be the only bug - so I'll
close this ticket once this is resolved. If we then get new occurrenses of the
same error message, let's open new ticket.

(file #15227)
___

Additional Item Attachment:

File name: CheckTransferedUnitAct.diffSize:0 KB


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-09-12 Thread Jacob Nevins

Follow-up Comment #22, bug #16429 (project freeciv):

I haven't tried reproducing this from that recipe, but I still don't think
tech loss can be the only cause of this symptom; see comment #8, and more
recently comment #19 where the experimental ruleset is not in use.

I suggest you raise the tech upkeep trouble as a separate ticket (since we
haven't got to the bottom of whatever is causing this in the absence of tech
upkeep, we need this ticket for that).

That said, perhaps the way in which tech upkeep provokes this symptom may
shed light on other causes?

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-09-11 Thread Matthias Pfafferodt

Follow-up Comment #21, bug #16429 (project freeciv):

Ok, this bug is really alive. I suspect it is related to the possibility of
tech loss (tech upkeep; techlost) as it happens only for the experimental
ruleset. (for reference trunk - svn20226).

To reproduce do an autogame with the following settings (important is tech
upkeep [experimental ruleset] and the techlost_+ settings; the other settings
do only speed up the result):


rulesetdir experimental
hard
set techlost_recv   75
set techlost_donor  75
set techlevel   75
set minplayers  0
set size1
set aifill  10


There are similar error messages which are related to a lost tech.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-07-05 Thread Jacob Nevins

Follow-up Comment #20, bug #16429 (project freeciv):

I had a go at reproducing it from that autogame and couldn't :(
I tried both the stated r19809 and the head of S2_3 (r19897). The final
savegame (fantasy-T0668-Y02243-auto.sav) was identical in both cases, but no
messages like those in comment #0 appeared in the server output.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-06-20 Thread Marko Lindqvist

Update of bug #16429 (project freeciv):

  Status:None = Confirmed  
 Planned Release:   2.3.0 = 2.3.0, 2.4.0   

___

Follow-up Comment #19:

Reproduced in S2_3 revision 19809 with attached autogame. Note that while
this tries to select fantasy ruleset, I had not that ruleset available so
this ruleset setting failed.

(file #13296)
___

Additional Item Attachment:

File name: fantasy_16429.serv Size:0 KB


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-06-04 Thread Matthias Pfafferodt

Follow-up Comment #18, bug #16429 (project freeciv):

OK; I do not remember the freeciv version used in comment #14. Furthermore,
as this is a sanity check, it is only activated in development and beta
builds. Let's see if there are other reports of this bug ...

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-06-03 Thread Matthias Pfafferodt

Update of bug #16429 (project freeciv):

  Status:   Need Info = Works For Me   
 Open/Closed:Open = Closed 

___

Follow-up Comment #16:

I did test the server script mentioned in comment #14 but could not reproduce
(tested on S2_3 and trunk) - closing this as 'works for me'

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2011-01-19 Thread Matthias Pfafferodt

Update of bug #16429 (project freeciv):

  Status: In Progress = Need Info  

___

Follow-up Comment #15:

I can not reproduce anymore ...

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-11-02 Thread pepeto

Update of bug #16429 (project freeciv):

 Planned Release: = 2.3.0  


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-10-03 Thread Matthias Pfafferodt

Follow-up Comment #14, bug #16429 (project freeciv):

this bug still exists after bug #16767 was fixed, see attached core dump. The
bug can't be reproduced using a savegame but if the attached server script is
run as './ser -r test031.serv -F' the server will segfault in turn 182.

(file #10587, file #10588, file #10589)
___

Additional Item Attachment:

File name: test031.coredump   Size:1 KB
File name: test031-T0182-Y01258-auto.sav.bz2 Size:29 KB
File name: test031.serv   Size:0 KB


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-26 Thread Matthias Pfafferodt

Follow-up Comment #13, bug #16429 (project freeciv):

the bug fix posted in comment #5 has its own ticket: bug #16767

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-12 Thread pepeto

Update of bug #16429 (project freeciv):

Category:None = general
Priority:   1 - Later = 5 - Normal 
  Status:None = In Progress


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-08 Thread Matthias Pfafferodt

Follow-up Comment #11, bug #16429 (project freeciv):

 Sorry, but I really think your patch doesn't fix the problem
 on trunk.

If you mean the bug raised by file #10221 it is fixed by the patch (file
#10231), e.g. after applying the patch no error message occurs.

Have a look into techtools.c:player_tech_lost() (line 616). There is a check
for each unit if the current activity is still valid after a tech was lost.
If not, the activity is cancelled and thus no error message by the sanity
check.

 The problem on S2_2 looks only linked with civil war. Maybe
 there is problem or a delay in the transfer of the tech
 between the players?

This would mean, that the tech data of one player is updated to late =
player_research_update() is not called at the right place. But for an
activity to fail, the player has to lose a tech!

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-08 Thread pepeto

Follow-up Comment #12, bug #16429 (project freeciv):

I will check this, thanks.


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread pepeto

Follow-up Comment #3, bug #16429 (project freeciv):

See also bug #16654.


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread pepeto

Follow-up Comment #4, bug #16429 (project freeciv):

In my case for trunk, it is a bit different. I have gave all technologies to
the players at start, so they have a big tech upkeep, losing 1 tech per turn.
When losing Railroads or Bridge Building, it produces that error. Attaching
savegame to illustrate what I am saying.


(file #10221, file #10222)
___

Additional Item Attachment:

File name: freeciv-T0031-Y-3969-auto.sav.gz Size:72 KB
File name: freeciv-T0036-Y-3964-interrupted.sav.gz Size:75 KB


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread Matthias Pfafferodt

Follow-up Comment #5, bug #16429 (project freeciv):

 In my case for trunk, it is a bit different. I have gave all
 technologies to the players at start, so they have a big tech
 upkeep, losing 1 tech per turn. When losing Railroads or
 Bridge Building, it produces that error. Attaching savegame to
 illustrate what I am saying. 

This should be checked in ./server/techtools.c:player_tech_lost() line 616
... 

I had to modify file #10221 to load it (remove the first option= setting;
see bug #16645). The attached patch fixes the bug. A call to
player_research_update() was missing.

I did not test the savegames listed in comment #0.

(file #10231)
___

Additional Item Attachment:

File name: 20100907-07-trunk-fix-tech-tree-after-a-tech-was-lost.patch Size:0
KB


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread pepeto

Follow-up Comment #6, bug #16429 (project freeciv):

 I had to modify file #10221 to load it (remove the first
 option= setting; see bug #16645). The attached patch fixes the
 bug. A call to player_research_update() was missing.

Oops, I didn't attach the right file, and I don't have it anymore.

How calling player_research_update() can fix that?


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread Matthias Pfafferodt

Follow-up Comment #7, bug #16429 (project freeciv):

 How calling player_research_update() can fix that? 

in techtools.c:player_tech_lost() the tech is removed from the player by
player_invention_set(plr, tech, TECH_UNKNOWN). After this function
player_research_update() must be called to update the information about the
tech tree (especially research-num_known_tech_with_flag). Without the update
the following checks for now invalid action will not fix all possible changes
due to the now missing tech.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread Jacob Nevins

Follow-up Comment #8, bug #16429 (project freeciv):

My original test (comment #0) was with S2_2 and the default ruleset. One of
pepeto's reports in bug #16654 was with S2_2. Tech upkeep and related
features (and hence player_tech_lost()) don't exist there.

I guess we're dealing with two separate bugs?

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread Matthias Pfafferodt

Follow-up Comment #9, bug #16429 (project freeciv):

 I guess we're dealing with two separate bugs?

It seems to be. My patch solves the bug for trunk. I did not investigate the
original report. But perhaps an additional check if the tech is known could
help there? Are the techs split at civil war and the units are transferred
without a check if their activity is valid? Is player_research_update() run
for each player after the split?

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Nachricht geschickt von/durch Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-09-07 Thread pepeto

Follow-up Comment #10, bug #16429 (project freeciv):

Sorry, but I really think your patch doesn't fix the problem on trunk. It may
fix a bug but probably not this one. I don't see how calling
player_research_update() can stop units doing invalid actions (like doing
Railroads when losing the Railroad tech) and do the notifications to the
clients.

The problem on S2_2 looks only linked with civil war. Maybe there is problem
or a delay in the transfer of the tech between the players?


___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-08-20 Thread Jacob Nevins

Follow-up Comment #2, bug #16429 (project freeciv):

Don't think it's alliance/pillaging: there's no other unit on the tile in any
of the savegames. The Himyarites, who start out owning the land, are only
allied to the Normans who are nowhere near.

Think it's somehow to do with civil war. In T0370 and T0371 the land and
relevant Engineers unit belong to the Himyarites, but in T0372 they both
belong to a new Arab player; it looks like the result of civil war.

Still not sure why that should make a difference, but it's a clue.
* T0370: Grassland, Road/Irrigation, Engineers working on Mine(1)
* T0371: Forest, Road, Engineers working on nothing
* T0372: Forest, Road, Engineers (now Arab) working on Railroad(1)
Global warming and nuclear winter chance are both 0. Checked with the editor
that it's the same unit on that tile all three times (ID 4105).

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-08-15 Thread Marko Lindqvist

Follow-up Comment #1, bug #16429 (project freeciv):

I guess this warning could be caused by another unit pillaging road from the
tile while engineers are set to build railroad. It must be allied unit
though, to exist in same tile.

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16429] Failed sanitycheck.c: Engineers has activity Railroad, but it can't continue at Forest

2010-08-14 Thread Jacob Nevins

URL:
  http://gna.org/bugs/?16429

 Summary: Failed sanitycheck.c: Engineers has activity
Railroad, but it can't continue at Forest
 Project: Freeciv
Submitted by: jtn
Submitted on: Saturday 08/14/10 at 17:42
Category: None
Severity: 3 - Normal
Priority: 1 - Later
  Status: None
 Assigned to: None
Originator Email: 
 Open/Closed: Open
 Release: 2.2.2+
 Discussion Lock: Any
Operating System: GNU/Linux
 Planned Release: 

___

Details:

I was testing my fix for bug #16418 with an autogame and happened to notice
the following scrolling past:


1: Failed sanitycheck.c:538 at srv_main.c:812! (  58,  21) Engineers has
activity Railroad, but it can't continue at Forest

Game saved as
/home/jtn/src/freeciv/2.2-svn3/autogame/freeciv-T0372-Y01905-auto.sav.bz2

1: Failed sanitycheck.c:538 at srv_main.c:2068! (  58,  21) Engineers has
activity Railroad, but it can't continue at Forest

1: Failed sanitycheck.c:538 at srv_main.c:745! (  58,  21) Engineers has
activity Railroad, but it can't continue at Forest


That's bad, right? However, I don't think it can be caused by my patch.

Unfortunately, it doesn't seem deterministic; starting an autogame from
scratch with the same seeds doesn't reproduce it at the right time, and
starting the server with nearby savegames doesn't either. (So I can't _prove_
it's not my fix.)

Attached a few savegames in case anyone else can work out what's going on
here. I have the full set of savegames (but not for long).

(I think (58,21) is the tile south of Shirjan, right on the corner of the
continent, to save searching.)

S2_2 r17751 + patch for bug #16418, with debug enabled.



___

File Attachments:


---
Date: Saturday 08/14/10 at 17:42  Name: freeciv-T0370-Y01903-auto.sav.bz2 
Size: 59kB   By: jtn

http://gna.org/bugs/download.php?file_id=9828
---
Date: Saturday 08/14/10 at 17:42  Name: freeciv-T0371-Y01904-auto.sav.bz2 
Size: 58kB   By: jtn

http://gna.org/bugs/download.php?file_id=9829
---
Date: Saturday 08/14/10 at 17:42  Name: freeciv-T0372-Y01905-auto.sav.bz2 
Size: 61kB   By: jtn

http://gna.org/bugs/download.php?file_id=9830
---
Date: Saturday 08/14/10 at 17:42  Name: freeciv-T0373-Y01906-auto.sav.bz2 
Size: 62kB   By: jtn

http://gna.org/bugs/download.php?file_id=9831

___

Reply to this item at:

  http://gna.org/bugs/?16429

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev