[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-11-19 Thread pepeto

Update of bug #16769 (project freeciv):

  Status:  Ready For Test = Fixed  
 Open/Closed:Open = Closed 


___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-11-17 Thread pepeto

Update of bug #16769 (project freeciv):

  Status:None = Ready For Test 
 Assigned to:None = pepeto 
 Planned Release: = 2.2.4, 2.3.0, 2.4.0

___

Follow-up Comment #7:

Fix attached for current branches.


(file #11252, file #11253)
___

Additional Item Attachment:

File name: S2_2_inf_read_a_line.diff  Size:1 KB
File name: trunk_S2_3_inf_read_a_line.diff Size:0 KB


___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-11-03 Thread pepeto

Follow-up Comment #6, bug #16769 (project freeciv):

See also patch #1700.


___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-10-13 Thread pepeto

Follow-up Comment #5, bug #16769 (project freeciv):

Also reported by Martin Melhus (aeronaut _AT_ gmail _DOT_ com) on the
freeciv-dev list.

See http://mail.gna.org/public/freeciv-dev/2010-10/msg00451.html


___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-10-08 Thread Angelo Lucia

Follow-up Comment #3, bug #16769 (project freeciv):

i report the same problem.

on MacOsX 10.6.4, Freeciv version 2.2.3, both the SDL and the GTK2 version.

the game run just fine, saves automatically and manually, but at the time of
loading, an error appears:


Did not find closing doublequote for '*include' line
  file /opt/com.bitaxis/share/freeciv/default/nations.ruleset, line 241,
pos 10, EOF
  looking at: 'nation/zulu.ruleset'
  original line: '*include nation/zulu.ruleset'


at the sime time, the local user is removed from the game, and another AI is
added in his place. Pressing the Play button in any of the two clients
starts the saved game, with the local human user controlling the right
nation.

I had a look at nations.ruleset, and it looked fine to me, no missing
doublequotes. The error on the Zulu ruleset is probably due to the fact that
is the last one in alphabetic order.

___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Messaggio inviato con/da Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-10-08 Thread David Lowe

Follow-up Comment #4, bug #16769 (project freeciv):

I don't believe our Mac packager monitors Gna!, so i'll forward this to him
and see if he can't put an extra linefeed at the end of nations.ruleset.

___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-09-28 Thread anonymous

Follow-up Comment #2, bug #16769 (project freeciv):

[My guess at a solution appears at the bottom.]


I did a search of my computer for “nation” (as contents).

The file that you mention appears to be okay.

The “nations.ruleset” file in …/freeciv/civ1 is different, but has a
zulu line; this, too, appears to be okay.

These are the only two files that found.  Ditto “ruleset”.  


 Download Source

I have attached the file Info information about whence I got the download. 
My browser history seems to show that I started at SourceForge.  My memory
says that, when I was downloading a file (by which I mean that I do not
recall what file), there were two mirror sites, and I selected the second
one.  This matches with a “…download…” entry in my browser history,
which is

http://freeciv.wikia.com/wiki/Download#Mac_OS_X_Packages

; the second MacOS mirror site is

gna.org

.  I also have a item:

http://freeciv.wikia.com/index.php?title=Special:Outboundf=Downloadu=http%3A%2F%2Fdownload.gna.org%2Ffreeciv%2Fpackages%2Fmacosx%2Ffreeciv-sdl-2.2.3-leopard-intel.dmg

, which appears to be the download instance address.  


 Attempt to Fix Locally

I have run a Disk Utility check of my hard disc; it says that it is okay.  

I saved the file for which you gave the link, as nations.ruleset.txt.  (I had
to add myself in the permissions to do this.)  

I tried opening my saved game before making the (following) change, just in
case - same problem.

Then I renamed the existing file to “nations.ruleset  [original]”, and
renamed the new file by deleting the “.txt”.  When I ran the program…
same problem.  



 Checking the Save File

After some stuffing around with Terminal, I managed to get a readable copy of
the save file.  It does not have any apparent problems or errors.  



 SDL vs GTK2

Under the SDL build, the program displays the error message and then stops. 
I installed the GTK2 version; under this, the error message part is the same,
but there is also a “Start” button; clicking this results in a normal
game.  (It happens that the Zulus are not represented among the
“players”.)

[Blush (contingently)]  Having installed the GTK2 version… I have just
launched the SDL app; I noticed that the it has a start button as well.  (I
do not know enough about these things to know whether it is there because I
installed the STK2 version or not.)  Clicking this Start button has the same
effect — the game opens normally.  


 Deleting the “zulu” entry, et al.
I modified the “nations.ruleset” file, deleting the  zulu  line. 
Launching the SDL version and loading the original game resulted in the same
error occurring with the previous line — now the last line.

!!  I added an extra line-feed to the end of the file… no error.  I think
there must be a simple coding error in the loop processing.  (Conversely, one
would expect this to affect everyone.)


(file #10491)
___

Additional Item Attachment:

File name: Picture 2.png  Size:23 KB


___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-09-27 Thread anonymous

URL:
  http://gna.org/bugs/?16769

 Summary: corrupt save files ( query(bad EOF) )
 Project: Freeciv
Submitted by: None
Submitted on: Monday 09/27/2010 at 10:20 CEST
Category: general
Severity: 3 - Normal
Priority: 5 - Normal
  Status: None
 Assigned to: None
Originator Email: davidevering...@mysoul.com.au
 Open/Closed: Open
 Release: 2.2.3
 Discussion Lock: Any
Operating System: Mac OS
 Planned Release: 

___

Details:

I have just installed FreeCiv 2.2.3.  (iMac 24, 2.8GHz Core2Duo.  MacOS X
10.5.8.)  

I played a game for about 7 turns.  The problem applies to both the manual
and the auto saves.

When I relaunched FreeCiv, and asked to load the game, I got an error message
about 

file /opt/com.bitaxis/share/freeciv/default/nations.ruleset, line 241, pos
10, EOF

; the line

'*include nation/zulu.ruleset'

does not have a closing  (double quote).

It is not clear to me why, but the saves are, within my home folder, in a
folder

…/.freeciv/saves

.  This seems strange because the folder is invisible.  (That is:  I believe
that there is an invisible folder with that name, as I believe that names
starting with “.” are supposed to be invisible, and the program behaves
as though the folder is there.)  Is that a separate issue?

As I noted in the summary, my slightly educated guess would be that the 
(double quote) was put in and then chopped off.

For the record, v2.1.3 worked fine (in this respect).


p.s.  Thank-you everyone!




___

File Attachments:


---
Date: Monday 09/27/2010 at 10:20 CEST  Name: Picture 2.png  Size: 491kB   By:
None

http://gna.org/bugs/download.php?file_id=10472

___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #16769] corrupt save files ( query(bad EOF) )

2010-09-27 Thread pepeto

Follow-up Comment #1, bug #16769 (project freeciv):

Folder prefixed by a '.' are usually invisible in many OS; this is not a bug.
It is used like most of other software to don't fill your own directory with
tons of undesired Freeciv savegames.

Actually, reading your report, it's not linked with the savegame but with the
ruleset. The server seems unable to load the ruleset because the end of a file
(probably data/default/nations.ruleset) is corrupted.

However, I don't know if your problem is local or if the file in the package
you downloaded is also corrupted. So, could you post the link you got the
package you installed?

Downloading the right file (
http://svn.gna.org/viewcvs/*checkout*/freeciv/tags/R2_2_3/data/default/nations.ruleset?revision=17997
) and installing it at the right place would solve your problem.


___

Reply to this item at:

  http://gna.org/bugs/?16769

___
  Message posté via/par Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev