[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-13 Thread Marko Lindqvist
Follow-up Comment #7, bug #18200 (project freeciv): It seemed to find header this time, but to fail compile test program. Does attached patch help for that problem? I still don't believe that libraries would be in directory named Headers, so presumably you will later have problems with linking

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-12 Thread Marko Lindqvist
Follow-up Comment #3, bug #18200 (project freeciv): Yes, it's one line setting CFLAGS and LDFLAGS environment variables for run of configure. Is that not found still about headers or about libraries (they are separate tests)? Include paths given in CFLAGS affect how headers are found, library

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-12 Thread David Lowe
Follow-up Comment #4, bug #18200 (project freeciv): I'll attach the log. I suspect conftest.cpp should also try to #include QApplication/qapplication.h . (file #13173) ___ Additional Item Attachment: File name: config.log

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-12 Thread Marko Lindqvist
Follow-up Comment #5, bug #18200 (project freeciv): Stupid mistake from my part. Qt-client is C++ program (and so is configure check for it). Use CXXFLAGS instead of CFLAGS. ___ Reply to this item at: http://gna.org/bugs/?18200

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-12 Thread David Lowe
Follow-up Comment #6, bug #18200 (project freeciv): CXXFLAGS gives me the same result. FWIW i've started a thread at the QtDevNet forum asking for info or an example. http://developer.qt.nokia.com/forums/viewthread/6743 (file #13175)

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-11 Thread David Lowe
URL: http://gna.org/bugs/?18200 Summary: Configure is unable to detect frameworks Project: Freeciv Submitted by: doctorjlowe Submitted on: Sat 11 Jun 2011 03:00:44 PM GMT Category: None Severity: 3 -

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-11 Thread Marko Lindqvist
Update of bug #18200 (project freeciv): Assigned to:None = cazfi ___ Follow-up Comment #1: Until we get configure somehow to work around this, you can test if you can build by setting

[Freeciv-Dev] [bug #18200] Configure is unable to detect frameworks

2011-06-11 Thread David Lowe
Follow-up Comment #2, bug #18200 (project freeciv): I still get 'not found'. Am i right that from CFLAGS= to =qt is one line? Manually inspecting a framework reveals there is no Libraries subdirectory. For each of the header files, there is a similar named file right next to it. For example,