[Freeciv-Dev] [bug #18440] "IP_ADD_MEMBERSHIP (225.1.1.1) failed" on Windows

2016-05-03 Thread Marko Lindqvist
Update of bug #18440 (project freeciv):

 Planned Release:   2.6.0 => 2.6.0, 3.0.0   


___

Reply to this item at:

  

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] "IP_ADD_MEMBERSHIP (225.1.1.1) failed" on Windows

2015-12-08 Thread Marko Lindqvist
Follow-up Comment #9, bug #18440 (project freeciv):

Unfortunately it seems that there's more to this. Initial success was achieved
on testing patch #6533 on S2_6, but the error is present in current S2_5 (with
patch #6533 committed)

In S2_6/TRUNK there's also patch #6496 + bug #24000 that could have some
effect on this.

___

Reply to this item at:

  

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] "IP_ADD_MEMBERSHIP (225.1.1.1) failed" on Windows

2015-12-08 Thread Jacob Nevins
Follow-up Comment #8, bug #18440 (project freeciv):

cazfi reports that upgrading to winsock2 (patch #6533) has, with his crosser
builds, (a) made this message go away (b) made LAN announcements work for the
first time.

___

Reply to this item at:

  

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2014-10-12 Thread anonymous
Follow-up Comment #7, bug #18440 (project freeciv):

This bug is also seen at http://gna.org/bugs/?22448#comment10
with crosser build freeciv-win32-2.5.99-dev-r25830 

and

http://gna.org/bugs/?22448#comment16
a user compiled freeciv 2.5.0-beta1+ on windows

___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2014-03-11 Thread Jacob Nevins
Follow-up Comment #6, bug #18440 (project freeciv):

See also bug #19840.

___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2014-02-02 Thread Jacob Nevins
Follow-up Comment #4, bug #18440 (project freeciv):

Just tried both cproc's r24327 test build
http://download.gna.org/freeciv/packages/windows/testing/S2_4-r24327/ and
cazfi's S2_4 r24328 crosser build (with win32stack-0.12).

cproc's build did not show the issue but cazfi's did show it:


1: IP_ADD_MEMBERSHIP (225.1.1.1) failed: An unknown, invalid, or unsupported
option or level was specified in a getsockopt or setsockopt call.


Same Windows 7 install as before. This time I can confirm it was not connected
to a network.

___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2014-02-02 Thread Jacob Nevins
Follow-up Comment #5, bug #18440 (project freeciv):

(On starting a standalone server, this is.)

___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2013-08-04 Thread Marko Lindqvist
Follow-up Comment #3, bug #18440 (project freeciv):

Maybe relevant information about conditional compilation around the failing
call about crosser builds (from fc_config.h)

IPV6_SUPPORT not defined
HAVE_INET_ATON not defined


___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2012-07-20 Thread Jacob Nevins
Follow-up Comment #2, bug #18440 (project freeciv):

The whole message is there, but you have to select the text and drag right to
see it (dodgy CSS?)

An unknown, invalid, or unsupported option or level was specified in a
getsockopt or setsockopt call.

I think I get something like this on Linux when starting Freeciv with no
Internet connection; it's quite possible that Windows didn't have access to
the Internet this time (it often doesn't).

___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2012-07-19 Thread Marko Lindqvist
Follow-up Comment #1, bug #18440 (project freeciv):

Was the end of error message eaten by gna formatting, or does it really not
tell what is invalid?

This comes from sernet.c:server_open_socket() and as you suspected it's part
of setting up game announcement socket.

___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev


[Freeciv-Dev] [bug #18440] IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows

2011-08-01 Thread Jacob Nevins

URL:
  http://gna.org/bugs/?18440

 Summary: IP_ADD_MEMBERSHIP (225.1.1.1) failed on Windows
 Project: Freeciv
Submitted by: jtn
Submitted on: Tue Aug  2 01:39:48 2011
Category: general
Severity: 3 - Normal
Priority: 5 - Normal
  Status: None
 Assigned to: None
Originator Email: 
 Open/Closed: Open
 Release: 
 Discussion Lock: Any
Operating System: Microsoft Windows
 Planned Release: 2.4.0

___

Details:

Noticed with cazfi's trunk build (r20045) on Windows 7 Home Premium 32-bit:
on starting the server, I get:


1: IP_ADD_MEMBERSHIP (225.1.1.1) failed: An unknown, invalid, or unsupported
option or level was specified in a getsockopt or setsockopt call.


Also visible briefly in the client when it spawns a server.

I think I've seen this previously with other versions, probably S2_3 builds.
Haven't checked yet if it's just cazfi's builds or cproc's as well.

I'm guessing this is something to do with the LAN scan. When I started a
server and a separate client, the server didn't show up on the scan.




___

Reply to this item at:

  http://gna.org/bugs/?18440

___
  Message sent via/by Gna!
  http://gna.org/


___
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev