Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Martin Kosek
On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote: On 04/15/2013 07:06 PM, Martin Kosek wrote: On 04/15/2013 06:53 PM, Ana Krivokapic wrote: On 04/15/2013 06:30 PM, Martin Kosek wrote: On 04/12/2013 08:45 PM, Ana Krivokapic wrote: On 04/12/2013 01:26 PM, Ana Krivokapic

Re: [Freeipa-devel] [PATCHES] 126-127 Use A/AAAA records instead of CNAME records in ipa-ca

2013-04-16 Thread Jan Cholasta
On 15.4.2013 21:16, Martin Kosek wrote: Jan, can you please rebase the patch also for ipa-3-1? We will need to fix this issue also for 3.1. Yep. -- Jan Cholasta From eb97cc1e5fa6b1d2953b78c72e601e17a87be208 Mon Sep 17 00:00:00 2001 From: Jan Cholasta jchol...@redhat.com Date: Mon, 15 Apr 2013

[Freeipa-devel] [PATCH] 128 Do not use new LDAP API in old code

2013-04-16 Thread Jan Cholasta
Hi, while rebasing patches 126 127 on top of ipa-3-1, I have noticed that commit bceccbd6 uses new LDAP API, which is not available in 3.1. The attached patch fixes this. Honza -- Jan Cholasta From 19090a990a48934459ae66d7ce1443ce2c6fdbfd Mon Sep 17 00:00:00 2001 From: Jan Cholasta

[Freeipa-devel] [PATCH 0146] Disallow all dynamic updates if update policy configuration failed

2013-04-16 Thread Petr Spacek
Hello, Disallow all dynamic updates if update policy configuration failed. Without this patch the old update policy stays in effect when re-configuration failed. -- Petr^2 Spacek From b21eb8a84e2c02e7dd090d24d68f1e385b0604c3 Mon Sep 17 00:00:00 2001 From: Petr Spacek pspa...@redhat.com Date:

Re: [Freeipa-devel] [PATCH 0044] Update only selected attributes for winsync agreement

2013-04-16 Thread Tomas Babej
On 04/15/2013 11:58 PM, Rob Crittenden wrote: Tomas Babej wrote: On 04/09/2013 11:47 PM, Rob Crittenden wrote: Tomas Babej wrote: Hi, Trying to insert nsDS5ReplicatedAttributeListTotal and nsds5ReplicaStripAttrs to winsync agreements caused upgrade errors. With this patch, these attributes

Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Ana Krivokapic
On 04/16/2013 09:14 AM, Martin Kosek wrote: On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote: On 04/15/2013 07:06 PM, Martin Kosek wrote: On 04/15/2013 06:53 PM, Ana Krivokapic wrote: On 04/15/2013 06:30 PM, Martin Kosek wrote: On 04/12/2013 08:45 PM, Ana Krivokapic wrote:

[Freeipa-devel] [PATCH 0147] Improve error logging for zones with idnsAllowDynUpdate == FALSE.

2013-04-16 Thread Petr Spacek
Hello, Improve error logging for zones with idnsAllowDynUpdate == FALSE. Zones with dynamic updates disabled are re-configured with empty update policy string, so the update is refused by BIND and an error is logged. -- Petr Spacek From 88a472349aec5216467aa1e30a35b8689b1cd439 Mon Sep 17

[Freeipa-devel] [PATCH 0148] Explicitly return SERVFAIL if PTR synchronization is misconfigured.

2013-04-16 Thread Petr Spacek
Hello, Explicitly return SERVFAIL if PTR synchronization is misconfigured. SERVFAIL will be returned if PTR synchronization is enabled in forward zone but reverse zone has dynamic updates disabled. -- Petr Spacek From fe5f710b212b2cbe144f8132de5df3672ad479a5 Mon Sep 17 00:00:00 2001 From: Petr

Re: [Freeipa-devel] [PATCHES] 126-127 Use A/AAAA records instead of CNAME records in ipa-ca

2013-04-16 Thread Martin Kosek
On 04/16/2013 09:40 AM, Jan Cholasta wrote: On 15.4.2013 21:16, Martin Kosek wrote: Jan, can you please rebase the patch also for ipa-3-1? We will need to fix this issue also for 3.1. Yep. Thanks. Pushed both to ipa-3-1. Martin ___

Re: [Freeipa-devel] [PATCH] 128 Do not use new LDAP API in old code

2013-04-16 Thread Martin Kosek
On 04/16/2013 10:05 AM, Jan Cholasta wrote: Hi, while rebasing patches 126 127 on top of ipa-3-1, I have noticed that commit bceccbd6 uses new LDAP API, which is not available in 3.1. The attached patch fixes this. Honza ACK, pushed to ipa-3-1. Martin

[Freeipa-devel] [PATCH] 401 Require new samba and krb5

2013-04-16 Thread Martin Kosek
Require samba 4.0.5 (passdb API changed). Make sure that we use the right epoch number with samba so that the Requires is correctly enforced. Require krb5 1.11.2-1 to fix missing PAC issue. --- This patch makes sure we have the right dependencies in Fedora 19 (and Fedora 18 too for the samba

Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Alexander Bokovoy
On Tue, 16 Apr 2013, Martin Kosek wrote: On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote: On 04/15/2013 07:06 PM, Martin Kosek wrote: On 04/15/2013 06:53 PM, Ana Krivokapic wrote: On 04/15/2013 06:30 PM, Martin Kosek wrote: On 04/12/2013 08:45 PM, Ana Krivokapic wrote:

Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Martin Kosek
On 04/16/2013 12:31 PM, Ana Krivokapic wrote: On 04/16/2013 09:14 AM, Martin Kosek wrote: On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote: On 04/15/2013 07:06 PM, Martin Kosek wrote: On 04/15/2013 06:53 PM, Ana Krivokapic wrote: On 04/15/2013 06:30 PM, Martin Kosek wrote:

Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Ana Krivokapic
On 04/16/2013 01:55 PM, Martin Kosek wrote: On 04/16/2013 12:31 PM, Ana Krivokapic wrote: On 04/16/2013 09:14 AM, Martin Kosek wrote: On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote: On 04/15/2013 07:06 PM, Martin Kosek wrote: On 04/15/2013 06:53 PM, Ana Krivokapic wrote:

Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Martin Kosek
On 04/16/2013 03:03 PM, Ana Krivokapic wrote: On 04/16/2013 01:55 PM, Martin Kosek wrote: On 04/16/2013 12:31 PM, Ana Krivokapic wrote: On 04/16/2013 09:14 AM, Martin Kosek wrote: On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote: On 04/15/2013 07:06 PM, Martin Kosek wrote:

Re: [Freeipa-devel] [PATCH] 401 Require new samba and krb5

2013-04-16 Thread Martin Kosek
On 04/16/2013 01:16 PM, Martin Kosek wrote: Require samba 4.0.5 (passdb API changed). Make sure that we use the right epoch number with samba so that the Requires is correctly enforced. Require krb5 1.11.2-1 to fix missing PAC issue. --- This patch makes sure we have the right

Re: [Freeipa-devel] [PATCH] 0017 Integrate realmdomains with IPA DNS

2013-04-16 Thread Ana Krivokapic
On 04/16/2013 03:54 PM, Martin Kosek wrote: On 04/16/2013 03:03 PM, Ana Krivokapic wrote: On 04/16/2013 01:55 PM, Martin Kosek wrote: On 04/16/2013 12:31 PM, Ana Krivokapic wrote: On 04/16/2013 09:14 AM, Martin Kosek wrote: On 04/15/2013 11:21 PM, Rob Crittenden wrote: Ana Krivokapic wrote:

Re: [Freeipa-devel] [PATCH 0044] Update only selected attributes for winsync agreement

2013-04-16 Thread Rob Crittenden
Tomas Babej wrote: On 04/15/2013 11:58 PM, Rob Crittenden wrote: Tomas Babej wrote: On 04/09/2013 11:47 PM, Rob Crittenden wrote: Tomas Babej wrote: Hi, Trying to insert nsDS5ReplicatedAttributeListTotal and nsds5ReplicaStripAttrs to winsync agreements caused upgrade errors. With this

Re: [Freeipa-devel] [PATCH] 401 Require new samba and krb5

2013-04-16 Thread Petr Viktorin
On 04/16/2013 01:16 PM, Martin Kosek wrote: Require samba 4.0.5 (passdb API changed). Make sure that we use the right epoch number with samba so that the Requires is correctly enforced. Require krb5 1.11.2-1 to fix missing PAC issue. --- This patch makes sure we have the right dependencies in

Re: [Freeipa-devel] [PATCH] 401 Require new samba and krb5

2013-04-16 Thread Rob Crittenden
Petr Viktorin wrote: On 04/16/2013 01:16 PM, Martin Kosek wrote: Require samba 4.0.5 (passdb API changed). Make sure that we use the right epoch number with samba so that the Requires is correctly enforced. Require krb5 1.11.2-1 to fix missing PAC issue. --- This patch makes sure we have the

Re: [Freeipa-devel] [PATCH] 401 Require new samba and krb5

2013-04-16 Thread Rob Crittenden
Rob Crittenden wrote: Petr Viktorin wrote: On 04/16/2013 01:16 PM, Martin Kosek wrote: Require samba 4.0.5 (passdb API changed). Make sure that we use the right epoch number with samba so that the Requires is correctly enforced. Require krb5 1.11.2-1 to fix missing PAC issue. --- This patch