Re: [Freeipa-devel] [PATCH 0047] Unsaved changes dialog inconsistent

2015-05-07 Thread Petr Vobornik

On 05/05/2015 02:36 PM, Gabe Alford wrote:

Thanks Petr. I thought I had grepped all that out. Guess I didn't do it
from the top of the tree.

Updated patch attached.


ACK

Pushed to:
master: d1a0474d1851cd54a1fa7bdf4a0dc0ed452a0090
ipa-4-1: 5ac5564227757dfc367ca74fe86e99114d5b582b



On Tue, May 5, 2015 at 5:15 AM, Petr Vobornik pvobo...@redhat.com wrote:


On 04/30/2015 07:43 PM, Gabe Alford wrote:


Thanks Kyle and Petr.

Update patch attached.



Renaming the buttons also requires to update webui integration tests in
ipatests/test_webui, quick search:
   ipatests/test_webui/test_realmdomains.py:42,48
   ipatests/test_webui/ui_driver.py:1221,1246,1464,1483





On Wed, Apr 29, 2015 at 7:59 AM, Kyle Baker kyba...@redhat.com wrote:



- Original Message -


On 04/27/2015 03:03 PM, Gabe Alford wrote:


Hello,

Fix for https://fedorahosted.org/freeipa/ticket/4926

Thanks,

Gabe



PatternFly has new recommendations for terminology and wording [1]. I'm
not entirely sure if the usage of 'save' here is good. PF defines 'edit'
as the recommended term. The page doesn't say if 'save' is not
recommended, though. Save seems to me as a confirmation of editing.



Yes I think save would be best here based on the message given.

Thanks for checking out the Terminology screen!



Kyle, could you advise what is the best term for reflecting user changes
and for confirmation of this action?

Technical notes:
1. it would be better to add a new string and then use it in the button
instead of having 'Save' text for '@i18n:buttons.update' definition.

2. String changes in internal.py should be also reflected in
install/ui/test/data/ipa_init.json (for static web ui demo).

3. optional: in addition to text change, buttons and related actions
could also be renamed (same reasons as in 1). It's more proper but much
more complicated.


[1]


https://www.patternfly.org/styles/terminology-and-wording/#action-labels


--
Petr Vobornik








--
Petr Vobornik






--
Petr Vobornik

--
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code


Re: [Freeipa-devel] [PATCH 0047] Unsaved changes dialog inconsistent

2015-05-05 Thread Gabe Alford
Thanks Petr. I thought I had grepped all that out. Guess I didn't do it
from the top of the tree.

Updated patch attached.

On Tue, May 5, 2015 at 5:15 AM, Petr Vobornik pvobo...@redhat.com wrote:

 On 04/30/2015 07:43 PM, Gabe Alford wrote:

 Thanks Kyle and Petr.

 Update patch attached.


 Renaming the buttons also requires to update webui integration tests in
 ipatests/test_webui, quick search:
   ipatests/test_webui/test_realmdomains.py:42,48
   ipatests/test_webui/ui_driver.py:1221,1246,1464,1483




 On Wed, Apr 29, 2015 at 7:59 AM, Kyle Baker kyba...@redhat.com wrote:


 - Original Message -

 On 04/27/2015 03:03 PM, Gabe Alford wrote:

 Hello,

 Fix for https://fedorahosted.org/freeipa/ticket/4926

 Thanks,

 Gabe


 PatternFly has new recommendations for terminology and wording [1]. I'm
 not entirely sure if the usage of 'save' here is good. PF defines 'edit'
 as the recommended term. The page doesn't say if 'save' is not
 recommended, though. Save seems to me as a confirmation of editing.


 Yes I think save would be best here based on the message given.

 Thanks for checking out the Terminology screen!


 Kyle, could you advise what is the best term for reflecting user changes
 and for confirmation of this action?

 Technical notes:
 1. it would be better to add a new string and then use it in the button
 instead of having 'Save' text for '@i18n:buttons.update' definition.

 2. String changes in internal.py should be also reflected in
 install/ui/test/data/ipa_init.json (for static web ui demo).

 3. optional: in addition to text change, buttons and related actions
 could also be renamed (same reasons as in 1). It's more proper but much
 more complicated.


 [1]

 https://www.patternfly.org/styles/terminology-and-wording/#action-labels

 --
 Petr Vobornik





 --
 Petr Vobornik

From 03863c17968a182b5e1857c0cb57ebb956576021 Mon Sep 17 00:00:00 2001
From: Gabe redhatri...@gmail.com
Date: Tue, 5 May 2015 06:33:27 -0600
Subject: [PATCH] Unsaved changes dialog internally inconsistent

https://fedorahosted.org/freeipa/ticket/4926
---
 install/ui/src/freeipa/details.js| 30 +++---
 install/ui/src/freeipa/dns.js|  2 +-
 install/ui/src/freeipa/ipa.js|  8 
 install/ui/test/data/ipa_init.json   |  2 ++
 install/ui/util/make-ui.sh   |  2 +-
 ipalib/plugins/internal.py   |  2 ++
 ipatests/test_webui/test_realmdomains.py |  4 ++--
 ipatests/test_webui/ui_driver.py |  8 
 8 files changed, 31 insertions(+), 27 deletions(-)

diff --git a/install/ui/src/freeipa/details.js b/install/ui/src/freeipa/details.js
index 7aa4c0ef6541900d6fa5b14b16ec964b50349015..e428dc90875a1ad567a13f379aa5ca079e47b672 100644
--- a/install/ui/src/freeipa/details.js
+++ b/install/ui/src/freeipa/details.js
@@ -453,8 +453,8 @@ exp.facet_policies = IPA.facet_policies = function(spec) {
  * - sets name, title, label if not present
  * - adds default actions and related buttons
  *   - refresh
- *   - reset
- *   - update
+ *   - revert
+ *   - save
  * - adds dirty state evaluator
  *
  * @member details
@@ -472,21 +472,21 @@ exp.details_facet_pre_op = function(spec, context) {
 spec.actions = spec.actions || [];
 spec.actions.unshift(
 'refresh',
-'reset',
-'update');
+'revert',
+'save');
 
 spec.control_buttons = spec.control_buttons || [];
 
 if (!spec.no_update) {
 spec.control_buttons.unshift(
 {
-name: 'reset',
-label: '@i18n:buttons.reset',
+name: 'revert',
+label: '@i18n:buttons.revert',
 icon: 'fa-undo'
 },
 {
-name: 'update',
-label: '@i18n:buttons.update',
+name: 'save',
+label: '@i18n:buttons.save',
 icon: 'fa-upload'
 });
 }
@@ -1404,8 +1404,8 @@ exp.refresh_action = IPA.refresh_action = function(spec) {
 exp.reset_action = IPA.reset_action = function(spec) {
 
 spec = spec || {};
-spec.name = spec.name || 'reset';
-spec.label = spec.label || '@i18n:buttons.reset';
+spec.name = spec.name || 'revert';
+spec.label = spec.label || '@i18n:buttons.revert';
 spec.enable_cond = spec.enable_cond || ['dirty'];
 
 var that = IPA.action(spec);
@@ -1426,8 +1426,8 @@ exp.reset_action = IPA.reset_action = function(spec) {
 exp.update_action = IPA.update_action = function(spec) {
 
 spec = spec || {};
-spec.name = spec.name || 'update';
-spec.label = spec.label || '@i18n:buttons.update';
+spec.name = spec.name || 'save';
+spec.label = spec.label || '@i18n:buttons.save';
 spec.needs_confirm = spec.needs_confirm !== undefined ? spec.needs_confirm : false;
 spec.enable_cond = spec.enable_cond || ['dirty'];
 
@@ -2007,8 +2007,8 @@ exp.register = function() {
 var f = reg.facet;
 
 

Re: [Freeipa-devel] [PATCH 0047] Unsaved changes dialog inconsistent

2015-05-05 Thread Petr Vobornik

On 04/30/2015 07:43 PM, Gabe Alford wrote:

Thanks Kyle and Petr.

Update patch attached.


Renaming the buttons also requires to update webui integration tests in 
ipatests/test_webui, quick search:

  ipatests/test_webui/test_realmdomains.py:42,48
  ipatests/test_webui/ui_driver.py:1221,1246,1464,1483




On Wed, Apr 29, 2015 at 7:59 AM, Kyle Baker kyba...@redhat.com wrote:



- Original Message -

On 04/27/2015 03:03 PM, Gabe Alford wrote:

Hello,

Fix for https://fedorahosted.org/freeipa/ticket/4926

Thanks,

Gabe



PatternFly has new recommendations for terminology and wording [1]. I'm
not entirely sure if the usage of 'save' here is good. PF defines 'edit'
as the recommended term. The page doesn't say if 'save' is not
recommended, though. Save seems to me as a confirmation of editing.


Yes I think save would be best here based on the message given.

Thanks for checking out the Terminology screen!



Kyle, could you advise what is the best term for reflecting user changes
and for confirmation of this action?

Technical notes:
1. it would be better to add a new string and then use it in the button
instead of having 'Save' text for '@i18n:buttons.update' definition.

2. String changes in internal.py should be also reflected in
install/ui/test/data/ipa_init.json (for static web ui demo).

3. optional: in addition to text change, buttons and related actions
could also be renamed (same reasons as in 1). It's more proper but much
more complicated.


[1]

https://www.patternfly.org/styles/terminology-and-wording/#action-labels

--
Petr Vobornik








--
Petr Vobornik

--
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code


Re: [Freeipa-devel] [PATCH 0047] Unsaved changes dialog inconsistent

2015-04-30 Thread Gabe Alford
Thanks Kyle and Petr.

Update patch attached.

On Wed, Apr 29, 2015 at 7:59 AM, Kyle Baker kyba...@redhat.com wrote:


 - Original Message -
  On 04/27/2015 03:03 PM, Gabe Alford wrote:
   Hello,
  
   Fix for https://fedorahosted.org/freeipa/ticket/4926
  
   Thanks,
  
   Gabe
  
 
  PatternFly has new recommendations for terminology and wording [1]. I'm
  not entirely sure if the usage of 'save' here is good. PF defines 'edit'
  as the recommended term. The page doesn't say if 'save' is not
  recommended, though. Save seems to me as a confirmation of editing.

 Yes I think save would be best here based on the message given.

 Thanks for checking out the Terminology screen!

 
  Kyle, could you advise what is the best term for reflecting user changes
  and for confirmation of this action?
 
  Technical notes:
  1. it would be better to add a new string and then use it in the button
  instead of having 'Save' text for '@i18n:buttons.update' definition.
 
  2. String changes in internal.py should be also reflected in
  install/ui/test/data/ipa_init.json (for static web ui demo).
 
  3. optional: in addition to text change, buttons and related actions
  could also be renamed (same reasons as in 1). It's more proper but much
  more complicated.
 
 
  [1]
 https://www.patternfly.org/styles/terminology-and-wording/#action-labels
  --
  Petr Vobornik
 

From 45ea1a7804b76f73a3a83b1452f83b5895614986 Mon Sep 17 00:00:00 2001
From: Gabe redhatri...@gmail.com
Date: Thu, 30 Apr 2015 11:39:34 -0600
Subject: [PATCH] Unsaved changes dialog internally inconsistent

https://fedorahosted.org/freeipa/ticket/4926
---
 install/ui/src/freeipa/details.js  | 30 +++---
 install/ui/src/freeipa/dns.js  |  2 +-
 install/ui/src/freeipa/ipa.js  |  8 
 install/ui/test/data/ipa_init.json |  2 ++
 ipalib/plugins/internal.py |  2 ++
 5 files changed, 24 insertions(+), 20 deletions(-)

diff --git a/install/ui/src/freeipa/details.js b/install/ui/src/freeipa/details.js
index 7aa4c0ef6541900d6fa5b14b16ec964b50349015..e428dc90875a1ad567a13f379aa5ca079e47b672 100644
--- a/install/ui/src/freeipa/details.js
+++ b/install/ui/src/freeipa/details.js
@@ -453,8 +453,8 @@ exp.facet_policies = IPA.facet_policies = function(spec) {
  * - sets name, title, label if not present
  * - adds default actions and related buttons
  *   - refresh
- *   - reset
- *   - update
+ *   - revert
+ *   - save
  * - adds dirty state evaluator
  *
  * @member details
@@ -472,21 +472,21 @@ exp.details_facet_pre_op = function(spec, context) {
 spec.actions = spec.actions || [];
 spec.actions.unshift(
 'refresh',
-'reset',
-'update');
+'revert',
+'save');
 
 spec.control_buttons = spec.control_buttons || [];
 
 if (!spec.no_update) {
 spec.control_buttons.unshift(
 {
-name: 'reset',
-label: '@i18n:buttons.reset',
+name: 'revert',
+label: '@i18n:buttons.revert',
 icon: 'fa-undo'
 },
 {
-name: 'update',
-label: '@i18n:buttons.update',
+name: 'save',
+label: '@i18n:buttons.save',
 icon: 'fa-upload'
 });
 }
@@ -1404,8 +1404,8 @@ exp.refresh_action = IPA.refresh_action = function(spec) {
 exp.reset_action = IPA.reset_action = function(spec) {
 
 spec = spec || {};
-spec.name = spec.name || 'reset';
-spec.label = spec.label || '@i18n:buttons.reset';
+spec.name = spec.name || 'revert';
+spec.label = spec.label || '@i18n:buttons.revert';
 spec.enable_cond = spec.enable_cond || ['dirty'];
 
 var that = IPA.action(spec);
@@ -1426,8 +1426,8 @@ exp.reset_action = IPA.reset_action = function(spec) {
 exp.update_action = IPA.update_action = function(spec) {
 
 spec = spec || {};
-spec.name = spec.name || 'update';
-spec.label = spec.label || '@i18n:buttons.update';
+spec.name = spec.name || 'save';
+spec.label = spec.label || '@i18n:buttons.save';
 spec.needs_confirm = spec.needs_confirm !== undefined ? spec.needs_confirm : false;
 spec.enable_cond = spec.enable_cond || ['dirty'];
 
@@ -2007,8 +2007,8 @@ exp.register = function() {
 var f = reg.facet;
 
 a.register('refresh', exp.refresh_action);
-a.register('reset', exp.reset_action);
-a.register('update', exp.update_action);
+a.register('revert', exp.reset_action);
+a.register('save', exp.update_action);
 a.register('object', exp.object_action);
 a.register('enable', exp.enable_action);
 a.register('disable', exp.disable_action);
@@ -2026,4 +2026,4 @@ exp.register = function() {
 phases.on('registration', exp.register);
 
 return exp;
-});
\ No newline at end of file
+});
diff --git a/install/ui/src/freeipa/dns.js b/install/ui/src/freeipa/dns.js
index 

Re: [Freeipa-devel] [PATCH 0047] Unsaved changes dialog inconsistent

2015-04-29 Thread Kyle Baker

- Original Message -
 On 04/27/2015 03:03 PM, Gabe Alford wrote:
  Hello,
 
  Fix for https://fedorahosted.org/freeipa/ticket/4926
 
  Thanks,
 
  Gabe
 
 
 PatternFly has new recommendations for terminology and wording [1]. I'm
 not entirely sure if the usage of 'save' here is good. PF defines 'edit'
 as the recommended term. The page doesn't say if 'save' is not
 recommended, though. Save seems to me as a confirmation of editing.

Yes I think save would be best here based on the message given. 

Thanks for checking out the Terminology screen!

 
 Kyle, could you advise what is the best term for reflecting user changes
 and for confirmation of this action?
 
 Technical notes:
 1. it would be better to add a new string and then use it in the button
 instead of having 'Save' text for '@i18n:buttons.update' definition.
 
 2. String changes in internal.py should be also reflected in
 install/ui/test/data/ipa_init.json (for static web ui demo).
 
 3. optional: in addition to text change, buttons and related actions
 could also be renamed (same reasons as in 1). It's more proper but much
 more complicated.
 
 
 [1] https://www.patternfly.org/styles/terminology-and-wording/#action-labels
 --
 Petr Vobornik
 

-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code


Re: [Freeipa-devel] [PATCH 0047] Unsaved changes dialog inconsistent

2015-04-27 Thread Petr Vobornik

On 04/27/2015 03:03 PM, Gabe Alford wrote:

Hello,

Fix for https://fedorahosted.org/freeipa/ticket/4926

Thanks,

Gabe



PatternFly has new recommendations for terminology and wording [1]. I'm 
not entirely sure if the usage of 'save' here is good. PF defines 'edit' 
as the recommended term. The page doesn't say if 'save' is not 
recommended, though. Save seems to me as a confirmation of editing.


Kyle, could you advise what is the best term for reflecting user changes 
and for confirmation of this action?


Technical notes:
1. it would be better to add a new string and then use it in the button 
instead of having 'Save' text for '@i18n:buttons.update' definition.


2. String changes in internal.py should be also reflected in 
install/ui/test/data/ipa_init.json (for static web ui demo).


3. optional: in addition to text change, buttons and related actions 
could also be renamed (same reasons as in 1). It's more proper but much 
more complicated.



[1] https://www.patternfly.org/styles/terminology-and-wording/#action-labels
--
Petr Vobornik

--
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code