Problems with compiling freeradius on Ubuntu Linux

2013-10-12 Thread Andrei Petru Mura
Hello,

I imported FreeRADIUS from git on Eclipse, and tried to build it, but this
error occurs while building the project:

*threads.h:47:2: error: #error WITH_THREADS defined, but pthreads not
available*
*
*
Can anybody guide me how to solve this issue? Thanks.
-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html

Re: Problems with compiling freeradius on Ubuntu Linux

2013-10-12 Thread Arran Cudbard-Bell

On 12 Oct 2013, at 17:40, Andrei Petru Mura mapand...@gmail.com wrote:

 Hello,
 
 I imported FreeRADIUS from git on Eclipse, and tried to build it, but this 
 error occurs while building the project:
 
 threads.h:47:2: error: #error WITH_THREADS defined, but pthreads not available
 
 Can anybody guide me how to solve this issue? Thanks.

This is an invalid state. The configure script will not define WITH_THREADS 
unless the pthread headers are available.

Check if HAVE_PTHREAD_H and WITH_THREADS are defined src/include/autoheader.h. 
If they're both defined then Eclipse is messing with the build system, if one 
is defined and the other is not, then autoconf/the configure scripts are broken.

Arran Cudbard-Bell a.cudba...@freeradius.org
FreeRADIUS Development Team

-
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html