[FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Lilian RIGARD - Devclic

Bonjour à tous,

Etant donné que je n'ai plus d'idée et que je pense avoir exploré toutes 
les pistes possibles, j'expose mon problème, peut-être que vous l'avez 
déjà rencontré ...


Je dispose de 3 routeurs qui sont connectés de cette façon :

routeur1 - routeur 2 - routeur 3 ( jusque là rien de bien délirant 
et de bien compliqué )


OSPF est actif entre routeur 1 et routeur 2 avec la redistribution des 
statiques et des connected.

Routeur 3 dispose d'une gateway par défaut qui est routeur 2
routeur 1 a plusieurs vlans

Quand je prends un host qui est connecté derrière mon routeur 1 sur un 
vlan et que je veux pinguer l'IP de l'interface du routeur 2 qui est 
connectée avec le routeur 3, j'ai une perte de paquets de 1 sur 2 ( 50 %)


Pire encore ... quand je prends un autre host connecté à un autre vlan 
sur routeur 1 ( pas la même classe d'adresses IP ), les hosts ne 
pinguent nullement l'IP de l'interface du routeur 2 qui est connectée 
avec le routeur.


Je précise que toutes les routes sont bien renseignées :

A savoir que routeur 1 récupère bien une route de la part de routeur 2 
avec le netmask en /29 d'interconnexion avec routeur 3 et définit bien 
routeur 2 comme Next Hop et routeur 2 connait bien les Vlans de routeur 
1, ils sont également reçus via l'OSPF.


Un autre test que j'ai fait : pinguer depuis routeur 3, un Vlan de 
routeur 1 : le résultat est que je peux pinguer la passerelle mais pas 
les hosts ?!  ou bien même phénomène : un paquet sur 2 passe


Voici ma version d'IOS:

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
BOOTLDR: s222_rp Software (s222_rp-IPSERVICESK9_WAN-M), Version 
12.2(18)SXF17, RELEASE SOFTWARE (fc1)


Pensez-vous que l'IOS peut être buggué ?

En vous remerciant par avance pour vos lumières et votre aide.

Cordialement.
Lilian
---
Liste de diffusion du FRnOG
http://www.frnog.org/



Re: [FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Faycal
Est-ce que les hosts ont les routes vers R3 ?
Je pense qu il te faut une défault route dans tes hosts (connectes sur R1) qui 
pointe vers les interfaces vlan de ton catalyst 6000. C est la seule façon pour 
que tes hosts répondent aux Ping de R3

Envoyé de mon iPhone

Le 23 déc. 2010 à 08:57, Lilian RIGARD - Devclic lil...@devclic.fr a écrit :

 Bonjour à tous,
 
 Etant donné que je n'ai plus d'idée et que je pense avoir exploré toutes les 
 pistes possibles, j'expose mon problème, peut-être que vous l'avez déjà 
 rencontré ...
 
 Je dispose de 3 routeurs qui sont connectés de cette façon :
 
 routeur1 - routeur 2 - routeur 3 ( jusque là rien de bien délirant et de 
 bien compliqué )
 
 OSPF est actif entre routeur 1 et routeur 2 avec la redistribution des 
 statiques et des connected.
 Routeur 3 dispose d'une gateway par défaut qui est routeur 2
 routeur 1 a plusieurs vlans
 
 Quand je prends un host qui est connecté derrière mon routeur 1 sur un vlan 
 et que je veux pinguer l'IP de l'interface du routeur 2 qui est connectée 
 avec le routeur 3, j'ai une perte de paquets de 1 sur 2 ( 50 %)
 
 Pire encore ... quand je prends un autre host connecté à un autre vlan sur 
 routeur 1 ( pas la même classe d'adresses IP ), les hosts ne pinguent 
 nullement l'IP de l'interface du routeur 2 qui est connectée avec le routeur.
 
 Je précise que toutes les routes sont bien renseignées :
 
 A savoir que routeur 1 récupère bien une route de la part de routeur 2 avec 
 le netmask en /29 d'interconnexion avec routeur 3 et définit bien routeur 2 
 comme Next Hop et routeur 2 connait bien les Vlans de routeur 1, ils sont 
 également reçus via l'OSPF.
 
 Un autre test que j'ai fait : pinguer depuis routeur 3, un Vlan de routeur 1 
 : le résultat est que je peux pinguer la passerelle mais pas les hosts ?! 
  ou bien même phénomène : un paquet sur 2 passe
 
 Voici ma version d'IOS:
 
 ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
 BOOTLDR: s222_rp Software (s222_rp-IPSERVICESK9_WAN-M), Version 
 12.2(18)SXF17, RELEASE SOFTWARE (fc1)
 
 Pensez-vous que l'IOS peut être buggué ?
 
 En vous remerciant par avance pour vos lumières et votre aide.
 
 Cordialement.
 Lilian
 ---
 Liste de diffusion du FRnOG
 http://www.frnog.org/
 
---
Liste de diffusion du FRnOG
http://www.frnog.org/



Re: [FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Lilian RIGARD - Devclic
Les hosts ont pour gateway le routeur 1 qui lui a les routes vers R3 via 
l'OSPF ( pour mémoire /29 d'interconnexion entre le router 2 et router 3 
annoncée par l'OSPF )


Lilian.

Le 23/12/10 13:10, Faycal a écrit :

Est-ce que les hosts ont les routes vers R3 ?
Je pense qu il te faut une défault route dans tes hosts (connectes sur R1) qui 
pointe vers les interfaces vlan de ton catalyst 6000. C est la seule façon pour 
que tes hosts répondent aux Ping de R3

Envoyé de mon iPhone

Le 23 déc. 2010 à 08:57, Lilian RIGARD - Devcliclil...@devclic.fr  a écrit :


Bonjour à tous,

Etant donné que je n'ai plus d'idée et que je pense avoir exploré toutes les 
pistes possibles, j'expose mon problème, peut-être que vous l'avez déjà 
rencontré ...

Je dispose de 3 routeurs qui sont connectés de cette façon :

routeur1-  routeur 2-  routeur 3 ( jusque là rien de bien délirant et de 
bien compliqué )

OSPF est actif entre routeur 1 et routeur 2 avec la redistribution des 
statiques et des connected.
Routeur 3 dispose d'une gateway par défaut qui est routeur 2
routeur 1 a plusieurs vlans

Quand je prends un host qui est connecté derrière mon routeur 1 sur un vlan et 
que je veux pinguer l'IP de l'interface du routeur 2 qui est connectée avec le 
routeur 3, j'ai une perte de paquets de 1 sur 2 ( 50 %)

Pire encore ... quand je prends un autre host connecté à un autre vlan sur 
routeur 1 ( pas la même classe d'adresses IP ), les hosts ne pinguent nullement 
l'IP de l'interface du routeur 2 qui est connectée avec le routeur.

Je précise que toutes les routes sont bien renseignées :

A savoir que routeur 1 récupère bien une route de la part de routeur 2 avec le 
netmask en /29 d'interconnexion avec routeur 3 et définit bien routeur 2 comme 
Next Hop et routeur 2 connait bien les Vlans de routeur 1, ils sont également 
reçus via l'OSPF.

Un autre test que j'ai fait : pinguer depuis routeur 3, un Vlan de routeur 1 : 
le résultat est que je peux pinguer la passerelle mais pas les hosts ?!  ou 
bien même phénomène : un paquet sur 2 passe

Voici ma version d'IOS:

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
BOOTLDR: s222_rp Software (s222_rp-IPSERVICESK9_WAN-M), Version 12.2(18)SXF17, 
RELEASE SOFTWARE (fc1)

Pensez-vous que l'IOS peut être buggué ?

En vous remerciant par avance pour vos lumières et votre aide.

Cordialement.
Lilian
---
Liste de diffusion du FRnOG
http://www.frnog.org/



---
Liste de diffusion du FRnOG
http://www.frnog.org/



Re: [FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Julien Gormotte
On Thu, 23 Dec 2010 12:10:28 +, Faycal faycal.h...@gmail.com 
wrote:

Est-ce que les hosts ont les routes vers R3 ?
Je pense qu il te faut une défault route dans tes hosts (connectes
sur R1) qui pointe vers les interfaces vlan de ton catalyst 6000. C
est la seule façon pour que tes hosts répondent aux Ping de R3


On te l'a sûrement déjà faite, mais bon, quand même, y'a matière, 
Faycal.

Pardon, mais j'ai pas pu résister :)

Vraiment désolé :p



Envoyé de mon iPhone

Le 23 déc. 2010 à 08:57, Lilian RIGARD - Devclic lil...@devclic.fr
a écrit :


Bonjour à tous,

Etant donné que je n'ai plus d'idée et que je pense avoir exploré 
toutes les pistes possibles, j'expose mon problème, peut-être que vous 
l'avez déjà rencontré ...


Je dispose de 3 routeurs qui sont connectés de cette façon :

routeur1 - routeur 2 - routeur 3 ( jusque là rien de bien 
délirant et de bien compliqué )


OSPF est actif entre routeur 1 et routeur 2 avec la redistribution 
des statiques et des connected.

Routeur 3 dispose d'une gateway par défaut qui est routeur 2
routeur 1 a plusieurs vlans

Quand je prends un host qui est connecté derrière mon routeur 1 sur 
un vlan et que je veux pinguer l'IP de l'interface du routeur 2 qui 
est connectée avec le routeur 3, j'ai une perte de paquets de 1 sur 2 
( 50 %)


Pire encore ... quand je prends un autre host connecté à un autre 
vlan sur routeur 1 ( pas la même classe d'adresses IP ), les hosts ne 
pinguent nullement l'IP de l'interface du routeur 2 qui est connectée 
avec le routeur.


Je précise que toutes les routes sont bien renseignées :

A savoir que routeur 1 récupère bien une route de la part de routeur 
2 avec le netmask en /29 d'interconnexion avec routeur 3 et définit 
bien routeur 2 comme Next Hop et routeur 2 connait bien les Vlans de 
routeur 1, ils sont également reçus via l'OSPF.


Un autre test que j'ai fait : pinguer depuis routeur 3, un Vlan de 
routeur 1 : le résultat est que je peux pinguer la passerelle mais pas 
les hosts ?!  ou bien même phénomène : un paquet sur 2 passe


Voici ma version d'IOS:

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
BOOTLDR: s222_rp Software (s222_rp-IPSERVICESK9_WAN-M), Version 
12.2(18)SXF17, RELEASE SOFTWARE (fc1)


Pensez-vous que l'IOS peut être buggué ?

En vous remerciant par avance pour vos lumières et votre aide.

Cordialement.
Lilian
---
Liste de diffusion du FRnOG
http://www.frnog.org/


---
Liste de diffusion du FRnOG
http://www.frnog.org/


---
Liste de diffusion du FRnOG
http://www.frnog.org/



Re: [FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Nicolas CARTRON

On 12/23/10 2:06 PM, Julien Gormotte wrote:

On Thu, 23 Dec 2010 12:10:28 +, Faycal faycal.h...@gmail.com wrote:

Est-ce que les hosts ont les routes vers R3 ?
Je pense qu il te faut une défault route dans tes hosts (connectes
sur R1) qui pointe vers les interfaces vlan de ton catalyst 6000. C
est la seule façon pour que tes hosts répondent aux Ping de R3


On te l'a sûrement déjà faite, mais bon, quand même, y'a matière, Faycal.
Pardon, mais j'ai pas pu résister :)


je rêve...
---
Liste de diffusion du FRnOG
http://www.frnog.org/



Re: [FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Julien Gormotte
On Thu, 23 Dec 2010 14:08:45 +0100, Nicolas CARTRON cart...@me.com 
wrote:

On 12/23/10 2:06 PM, Julien Gormotte wrote:
On Thu, 23 Dec 2010 12:10:28 +, Faycal faycal.h...@gmail.com 
wrote:

Est-ce que les hosts ont les routes vers R3 ?
Je pense qu il te faut une défault route dans tes hosts (connectes
sur R1) qui pointe vers les interfaces vlan de ton catalyst 6000. C
est la seule façon pour que tes hosts répondent aux Ping de R3


On te l'a sûrement déjà faite, mais bon, quand même, y'a matière, 
Faycal.

Pardon, mais j'ai pas pu résister :)


je rêve...


J'ai honte, je le confesse.


---
Liste de diffusion du FRnOG
http://www.frnog.org/


---
Liste de diffusion du FRnOG
http://www.frnog.org/



RE: [FRnOG] Cisco / Drop de paquets

2010-12-23 Par sujet Michel Py
 routeur1 - routeur 2 - routeur 3 ( jusque là rien de
 bien délirant et de bien compliqué )

- Regarde l'âge de tes routes. Si certaines des routes sont récentes, tu as une 
route qui flappe, donc ton routage n'est pas stable et il faut trouver pourquoi.

- Surement très bête, mais est-ce que routeur 2 a une route pour le coté hosts 
de router 3?

- Il y a des loopbacks sur tes routeurs? En pinguant de loopback à loopback on 
peut des fois avoir une meilleure idée.

- Une perte de 50% suggère qu'il pourrait y avoir 2 routes pour 1 destination 
et qu'une des routes est invalide, souvent une redistribuée qui se mord la 
queue.

- Quand rien d'autre ne marche, mets des statiques de bout en bout pour 
vérifier que tu n'a pas un problème physique.

- term mon est ton ami pour voir les messages genre duplex mismatch et autres.



 Pensez-vous que l'IOS peut être buggué ?

Mais non, un IOS buggué c'est impossible, tout le monde ici le sait :P

Michel.

---
Liste de diffusion du FRnOG
http://www.frnog.org/