Re: [galaxy-dev] Galaxy Tool Shed:- Uploading tool packages fails with Server Error message

2011-04-19 Thread Vipin TS
Hi Greg, Regarding the tools contained in fml_gff_converter_programs.tar.bz2, the following xml files are not well formed due to the malformed ! -- TODO EDIT HERE tag: fml_gff_converter_programs/galaxy/bed_to_gff3.xml fml_gff_converter_programs/galaxy/gff3_to_bed.xml

[galaxy-dev] Setting min/max limit on repeat tag in tool XML file

2011-04-19 Thread Peter Cock
Hi all, I'm working on a tool where the repeat tag looks like an elegant solution - however I want to limit the number of repeats to be 1, 2 or 3. i.e. I want to set min=1 and max=3 attributes for the repeat, based on analogy to the param tag. Is this possible, but not documented here?

Re: [galaxy-dev] Setting min/max limit on repeat tag in tool XML file

2011-04-19 Thread Daniel Blankenberg
Hi Peter, Yes, setting min and max values in the repeat tag should work as you need. As you point out, it is probably not well documented, so please let us know if it isn't working as you imagine it should. Thanks for using Galaxy, Dan On Apr 19, 2011, at 6:47 AM, Peter Cock wrote: Hi

Re: [galaxy-dev] Setting min/max limit on repeat tag in tool XML file

2011-04-19 Thread Peter Cock
On Tue, Apr 19, 2011 at 1:46 PM, Daniel Blankenberg d...@bx.psu.edu wrote: Hi Peter, Yes, setting min and max values in the repeat tag should work as you need. As you point out, it is probably not well documented, so please let us know if it isn't working as you imagine it should. Thanks

Re: [galaxy-dev] FTP upload of data

2011-04-19 Thread Dannon Baker
To be clear, you were able to connect to the galaxy server using WinSCP in plain FTP mode, and had no errors uploading the files? -Dannon On Apr 19, 2011, at 9:37 AM, vasu punj wrote: Dannon, I used winSCP to upload the files but dont see in Galaxy in history of uploaded files or even

Re: [galaxy-dev] FTP upload of data

2011-04-19 Thread Dannon Baker
Ok, great. Please do remember to reply-all and include the list in the future. Among other things, it helps us immensely in keeping track of what has and has not been answered. -Dannon On Apr 19, 2011, at 9:43 AM, vasu punj wrote: I figured out and find files. Thanks. --- On Tue,

Re: [galaxy-dev] Setting min/max limit on repeat tag in tool XML file

2011-04-19 Thread Peter Cock
On Tue, Apr 19, 2011 at 2:23 PM, Peter Cock p.j.a.c...@googlemail.com wrote: What I need to work out now is how to use repeat parameters in the unit tests. There seems to be examples in tools/mutation/visualize.xml and tools/plotting/xy_plot.xml which only use the first repeat... I've tried to

Re: [galaxy-dev] Launching multiple jobs using one tool form with multiple selected datasets

2011-04-19 Thread Dave Walton
Is the server below down? I'm trying to get there this morning and having no luck... https://wiki.nbic.nl/index.php/NBIC_Galaxy_Hackathon_project#Loop_over_files _in_a_directory Dave On 4/15/11 12:16 PM, Pieter Neerincx pieter.neeri...@gmail.com wrote: Hi, You're not alone with this

Re: [galaxy-dev] Setting min/max limit on repeat tag in tool XML file

2011-04-19 Thread Peter Cock
On Tue, Apr 19, 2011 at 3:38 PM, Daniel Blankenberg d...@bx.psu.edu wrote: Hi Peter, The test framework could use a bit of work, and better handling of grouping-style parameters (such as repeats) is one significant area needing improvement. Noted. Is there an issue open on this already?

[galaxy-dev] Execution of workflows using API

2011-04-19 Thread Takafumi Yamaguchi
Hello, I have a question regarding execution of workflows using API (workflow_execute.py). I am writing a script to automate file uploading and workflow execution using API. I was able to upload files and the response gave me ids for each file with 32 characters although the README

[galaxy-dev] BLAST+ HTML output broken

2011-04-19 Thread Peter Cock
Hi Kanwei, I noticed that the BLAST+ output options for HTML are not working, a side effect of my recent refactoring. Could you transplant/merge this fix and test please: https://bitbucket.org/peterjc/galaxy-central/changeset/e1e6f92e07bf

[galaxy-dev] DRMAA_python installation problem

2011-04-19 Thread Johannes Eichner
Dear Galaxy Team, I just updated my local instance of galaxy, and now I have a problem with the DRMAA_python egg, which makes it impossible to run jobs on our SGE cluster. I get the following error message after executing run.sh: Traceback (most recent call last): File

Re: [galaxy-dev] Execution of workflows using API

2011-04-19 Thread Dannon Baker
Taka, Would you mind sharing the exact command you used to call workflow_execute.py? It does sound like you're doing something very similar to what scripts/api/example_watch_folder.py does. That script also uploads from the file system to a data library and subsequently executes a workflow

[galaxy-dev] bwa failure preparing job

2011-04-19 Thread Branden Timm
Hi All, I'm having issues running BWA for Illumina with the latest version of Galaxy (5433:c1aeb2f33b4a). It seems that the error is a python list error while preparing the job: Traceback (most recent call last): File /home/galaxy/galaxy-central/lib/galaxy/jobs/runners/local.py, line 58,

Re: [galaxy-dev] DRMAA_python installation problem

2011-04-19 Thread Nate Coraor
Hi Johannes, Johannes Eichner wrote: Dear Galaxy Team, I just updated my local instance of galaxy, and now I have a problem with the DRMAA_python egg, which makes it impossible to run jobs on our SGE cluster. I get the following error message after executing run.sh: ... gcc -pthread

[galaxy-dev] No Menu after submitting workflow

2011-04-19 Thread Dave Walton
I'm getting inconsistent behavior when I run a workflow. I have one workflow,that when I run it, the green box indicating my workflow has been submitted shows up in the middle panel with Tools to the left, histories to the right, and menu above. For another workflow, I submit it successfully,

Re: [galaxy-dev] No Menu after submitting workflow

2011-04-19 Thread Dannon Baker
Dave, What revision of galaxy are you running (hg tip)? We've made a few changes quite recently to running workflows, though I haven't seen any errors like this yet. Also, what's different about the two workflows (history destinations, multiple-inputs, rename actions, etc.)? -Dannon On

Re: [galaxy-dev] No Menu after submitting workflow

2011-04-19 Thread Dave Walton
ca0c4ad2bb39 is the last upstream change set in our fork (Glen is planning to update our fork with the latest dist later this week). Neither workflow does history destinations. Both histories have multiple inputs going to varying tools in the workflow. Both histories rename outputs. One workflow

Re: [galaxy-dev] BLAST+ HTML output broken

2011-04-19 Thread Kanwei Li
K On Tue, Apr 19, 2011 at 11:22 AM, Peter Cock p.j.a.c...@googlemail.com wrote: Hi Kanwei, I noticed that the BLAST+ output options for HTML are not working, a side effect of my recent refactoring. Could you transplant/merge this fix and test please: