Re: [galaxy-dev] Syntax issue for adding new tool

2012-02-07 Thread Louise-Amélie Schmitt
Hello, I'm not sure this will fix the issue but you might have to use -p $param_file.params instead of -p $params in your command line. Best, L-A Le 06/02/2012 22:15, Jeffrey Long a écrit : Hi all, I am having trouble with what looked to me at first to be a simple syntactical issue with

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Florent Angly
Hi Amanda, I would certainly be interested in using your helpful QIIME wrappers if you put them on the Toolshed. Best, Florent On 06/02/12 06:22, Amanda Zuzolo wrote: Hello, all. I have been working on getting the Qiime scripts into Galaxy as mentioned before, and they are working with Qiime

[galaxy-dev] Importing data from password protected UCSC Genome Browser

2012-02-07 Thread Federico De Masi
Dear colleagues, I have been struggling with this issue for quite a while now, and I don't seem to find a solution (neither in situ nor in webo). here it is: Because of the confidentiality of our data, I have setup both a Galaxy server and a UCSC Genome Browser locally on my server. Both

[galaxy-dev] Adding a new python tool

2012-02-07 Thread Sarah Maman
Hello, I managed to add a new tool coded in bash but I am having some difficulty adding a tool coded in python. Here are the contents of the test files: * Content of test.xml file in galaxy/galaxy-dist/tools/test/test.xml : tool id=test name=Test name descriptionTest description/description

Re: [galaxy-dev] Adding a new python tool

2012-02-07 Thread Langhorst, Brad
Sarah: I've had trouble before with invalid xml files (in your case test.xml) I don't see an obvious problem with your file, but I've never tried such a minimal file. Have a look at galaxy's log during startup to see if it tells you what it does not like about the file. Brad -- Brad Langhorst

Re: [galaxy-dev] Looking for recommendations: How to run galaxy workflows in batch

2012-02-07 Thread Louise-Amélie Schmitt
Hello Dannon Could it be possible to have the input dataset's display name appended to the new history's name instead of plain numbers when the Send results in a new history option is checked? This new feature is indeed very useful (thanks a million for it) but the numbered suffixes

Re: [galaxy-dev] Looking for recommendations: How to run galaxy workflows in batch

2012-02-07 Thread Dannon Baker
Thanks for the suggestion, I like that! I'll make the change shortly. -Dannon On Feb 7, 2012, at 8:03 AM, Louise-Amélie Schmitt wrote: Hello Dannon Could it be possible to have the input dataset's display name appended to the new history's name instead of plain numbers when the Send

Re: [galaxy-dev] Galaxy Main Server Tool Repository

2012-02-07 Thread Nate Coraor
Hi Charlie, Just a minor correction, the Main server is Solaris 10, the clusters on which jobs run are Debian testing/unstable and RHEL 5.7. --nate On Feb 6, 2012, at 9:01 PM, Dannon Baker wrote: Hi Charlie, Our main galaxy server is actually running CentOS 5.10. The galaxy cloud

Re: [galaxy-dev] manage_db.sh error

2012-02-07 Thread Nate Coraor
On Feb 6, 2012, at 1:27 PM, Zachary Charlop-Powers wrote: Hi Galaxy Team, I am running a small local instance of Galaxy and I've run into a database error following an upgrade to the Jan27th galaxy-dist release. The last line when I run run.sh tells me to upgrade my database:

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Jeffrey Long
Hello Amanda, I was just about to embark on EXACTLY this process, so I would certainly be very interested in saving myself some work. Would there be any issue (that you're aware of, of course) with using QIIME 1.4.0 instead of 1.3? -Jeff On Tue, Feb 7, 2012 at 2:32 AM, Florent Angly

Re: [galaxy-dev] Postgresql To Galaxy

2012-02-07 Thread Nate Coraor
On Feb 7, 2012, at 6:28 AM, Rehan Saleem wrote: Hi nate , thanks for reply , actually i want to know how can i add my own tool in galaxy , how can i show the output of my postgreSQL function in galaxy just asume my postgresql database is connected to galaxy . i need the python and xml

Re: [galaxy-dev] Problem with latest database upgrade

2012-02-07 Thread Greg Von Kuster
Hi Thon, The fix for this issue in now available in the central repo in change set revision 271ccd09bc23. Even though you have a working version of Galaxy, you should update your instance to at least this revision, and then do the following as soon as possible. %sh manage_db.sh downgrade 90

Re: [galaxy-dev] More helpful cluster job names

2012-02-07 Thread Peter Cock
On Mon, Feb 6, 2012 at 6:17 PM, Nate Coraor n...@bx.psu.edu wrote: On Feb 6, 2012, at 1:05 PM, Nate Coraor wrote: On Feb 3, 2012, at 7:30 AM, Peter Cock wrote: On Fri, Feb 3, 2012 at 11:55 AM, Ryan Golhar ngsbioinformat...@gmail.com wrote: 'qstat -f | grep jobname' will give you the full

Re: [galaxy-dev] Problems with custom data types and sniffers in shed tools

2012-02-07 Thread Greg Von Kuster
Hello Ira, Very sorry for the back-and-forth on this. The behavior you encountered was accurate - the environment in which I was testing was not pristine. I have committed a fix for this issue in revision b4ba8b20d78d, which is now available from our central repo. I started looking at

[galaxy-dev] set_metadata.py

2012-02-07 Thread Bram Slabbinck
Hi I am running into a problem with the scripts/set_metadata.py file since the last update of galaxy-dist. In this script the name of the universe file is hard-coded as 'universe_wsgi.ini', see line 44: config_file_name = 'universe_wsgi.ini' # Safe assumption? I renamed the universe file in

Re: [galaxy-dev] Problem with latest database upgrade

2012-02-07 Thread Anthonius deBoer
Thanks for fixing it so fast! Regards, Thon Thon de Boer, Ph.D Bioinformatics Guru T: +1.650.799.6839 | E-mail: thondeb...@me.com http://www.linkedin.com/pub/thon-de-boer/1/1ba/a5b IMPORTANT NOTICE: This email message is legally privileged, confidential and is for the use of the individual

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Amanda Zuzolo
Rob, I am not aware that there would be any issue, as I've verified all the options with the Qiime documentation that is up now (and I've eliminated those being deprecated). Amanda Zuzolo On 2/7/12, Jeffrey Long jlo...@ualberta.ca wrote: Hello Amanda, I was just about to embark on EXACTLY

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Rob Knight
I can't make the call at that time (am in Dhaka) but am very enthusiastic about that effort; please keep me in the loop. I am cc:ing a couple of the people in my lab who also indicated interest in the qiime/galaxy integration effort (though Antonio won't be able to make it either, for the same

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Daniel McDonald
I'll be there Daniel On Feb 7, 2012, at 10:30, Greg Caporaso gregcapor...@gmail.com wrote: OK, let's plan on a Skype call at 1pm MT/3pm ET this Thursday (9 Feb 2012). I will initiate the call - my Skype ID is gregcaporaso. Please let me know if you'd like to join the call, and send my your

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Gillevet Patrick
Skype ID : patrickgillevet On Feb 7, 2012, at 12:33 PM, Daniel McDonald wrote: I'll be there Daniel On Feb 7, 2012, at 10:30, Greg Caporaso gregcapor...@gmail.com wrote: OK, let's plan on a Skype call at 1pm MT/3pm ET this Thursday (9 Feb 2012). I will initiate the call - my Skype

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Rob Knight
That's great news! Thanks for checking. Rob On Feb 7, 2012, at 10:59 AM, Amanda Zuzolo wrote: Rob, I am not aware that there would be any issue, as I've verified all the options with the Qiime documentation that is up now (and I've eliminated those being deprecated). Amanda Zuzolo

Re: [galaxy-dev] Existing efforts to convert the QIIME pipeline to Galaxy?

2012-02-07 Thread Greg Caporaso
OK, let's plan on a Skype call at 1pm MT/3pm ET this Thursday (9 Feb 2012). I will initiate the call - my Skype ID is gregcaporaso. Please let me know if you'd like to join the call, and send my your skype id. Looking forward to talking about this! Greg 2012/2/7 Rob Knight

[galaxy-dev] 01/27 galaxy-dist startup problem (toolshed/pgsql related)

2012-02-07 Thread Oleksandr Moskalenko
I've upgraded my developmental Galaxy instance to the latest galaxy-dist release with a transplanted the drmaa.py patch from galaxy-central. All .conf files have been updated. However, I can't start the instance now The error listed below is generated. I tried enabling/disabling the toolshed

Re: [galaxy-dev] 01/27 galaxy-dist startup problem (toolshed/pgsql related)

2012-02-07 Thread Greg Von Kuster
Hi Alex, If your migration scripts through 90 executed cleanly, then your tool_shed_repository.uninstalled column should exist as that column is created in the 0090 script. What was the log of your db migration upgrades that occurred when your database was migrated from version 85 to 90?

Re: [galaxy-dev] 01/27 galaxy-dist startup problem (toolshed/pgsql related)

2012-02-07 Thread Oleksandr Moskalenko
$ sh manage_db.sh -c ./dev_universe_wsgi.runner.ini upgrade 85 - 86... Migration script to add the metadata, update_available and includes_datatypes columns to the tool_shed_repository table. done 86 - 87... Migration script to create the tool_id_guid_map table. done 87 - 88... Migration script

[galaxy-dev] generate dynamic select list based on other input dataset

2012-02-07 Thread Holger Klein
Dear all, I have a working module which generates wig files for genomic annotation from a single column of a bigger input data matrix (Input A). In the current state, the user has to input the column name (Input B) from which to calculate the values in the wig file. Now I'd like to modify the

Re: [galaxy-dev] 01/27 galaxy-dist startup problem (toolshed/pgsql related)

2012-02-07 Thread Greg Von Kuster
Alex, this is strange, so it'll be tricky to figure out what's causing the problem. I can't think of anything that would cause this unless 2 different databases are somehow being used. I assume your database configured in your file dev_universe_wsgi.runner.ini is the same as the database

Re: [galaxy-dev] 01/27 galaxy-dist startup problem (toolshed/pgsql related)

2012-02-07 Thread Oleksandr Moskalenko
Greg, Startup log: galaxy.tool_shed.tool_shed_registry DEBUG 2012-02-07 16:13:29,613 Loading references to tool sheds from tool_sheds_conf.xml galaxy.tool_shed.tool_shed_registry DEBUG 2012-02-07 16:13:29,614 Loaded reference to tool shed: Galaxy main tool shed

Re: [galaxy-dev] Problem with latest database upgrade

2012-02-07 Thread Anthonius deBoer
Hi Greg,I tried to upgrade the GALAXY-CENTRAL version of my installation to fix the 90-91 upgrade bug, but I don't seem to see revision 271ccd09bc23 there...Is this issue fixed in galaxy central or only in the main installation?ThanksThonOn Feb 07, 2012, at 08:11 AM, Greg Von Kuster

Re: [galaxy-dev] Problem with latest database upgrade

2012-02-07 Thread Anthonius deBoer
Never mind...I plucked the edit from a pristine instance of galaxy-central...It's fixed for me nowOn Feb 07, 2012, at 02:42 PM, Anthonius deBoer thondeb...@me.com wrote:Hi Greg,I tried to upgrade the GALAXY-CENTRAL version of my installation to fix the 90-91 upgrade bug, but I don't seem to see

Re: [galaxy-dev] Problem with latest database upgrade

2012-02-07 Thread Greg Von Kuster
Thon, Since you are using the features enabling communication between your Galaxy instance and the tool shed, I recommend that you keep your Galaxy instance code base current with the tip from our Galaxy central repo, at least until the tool shed features become more stable. I've committed

Re: [galaxy-dev] Problems with custom data types and sniffers in shed tools

2012-02-07 Thread Ira Cooke
Hi Greg, Thanks for that fix ... I'll check it out. I think the issue of sniff order is a pretty important one for shed tools that require proprietary datatypes. The problem is that galaxy's default sniffers include some extremely generic sniffers (eg text,xml) which will catch pretty much

Re: [galaxy-dev] Problems with custom data types and sniffers in shed tools

2012-02-07 Thread Greg Von Kuster
Ira, Thanks for the feedback - I'll come up with something that allows for proprietary sniffers to be loaded first and let you know when it's available. It shouldn't take me too long. I will probably continue to keep the rule of ignoring conflicts in proprietary datatypes, so sniffers for

Re: [galaxy-dev] Problems with custom data types and sniffers in shed tools

2012-02-07 Thread Ira Cooke
Hi Greg, Thanks .. that sounds like a good solution. I'll be happy to test it when its ready. Ira On 08/02/2012, at 10:22 AM, Greg Von Kuster wrote: Ira, Thanks for the feedback - I'll come up with something that allows for proprietary sniffers to be loaded first and let you know when

[galaxy-dev] Error when attempting to get_updates from toolshed

2012-02-07 Thread Ira Cooke
Dear Greg, In the latest version of the galaxy-central code there seems to be a bug preventing me from updating my tools. When I go to update a tool I get the following error URL:

Re: [galaxy-dev] Error when attempting to get_updates from toolshed

2012-02-07 Thread Greg Von Kuster
Thanks Ira, I'll have this fixed tomorrow and let you know. Sorry for these glitches, we'll get these things ironed out rapidly. Thanks for helping! On Feb 7, 2012, at 7:40 PM, Ira Cooke wrote: Dear Greg, In the latest version of the galaxy-central code there seems to be a bug

[galaxy-dev] Galaxy server configuration question

2012-02-07 Thread Huayan Gao
Dear Sir or Madam, I am installing a galaxy server on CentOS with UCSC Genome Browser mirror site. The mirror site works well. I installed the galaxy in the same server. Now my question is: how to set up httpd.conf file so I can access both websites(UCSC Genome Browser, and Galaxy) remotely?