[galaxy-dev] javascript

2012-07-11 Thread Cathy Riemer
Hi all, I just now tried visiting Galaxy main with my browser's javascript turned off. Formerly the left Tools panel would appear with all of the sections expanded, however now it is empty except for Workflows. Also, some of the top menu bar items work without scripting, but others (including

[galaxy-dev] Job doesn't runnig

2012-07-11 Thread Amandin Talbot
Dear Galaxy Dev Team- I try to run a job with Tophat for Illumina (version 1.5.0) but in my history job always stay at Job is waiting to run. I use the following parameters : RNA-Seq FASTQ file: FASTQ Groomer on upload dataset Reference Genome : build-in index : Chicken (Gallus gallus): galGal3

Re: [galaxy-dev] javascript

2012-07-11 Thread Jeremy Goecks
I just now tried visiting Galaxy main with my browser's javascript turned off. Formerly the left Tools panel would appear with all of the sections expanded, however now it is empty except for Workflows. Also, some of the top menu bar items work without scripting, but others (including Help

[galaxy-dev] DRMAA.NoActiveSessionError

2012-07-11 Thread Johannes Eichner
Dear Galaxy-Dev-Team, I just restarted our local Galaxy instance at the University of Tuebingen, Germany, and obtained a DRMAA.NoActiveSessionError. You can find an excerpt from my shell below. The error can be avoided by disabling the SGE support in the universe.wsgi.ini. However, as our

Re: [galaxy-dev] pbs_python issues

2012-07-11 Thread Iry Witham
I was successful in getting the bps_python egg to load finally. However, there is an issue that remains. When I submit a job it is sent to the local runner and not to pbs. Where should I start looking to change this work? Thanks, Iry On 7/10/12 12:00 PM, galaxy-dev-requ...@lists.bx.psu.edu

Re: [galaxy-dev] Sample tracking data transfer hangs in queue forever

2012-07-11 Thread Greg Von Kuster
Hello Luobin, I'm on my way to ISMB for a week, and then will be at the Galaxy Community Conference the following week, so I won't have time to help you track this problem down until some time in August unless you will be at either of these 2 conferences. Sorry for the inconvenience on this,

Re: [galaxy-dev] Sample tracking data transfer hangs in queue forever

2012-07-11 Thread TerAvest, Emily
Hi Greg, I will be at the galaxy conference and am experiencing the same problem. I would love to meet with you to look at this together. Emily From: Greg Von Kuster [mailto:g...@bx.psu.edu] Sent: Wednesday, July 11, 2012 7:55 AM To: Luobin Yang Cc: TerAvest, Emily; galaxy-...@bx.psu.edu

Re: [galaxy-dev] Byte-range support for IGV ?

2012-07-11 Thread Nate Coraor
On Jul 4, 2012, at 7:57 AM, Chebbi Mohamed Amine wrote: HI Geert ! I did well : Location / XSendFile on XSendFilePath / /Location and Location / # Compress all uncompressed content. SetOutputFilter DEFLATE SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$

[galaxy-dev] is there a way too automatically select references based on the genome of the dataset?

2012-07-11 Thread Langhorst, Brad
I would like the reference list to be automatically selected based on the dbkey of the selected input... I think I've seen this, but I can'f seem to find an example. Anybody know? Should be some easy jquery i guess. Brad -- Brad Langhorst langho...@neb.commailto:langho...@neb.com 978-380-7564

Re: [galaxy-dev] Galaxy cleaning up after it self after jobs fail

2012-07-11 Thread Nate Coraor
On Jul 5, 2012, at 8:02 PM, Anthonius deBoer wrote: I am running galaxy on a system that normally runs all jobs on the cluster, but some jobs need to be run locally... But when I restart galaxy when these jobs are running, those jobs fail (and I am fine with that)... But then when I

Re: [galaxy-dev] Output file permissions different pbs:/// VS local:/// job runners

2012-07-11 Thread Nate Coraor
On Jul 5, 2012, at 9:21 PM, Rob Syme wrote: Hi all. When I run the FastQC tool using the default local job runner, it produces a folder of files with permission 664: snip -rw-rw-r-- 1 galaxy galaxy 17K Jul 5 17:29 duplication_levels.png -rw-rw-r-- 1 galaxy galaxy 1.6K Jul 5 17:29

Re: [galaxy-dev] is there a way too automatically select references based on the genome of the dataset?

2012-07-11 Thread Jeremy Goecks
(1) There are quite a few tools that use the input's dbkey in some way, such as to retrieve sequence/index data. You'll see this quite a bit in tool command lines: --dbkey=${input.metadata.dbkey} With this approach, you won't need to provide a reference list parameter at all. Tools such as

[galaxy-dev] Tool migration errors

2012-07-11 Thread Anthonius deBoer
I'm getting this error when I try to run the tool migration:sh ./scripts/migrate_tools/0003_tools.sh install_dependenciesNo handlers could be found for logger "docutils"Repositories will be installed into configured tool_path location ../shed_toolsAdding new row (or updating an existing row) for

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread Greg Von Kuster
Hi Thon, What revision of Galaxy are you running? Have you made multiple attempts at the migration? Are you running a postgres database? How many records do you have in your tool_dependency table in your database, and what is the status of each record? Have you made any changes to the

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread Anthonius deBoer
My Galaxy version is the most recent, but I had cloned this from an earlier version and have made lots of changes over the months...I'm a little confused by the fact that the tool_shed tools seem to be defined BOTH by the various XML files AND the databaseI have on occasions manually edited

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread Anthonius deBoer
If I drop the following two tables, would those be reconstructed again correctly if I had the XML files in order?tool_version_associationandtool_versionThanksThonOn Jul 11, 2012, at 12:29 PM, Greg Von Kuster g...@bx.psu.edu wrote:Hi Thon, What revision of Galaxy are you running? Have you made

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread Greg Von Kuster
Hi Thon, On Jul 11, 2012, at 3:38 PM, Anthonius deBoer wrote: My Galaxy version is the most recent, but I had cloned this from an earlier version and have made lots of changes over the months... This could pose problems unless you are sure that your code is in a functional state after you

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread Greg Von Kuster
I would not advise doing this. Based on your environment, I recommend that you do not attempt to install tools from the tool shed as doing so may pose problems for the same tools that you have altered in your environment and that you do not want to get out of sync. On Jul 11, 2012, at 4:09

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread John Chilton
On Wed, Jul 11, 2012 at 3:25 PM, Greg Von Kuster g...@bx.psu.edu wrote: Hi Thon, On Jul 11, 2012, at 3:38 PM, Anthonius deBoer wrote: My Galaxy version is the most recent, but I had cloned this from an earlier version and have made lots of changes over the months... This could pose

[galaxy-dev] Where are the datatype associations stored?

2012-07-11 Thread Anthonius deBoer
Hi,I had some more bad luck trying to install the GMAP stuff from the TOOLSHEd but revision 10 is broken since it does not allow you to select a section and just stores the programs in the main tree...But when I tried to remove the tool I got the following error for every run, since the sniffers

Re: [galaxy-dev] Where are the datatype associations stored?

2012-07-11 Thread Greg Von Kuster
How did you try to remove the tool? Do you mean that you used the Galaxy Admin UI to Uninstall the repository? The datatypes are defined in a file named datatypes_conf.xml in the installed gmap repository. Assuming you can uninstall this repository, doing so will eliminate this problem.

Re: [galaxy-dev] Where are the datatype associations stored?

2012-07-11 Thread Anthonius deBoer
Yeah, I had messed around with the database already, but removing the repository worked...Not sure why it was still loading it, but its all cool now...Thanks!ThonOn Jul 11, 2012, at 04:20 PM, Greg Von Kuster g...@bx.psu.edu wrote:How did you try to remove the tool? Do you mean that you used the

Re: [galaxy-dev] Tool migration errors

2012-07-11 Thread Greg Von Kuster
Hi John, On Jul 11, 2012, at 4:53 PM, John Chilton wrote: On Wed, Jul 11, 2012 at 3:25 PM, Greg Von Kuster g...@bx.psu.edu wrote: The way the tool shed components are architected do not result in this syncing issues. You do not have to use the tool shed at all. Based on your statements

Re: [galaxy-dev] Job doesn't runnig

2012-07-11 Thread Jennifer Jackson
Hello Amandin, The job queue for NGS jobs on the public main Galaxy instance has been very busy since last Friday. We have been tracking the queue carefully all week and this afternoon took additional action to ensure fair access to the public resource. I didn't find any of your jobs in the

Re: [galaxy-dev] Tophat and bowtie jobs failed!

2012-07-11 Thread Jennifer Jackson
Hello Avazeh, Your jobs were effected by two issues: 1 - This specific error was due to a problem on our side with the data processing around the time that you submitted this email. Next time, submitting a bug report (green bug icon) for failed jobs that are clearly processing related will

[galaxy-dev] Is the galaxy main toolshed compatible with local installs of galaxy-dist?

2012-07-11 Thread Ira Cooke
I was wondering whether the general policy is to keep the toolshed at toolshed.g2.bx.psu.edu compatible with galaxy-dist or galaxy-central. The reason I ask is that I went to install a tool from a production server I'm trying to setup based on galaxy-dist ... but got an error; The resource