Re: [galaxy-dev] Display of HTML type broken in new Galaxy ?

2012-10-18 Thread Lukasse, Pieter
Thanks Joachim, that solved the problem! -Original Message- From: Joachim Jacob [mailto:joachim.ja...@vib.be] Sent: woensdag 17 oktober 2012 10:47 To: Lukasse, Pieter Cc: galaxy-dev@lists.bx.psu.edu Subject: Re: [galaxy-dev] Display of HTML type broken in new Galaxy ? Hi, Make sure

[galaxy-dev] Fwd: 'UsesFormDefinitions' is not defined

2012-10-18 Thread Alexander Graf
Hi, yesterday I updated Galaxy to the latest revision and now it is not possible to access any Data Libraries or to create a new one. Galaxy shows me a read box with following error message: *Error attempting to display contents of library (100326_HWUSI-EAS632R_0002): name 'UsesFormDefinitions'

[galaxy-dev] Corner case in task splitter - merging zero files

2012-10-18 Thread Peter Cock
Hi Scott, Following some failing hard drives, I'm rebuilding our Galaxy server. Something isn't quite right with our cluster integration yet, but it has exposed a problem in Galaxy's handling of task splitting - it can sometimes attempt to merge zero files. Here is my fix for the BLAST XML

Re: [galaxy-dev] Fwd: 'UsesFormDefinitions' is not defined

2012-10-18 Thread Hans-Rudolf Hotz
Hi Alex I am in the same situation, updating our galaxy servers to the Oct 5th release (changeset: 7824:b5bda7a5c345), and I have encountered the same problem. I guess, there are actually two problems: First problem - this happens with a fresh install:

Re: [galaxy-dev] Fwd: 'UsesFormDefinitions' is not defined

2012-10-18 Thread Scott McManus
This was fixed in galaxy-central last week and should be part of galaxy-dist. What happened is that controllers were migrated and a couple of modules were left out. See changeset 210c39f4bf7f or later, which I believe was fixed on October 4th. In particular, the problem you're seeing had to do

Re: [galaxy-dev] Fwd: 'UsesFormDefinitions' is not defined

2012-10-18 Thread Scott McManus
Excuse me - I meant to say that this will part of the upcoming galaxy-dist. -Scott - Original Message - This was fixed in galaxy-central last week and should be part of galaxy-dist. What happened is that controllers were migrated and a couple of modules were left out. See

Re: [galaxy-dev] Corner case in task splitter - merging zero files

2012-10-18 Thread Scott McManus
Hey Peter- Thanks - I'll look into it. If you're able to reproduce the problem easily and wouldn't mind crafting a pull request, then it would be much appreciated. Otherwise I'll put this on my to-do list to be done soon. I or someone else may want to revisit the exception handling to prevent

[galaxy-dev] Apache proxy to Galaxy: mod_rewrite or mod_proxy ?

2012-10-18 Thread Christophe Antoniewski
Hi, Currently, the guide lines for using Apache as a reverse proxy to galaxy are to use the mod_rewrite module and the rewrite rules as explained in the galaxy wiki. I was wondering whether anybody has tried to use mod_proxy, mod_proxy-http instead, with proxypass and proxypassreverse directives

Re: [galaxy-dev] Fwd: 'UsesFormDefinitions' is not defined

2012-10-18 Thread Hans-Rudolf Hotz
Hi Scott Thank you very much for your quick reply! after fixing (ie replacing galaxy.web.controllers.library_common with galaxy.webapps.galaxy.controllers.library_common) in the following four files: ~/templates/library/common/library_dataset_search_results.mako

Re: [galaxy-dev] Apache proxy to Galaxy: mod_rewrite or mod_proxy ?

2012-10-18 Thread Oleksandr Moskalenko
On Oct 18, 2012, at 12:28 PM, Christophe Antoniewski christophe.antoniew...@snv.jussieu.fr wrote: Hi, Currently, the guide lines for using Apache as a reverse proxy to galaxy are to use the mod_rewrite module and the rewrite rules as explained in the galaxy wiki. I was wondering

Re: [galaxy-dev] Jobs crash only in workflow context

2012-10-18 Thread Todd Oakley
Hi James, We have made some progress in understanding the workflow-specific job crashes. It seems that 'parallel' workflows are sending jobs simultaneously, and this is problematic for torque. We get this error: 10/18/2012 10:06:18;0080;PBS_Server;Req;req_reject;Reject reply

Re: [galaxy-dev] How to get a shedtool to run locally

2012-10-18 Thread Fields, Christopher J
On Oct 17, 2012, at 3:53 PM, Carlos Borroto carlos.borr...@gmail.com wrote: On Mon, Oct 15, 2012 at 11:49 AM, Liisa Koski liisa.ko...@basf.com wrote: Hello, I've installed a tool to my local Galaxy installation via my local ToolShed. I would like to run this tool locally, and not have it

Re: [galaxy-dev] Retreiving a library data type in command

2012-10-18 Thread Simon Gladman
oops, clicked send too early.. On 19 October 2012 16:33, Simon Gladman simon.glad...@monash.edu wrote: Hi all, Have searched mailing list to no avail. Therefore: How can I get a data library's data_type in the command tagset? Example: command dosomething.pl