Re: [galaxy-dev] About the output

2012-12-11 Thread Hans-Rudolf Hotz
On 12/10/2012 11:26 PM, Chenhao wrote: I made a galaxy tool which is just create a txt file. When I use this tool , I wish to let it show the detail of the txt. In the xml file I use : output data name=”test” format=”txt”output/ I assume, this should be written: outputs data name=”test”

[galaxy-dev] Displayed versions of tools in Galaxy

2012-12-11 Thread Clare Sloggett
Hi guys, I wasn't sure if I should send this one to galaxy-user. I have just confused myself about the versions of tools displayed within Galaxy. If I select the TopHat tool, the tool UI says Tophat for Illumina (version 1.5.0). After I have run the job, the step panel in the History window says

Re: [galaxy-dev] Trying to Run MegaBlast

2012-12-11 Thread Peter Cock
On Monday, December 10, 2012, Jeremy Goecks wrote: Decompress and unpack the file and you'll find the relevant files (though everything now has extensions with p* rather than n*); add an entry to blastdb pointing to the directory with these files and you should be good to go. J. Not

Re: [galaxy-dev] Displayed versions of tools in Galaxy

2012-12-11 Thread Ivan Lovric
This has been confusing for me also. Perhaps if we had a way to distinguish between the two by prefixing the tool version of a wrapper with w0.0.5 and the actual tool version with v1.3.0? I think that Galaxy determines the versions of the tools it loads at startup in lib/galaxy/tools/__init__.py

[galaxy-dev] some problem with the fastq interlacer

2012-12-11 Thread 泽 蔡
Hi all,   I ran the fastq interlacer with a fastq encoding 1.8+ data, the interlacer seems do not reganize the name of the pair-end reads, and treat the pair-end reads as non-pair-edn reads.   Best regards___ Please keep all replies on the

[galaxy-dev] Public Tool Shed Error

2012-12-11 Thread Adam Carr (NBI)
Hi, I have been using the tool shed recently and come across a problem. When a searching for valid tools within the Public Tool Shed, it seems that if the search should return nothing found, it is instead displaying a Server Error page instead. For example:

Re: [galaxy-dev] Public Tool Shed Error

2012-12-11 Thread Greg Von Kuster
Hello Adam, Thanks for reporting this. It was fixed in a change set 10 days ago that just missed the cutoff of the last Galaxy distribution release. The fix is currently running on the test Galaxy tool shed and will be applied to the main Galaxy tool shed with the next Galaxy distribution

[galaxy-dev] Server Error / Edit attribut of a dataset generated by a tool

2012-12-11 Thread Sarah Maman
Hello, One of my users gets the following message when he wishes to edit the attribute of a dataset which is generated by using a tool (same problem as it is a tool provided by Galaxy or a tool coded by us). Do you have any idea? Thanks in advance, Sarah Maman URL:

[galaxy-dev] Impossible to add a (new) tool in a workflow (in edition mode)

2012-12-11 Thread Sarah Maman
Hello, For one of my tools that I have added to my local instance of Galaxy, I can not add this tool in the editing workflow. When I click on the tool name in the tools windows on the left, it does not appear in the editing workflow. Do you have any idea? Thank you in advance, Sarah Maman

Re: [galaxy-dev] Impossible to add a (new) tool in a workflow (in edition mode)

2012-12-11 Thread Dannon Baker
Do you see any errors in Galaxy's paster.log, or in the javascript console? -Dannon On Dec 11, 2012, at 8:40 AM, Sarah Maman sarah.ma...@toulouse.inra.fr wrote: Hello, For one of my tools that I have added to my local instance of Galaxy, I can not add this tool in the editing workflow.

Re: [galaxy-dev] Installation issue on EC2

2012-12-11 Thread Fabiano Lucchese
Hi, Dannon. Thanks for the tip. No, I was not reusing the cluster names exactly to avoid previous data to mess up with my fresh new deployments. There were indeed about 8 buckets referring to clusters that don`t exist anymore. Write now I can`t remove my current cluster by the

Re: [galaxy-dev] About the output

2012-12-11 Thread Chenhao Li
Thx Hans-Rudolf But I did write /output in the xml file Here is just a mistake In ~in ~/database/files/ folder there is just a folder named 000 and there are lots of *.dat file in 000 folder From: Hans-Rudolf Hotz h...@fmi.ch To: Chenhao

Re: [galaxy-dev] [SPAM] Re: About the output

2012-12-11 Thread Hans-Rudolf Hotz
On 12/11/2012 03:49 PM, Chenhao Li wrote: Thx Hans-Rudolf But I did write /output in the xml file Here is just a mistake In ~in ~/database/files/ folder there is just a folder named 000 and there are lots of *.dat file in 000 folder I assume, the latest *.dat file is the txt file you are

Re: [galaxy-dev] [SPAM] Re: About the output

2012-12-11 Thread Chenhao Li
my phthon file: gf = open('showme.txt', 'w') gf.write('this is a test text') gf.close print info my xml file: tool name=Tool1 id=toolone   descriptiontable browser proxy/description   command interpreter=python     test.py   /command   inputs  check_values=false     param  name=one sise=100

Re: [galaxy-dev] Impossible to add a (new) tool in a workflow (in edition mode)

2012-12-11 Thread Sarah Maman
Thanks Danon, But I have no error generated in my error log file (logs of run.sh): [11/Dec/2012:16:39:09 +0200] GET /galaxy/workflow HTTP/1.1 200 - http://URL/galaxy/root; Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0 IP - - [11/Dec/2012:16:39:11 +0200] GET

Re: [galaxy-dev] Impossible to add a (new) tool in a workflow (in edition mode)

2012-12-11 Thread Dannon Baker
The paster.log is just the file for the output you've copied below when running daemonized -- if you're running in the foreground it just gets sent there instead of to the file. So, no obvious errors there. Could you check for javascript console errors? And, if you'd like, feel free to send

Re: [galaxy-dev] Impossible to add a (new) tool in a workflow (in edition mode)

2012-12-11 Thread Sarah Maman
Dannon, Here is myjavascript console errors : SyntaxError: missing ) after argument list : /* ool( 'sm_miRNA_join_annot', '* Construction de la matrice d'annotations' ) */ /*editor...8829fc# (ligne 1, col. 60)*/ I replaced this syntax Construction de la matrice d'annotations by the latter

[galaxy-dev] Mutation/SNP detection RNA-Seq

2012-12-11 Thread suzan katie
Hi, I am trying to look mutations/SNPs in RNA-Seq data. Can anyone suggest me a workflow in Galaxy on how to detect SNPs and mutations Thanks in advance Suz ___ Please keep all replies on the list by using reply all in your mail client.

[galaxy-dev] Downloading datasets without username/password when login is required

2012-12-11 Thread Sytchev, Ilya
Hi, Is it possible to download a dataset when require_login=True in universe_wsgi.ini using the API key? Thanks, Ilya ___ Please keep all replies on the list by using reply all in your mail client. To manage your subscriptions to this

[galaxy-dev] Impersonate a User

2012-12-11 Thread greg
Hi guys, I tried the impersonate a user feature, but I don't know how to stop impersonating a user? I tried going back to the impersonate a user feature and selecting myself but it's not clear if it changed anything, and I no longer see the History items I had before I did the impersonation.

Re: [galaxy-dev] Re-installing error persists

2012-12-11 Thread Greg Von Kuster
Hi Franco, I'm not quite sure what page you'r eon, but if you're looking at the page that has the tool dependency with the error status, you should be able to click the link of the tool dependency and see the error, log, etc. If this is not the page you're referring to, then I'll have to take

[galaxy-dev] Extra files saved outside of Galaxy's history?

2012-12-11 Thread Gomez, Ann
Hi all, I have a pipeline involving a series of scripts, which creates directories (and many subdirectories), that I'd like to wrap for use in Galaxy. Although the contents of the folders are not the primary output of the pipeline, (and I don't want them as history items), I'd still like them

[galaxy-dev] problem with uploading data

2012-12-11 Thread Banday, Abdul
Hi Nate, I loaded the file named s_6_1_sequence.txt.gz (Illumni file) under the login name abdul.ban...@uconn.edumailto:abdul.ban...@uconn.edu as FTP.ftp://ftp.R Whenever I am trying to load it as history so that I can run it for analysis, the file upload is showing error and massage comes

Re: [galaxy-dev] Impersonate a User

2012-12-11 Thread Edward Hills
Hi Greg, Try clicking the logout button. That should logout of the user you are impersonating and back into you. Although, this does have a few quirks also and may log you right out. Don't forget that when you are impersonating someone the history may not be automatically loaded and you will have

[galaxy-dev] Installing Job Runners on a Cluster

2012-12-11 Thread Ganote, Carrie L
Hi all, I could use some help getting DMRAA to run. We already have a galaxy instance with pbs running, but I'd like to connect to Torque using dmraa because we eventually intend to port over to a different resource manager. I've followed these instructions:

[galaxy-dev] Job is waiting to run

2012-12-11 Thread Fenglou Mao
I have a local galaxy server, and I built a workflow, it got stuck in one step in the middle. The computer is a 64 cores server, and no other jobs running in this server. Any idea how to trouble shooting? Thanks, Fenglou ___ Please keep all

Re: [galaxy-dev] [galaxy-bugs] galaxy.genenetwork.org

2012-12-11 Thread Yunbo Xu
有olb吃掉 Yunbo Xu 817 Hickman rd, Apt A-23 Augusta,GA 30904 706 - 877 3892 On Dec 11, 2012, at 4:13 PM, Lei Yan leiyan2...@gmail.com wrote: Dear Dannon and James, On Mon, Dec 10, 2012 at 8:04 AM, Dannon Baker dannonba...@me.com wrote: • I installed a Cloud Galaxy instance one month

[galaxy-dev] Tool dependency installation fail, any documentation?

2012-12-11 Thread Franco Caramia
Hi list, I got the following tool_dependencies.xml file failing: ?xml version=1.0? tool_dependency    package name=bedtools version=2.17.0    install version=1.0    actions action type=download_by_url target_filename=bedtools-2.17.0.tar. gz 

Re: [galaxy-dev] Tool dependency installation fail, any documentation?

2012-12-11 Thread Dave Bouvier
Franco, BEDTools, unlike some other packages, does not require the 'make clean' shell command to compile. If you remove that line, the dependency should install without problems. --Dave B. On 2012-12-11 21:16, Franco Caramia wrote: Hi list, I got the following tool_dependencies.xml file

[galaxy-dev] Galaxy doesn't detect the file when we add dataset to a library under Manage data libraries

2012-12-11 Thread Sachit Adhikari
Hi list, We have found that, in Galaxy, when we add dataset to a library under Manage data libraries, Galaxy sometimes detects the type of the file and sometimes does not. What I have noticed is that it detects the type of the file when we select Copy file into Galaxy under Copy data into Galaxy?

[galaxy-dev] pbs_python and torque 4.x

2012-12-11 Thread Steve.Mcmahon
Hi all, We are trying to get our instance of Galaxy submitting jobs to a cluster a using the staged method referred to at http://wiki.galaxyproject.org/Admin/Config/Performance/Cluster. Our cluster is running Torque 4.1.3. We need to use Torque 4.x clients to be able to submit jobs to it.

Re: [galaxy-dev] Tool dependency installation fail, any documentation?

2012-12-11 Thread Dave Bouvier
Franco, You're right, I see a both clean and all rules in the makefile. It looks almost like it's not finding the expected makefile, I'll have to look into that in the morning. As for the download_by_url action, it downloads and extracts the specified file, then changes to the extracted