[galaxy-dev] How to display tool instead of html WWFSMD page at start-up?

2013-07-29 Thread Neil.Burdett
Hi, When Galaxy is started the centre column displays the Hello world! It's running ... WWFSMD? Html Page. How can this be changed so that a tool i.e. get data tool is shown up on start-up with all its text boxes etc rather than the default html file? Is this possible? Thanks Neil

Re: [galaxy-dev] How to display tool instead of html WWFSMD page at start-up?

2013-07-29 Thread Ross
Neil, good news: the initial center panel renders static/welcome.html so easy to change. bad news: AFAIK no way to show a (dynamic) default tool form instead - others may know more.. On Mon, Jul 29, 2013 at 5:03 PM, neil.burd...@csiro.au wrote: Hi, When Galaxy is started the centre

[galaxy-dev] data snapshot is not the same on local instance of Galaxy

2013-07-29 Thread Nikhil Mallela
Hi, A few days ago, I have installed the stable release of of Galaxy local instance on my Workstation I am running it behind Apache web server proxy . In regard to the data snapshots, I've observed that, it is much more organized on the Galaxy main rather than on my local instance. For example,

[galaxy-dev] Problem with tabular files

2013-07-29 Thread Misharl mon
Hi everybody, In my lab, after upgrading our Galaxy instance to the latest version, we have a problem with displaying tabular files. Any idea from where the problem can come? Thanks in advance to all. Mish

[galaxy-dev] [GSoC2013] Week 6 Update

2013-07-29 Thread Saket Choudhary
Week 6 updates are here : http://galaxy-gsoc2013.blogspot.in/2013/07/week-6-update.html Thanks Saket ___ Please keep all replies on the list by using reply all in your mail client. To manage your subscriptions to this and other Galaxy

Re: [galaxy-dev] GATK

2013-07-29 Thread Sridhar Srinivasan
Thanks for the suggestin Linda... i removed the line -et NO_ET ##ET no phone home Now i am not getting the Error as get key to run the GATK.. But i am getting error as the fasta file is not found.. even in backend i found the command as mentioned below in the reference file section -R there

Re: [galaxy-dev] Problem with tabular files

2013-07-29 Thread Dannon Baker
What is the problem you're observing, and do you see any errors in the galaxy log or javascript console? -Dannon On Mon, Jul 29, 2013 at 5:51 AM, Misharl mon mish...@hotmail.com wrote: Hi everybody, In my lab, after upgrading our Galaxy instance to the latest version, we have a problem

[galaxy-dev] Display BAM and bigWig on UCSC when require_login = False

2013-07-29 Thread Federico Zambelli
Dear all, I'm running a local version of Galaxy using nginx as proxy and I have problems with the visualization of remote tracks (like .bam or .bigwig) on the UCSC genome browser. If I disable the anonymous login and then try to display a .bam or .bigwig file on UCSC genome browser I get this

Re: [galaxy-dev] Tool Shed Request - sanity check uploads?

2013-07-29 Thread Peter Cock
On Thu, May 2, 2013 at 4:29 PM, Peter Cock p.j.a.c...@googlemail.com wrote: Hi all, For what is I think the second time (fortunately this was only on the Test Tool Shed), I have managed to upload a tar-ball to the wrong repository: 2:fae4084a0bc0

Re: [galaxy-dev] Tool Shed test framework breaking where run_functional_tests.sh works

2013-07-29 Thread Peter Cock
Hi Dave, Did a Trello card get filled for this problem of failing tests on the Tool Shed? Thanks, Peter On Tue, Jun 11, 2013 at 9:04 AM, Björn Grüning bjo...@gruenings.eu wrote: Hi, I also have that error in the latest toolshed: AssertionError: Attempting to set field 'topology' to value

Re: [galaxy-dev] Missing test results on (Test) Tool Shed

2013-07-29 Thread Peter Cock
Hello all, I'm seeing missing test results again on the Test Tool Shed, e.g. listed under Latest revision: failing tool testshttp://toolshed.g2.bx.psu.edu/repository/browse_my_writable_repositories_with_failing_tool_tests I have: http://toolshed.g2.bx.psu.edu/view/peterjc/nlstradamus Tool

[galaxy-dev] Problem with tabular files

2013-07-29 Thread Misharl mon
Hi Dannon, Thank you very much for replying. The problem is that we cannot display any tabular files in the galaxy result panel. The tabular files are correct. We have checked the galaxy log, and didn't see anything. Thank you, Mish Date: Mon, 29 Jul 2013 07:57:28 -0400 Subject: Re:

Re: [galaxy-dev] Problem with tabular files

2013-07-29 Thread Dannon Baker
What happens when you attempt view the tabular file? Does it automatically download instead of displaying, for example? On Mon, Jul 29, 2013 at 9:54 AM, Misharl mon mish...@hotmail.com wrote: Hi Dannon, Thank you very much for replying. The problem is that we cannot display any tabular

Re: [galaxy-dev] Missing test results on (Test) Tool Shed

2013-07-29 Thread Dave Bouvier
Peter, I've created a Trello card where you can track this issue: https://trello.com/c/wHXz9j0v/1018-toolshed-test-result-display-issue Most of these look like display issues, the test results are correctly recorded in the database. I hope to have that and the seq_rename and

Re: [galaxy-dev] Problem with tabular files

2013-07-29 Thread Misharl mon
When i attempt viewing the tabular file, it doesn't download automatically. it displays nothing, a blank panel. Thanks Dannon Date: Mon, 29 Jul 2013 09:55:10 -0400 Subject: Re: [galaxy-dev] Problem with tabular files From: dannon.ba...@gmail.com To: mish...@hotmail.com CC:

[galaxy-dev] Cloudman - When will the symlinks be resolved ?

2013-07-29 Thread Ravpreet Setia
I am referring to the following bug: https://bitbucket.org/galaxy/cloudman/issue/6/tool-default-symbolic-links-to-mnt We are waiting for this bug to resolve before we fix any other issues with our Cloudman scripts. I am wondering when you think this bug will be resolved so I can plan my time.

Re: [galaxy-dev] Missing test results on (Test) Tool Shed

2013-07-29 Thread Peter Cock
On Mon, Jul 29, 2013 at 3:10 PM, Dave Bouvier d...@bx.psu.edu wrote: Peter, I've created a Trello card where you can track this issue: https://trello.com/c/wHXz9j0v/1018-toolshed-test-result-display-issue Thanks Dave. Most of these look like display issues, the test results are correctly

Re: [galaxy-dev] Cloudman - When will the symlinks be resolved ?

2013-07-29 Thread Dannon Baker
We're working on it but don't have a specific ETA for the release of the new volume. For now, you can continue to create and run non-migrated clusters using the previous version of Cloudman using this launch form: https://main.g2.bx.psu.edu/cloudlaunch?ami=ami-da58aab3bucket_default=gxy-workshop

Re: [galaxy-dev] Missing test results on (Test) Tool Shed

2013-07-29 Thread Dave Bouvier
Peter, The issue with seq_rename incorrectly failing functional tests has been resolved in 10266:fe04978dadac, and the test results will be corrected the next time the automated testing framework runs. I'm still looking into the other issues you reported. --Dave B. On 7/29/13

Re: [galaxy-dev] Tool Shed test framework breaking where run_functional_tests.sh works

2013-07-29 Thread Peter Cock
On Mon, Jul 29, 2013 at 2:49 PM, Peter Cock p.j.a.c...@googlemail.com wrote: Hi Dave, Did a Trello card get filled for this problem of failing tests on the Tool Shed? Thanks, Peter For anyone following this issue, on another thread Dave just replied: Peter, The issue with seq_rename

[galaxy-dev] Does the xml tool wrapper language have ifs or functions?

2013-07-29 Thread Ben Gift
I'm finding it hard to deal with mutually exclusive options that also share many options between them for certain command line tools. Functions of if statements could solve this copy/pasting problem. Thanks ___ Please keep all replies on the

Re: [galaxy-dev] Does the xml tool wrapper language have ifs or functions?

2013-07-29 Thread Peter Cock
On Mon, Jul 29, 2013 at 5:35 PM, Ben Gift corn8b...@gmail.com wrote: I'm finding it hard to deal with mutually exclusive options that also share many options between them for certain command line tools. Functions of if statements could solve this copy/pasting problem. Thanks Yes, it has if

[galaxy-dev] Next Galaxy Release date (and Tool Shed update)?

2013-07-29 Thread Peter Cock
Hi all, Is there a target date for the next Galaxy release, or should that differ, the next update to the main Tool Shed? I'd like to start using reStructuredText README.rst files in my tools which render much more nicely on the Test Tool Shed, but are currently ignored on the Main Tool Shed

Re: [galaxy-dev] Missing test results on (Test) Tool Shed

2013-07-29 Thread Dave Bouvier
Peter, From what I've been able to determine, the tmhmm_and_signalp test results predate the introduction of the skip tool tests option, and the script to check repositories for the presence of functional tests and test data has been updating the last test date every day, hence the

Re: [galaxy-dev] Next Galaxy Release date (and Tool Shed update)?

2013-07-29 Thread Nate Coraor
On Jul 29, 2013, at 1:02 PM, Peter Cock wrote: Hi all, Is there a target date for the next Galaxy release, or should that differ, the next update to the main Tool Shed? Hi Peter, The next release is planned for August 12. The next-stable freeze will occur on 7/30 (tomorrow). --nate

Re: [galaxy-dev] Missing test results on (Test) Tool Shed

2013-07-29 Thread Peter Cock
On Monday, July 29, 2013, Dave Bouvier wrote: Peter, From what I've been able to determine, the tmhmm_and_signalp test results predate the introduction of the skip tool tests option, and the script to check repositories for the presence of functional tests and test data has been updating

Re: [galaxy-dev] How to display tool instead of html WWFSMD page at start-up?

2013-07-29 Thread Neil.Burdett
Thanks Jeremy, But this doesn't seem to work. If I add the welcome_url to the universe_wsgi.ini (is this the universe config file you mentioned?) as shown below, I continue to get the welcome.html page # Galaxy

Re: [galaxy-dev] How to display tool instead of html WWFSMD page at start-up?

2013-07-29 Thread Jeremy Goecks
You'll need to add the setting further down in the config file, such as under the 'UI Localization' section. Best, J. On Jul 29, 2013, at 8:49 PM, neil.burd...@csiro.au wrote: Thanks Jeremy, But this doesn’t seem to work. If I add the welcome_url to the

Re: [galaxy-dev] How to display tool instead of html WWFSMD page at start-up?

2013-07-29 Thread Neil.Burdett
Yes I tried that but I still only see the default welcome.html page. Have you got this to work? Thanks Neil From: Jeremy Goecks [mailto:jeremy.goe...@emory.edu] Sent: Tuesday, 30 July 2013 12:37 PM To: Burdett, Neil (ICT Centre, Herston - RBWH) Cc: ross.laza...@gmail.com;

[galaxy-dev] Auto hide tool and history panels

2013-07-29 Thread Neil.Burdett
Hi When starting Galaxy the tool panel and history panels appear as default. On the bottom of these panels are two arrows to minimise / hide the panels. Can someone show me how to make the panels be hidden by default rather than shown ? Thanks Neil

[galaxy-dev] importing data from other public websites into galaxy

2013-07-29 Thread Prasun Dutta
Hi, I wish to import data into my local instance of galaxy from another website. Kindly let me know how to achieve that and what all is required. I want to import data from a chemoinformatic database (mainly compound structures) into galaxy and run my own analysis tools on them.   Regards,