[galaxy-dev] Plans for Docker image generation in galaxy

2014-08-19 Thread Marius van den Beek
Hi everyone, it’s my first post to the list, so forgive me if I miss something obvious, I tried to get all the information I could so if there was already a discussion I’d be glad if you can point me towards this. I’m posting to start a discussion about how galaxy is going to handle

Re: [galaxy-dev] Plans for Docker image generation in galaxy

2014-08-19 Thread Björn Grüning
Hi Marius, thanks for shifting the discussion over to the mailinglist. Am 19.08.2014 um 13:13 schrieb Marius van den Beek: Hi everyone, it’s my first post to the list, so forgive me if I miss something obvious, I tried to get all the information I could so if there was already a discussion

Re: [galaxy-dev] Plans for Docker image generation in galaxy

2014-08-19 Thread Marius van den Beek
On 19 August 2014 14:07, Björn Grüning bjoern.gruen...@gmail.com wrote: Hi Marius, thanks for shifting the discussion over to the mailinglist. Am 19.08.2014 um 13:13 schrieb Marius van den Beek: Hi everyone, it’s my first post to the list, so forgive me if I miss something obvious, I

[galaxy-dev] redirecting to unnamed history

2014-08-19 Thread Michael Mason
Hi I am running a work flow on data in a history with 54 input fastq files. About every other time I run Galaxy generates another history (unnamed) and sends a third to half the jobs to it. I am not clicking send results to a new history so I am not sure why this is happening. Any ideas? Is

Re: [galaxy-dev] bug: API broken under remote_user

2014-08-19 Thread Eric Rasche
Hi All, Digging up an ancient thread because it is, once again, relevant to me. As per Iyad's suggestion, we added a special apache conf section for the API access which sets REMOTE_USER, and API access works, but it introduces a whole new set of issues! History is (now?) accessed through the

Re: [galaxy-dev] bug: API broken under remote_user

2014-08-19 Thread Eric Rasche
On this topic, I'm seeing the following in sentry: A new event has been recorded in Sentry: User logged in as 'none@' externally, but has a cookie as 'esr@DOMAIN' invalidating session I'm /pretty/ sure this is for the history requests from the browser as there were 18 of these. Cheers,

Re: [galaxy-dev] Internal Server Error when trying to install a tool from the Tool shed

2014-08-19 Thread John Chilton
Hello Audrey, Please keep responses on list - it ensures people smarter than me can respond :). Can you tell me what is sitting in front of Galaxy - Apache, Nginx, uwsgi, etc... and send the configurations if possible? I believe the out-of-the-box uwsgi configuration has some problems with

Re: [galaxy-dev] redirecting to unnamed history

2014-08-19 Thread John Chilton
Interesting. I have never seen that behavior before - any chance you can try this patch and see if it fixes the problem? https://gist.github.com/jmchilton/b9ae7588de4b21e59cec -John On Tue, Aug 19, 2014 at 1:24 PM, Michael Mason mma...@benaroyaresearch.org wrote: Hi I am running a work flow on

Re: [galaxy-dev] Problem selecting datasets with a specified datatype

2014-08-19 Thread George Weingart
Hi John, I think I have it resolved: At the end of the day the only thing I had to do was to change in the definitions of the datatypes from: datatype extension=lefse type=galaxy.datatypes.data:Lefse display_in_upload=true/ datatype extension=lefse_res

Re: [galaxy-dev] redirecting to unnamed history

2014-08-19 Thread Michael Mason
Thanks John, I cleaned things up with the python png script under scripts/clean up and that seams to have worked. We are freezing our pipeline for a month but if it happens again we'll try the patch and let you know how it goes. Original message From: John Chilton