Re: [galaxy-dev] Dependencies on other Tool Shed repositories

2013-02-08 Thread Greg Von Kuster
Hi Peter,

The changset_revision=xxx tag attribute is a minimum version setting.  
What this means is that the repository being defined will be installed with any 
updates to the repository within the set of changeset revisions up to and 
including the next installable changeset revision for the repository.  The 
exception on this rule is if the defined changeset revisions xxx is an 
installble changeset revision itself, in which case it will be the revision 
installed.

I know this is a bit confusing, so let me know if this is not clear.  The 
following section of the tool shed wiki provides more details about how an 
installable changeset revision is defined.

http://wiki.galaxyproject.org/RepositoryRevisions

Greg Von Kuster


On Feb 8, 2013, at 7:54 AM, Peter Cock wrote:

 Hi all,
 
 I've been reading http://wiki.galaxyproject.org/ToolShedToolFeatures
 and focused on the example of EMBOSS where the tool definitions
 depend on the data type definitions. Here the emboss_5 repository
 (the tool wrappers) contains depository_dependencies.xml saying:
 
 ?xml version=1.0?
 repositories description=Emboss 5 requires the Galaxy applicable
 data formats used by Emboss tools.
 repository toolshed=http://toolshed.g2.bx.psu.edu;
 name=emboss_datatypes owner=devteam
 changeset_revision=a89163f31369 /
 /repositories
 
 Is that revision treated as a minimum version, or an absolute one?
 This concerns me as I have three repositories which will all depend
 on the blast_datatypes repository for the 'blastxml' format (etc) - so
 what happens when these three repositories don't all request the
 same revision of the blast_datatypes repository?
 
 What I'm using for now is:
 
 ?xml version=1.0?
 repositories description=This requires the BLAST datatype
 definitions (e.g. the BLAST XML format).
 !-- Revision 4:f9a7783ed7b6 on the main tool shed is v0.0.14 which
 added BLAST databases --
 repository toolshed=http://toolshed.g2.bx.psu.edu;
 name=blast_datatypes owner=devteam
 changeset_revision=f9a7783ed7b6 /
 /repositories
 
 Regards,
 
 Peter
 ___
 Please keep all replies on the list by using reply all
 in your mail client.  To manage your subscriptions to this
 and other Galaxy lists, please use the interface at:
 
  http://lists.bx.psu.edu/


___
Please keep all replies on the list by using reply all
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/


Re: [galaxy-dev] Dependencies on other Tool Shed repositories

2013-02-08 Thread Peter Cock
 On Feb 8, 2013, at 7:54 AM, Peter Cock wrote:

 Hi all,

 I've been reading http://wiki.galaxyproject.org/ToolShedToolFeatures
 and focused on the example of EMBOSS where the tool definitions
 depend on the data type definitions. Here the emboss_5 repository
 (the tool wrappers) contains depository_dependencies.xml saying:

 ?xml version=1.0?
 repositories description=Emboss 5 requires the Galaxy applicable
 data formats used by Emboss tools.
 repository toolshed=http://toolshed.g2.bx.psu.edu;
 name=emboss_datatypes owner=devteam
 changeset_revision=a89163f31369 /
 /repositories

 Is that revision treated as a minimum version, or an absolute one?
 ..

On Fri, Feb 8, 2013 at 1:58 PM, Greg Von Kuster g...@bx.psu.edu wrote:
 Hi Peter,

 The changset_revision=xxx tag attribute is a minimum version setting.
 ...

That should be fine then - I've tried to clarify the repository description
on http://wiki.galaxyproject.org/ToolShedToolFeatures to say that.

Thanks,

Peter
___
Please keep all replies on the list by using reply all
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/