Re: [galaxy-dev] Galaxy updated botched?

2014-06-12 Thread Hans-Rudolf Hotz
On 06/12/2014 12:06 AM, John Chilton wrote: If anyone out there has tired using Galaxy with strictly MyISAM tables and found it untenable - by all means please chime in. Well, due to several reasons we are (still) using MySQL (version: 5.1.69) with only MyISAM tables. We have been

[galaxy-dev] jobs submitted to a cluster

2014-06-12 Thread Shrum, Donald C
I've setup galaxy to submit jobs to our HPC cluster as the logged in user. I used the drama python module to submit the jobs to our moab server. It appears that the working directory for a submitted job is being removed by galaxy prior to the job completing on the cluster. I can see a

[galaxy-dev] Object-Store, setting filetypes crashes Galaxy

2014-06-12 Thread bjoern.gruen...@googlemail.com
Hi, I have configured to use the hierarchical object store but as soon as I try to reset the filetpye of a dataset Galaxy is crashing with: galaxy.objectstore DEBUG 2014-06-12 14:39:21,180 Using preferred backend 'files3' for creation of MetadataFile 5963 132.230.153.57 - - [12/Jun/2014:14:39:20

Re: [galaxy-dev] Missing navigation pane

2014-06-12 Thread Geert Vandeweyer
Hey Stephen, Not a true solution, but I solved a similar issue (missing history pane) by clearing out the browser cache. Geert On 06/10/2014 04:39 PM, Dannon Baker wrote: Hey Stephen, Can you look in the server logs to see if there are any errors being reported? Or if there are any

Re: [galaxy-dev] Galaxy updated botched?

2014-06-12 Thread Dannon Baker
Hey Hans (and anyone else using MySQL), Just to clarify -- MySQL doesn't have this (particular) error by default and as long as your server default table type has not and does not change you should be fine. I've just successfully tested MySQL using MyISAM all the way to the current tip revision

Re: [galaxy-dev] Galaxy updated botched?

2014-06-12 Thread Kandalaft, Iyad
Thanks to everyone for their input. John, your explanation was excellent. I completely agree with the implementation of galaxy as it stands now (with a minor documentation warning about default mysql engine switch in v5.5). Personally, I either place trust in the ORM to maintain referential

Re: [galaxy-dev] jobs submitted to a cluster

2014-06-12 Thread Evan Bollig
Hey Donny, What is the value of keep_completed on your queue (from qmgr -c 'p s')? Could it be that your spool is flushing completed jobs immediately? I ran into issues the other day with libdrmaa requiring at least keep_complete = 60 seconds to properly detect completed jobs and clean up after

Re: [galaxy-dev] jobs submitted to a cluster

2014-06-12 Thread Shrum, Donald C
It's set to 600 seconds so I don't think that is the issue... Is there some sort of wait time to set in job_conf.xml -Original Message- From: Evan Bollig [mailto:boll0...@umn.edu] Sent: Thursday, June 12, 2014 9:27 AM To: Shrum, Donald C Cc: galaxy-dev@lists.bx.psu.edu Subject: Re:

Re: [galaxy-dev] bug: API broken under remote_user

2014-06-12 Thread Kandalaft, Iyad
Hi Eric, It's not broken per se but the documentation is lacking on this front. You need to route your /galaxy/api folder to a proxy that does not require authentication. Maybe this isn't the best way but it works for AAFC's production galaxy. See my apache configuration file below:

Re: [galaxy-dev] jobs submitted to a cluster

2014-06-12 Thread Evan Bollig
job_conf.xml is outside of my knowledge. Better wait to see what the others can tell us. -E -Evan Bollig Research Associate | Application Developer | User Support Consultant Minnesota Supercomputing Institute 599 Walter Library 612 624 1447 e...@msi.umn.edu boll0...@umn.edu On Thu, Jun 12, 2014

Re: [galaxy-dev] Toolshed upload error message

2014-06-12 Thread Dave Bouvier
Vipin, I've attempted to duplicate this error locally, with no luck as yet. Would you be able to send me the specific tar.gz file that was causing problems? --Dave B. On Wed 11 Jun 2014 05:02:34 PM EDT, Vipin TS wrote: Hi Greg, Please find the attached screenshot from my side. The same

Re: [galaxy-dev] bug: API broken under remote_user

2014-06-12 Thread Eric Rasche
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hi Iyad, Thanks for posting configs! I'm very curious how this actually works for you. I'm running the API scripts from the galaxy server itself, and I made requests to http://fqdn/galaxy/, http://localhost:/, and http://localhost:/galaxy/

Re: [galaxy-dev] Object-Store, setting filetypes crashes Galaxy

2014-06-12 Thread Nate Coraor
Hi Björn, I believe the problem is most likely this bug: https://trello.com/c/OHlQoCrx If you symlink /usr/local/galaxy/galaxy-dist/database/tmp to somewhere writeable (e.g. what you have new_files_path set to), that'd confirm it. I'm going to take a look at fixing this today. --nate On

Re: [galaxy-dev] bug: API broken under remote_user

2014-06-12 Thread John Chilton
Hey Eric, I am pretty sure Iyad's configuration is right - here is a similar config for nginx with some discussion of the API problem http://production-galaxy-instances-with-cloudman-and-cloudbiolinux.readthedocs.org/en/latest/#external-authentication-ldap. It is fine if it is empty it just has

Re: [galaxy-dev] Object-Store, setting filetypes crashes Galaxy

2014-06-12 Thread Björn Grüning
Hi Nate, yes that is fixing it for me! Thanks! Bjoern Am 12.06.2014 16:26, schrieb Nate Coraor: writeable (e.g. what you have new_files_path set to), that'd confirm it. ___ Please keep all replies on the list by using reply all in your

Re: [galaxy-dev] bug: API broken under remote_user

2014-06-12 Thread Eric Rasche
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hi John, Seems like odd behaviour, but if that's how it works, then that'll adequately fix my problem. Thanks John/Iyad! Cheers, Eric On 06/12/2014 09:40 AM, John Chilton wrote: Hey Eric, I am pretty sure Iyad's configuration is right - here

Re: [galaxy-dev] jobs submitted to a cluster

2014-06-12 Thread John Chilton
My guess is Galaxy is deleting the directory because it believe the job is in error because of some communication problem while polling your DRM via DRMAA - Galaxy thinks the job has failed before it has even been run. You can set cleanup_job = never in universe_wsgi.ini's app:main section to

Re: [galaxy-dev] jobs submitted to a cluster

2014-06-12 Thread Shrum, Donald C
Hi John, That did the trick. I have some other problem but I don't think it's galaxy from here. Thanks again for the reply. Donny -Original Message- From: John Chilton [mailto:jmchil...@gmail.com] Sent: Thursday, June 12, 2014 10:53 AM To: Evan Bollig Cc: Shrum, Donald C;

[galaxy-dev] Error with fastx reverse compliment

2014-06-12 Thread Umd Bioinformatics
Hello, I'm getting an error with fastx tools on a local install of galaxy. From this error I can't tell if it's a problem with the file, database, or tool. An error occurred with this dataset: zcat: /Volumes/Jose-Drobo/galaxy-dist/database/files/002/dataset_2875.dat.Z: No such file or

[galaxy-dev] Browsing toolsheds - HTTP(s) and firewalls

2014-06-12 Thread Eric Rasche
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Today I tried to access my org's toolshed, only to realise that it wouldn't load as it was behind the firewall. Since I'm not in the mood to connect my VPN, I thought I'd posit the following: Perhaps the galaxy server should make the HTTP requests to

[galaxy-dev] multiple file selection for from_file

2014-06-12 Thread Jun Fan
Hi all I gather that it is NOT allowed to assign multiple file to from_file attribute for options in select param as the expect value of from_file attribute is the name of A file. But would it be nice to allow this feature? For example, there are two loc file A and B, when I want to get

Re: [galaxy-dev] galaxy-dev Digest, Vol 96, Issue 14

2014-06-12 Thread xlwang
Hello, when i run my galaxy instance type: $ sh run.sh I get some error like this: Traceback (most recent call last): File /export/galaxy-dist/lib/galaxy/webapps/galaxy/buildapp.py, line 38, in app_factory from galaxy.app import UniverseApplication File