Re: [galaxy-dev] Galaxy, Docker Containers, and Installing tools not in Toolshed

2016-07-21 Thread Yip, Miu ki
when I attach. Thanks so much, Miuki From: Björn Grüning [bjoern.gruen...@gmail.com] Sent: Wednesday, July 20, 2016 2:05 PM To: Yip, Miu ki; Björn Grüning; galaxy-dev@lists.galaxyproject.org Subject: Re: [galaxy-dev] Galaxy, Docker Containers, and Installing too

[galaxy-dev] Galaxy in Docker and nginx

2016-07-29 Thread Yip, Miu ki
Hi Galaxy Team, I'm currently trying to use Galaxy in Docker, and I wanted to know if there are special actions that I have to do in Galaxy for nginx. I'm trying to set up a reserve proxy and have url forwarding. Do I need to inform Galaxy in Docker that nginx is being use? Thanks, Miuki

Re: [galaxy-dev] Galaxy in Docker and nginx

2016-07-29 Thread Yip, Miu ki
Hi, I ended up getting nginx running. Turns out it was just a selinux issue. Thanks and sorry for the trouble! Best, Miuki From: Yip, Miu ki Sent: Thursday, July 28, 2016 4:28 PM To: galaxy-dev@lists.galaxyproject.org Subject: Galaxy in Docker and nginx Hi

[galaxy-dev] Galaxy, Docker Containers, and Installing tools not in Toolshed

2016-07-19 Thread Yip, Miu ki
Hello Galaxy Team, We're from the Bioinformatics Shared Resources at Cold Spring Harbor Lab and we're trying to create a new flavour of Galaxy for local use in the lab using docker containers. We want to add tools that are specific for our lab, such as importing files from our system, onto

Re: [galaxy-dev] Galaxy, Docker Containers, and Installing tools not in Toolshed

2016-07-20 Thread Yip, Miu ki
iables are stored for docker Galaxy? I have tried looking for an env file, but could not find it. Thanks so much! Miuki From: Björn Grüning [bjoern.gruen...@gmail.com] Sent: Wednesday, July 20, 2016 2:23 AM To: Yip, Miu ki; galaxy-dev@lists.galaxyproject.org S

[galaxy-dev] Implementing iRODS with Galaxy

2016-07-01 Thread Yip, Miu ki
Hello Galaxy Team, We're from the Bioinformatics Shared Resources (BSR) at Cold Spring Harbor Labs and we're looking to implement irods on a newly installed version of Galaxy. We want to incorporate iRODS (http://irods.org/). Is there a recommended way to do this, or no? Thanks in advance for

[galaxy-dev] AD/LDAP Integration

2017-02-02 Thread Yip, Miu ki
Hi all, After setting up AD/LDAP in Galaxy, we noticed that for some reason, some users are able to log in but others were not. We don’t think that it has anything to do with the set up of LDAP or AD at our institute and we’ve tried to find common threads between the users who can log in but

[galaxy-dev] Galaxy Restart & Jobs finishing

2017-02-14 Thread Yip, Miu ki
Hi all, Is there a way to restart Galaxy without having to wait till all the outstanding jobs are finished running? I’ve noticed that whenever Galaxy daemon is stopped and then started, the UI does not return back online until all the jobs that were running are finished or killed because they

[galaxy-dev] Docker ToolShed Imports Issue

2016-08-22 Thread Yip, Miu ki
Hi all, I’m trying to import shed tools into Galaxy for Docker. When I build the container, I get this error message: TASK [galaxy_tools : Install Tool Shed tools] ** [WARNING]: The loop variable 'item' is already in use. You should set the `loop_var` value in

[galaxy-dev] Galaxy and Torque

2017-02-27 Thread Yip, Miu ki
Hi all, Is Torque still supported as a resource manager? This page ( https://wiki.galaxyproject.org/Admin/Config/Performance/Cluster ) mentioned the usage of Torque and how to set it up. However, the setup instructions refer to a /script/scramble.py file which I assume interfaces with eggs.

[galaxy-dev] Galaxy Pulsar unable to access DRMAA so

2016-10-24 Thread Yip, Miu ki
Hi all, When trying to submit a job to the cluster via Pulsar from Galaxy, an error is thrown and the job won’t be submitted. The paster.log file has the following error: Exception: Attempt to use DRMAA, but DRMAA Python library cannot be loaded. OSError - problem loading shared library

[galaxy-dev] Galaxy ToolShed Installation Question

2016-11-28 Thread Yip, Miu ki
Hi all, When a tool is installed onto Galaxy via the GUI from the ToolShed, where is the tool itself installed on the system? For instance, having installed Bed Tools from the ToolShed, the tool errors out on a run with the following error: Fatal error: Exit code 127 ()

[galaxy-dev] Installing ToolShed Tools into Galaxy via Browser Interface Exception Thrown

2016-11-03 Thread Yip, Miu ki
Hi all, While trying to install tools from the toolshed via the browser interface, an error keeps appearing and nothing is abled to be installed. Currently using the latest version of Galaxy and having tried to install several different tools, the following error keeps appearing in the log

Re: [galaxy-dev] Installing ToolShed Tools into Galaxy via Browser Interface Exception Thrown

2016-11-03 Thread Yip, Miu ki
gt; this looks like your integrated_tool_panel.xml file has some problems. > Can you try to move this file to a different location and try the > installation again? > It should be located in your galaxy directory. > > Best, > Marius > > > On 11/03/2016 03:16 PM, Yip, Miu ki wro

Re: [galaxy-dev] Installing ToolShed Tools into Galaxy via Browser Interface Exception Thrown

2016-11-03 Thread Yip, Miu ki
/galaxyproject/galaxy/issues/3084 > > More good news: This will likely be fixed in the next release > of Galaxy: > > https://github.com/galaxyproject/galaxy/pull/3122 > > Right now I suggest you manually edit these XML files to > use the word "and" instead of "

[galaxy-dev] ToolShed devteam tools error

2016-12-05 Thread Yip, Miu ki
Hi all, After installing the following devteam tools from the ToolShed: Base Coverage/Cluster/Complement/Concatenate/Flanking_features/get_flanks/Intersect/Join/Merge/Subtract The tools give an error after being run. Traceback (most recent call last): File

Re: [galaxy-dev] All Jobs Error Out

2017-03-15 Thread Yip, Miu ki
Hi John, Thanks for the reply. I saw in the stack trace that there was a issue with mercurial, which was recently installed in the system. After uninstalling it, everything ran again. Not entirely sure what happened. Thanks, Miuki On Mar 14, 2017, at 8:27 AM, John Chilton

[galaxy-dev] All Jobs Error Out

2017-03-07 Thread Yip, Miu ki
Hi all, This afternoon, our local instance of Galaxy suddenly started producing errors for all jobs. This is the trace that gets printed out. Not sure what is happening because the error doesn’t give much information other than python not being able to find a module. Traceback (most recent

[galaxy-dev] Tool Shed tools - Uncaught Error

2017-08-13 Thread Yip, Miu ki
Hi all, We’re having a bit of trouble with a local version of Galaxy where all the tools that were installed via tool shed is showing an uncaught error on the user interface. The tools have clearly been installed and can be seen in the admin panel on the interface as well as the psql database

[galaxy-dev] Job output not returned from Cluster Error

2017-08-17 Thread Yip, Miu ki
Hi, We’re having a bit of an error where the GUI shows that a job had an error. When the user submits the job, the job is seen to have run via terminal and uge. The job working directory exists and the out and error file is in there. Once the job completes, it seems like the GUI will say that

[galaxy-dev] Galaxy Start Up Error - Double Requirements, Tempita

2017-05-12 Thread Yip, Miu ki
Hi all, When attempting to start up Galaxy, via the run.sh script, we’re getting the following error: galaxyd@genomics:/galaxy$ sh run.sh Activating virtualenv at .venv Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages Double requirement given: Tempita==0.5.3.dev0