Re: [PATCH] ENTRY_VALUE fixes (PR debug/48203)

2011-03-28 Thread Jakub Jelinek
On Mon, Mar 28, 2011 at 09:58:38AM -0700, Richard Henderson wrote: * var-tracking.c (vt_add_function_parameter): Ensure cselib_lookup on ENTRY_VALUE is able to find the canonical parameter VALUE. I don't really understand what's going on here. Whatever it is, it could definitely

Re: [PATCH] ENTRY_VALUE fixes (PR debug/48203)

2011-03-28 Thread Richard Henderson
On 03/28/2011 10:32 AM, Jakub Jelinek wrote: Say vt_add_function_parameter is called for first parameter in %rdi, cselib_lookup_from_insn gives us VALUE 2:2 for it. We add (entry_value:DI (reg:DI %rdi)) to list of locations for that VALUE. The second cselib_lookup_from_insn gives us VALUE

Re: fix for 48208 and 48260 on darwin

2011-03-28 Thread Mike Stump
On Mar 27, 2011, at 8:55 PM, Christian Schüler wrote: please review the following patch (and besides, bear with me as this is the first patch proposal from me). For gcc 4.5 and earlier it was possible to configure xcode via a modified xcplugin to use the newer gcc directly (yes, the -arch

Re: [google] Allow relative profile paths. (issue4280074)

2011-03-28 Thread dnovillo
OK. A nit and a question below. Diego. http://codereview.appspot.com/4280074/diff/1/gcc/doc/invoke.texi File gcc/doc/invoke.texi (right): http://codereview.appspot.com/4280074/diff/1/gcc/doc/invoke.texi#newcode gcc/doc/invoke.texi:: and its related options. Both absolute and

libgo patch committed: Rename fd_rtems.go to fd_select.go

2011-03-28 Thread Ian Lance Taylor
I renamed fd_rtems.go to fd_select.go in libgo, since the file is used for operating systems other than RTEMS. Bootstrapped on x86_64-unknown-linux-gnu. Committed to mainline. Ian diff -r 381b9fce29e2 libgo/Makefile.am --- a/libgo/Makefile.am Mon Mar 28 11:07:46 2011 -0700 +++

Re: Improve jump threading #1 of N

2011-03-28 Thread Jeff Law
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 03/26/11 11:43, Richard Guenther wrote: Looks good to me apart from not using gsi_start_nondebug_bb in thread_around_empty_block. Ah. I wasn't aware of gsi_start_nondebug_bb. I updated the patch to use it, ran another bootstrap and regression

libgo patch committed: Fix fd_select.go

2011-03-28 Thread Ian Lance Taylor
This patch fixes fd_select.go for the changes in FD handling in the latest libgo update. The code in libgo now takes advantage of the fact that if you change the set of descriptors used by epoll, it is not necessary to wake up the thread waiting in epoll_wait. That is not true of select: if you

Re: [patch] Split RTL constant/copy propagation off from gcse.c to new cprop.c

2011-03-28 Thread Jeff Law
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 03/28/11 10:25, Steven Bosscher wrote: Hello, This patch splits the CPROP pass (constant/copy propagation for RTL) out of gcse.c into a new file cprop.c. Originally all the Muchnick-passes (GCSE, PRE, CPROP, HOIST, store motion, ...) lived

Re: [google] Allow relative profile paths. (issue4280074)

2011-03-28 Thread Diego Novillo
On Mon, Mar 28, 2011 at 14:14, mart...@google.com wrote: On 2011/03/28 17:59:32, Diego Novillo wrote: I'm confused.  why did you take !HAS_DRIVE_SPEC() out? Earlier in the function, the following code makes sure we don't start the fname with a DRIVE_SPEC.      if (prefix_length != 0

Re: [patch, fortran] Extend character optimization to LLE and friends

2011-03-28 Thread Richard Henderson
On 03/28/2011 11:50 AM, Thomas Koenig wrote: +case GFC_ISYM_LLE: + return optimize_comparison (e, INTRINSIC_LE); + break; Style nit: remove the unreachable break statements. r~

Re: PATCH: Split AVX 32byte unalignd load/store

2011-03-28 Thread Richard Henderson
On 03/27/2011 11:57 AM, H.J. Lu wrote: +{ -mavx256-split-unaligned-stroe, MASK_AVX256_SPLIT_UNALIGNED_STORE}, Typo. r~

[pph] Tidy naming scheme for some functions (issue4291074)

2011-03-28 Thread Diego Novillo
No functional changes. Rename some functions to make them consistent with the other functions in the file. cp/ChangeLog.pph. 2011-03-28 Diego Novillo dnovi...@google.com * pph.c (pph_write_format): Rename from write_pph_format. (pph_write_namespace): Rename from

Go patch committed: Don't check for dup interface/named method

2011-03-28 Thread Ian Lance Taylor
A named interface type may not have methods. Therefore, there is no reason to check whether the same name is used for an interface method and a regular method. This patch removes this useless test. Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu. Committed to mainline. Ian diff

Re: [PING][PATCH, testsuite] Update gcc.dg/stack-usage-1.c SIZE values for powerpc

2011-03-28 Thread Peter Bergner
On Mon, 2011-03-28 at 20:48 +0200, Dominique Dhumieres wrote: The test gcc.dg/stack-usage-1.c already failed on powerpc-apple-darwin9 before you change with: FAIL: gcc.dg/stack-usage-1.c scan-file foo\t(256|264)\tstatic and is still failing the same way after it. [karma] f90/bug% grep

Interlacing switch labels and compound statements

2011-03-28 Thread Bruce Korb
I stumbled over this code using a source code analyzer. It incorrectly assumed that switch labels cannot be inserted into random places inside of enclosed compound statements. It correctly assumes that you shouldn't be doing that. :) I propose making this change solely for aesthetics: static

Go patch committed: Pointer to interface type has no methods

2011-03-28 Thread Ian Lance Taylor
In the patch I just committed, I overlooked that a pointer to a named interface type has no methods, and therefore that you can not use such a type with a method expression. This patch corrects that oversight. To make the error more clear, I added a '*' to the error output for a pointer type.

Re: [PING][PATCH, testsuite] Update gcc.dg/stack-usage-1.c SIZE values for powerpc

2011-03-28 Thread Dominique Dhumieres
Just guessing at the numbers, does the following patch fix the failures for you? As I am currently bootstrapping gcc, I cannot regtest right now, but running the test manually I get 256 at -m32 (I guess this is right) while I get 272 at -m64 (so the test will fail). Dominique

Go patch committed: Better errors for missing chan element type

2011-03-28 Thread Ian Lance Taylor
This patch to the Go frontend gives better error messages for the common error of omitting a channel element type. Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu. Committed to mainline. Ian diff -r 5e8176633433 go/parse.cc --- a/go/parse.cc Mon Mar 28 14:34:54 2011 -0700 +++

Re: [google] Allow relative profile paths. (issue4280074)

2011-03-28 Thread Diego Novillo
Committed to google/main rev 171635.

Re: [committed] Fix PA ior expanders

2011-03-28 Thread Richard Henderson
On 03/27/2011 03:17 PM, John David Anglin wrote: +(define_predicate reg_or_ior_operand + (match_code subreg,reg,const_int) +{ + return (register_operand (op, mode) + || (GET_CODE (op) == CONST_INT ior_mask_p (INTVAL (op; +}) + Better written, IMO, as (ior (match_operand 0

Go patch committed: Better error message for missing if condition

2011-03-28 Thread Ian Lance Taylor
This patch to the Go frontend gives a better error message when the condition is omitted from an if statement. Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu. Committed to mainline. Ian diff -r a05deef47b01 go/parse.cc --- a/go/parse.cc Mon Mar 28 15:48:35 2011 -0700 +++

[wwwdocs] PATCH for Re: GCC 4.6.0 Released

2011-03-28 Thread Gerald Pfeifer
Committed. Gerald Index: index.html === RCS file: /cvs/gcc/wwwdocs/htdocs/index.html,v retrieving revision 1.781 diff -u -3 -p -r1.781 index.html --- index.html 25 Mar 2011 19:56:41 - 1.781 +++ index.html 28 Mar 2011

Re: [committed] Fix PA ior expanders

2011-03-28 Thread John David Anglin
You've already got an ior_operand, which has a redundant test for CONST_INT. Actually, this is true of quite a few of the PA predicates... Quite true. The predicates were originally derived from the code in pa.md without a significant review. I'll look at implementing your suggestion.

[gc-improv] [PATCH] Separate function RTL memory

2011-03-28 Thread Laurynas Biveinis
This is a first attempt to separate function RTL and make it default. This patch is enough for --disable-bootstrap --enable-languages=c to complete on Linux x64, but there still remains some RTL that is allocated on function obstack when it should be permanent instead. The patch disables

Re: [PING][PATCH, testsuite] Update gcc.dg/stack-usage-1.c SIZE values for powerpc

2011-03-28 Thread Dominique Dhumieres
Ok, slightly updated. How about this? ... It did not work either at -m64, but the following one seems to work (manual testing): --- /opt/gcc/_gcc_clean/gcc/testsuite/gcc.dg/stack-usage-1.c2011-03-28 20:27:57.0 +0200 +++ /opt/gcc/work/gcc/testsuite/gcc.dg/stack-usage-1.c

<    1   2   3