Fix typo on cygming.h

2011-03-22 Thread Nick Clifton
Hi Guys, I am applying the patch below as an obvious fix. The definition of SUBTARGET_OVERRIDE_OPTIONS in the i386/cygming.h header file has a trailing backslash at the end of the macro, leading it to include the line that follows. Fortunately that line is blank, but could change one

Re: Fix typo on cygming.h

2011-03-22 Thread Kai Tietz
2011/3/22 Nick Clifton ni...@redhat.com: Hi Guys,  I am applying the patch below as an obvious fix.  The definition of  SUBTARGET_OVERRIDE_OPTIONS in the i386/cygming.h header file has a  trailing backslash at the end of the macro, leading it to include the  line that follows.  Fortunately

Re: [patch] Couple of tweaks to the gimplifier

2011-03-22 Thread Richard Guenther
On Mon, Mar 21, 2011 at 6:48 PM, Eric Botcazou ebotca...@adacore.com wrote:  1) Set TREE_THIS_NOTRAP on the INDIRECT_REF built for VLA decls.  This is correct since stack memory isn't considered as trapping in the IL. This is ok. Thanks.  2) Improve gimplification of complex conditions

Re: RFA: Add MN10300 to list of targets not supporting profiling

2011-03-22 Thread Rainer Orth
Hi Nick, Please may I apply the patch below to add the MN10300 target, and its AM33/AM34 variation, to the list of targets which do not currently support profiling ? sure, such a change is ok for a target maintainer to apply without approval. Index:

Re: [Patch, Fortran] PR 48174+45304: No varags if interface is known

2011-03-22 Thread Paul Richard Thomas
Dear Tobias, Why did Jakub's patch for PR45304 not fix this? He visited the fix in your patch upon build_library_function_decl_1 and gfc_get_intrinsic_lib_fndecl. Should trans-decl.c(create_function_arglist) have received the same treatment? Otherwise it is OK for trunk. Thanks for the patch.

[PATCH, libstdc++]: Export _ZNSt14numeric_limitsIgE12max_digits10E@@GLIBCXX_LDBL_3.4.14

2011-03-22 Thread Uros Bizjak
Hello! std::numeric_limits__float128::max_digits10 long double export should probably match other max_digits10 functions. At least alpha abi check complains on incompatible added symbol without this patch. 2011-03-22 Uros Bizjak ubiz...@gmail.com * config/os/gnu-linux/ldbl-extra.ver:

Re: [avr] fixup dwarf2 unwind info

2011-03-22 Thread Denis Chertykov
2011/3/21 Richard Henderson r...@redhat.com: This is a slightly tidied patch from sometime last month, which was buried in a thread about dwarf2 unwind info for gas.  This fixes some totally incorrect unwind markings in the avr backend, and adds support in the dwarf2 middle-end for handling

Re: [PATCH, libstdc++]: Export _ZNSt14numeric_limitsIgE12max_digits10E@@GLIBCXX_LDBL_3.4.14

2011-03-22 Thread Jakub Jelinek
On Tue, Mar 22, 2011 at 11:25:28AM +0100, Uros Bizjak wrote: std::numeric_limits__float128::max_digits10 long double export should probably match other max_digits10 functions. At least alpha abi check complains on incompatible added symbol without this patch. 2011-03-22 Uros Bizjak

[patch] Fix annoying gcov filename handling

2011-03-22 Thread Eric Botcazou
Hi, this is a repost of http://gcc.gnu.org/ml/gcc-patches/2008-08/msg01389.html to fix the annoying gcov filename handling whereby doing gcov path/to/file.gcda doesn't work since gcov drops the path and, therefore, doesn't find the file. Tested on i586-suse-linux, OK for the mainline?

RFC: Issue about assumption of DOSish file-system for cygwin

2011-03-22 Thread Kai Tietz
Hello, I noticed this issue while working on those directory-separator thing for DOSish file-systems, and somehow this looks odd to me. For some reason the filenames.h header assumes for cygwin DOSish file-system, but in fact cygwin uses POSIXish file-system. I assume this definition was caused

Re: [PATCH, libstdc++]: Export _ZNSt14numeric_limitsIgE12max_digits10E@@GLIBCXX_LDBL_3.4.14

2011-03-22 Thread Uros Bizjak
On Tue, Mar 22, 2011 at 11:43 AM, Jakub Jelinek ja...@redhat.com wrote: On Tue, Mar 22, 2011 at 11:25:28AM +0100, Uros Bizjak wrote: std::numeric_limits__float128::max_digits10 long double export should probably match other max_digits10 functions. At least alpha abi check complains on

Re: [PATCH, 4.7] Fix failure of two tests on 32-bit powerpc

2011-03-22 Thread David Edelsohn
On Mon, Mar 21, 2011 at 7:56 PM, Michael Meissner meiss...@linux.vnet.ibm.com wrote: I noticed that dg.gcc/torture/vector-1.c and dg.gcc/torture/vector-2.c were failing on 32-bit PowerPC Linux systems.  The failure was due to the compiler complaining that by default the ABI on 32-bit does not

[PATCH] Fix PR48228

2011-03-22 Thread Richard Guenther
Boostrapped and tested on x86_64-unknown-linux-gnu, applied to trunk. Richard. 2011-03-22 Richard Guenther rguent...@suse.de PR tree-optimization/48228 * tree-vrp.c (vrp_visit_phi_node): Do not stop propagating for single-arg PHIs. *

Re: [PATCH] refactor common bits of building CALL_EXPRs

2011-03-22 Thread Diego Novillo
On Tue, Mar 22, 2011 at 08:32, Nathan Froyd froy...@codesourcery.com wrote: The knowledge that building a CALL_EXPR requires three additional arguments is scattered about tree.c; the patch below centralizes that knowledge in a common function, build_call_1.  This function can also take care of

[Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Adam Butcher
Hi, I found that with the latest GCC 4.6.0 release candidate, dynamically linking against libstdc++ fails for client code that expects to move an object derived from std::string. The move constructor (either explicitly specified or compiler generated) of such a class fails to link in the

Re: [patch, libgfortran] Bug 48030 - Implement read_x using fbuf_getc

2011-03-22 Thread Janne Blomqvist
On Tue, Mar 22, 2011 at 03:15, Jerry DeLisle jvdeli...@frontier.com wrote: Ping On 03/19/2011 09:46 PM, Jerry DeLisle wrote: Hi, The attached patch re-implements read_x using fbuf_getc. Self explanatory. I suspect this doesn't actually fix the issue with reading from a pipe before we have

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Jakub Jelinek
On Tue, Mar 22, 2011 at 01:10:14PM -, Adam Butcher wrote: After a bit of poking around with nm in various objects I determined that the baseline_symbols files define what should be exported. The following grep+sed combo adds the necessary export for any architecture that exports the C1

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Paolo Carlini
Hi, After a bit of poking around with nm in various objects I determined that the baseline_symbols files define what should be exported. The following grep+sed combo adds the necessary export for any architecture that exports the C1 constructor symbol. grep _ZNSsC1EOSs

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Paolo Carlini
Hi, On Tue, Mar 22, 2011 at 01:10:14PM -, Adam Butcher wrote: After a bit of poking around with nm in various objects I determined that the baseline_symbols files define what should be exported. The following grep+sed combo adds the necessary export for any architecture that exports the C1

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Paolo Carlini
Il 22/03/11 14.52, Paolo Carlini ha scritto: Jakub, such a patch would be ok with me, if isn't too late, but, frankly I don't see why we are not seeing the issue in the existing cons/char/moveable.cc, maybe it's something sensitive to inlining decisions (yes a testcase is welcome!), and then

Re: [PATCH][ARM] Discourage use of NEON on Cortex-A8

2011-03-22 Thread Andrew Stubbs
On 14/03/11 18:17, Richard Earnshaw wrote: I think the order should be: not-a8, core-regs, core-regs, only-a8. Ok, how about this? I've tested that it still builds spec2k crafty. Andrew

Re: [PATCH][ARM] Discourage use of NEON on Cortex-A8

2011-03-22 Thread Richard Earnshaw
On Tue, 2011-03-22 at 14:05 +, Andrew Stubbs wrote: On 14/03/11 18:17, Richard Earnshaw wrote: I think the order should be: not-a8, core-regs, core-regs, only-a8. Ok, how about this? I've tested that it still builds spec2k crafty. Andrew ENOPATCH R.

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Adam Butcher
On Tue, March 22, 2011 1:39 pm, Jakub Jelinek wrote: On Tue, Mar 22, 2011 at 01:10:14PM -, Adam Butcher wrote: After a bit of poking around with nm in various objects I determined that the baseline_symbols files define what should be exported. The following grep+sed combo adds the

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Jakub Jelinek
On Tue, Mar 22, 2011 at 03:26:21PM +0100, Benjamin Kosnik wrote: Thanks for reporting this issue Adam. Don't hesitate to file bug reports in gcc bugzilla category libstdc++ when you find problems like this in the future! So, if Benjamin or other libstdc++ maintainers want it fixed for

Re: [Patch] [libstdc++] [C++0x] Export std::string base object move constructor.

2011-03-22 Thread Benjamin Kosnik
Here is updated patch with testcases, tested with unpatched libstdc++ where it failed to link and patched where it succeeded. The testcases are copies of corresponding moveable.cc tests, just using the new class inheriting from std::basic_stringchar resp. std::basic_stringwchar_t and with

[PATCH] FreeBSD SPARC allow target to be set via -mcpu and enable TLS

2011-03-22 Thread Marius Strobl
Hi, the following patch changes the GCC configuration for FreeBSD SPARC (we only support 64-bit v9 there) so that the target CPU type may be set via -mcpu instead of limiting to the hardcoded equivalent of -mcpu=ultrasparc and TLS support is enabled if available. Both changes are also present in

Fix some LTO -fPIC testcases

2011-03-22 Thread Bernd Schmidt
On targets where -fpic/-fPIC produce an error, we currently fail a large number of LTO testcases. These should be using the appropriate dg-require-effective-target so that they don't get run. Ok? Bernd * g++.dg/lto/20091002-1_0.C: Use dg-require-effective-target fpic. *

[v3] Implement DR 1401

2011-03-22 Thread Paolo Carlini
Hi, tested x86_64-darwin, committed to mainline. Paolo. /// 2011-03-22 Paolo Carlini paolo.carl...@oracle.com * include/bits/shared_ptr.h (operator, operator=, operator=): Add, per DR 1401. (operator==, operator!=, operator): Fix per the letter of DR 1401.

Re: Fix some LTO -fPIC testcases

2011-03-22 Thread Richard Guenther
On Tue, Mar 22, 2011 at 4:17 PM, Bernd Schmidt ber...@codesourcery.com wrote: On targets where -fpic/-fPIC produce an error, we currently fail a large number of LTO testcases. These should be using the appropriate dg-require-effective-target so that they don't get run. Ok? Ok. Thanks,

Re: [avr] fixup dwarf2 unwind info

2011-03-22 Thread Richard Henderson
On 03/22/2011 05:31 AM, Bernd Schmidt wrote: On 03/21/2011 09:50 PM, Richard Henderson wrote: Ok to commit? As far as the dwarf2out bits are concerned, yes but please change it to also accept POST_MODIFY - your patch is identical to some code I need for a new target except for the rtx code.

Re: PATCH: PR other/48007: Unwind library doesn't work with UNITS_PER_WORD sizeof (void *)

2011-03-22 Thread Jakub Jelinek
On Tue, Mar 22, 2011 at 04:19:46PM +0100, Ulrich Weigand wrote: Ian Lance Taylor wrote: H.J. Lu hjl.to...@gmail.com writes: Here is the updated patch. It has This patch is OK if it bootstraps and passes tests. I thought the _Unwind_Context structure was part of the libgcc ABI and

Re: [PATCH] FreeBSD SPARC allow target to be set via -mcpu and enable TLS

2011-03-22 Thread Loren J. Rittle
Approved. On Tue, Mar 22, 2011 at 10:06 AM, Marius Strobl mar...@freebsd.org wrote: 2011-03-22  Marius Strobl mar...@freebsd.org        * config/sparc/freebsd.h (CPP_CPU64_DEFAULT_SPEC): Replace with...        (FBSD_TARGET_CPU_CPP_BUILTINS): ...this.        (TARGET_GNU_TLS, TARGET_SUN_TLS):

[PATCH] sparc and alpha baseline_symbols.txt update

2011-03-22 Thread Jakub Jelinek
On Tue, Mar 22, 2011 at 01:27:32PM +0100, Matthias Klose wrote: sparc update attached. Maybe John Dave Anglin could update hppa? Trying to get updates for mips. Would it be too late for an armeabi baseline file? Thanks, I've taken your and Uros' update, added the two new exports from today,

Re: PATCH: PR other/48007: Unwind library doesn't work with UNITS_PER_WORD sizeof (void *)

2011-03-22 Thread Andrew Pinski
On Tue, Mar 22, 2011 at 9:42 AM, Ian Lance Taylor i...@google.com wrote: Any target on which _Unwind_Word is larger than void * is broken today, so I don't think we need to care about that case. So a MIPS N32 is broken? Lots of people use that target already and nothing like this has showed

[libgo] Provide strerror_r replacement (PR go/47515)

2011-03-22 Thread Rainer Orth
Apart from the lack of wait4, libgo on IRIX 6.5 contained an undefined reference to strerror_r. This patch provides a replacement, based on gnulib/lib/strerror_r.c, but massively simplified. This allowed me to link with libgo, and has been tested on i386-pc-solaris2.11 with the result of the

Re: Cleaning up expand optabs code

2011-03-22 Thread Richard Henderson
On 03/22/2011 08:08 AM, Richard Sandiford wrote: + for (i = 0; i + 1 nops; i++) +if (ops[i].commutative MAX_EXPAND_OPERANDS +swap_commutative_operands_with_target (ops[ops[i].commutative].value, + ops[i].value, +

Re: RFC: Issue about assumption of DOSish file-system for cygwin

2011-03-22 Thread Dave Korn
On 22/03/2011 11:00, Kai Tietz wrote: I noticed this issue while working on those directory-separator thing for DOSish file-systems, and somehow this looks odd to me. For some reason the filenames.h header assumes for cygwin DOSish file-system, but in fact cygwin uses POSIXish file-system. I

Re: RFC: Issue about assumption of DOSish file-system for cygwin

2011-03-22 Thread Kai Tietz
2011/3/22 Pedro Alves pe...@codesourcery.com: On Tuesday 22 March 2011 18:11:28, Kai Tietz wrote: Ok, thanks for explaining it. I am just a bit concerned here about the ABSOLUTE path detection. As then for cygwin this will be for UNIXish path never true.   So it might be necessary here for

Re: RFA: Add MN10300 to list of targets not supporting profiling

2011-03-22 Thread Mike Stump
On Mar 22, 2011, at 2:11 AM, Nick Clifton wrote: Please may I apply the patch below to add the MN10300 target, and its AM33/AM34 variation, to the list of targets which do not currently support profiling ? I think the target maintainers make for a better reviewer in this case, if not

Re: PATCH: PR other/48007: Unwind library doesn't work with UNITS_PER_WORD sizeof (void *)

2011-03-22 Thread Ian Lance Taylor
Andrew Pinski pins...@gmail.com writes: On Tue, Mar 22, 2011 at 9:42 AM, Ian Lance Taylor i...@google.com wrote: Any target on which _Unwind_Word is larger than void * is broken today, so I don't think we need to care about that case. So a MIPS N32 is broken? Lots of people use that target

Re: [RFC] Add a new argument to SELECT_CC_MODE

2011-03-22 Thread Eric Botcazou
Like in the attached patch. Sandra expressed an interest for it so I've installed it on the mainline after bootstrapping and regtesting on x86_64-suse-linux. 2011-03-22 Eric Botcazou ebotca...@adacore.com * combine.c (simplify_set): Try harder to find the best CC mode when

Re: Deprecating config-ml.in multilib selection options

2011-03-22 Thread Joseph S. Myers
Given the views expressed by target maintainers I've applied this patch to document the ARM and MIPS config-ml.in options as obsolete (with the expectation that they will be removed later in the 4.7 release cycle). I'd still encourage maintainers for the other targets with such options in

Re: [PATCH] dwarf2out: Print the name of the unspec as part of the warning

2011-03-22 Thread Richard Henderson
On 03/21/2011 03:26 AM, Andreas Krebbel wrote: + (XINT (rtl, 1) = 0 XINT (rtl, 1) NUM_UNSPEC_VALUES) + ? unspec_strings[XINT (rtl, 1)] : unkown, + XINT (rtl, 1)); The parentheses ought to be enclosing the entire ternary expression for clarity. Also, typo

[doc patch] fix PRs 48179, 48221 and 48234

2011-03-22 Thread Jonathan Wakely
This fixes three bugs reported against the docs generated from the 4.6.0 RC. 48179 and 48234 are caused by a @section appearing in a different order compared to the order they apepar in the @menu, so the order of sections in the TOC and the Next/Previous navigation links do not match the section

[alpha] purge windows nt code from the backend

2011-03-22 Thread Richard Henderson
Sadly, this lag is even longer than the cray port. Best I can tell, 2001-02-24 Zack Weinberg za...@stanford.edu (i750a-*-*): Error here if hosting on i750a. (alpha*-*-winnt*, ix86-*-winnt3*): Remove stanzas entirely. ... I.e. more than a decade ago the configury was

Re: [PATCH 2/2] refactor emit_*_{after,before}{,_setloc} using common functions

2011-03-22 Thread Nathan Froyd
On Tue, Mar 22, 2011 at 02:28:30PM -0700, Richard Henderson wrote: On 03/21/2011 08:18 PM, Nathan Froyd wrote: +/* Insert PATTERN before BEFORE, setting its INSN_LOCATION to LOC. + MAKE_RAW indicates how to turn PATTERN into a real insn. INSNP + indicates if PATTERN is meant for an

Re: [PATCH 2/2] refactor emit_*_{after,before}{,_setloc} using common functions

2011-03-22 Thread Richard Henderson
On 03/22/2011 04:13 PM, Nathan Froyd wrote: rtx emit_call_insn_before_setloc (rtx pattern, rtx before, int loc) { ... if (pattern == NULL_RTX) return last; first = NEXT_INSN (first); The jump_insn and debug_insn variants have identical behavior to call_insn. AFAICT, the

Re: PATCH: PR other/48007: Unwind library doesn't work with UNITS_PER_WORD sizeof (void *)

2011-03-22 Thread Ian Lance Taylor
H.J. Lu hjl.to...@gmail.com writes: This suggests that, at least, when sizeof(_Unwind_Word) sizeof(void*), we need to extend _Unwind_Context with a new array at the end, and use that new array when by_value[REG] is true. Will there be a case where 2 copies of unwind-dw2.c are within the