Re: Ping: Re: [patch, avr] Add flash size to device info and make wrap around default

2016-11-27 Thread Pitchumani Sivanupandi
On Saturday 26 November 2016 12:11 AM, Denis Chertykov wrote: I'm sorry for delay. I have a problem with the patch: (Stripping trailing CRs from patch; use --binary to disable.) patching file avr-arch.h (Stripping trailing CRs from patch; use --binary to disable.) patching file avr-devices.c

New Spanish PO file for 'gcc' (version 6.2.0)

2016-11-27 Thread Translation Project Robot
Hello, gentle maintainer. This is a message from the Translation Project robot. A revised PO file for textual domain 'gcc' has been submitted by the Spanish team of translators. The file is available at: http://translationproject.org/latest/gcc/es.po (This file, 'gcc-6.2.0.es.po', has

Re: [PR78365] ICE in determine_value_range, at tree-ssa-loo p-niter.c:413

2016-11-27 Thread Prathamesh Kulkarni
On 28 November 2016 at 10:55, kugan wrote: > Hi, > > On 24/11/16 19:48, Richard Biener wrote: >> >> On Wed, Nov 23, 2016 at 4:33 PM, Martin Jambor wrote: >>> >>> Hi, >>> >>> On Fri, Nov 18, 2016 at 12:38:18PM +1100, kugan wrote: Hi,

Re: [PR78365] ICE in determine_value_range, at tree-ssa-loo p-niter.c:413

2016-11-27 Thread kugan
Hi, On 24/11/16 19:48, Richard Biener wrote: On Wed, Nov 23, 2016 at 4:33 PM, Martin Jambor wrote: Hi, On Fri, Nov 18, 2016 at 12:38:18PM +1100, kugan wrote: Hi, I was relying on ipa_get_callee_param_type to get type of parameter and then convert arguments to this type

C++ PATCH for c++/77907 (constant init and PMF)

2016-11-27 Thread Jason Merrill
When evaluating a NOP_EXPR of a PTRMEM_CST, we should fold it into the PTRMEM_CST rather than wrap it. Tested x86_64-pc-linux-gnu, applying to trunk and 6. commit fa9d4e0435f71a0a335ecc00af23b1cfe568de3c Author: Jason Merrill Date: Wed Nov 23 17:15:29 2016 -0500

[PATCH] correct handling of non-constant width and precision (pr 78521)

2016-11-27 Thread Martin Sebor
PR 78521 notes that the gimple-ssa-sprintf pass doesn't do the right thing (i.e., the -Wformat-length and -fprintf-return-value options behave incorrectly) when a conversion specification includes a width or precision with a non-constant value. The code treats such cases as if they were not

[PATCH] remove invalid "tail +16c"

2016-11-27 Thread ma . jiang
Hi all, In "config/acx.m4", there are still some "tail +16c" which are invalid on POSIX systems. In my opinion, all "tail +16c" should be changed to "tail -c +16" directly, as most systems has accept the latter. And, to skip first 16 bytes, we should use "tail -c +17" instead of "tail

[Ada] Fix PR ada/78524

2016-11-27 Thread Eric Botcazou
This is the failure of ACATS c41104a introduced by the recent match.pd change. Fixed thusly, tested on x86_64-suse-linux, applied on the mainline. 2016-11-27 Eric Botcazou PR ada/78524 * gcc-interface/utils.c (max_size) : Add missing conversion

Re: [PATCH] Fix a couple of issues in gimple-ssa-sprintf.c

2016-11-27 Thread Jakub Jelinek
On Sat, Nov 26, 2016 at 11:17:09AM -0700, Martin Sebor wrote: > PS As the comment above the build_intmax_type_node function > mentions, its body was copied from lto/lto-lang.c. It would be > useful not to have to duplicate the code in the middle-end and > instead provide a shared definition of

Re: [patch, libfortran] Add AVX-specific matmul

2016-11-27 Thread Jerry DeLisle
On 11/27/2016 08:50 AM, Thomas Koenig wrote: Hello world, here is another, much revised, update of the AVX-specific matmul patch. The processor-specific switching is now done directly, using the --- snip --- This comment not right: +/* Put exhaustive list of possible architectures here

[Ada] Fix PR ada/78531

2016-11-27 Thread Eric Botcazou
This is the bootstrap failure on the mainline with _FORTIFY_SOURCE enabled. Fixed thusly, tested on x86_64-suse-linux, applied on the mainline. 2016-11-27 Eric Botcazou PR ada/78531 * namet.h (Max_Line_Length): Define. (struct Bounded_String):

ping x2: Re: [PATCH] shrink-wrap: New spread_components

2016-11-27 Thread Segher Boessenkool
Ping. On Sat, Nov 19, 2016 at 11:24:34AM -0600, Segher Boessenkool wrote: > Ping. > > On Wed, Nov 09, 2016 at 09:46:55PM +, Segher Boessenkool wrote: > > This patch changes spread_components to use a simpler algorithm that > > puts prologue components as early as possible, and epilogue

Re: [Patch, fortran] PR78474 - gfortran accepts invalid submodule syntax

2016-11-27 Thread Paul Richard Thomas
Hi Steve, Committed as revision 242900 together with a similarly trivial fix for PR78331. I would have submitted the latter separately but found myself timing out before I have to travel. Both will be added to 6-branch in a week's time. Thanks Paul On 27 November 2016 at 19:09, Steve Kargl

Re: [v3 PATCH] Implement LWG 2534, Constrain rvalue stream operators.

2016-11-27 Thread Ville Voutilainen
On 27 November 2016 at 20:50, Ville Voutilainen wrote: > * include/std/ostream /__is_convertible_to_basic_ostream): New. And yeah, I have fixed that typo in my ChangeLog already, it should indeed be * include/std/ostream (__is_convertible_to_basic_ostream):

[v3 PATCH] Implement LWG 2534, Constrain rvalue stream operators.

2016-11-27 Thread Ville Voutilainen
Tested on Linux-x64. 2016-11-27 Ville Voutilainen Implement LWG 2534, Constrain rvalue stream operators. * include/std/istream (__is_convertible_to_basic_istream): New. (__is_extractable): Likewise. (operator>>(basic_istream<_CharT, _Traits>&&,

Re: [Patch, fortran] PR78474 - gfortran accepts invalid submodule syntax

2016-11-27 Thread Steve Kargl
On Sun, Nov 27, 2016 at 06:42:12PM +0100, Paul Richard Thomas wrote: > > This is a rather trivial problem with a similarly trivial fix. The > ChangeLog says it all. > > Before anybody asks, the testcase number jumps by two because I am > going through the submodule PRs in reverse order. > >

[Patch, fortran] PR78474 - gfortran accepts invalid submodule syntax

2016-11-27 Thread Paul Richard Thomas
Dear All, This is a rather trivial problem with a similarly trivial fix. The ChangeLog says it all. Before anybody asks, the testcase number jumps by two because I am going through the submodule PRs in reverse order. Bootstraps and regtests on FC21/x86_64 - OK for trunk and 6-branch? Paul

Re: [Patch][i386] PR 70118: Fix ubsan warning on SSE2 loadl_epi64 and storel_epi64

2016-11-27 Thread Allan Sandfeld Jensen
On Sunday 27 November 2016, Marc Glisse wrote: > On Sat, 26 Nov 2016, Allan Sandfeld Jensen wrote: > > Use the recently introduced unaligned variant of __m128i and add a > > similar __m64 and use those to make it clear these two intrinsics > > require neither 128- bit nor 64-bit alignment. > >

Re: Hurd port for gcc go PATCH 1-4(23)

2016-11-27 Thread Samuel Thibault
Svante Signell, on Sun 27 Nov 2016 18:17:17 +0100, wrote: > On Sun, 2016-11-27 at 18:02 +0100, Samuel Thibault wrote: > > > But as you wish, an updated patch is attached. > > > >  _Bool > >  Continued (uint32_t *w) > >  { > > +#ifndef WCONTINUED > > +  *w = 0; > > +  return 0; > > +#else > >    

Re: Hurd port for gcc go PATCH 1-4(23)

2016-11-27 Thread Svante Signell
On Sun, 2016-11-27 at 18:02 +0100, Samuel Thibault wrote: > Hello, ... > > But as you wish, an updated patch is attached. > >  _Bool >  Continued (uint32_t *w) >  { > +#ifndef WCONTINUED > +  *w = 0; > +  return 0; > +#else >    return WIFCONTINUED (*w) != 0; > +#endif >  } > > Err, recheck the

[wwwdocs] Use "command-line option" (with a dash)

2016-11-27 Thread Gerald Pfeifer
Since I just responded to a recent patch where the dash was missing, I noticed we had a couple of older cases in our web pages as well. Fixed thusly. Gerald Index: gcc-4.6/changes.html === RCS file:

Re: [patch, libfortran] Add AVX-specific matmul

2016-11-27 Thread Thomas Koenig
I wrote: As an added bonus, I added some m4 hacks to disable both AVX and AVX2 code generation for REAL. This should have read "I hadded some m4 hacks to disable the AVX2 code generation for REAL." Regards Thomas

Re: [patch, libfortran] Add AVX-specific matmul

2016-11-27 Thread Thomas Koenig
Hello world, here is another, much revised, update of the AVX-specific matmul patch. The processor-specific switching is now done directly, using the machinery from gcclib. For this, I have moved information from the i386-specific cpuinfo.c file to a new header file cpuinfo.h, which is then

Re: Hurd port for gcc go PATCH 1-4(23)

2016-11-27 Thread Samuel Thibault
Hello, Svante Signell, on Sun 27 Nov 2016 17:33:52 +0100, wrote: > > > Index: gcc-6-6.2.1-4.1/src/libgo/go/syscall/wait.c > > > === > > > --- gcc-6-6.2.1-4.1.orig/src/libgo/go/syscall/wait.c > > > +++

New French PO file for 'gcc' (version 6.2.0)

2016-11-27 Thread Translation Project Robot
Hello, gentle maintainer. This is a message from the Translation Project robot. A revised PO file for textual domain 'gcc' has been submitted by the French team of translators. The file is available at: http://translationproject.org/latest/gcc/fr.po (This file, 'gcc-6.2.0.fr.po', has just

Re: [wwwdocs][PATCH][ARM] Add -mpure-code to changes.html

2016-11-27 Thread Gerald Pfeifer
On Mon, 21 Nov 2016, Andre Vieira (lists) wrote: > I added the description of the new ARM -mpure-code option to changes.html. Just as a note, per https://gcc.gnu.org/codingconventions.html#Spelling we are using "command-line option" (with a dash). I applied the obvious change (below) on top of