[committed] Reinstate dump_generic_expr_loc

2018-07-01 Thread David Malcolm
In r262149 ("Introduce dump_location_t", aka c309657f69df19eaa590b6650acf4d3bea9ac9e6), I removed dump_generic_expr_loc from dumpfile.h/c as it was unused in the source tree. It looks like this was overzealous of me, as Richard wants to use it in "Re: [14/n] PR85694: Rework overwidening

[PATCH, aarch64 4/4] aarch64: Add movprfx patterns for zero and unmatched select

2018-07-01 Thread Richard Henderson
* config/aarch64/aarch64-protos.h, config/aarch64/aarch64.c (aarch64_sve_prepare_conditional_op): Remove. * config/aarch64/aarch64-sve.md (cond_): Allow aarch64_simd_reg_or_zero as select operand; remove the aarch64_sve_prepare_conditional_op call.

[PATCH, aarch64 3/4] aarch64: Add movprfx alternatives for predicate patterns

2018-07-01 Thread Richard Henderson
* config/aarch64/iterators.md (SVE_INT_BINARY_REV): Remove. (SVE_COND_FP_BINARY_REV): Remove. (sve_int_op_rev, sve_fp_op_rev): New. * config/aarch64/aarch64-sve.md (*cond__0): New. (*cond__0): New. (*cond__0): New. (*cond__2): Rename, add

[PATCH, aarch64 1/4] aarch64: Add movprfx alternatives for unpredicated patterns

2018-07-01 Thread Richard Henderson
* config/aarch64/aarch64.md (movprfx): New attr. (length): Default movprfx to 8. * config/aarch64/aarch64-sve.md (*mul3): Add movprfx alt. (*madd, *msubmul3_highpart): Likewise. (*3): Likewise. (*v3): Likewise. (*3): Likewise. (*3):

[PATCH, aarch64 0/4] Add movprfx patterns and alternatives

2018-07-01 Thread Richard Henderson
These don't fire very often, but at least a few times within the testsuite. Enough to test my qemu implementation of the insns. r~ Richard Henderson (4): aarch64: Add movprfx alternatives for unpredicated patterns aarch64: Remove predicate from inside SVE_COND_FP_BINARY aarch64: Add

[PATCH, aarch64 2/4] aarch64: Remove predicate from inside SVE_COND_FP_BINARY

2018-07-01 Thread Richard Henderson
The predicate is present within the containing UNSPEC_SEL; there is no need to duplicate it. * config/aarch64/aarch64-sve.md (cond_): Remove match_dup 1 from the inner unspec. (*cond_): Likewise. --- gcc/config/aarch64/aarch64-sve.md | 9 +++-- 1 file changed, 3

Re: [PATCH 3/3][POPCOUNT] Remove unnecessary if condition in phiopt

2018-07-01 Thread Kugan Vivekanandarajah
Hi Richard, On 29 June 2018 at 18:45, Richard Biener wrote: > On Wed, Jun 27, 2018 at 7:09 AM Kugan Vivekanandarajah > wrote: >> >> Hi Richard, >> >> Thanks for the review, >> >> On 25 June 2018 at 20:20, Richard Biener wrote: >> > On Fri, Jun 22, 2018 at 11:16 AM Kugan Vivekanandarajah >> >

[testsuite/guality, committed] Use @main as bp loc instead of line nrs in const-volatile.c

2018-07-01 Thread Tom de Vries
Hi, this patch replaces the absolute line numbers used in gdb-test in guality testcase const-volatile.c. First there's line number 50, which used to point at the start of main: ... 47 int 48 main (int argc, char **argv) 49 { 50score as = argc; ... but has drifted in time

Re: [testsuite/guality, committed] Prevent optimization of local in vla-1.c

2018-07-01 Thread Tom de Vries
On 07/01/2018 09:11 PM, Jakub Jelinek wrote: > On Sun, Jul 01, 2018 at 06:19:20PM +0200, Tom de Vries wrote: >> So, the local vla a is optimized away. >> >> This patch adds VOLATILE to 'a', which prevents it from being optimized away, >> and fixes the non-lto failures. >> >> Committed as obvious.

Re: Limit Debug mode impact: overload __niter_base

2018-07-01 Thread François Dumont
    Here is a new proposal between yours and mine.     It is still adding a function to wrap what __niter_base unwrap, I called it __nwrap_iter for this reason. But it takes advantage of knowing that __niter_base will only unwrap random access iterator to use an expression to that will do the

[PATCH, committed] Add -mgnu-asm to pdp11 target, change -mdec-asm

2018-07-01 Thread Paul Koning
The pdp11 target has long had -mdec-asm which was documented to generate DEC compatible assembly language output but actually produces GNU assembler output. This patch adds -mgnu-asm to do what -mdec-asm used to do, and -mdec-asm now does produces output acceptable to DEC Macro-11. Committed.

Re: [testsuite/guality, committed] Prevent optimization of local in vla-1.c

2018-07-01 Thread Jakub Jelinek
On Sun, Jul 01, 2018 at 06:19:20PM +0200, Tom de Vries wrote: > So, the local vla a is optimized away. > > This patch adds VOLATILE to 'a', which prevents it from being optimized away, > and fixes the non-lto failures. > > Committed as obvious. That isn't obvious, it is just wrong. The intent

[testsuite/guality, committed] Prevent optimization of local in vla-1.c

2018-07-01 Thread Tom de Vries
Hi, Atm vla-1.c has the following failures: ... FAIL: gcc.dg/guality/vla-1.c -O1 -DPREVENT_OPTIMIZATION line 17 sizeof (a) == 6 FAIL: gcc.dg/guality/vla-1.c -O2 -DPREVENT_OPTIMIZATION line 17 sizeof (a) == 6 FAIL: gcc.dg/guality/vla-1.c -O3 -g -DPREVENT_OPTIMIZATION line 17 sizeof

[testsuite/guality, committed] Use relative line numbers in vla-1.c

2018-07-01 Thread Tom de Vries
Hi, this patch replaces absolute with relative line numbers in guality/vla-1.c. The test-case has a line: ... $ cat -n gcc/testsuite/gcc.dg/guality/vla-1.c 17return a[0]; /* { dg-final { gdb-test 17 "sizeof (a)" "6" } } */ ... which corresponds to relative line number '.'.

[testsuite, committed] Fix get-absolute-line error handling

2018-07-01 Thread Tom de Vries
Hi, in factoring out get-absolute-line, I made a typo in a variable name used in an error message, which causes a tcl ERROR when the error condition is triggered. Fixed by this patch. This tcl ERROR didn't show up unless the error message was triggered by an error condition, which normally

Re: [patch] jump threading multiple paths that start from the same BB

2018-07-01 Thread Aldy Hernandez
On 06/29/2018 02:50 PM, Jeff Law wrote: [ Returning to another old patch... ] On 11/07/2017 10:33 AM, Aldy Hernandez wrote: [One more time, but without rejected HTML mail, because apparently this is my first post to gcc-patches *ever* ;-)]. Howdy! While poking around in the backwards

abstract ABS_EXPR code for ranges into separate function

2018-07-01 Thread Aldy Hernandez
Boy those extract_range_from_*_expr functions are huge. OK to move the ABS_EXPR code into its own function? Tested on x86-64 Linux. Aldy commit 1e0dd52b909722e9387a34ef546fc308c68dac23 Author: Aldy Hernandez Date: Fri Jun 29 20:12:36 2018 +0200 * tree-vrp.c