Re: [Patch, fortran] PR90903 - Implement runtime checks for bit manipulation intrinsics

2019-07-15 Thread Paul Richard Thomas
Hi Harald and Steve, The patch looks fine to me - it's good be committed. Thanks Paul On Mon, 15 Jul 2019 at 03:34, Steve Kargl wrote: > > Harald, thanks for the patch. I'm that the best person > for reading the trans-* file, but your patch and changes > look good to me. If no one else

RE: Remove array_index inliner hint

2019-07-15 Thread JiangNing OS
Hi Honza, It seems this commit caused gcc bootstrap failure on aarch64 as below, Comparing stages 2 and 3 warning: gcc/cc1obj-checksum.o differs Bootstrap comparison failure! gcc/dwarf2out.o differs gcc/var-tracking.o differs gcc/aarch64.o differs make[2]: *** [compare] Error 1 Do you know the

libgo patch committed: Expose the g variable

2019-07-15 Thread Ian Lance Taylor
This libgo patch by Cherry Zhang expose the thread-local g variable. Currently, getg is implemented in C, which loads the thread-local g variable. The g variable is declared static in C. This CL exposes the g variable, so it can be accessed from the Go side. This allows the Go compiler to inline

[PATCH] rs6000: Always output .machine

2019-07-15 Thread Segher Boessenkool
We now can always output .machine (if we output it at all for the current target). Committing to trunk. Segher 2019-07-15 Segher Boessenkool PR target/91050 * config/rs6000/rs6000.c (rs6000_file_start): Never skip emitting a .machine directive. ---

[PATCH, i386]: Cleanup TEST insn patterns

2019-07-15 Thread Uros Bizjak
Attached patch cleans TEST insn patterns by removing unneeded alternatives from *testdi_1 (these were cargo-culted from *testsi_1, where they are used to describe pentium pairing, but pentium is not a 64bit target). The patch also removes manual definition of modrm attribute. This attribute is

Ping: [PATCH] RISC-V: Add -malign-data= option.

2019-07-15 Thread Ilia Diachkov
Hello, There are two weeks gone since the end of the patch discussion but no one has neither objected nor approved it. Please take a look to it and approve. Also please commit it since I have no write access. The updated version of the patch was attached to my message

Re: Rewrite some jump.c routines to use flags

2019-07-15 Thread Eric Botcazou
> gcc/ > * jump.c (FLAGS_EQ, FLAGS_LT, FLAGS_GT, FLAGS_UNORDERED, FLAGS_ORDER) > (FLAGS_SIGNED, FLAGS_UNSIGNED, FLAGS_SIGN_AGNOSTIC, FLAGS_SIGNEDNESS) > (FLAGS_TRAP_QNANS, FLAGS_TRAP_SNANS, FLAGS_TRAP_NANS, FLAGS_TRAP_NONE) > (FLAGS_TRAPS): New constants. >

Re: Ping: [06/11] [mips] Fix ambiguous .md attribute uses

2019-07-15 Thread Jim Wilson
On 7/12/19 1:16 AM, Richard Sandiford wrote: Ping. I think this is the only one of the series left. 2019-07-05 Richard Sandiford gcc/ * config/mips/micromips.md (*movep): Explicitly use for the mode attribute. OK. Jim

[PATCH 1/2] Add user-defined clock to libstdc++ condition_variable tests

2019-07-15 Thread Mike Crowe
libstdc++-v3/ * testsuite/30_threads/condition_variable/members/2.cc (test01): Parameterise so that test can be run against an arbitrary clock. (main): Test using std::chrono::steady_clock and a user-defined clock in addition to the previous

[PATCH 0/2] PR libstdc++/41861 Add full steady_clock support to condition_variable

2019-07-15 Thread Mike Crowe
The pthread_cond_clockwait function was recently added[1] to glibc, and is due to be released in glibc 2.30. If this function is available in the C library it can be used it to fix https://gcc.gnu.org/bugzilla/show_bug.cgi?id=41861 by supporting std::chrono::steady_clock properly with

[PATCH 2/2] PR libstdc++/41861 Add full steady_clock support to condition_variable

2019-07-15 Thread Mike Crowe
The pthread_cond_clockwait function was recently added[1] to glibc, and is due to be released in glibc 2.30. If this function is available in the C library it can be used it to fix https://gcc.gnu.org/bugzilla/show_bug.cgi?id=41861 by supporting std::chrono::steady_clock properly with

Re: Implement more rtx vector folds on variable-length vectors

2019-07-15 Thread Richard Sandiford
Richard Sandiford writes: > This patch extends the tree-level folding of variable-length vectors > so that it can also be used on rtxes. The first step is to move > the tree_vector_builder new_unary/binary_operator routines to the > parent vector_builder class (which in turn means adding a new >

Re: Rewrite some jump.c routines to use flags

2019-07-15 Thread Richard Sandiford
Eric Botcazou writes: >> AIUI, neither ORDERED nor UNEQ trap on signalling NaNs. Without this, >> the follow-on patch would fold >> >>(and (ordered x y) (uneq x y)) -> (eq x y) >> >> which is the same thing for quiet NaNs but not for signalling NaNs. > > Note that GCC defaults to

Re: [PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Segher Boessenkool
On Mon, Jul 15, 2019 at 04:41:28PM +0200, Martin Liška wrote: > On 7/15/19 4:31 PM, Segher Boessenkool wrote: > > On Mon, Jul 15, 2019 at 04:23:18PM +0200, Martin Liška wrote: > >> On 7/15/19 4:17 PM, Segher Boessenkool wrote: > >>> Is that enough? Can there be two entries with the same count as

Re: Check rrotate optab first when transforming lrotate

2019-07-15 Thread Segher Boessenkool
On Mon, Jul 15, 2019 at 10:59:29AM +0200, Jakub Jelinek wrote: > On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote: > > In match.pd and expmed.c, we have some codes to transform lrotate to > > rrotate if rotation count is const. But they don't consider the target > > whether supports the

Re: [PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Martin Liška
On 7/15/19 4:31 PM, Segher Boessenkool wrote: > On Mon, Jul 15, 2019 at 04:23:18PM +0200, Martin Liška wrote: >> On 7/15/19 4:17 PM, Segher Boessenkool wrote: >>> Is that enough? Can there be two entries with the same count as well >>> as value? >> >> Yes, it can happen very unlikely in a

Re: [PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Segher Boessenkool
On Mon, Jul 15, 2019 at 04:23:18PM +0200, Martin Liška wrote: > On 7/15/19 4:17 PM, Segher Boessenkool wrote: > > Is that enough? Can there be two entries with the same count as well > > as value? > > Yes, it can happen very unlikely in a multi-threaded instrumentation, > but it will not make a

Re: [PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Martin Liška
On 7/15/19 4:17 PM, Segher Boessenkool wrote: > Is that enough? Can there be two entries with the same count as well > as value? Yes, it can happen very unlikely in a multi-threaded instrumentation, but it will not make a problem. Martin

Re: [PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Segher Boessenkool
On Mon, Jul 15, 2019 at 11:20:34AM +0200, Martin Liška wrote: > On 7/15/19 10:20 AM, Xiong Hu Luo wrote: > > -/* Return most common value of TOPN_VALUE histogram. If > > - there's a unique value, return true and set VALUE and COUNT > > +struct value_count_t { > > + gcov_type value; > > +

Re: [C++ PATCH] PR c++/90590 Suppress warning for enumeration value not handled in switch warning

2019-07-15 Thread Matthew Beliveau
Okay I kept the TYPE_MAIN_VARIANT and dropped the accidental new line! Hopefully this should be fine! On Fri, Jul 12, 2019 at 6:49 PM Marek Polacek wrote: > > On Fri, Jul 12, 2019 at 02:38:59PM -0400, Marek Polacek wrote: > > On Fri, Jul 12, 2019 at 02:34:37PM -0400, Matthew Beliveau wrote: > >

[PATCH] Do not emit __gnu_lto_v1 symbol.

2019-07-15 Thread Martin Liška
Hi. The patch is about removal of the emission of __gnu_lto_v1. The symbol should not be needed any longer for GCC driver. Patch can bootstrap on x86_64-linux-gnu and survives regression tests. Ready to be installed? Thanks, Martin gcc/ChangeLog: 2019-07-15 Martin Liska *

[PATCH] Fix PR91162

2019-07-15 Thread Richard Biener
Bootstrapped / tested on x86_64-unknown-linux-gnu, applied. Richard. 2019-07-15 Richard Biener PR middle-end/91162 * tree-cfg.c (move_block_to_fn): When releasing a virtual PHI node make sure to replace all uses with something valid. *

Re: [PATCH] Use -flto instead of -flto=N in DWARF producer string.

2019-07-15 Thread Martin Liška
On 7/10/19 1:16 PM, Martin Liška wrote: > On 7/10/19 1:15 PM, Jakub Jelinek wrote: >> On Wed, Jul 10, 2019 at 01:08:52PM +0200, Martin Liška wrote: >>> --- a/gcc/dwarf2out.c >>> +++ b/gcc/dwarf2out.c >>> @@ -24460,6 +24460,13 @@ gen_producer_string (void) >>>case OPT_fchecking_: >>> /*

[COMMITTED][GCC8] Backport PR85711

2019-07-15 Thread Wilco Dijkstra
Backport PR85711 to GCC8 to fix failing testcases. AArch64 bootstrap & regtest OK. 2019-01-23 Bin Cheng Steve Ellcey PR target/85711 * recog.c (address_operand): Return false on wrong mode for address. (constrain_operands): Check for mode with 'p'

Re: [RFC][tree-vect]PR 88915: Further vectorize second loop when versioning

2019-07-15 Thread Richard Biener
On Mon, 15 Jul 2019, Andre Vieira (lists) wrote: > > > On 12/07/2019 11:19, Richard Biener wrote: > > On Thu, 11 Jul 2019, Andre Vieira (lists) wrote: > > > > > > I think for code-size reason it would make sense to do it like > > > >if (iterations_check_for_lowest_VF ()) > > { > >

Re: Check rrotate optab first when transforming lrotate

2019-07-15 Thread Kewen.Lin
Hi Jakub, on 2019/7/15 下午4:59, Jakub Jelinek wrote: > On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote: >> In match.pd and expmed.c, we have some codes to transform lrotate to >> rrotate if rotation count is const. But they don't consider the target >> whether supports the rrotate. It

Re: [RFC][tree-vect]PR 88915: Further vectorize second loop when versioning

2019-07-15 Thread Andre Vieira (lists)
On 12/07/2019 11:19, Richard Biener wrote: On Thu, 11 Jul 2019, Andre Vieira (lists) wrote: I think for code-size reason it would make sense to do it like if (iterations_check_for_lowest_VF ()) { if (alias_check_for_highest_VF ()) {

Re: [PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Martin Liška
On 7/15/19 10:20 AM, Xiong Hu Luo wrote: > Currently get_most_common_single_value could only return the max hist > , add qsort to enable this function return kth value. > Rename it to get_kth_value_count. > > gcc/ChangeLog: > > 2019-07-15 Xiong Hu Luo > > * ipa-profile.c

Re: Check rrotate optab first when transforming lrotate

2019-07-15 Thread Richard Sandiford
Jakub Jelinek writes: > On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote: >> In match.pd and expmed.c, we have some codes to transform lrotate to >> rrotate if rotation count is const. But they don't consider the target >> whether supports the rrotate. It leads to some suboptimal

Re: Check rrotate optab first when transforming lrotate

2019-07-15 Thread Richard Biener
On Mon, Jul 15, 2019 at 10:59 AM Jakub Jelinek wrote: > > On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote: > > In match.pd and expmed.c, we have some codes to transform lrotate to > > rrotate if rotation count is const. But they don't consider the target > > whether supports the

Re: Check rrotate optab first when transforming lrotate

2019-07-15 Thread Jakub Jelinek
On Mon, Jul 15, 2019 at 04:50:13PM +0800, Kewen.Lin wrote: > In match.pd and expmed.c, we have some codes to transform lrotate to > rrotate if rotation count is const. But they don't consider the target > whether supports the rrotate. It leads to some suboptimal generated > code since some

Check rrotate optab first when transforming lrotate

2019-07-15 Thread Kewen.Lin
Hi all, In match.pd and expmed.c, we have some codes to transform lrotate to rrotate if rotation count is const. But they don't consider the target whether supports the rrotate. It leads to some suboptimal generated code since some optimization can't get expected result by querying target

[PATCH v2] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Xiong Hu Luo
Currently get_most_common_single_value could only return the max hist , add qsort to enable this function return kth value. Rename it to get_kth_value_count. gcc/ChangeLog: 2019-07-15 Xiong Hu Luo * ipa-profile.c (get_most_common_single_value): Use

Re: [PATCH v2] Missed function specialization + partial devirtualization

2019-07-15 Thread Martin Liška
On 7/12/19 10:51 AM, Xiong Hu Luo wrote: > 2. Remove duplicate logic in ipa-profile. As > get_most_common_single_value could only return single value, but this > multiple indirect call needs store each hist value, will > consider specialize it later. Hi. I would like to see this patch

Re: [PATCH] Generalize get_most_common_single_value to return k_th value & count

2019-07-15 Thread Martin Liška
On 7/15/19 4:42 AM, Xiong Hu Luo wrote: > Currently get_most_common_single_value could only return the max hist > , add two paramter to enable this function return kth > value if needed. > > gcc/ChangeLog: > > 2019-07-15 Xiong Hu Luo > > * value-prof.c

Re: [PING^1][PATCH v4 3/3] PR80791 Consider doloop cmp use in ivopts

2019-07-15 Thread Bin.Cheng
On Fri, Jul 12, 2019 at 8:11 PM Richard Biener wrote: > > On Wed, 10 Jul 2019, Kewen.Lin wrote: > > > Hi all, > > > > I'd like to gentle ping the below patch: > > https://gcc.gnu.org/ml/gcc-patches/2019-06/msg01225.html > > > > The previous version for more context/background: > >