Re: [PATCH][ARM] Enable code hoisting with -Os (PR80155)

2019-09-14 Thread Prathamesh Kulkarni
On Wed, 11 Sep 2019 at 11:50, Wilco Dijkstra wrote: > > While code hoisting generally improves codesize, it can affect performance > negatively. Benchmarking shows it doesn't help SPEC and negatively affects > embedded benchmarks, so only enable code hoisting with -Os on Arm. > > Bootstrap OK,

Re: [PATCH, AArch64, v3 0/6] LSE atomics out-of-line

2019-09-14 Thread Richard Henderson
On 9/5/19 10:35 AM, Wilco Dijkstra wrote: > Agreed. I've got a couple of general comments: > > * The option name -matomic-ool sounds too abbreviated. I think eg. > -moutline-atomics is more descriptive and user friendlier. Changed. > * Similarly the exported __aa64_have_atomics variable could

[testsuite, obvious] Remove explicit "dg-do run" from g++.dg/vect/pr87914.cc

2019-09-14 Thread Sandra Loosemore
I found another instance of PR testsuite/83889 in the g++ testsuite. I've committed the attached patch to fix it in the same way as all the others. -Sandra 2019-09-14 Sandra Loosemore PR testsuite/83889 gcc/testsuite/ * g++.dg/vect/pr87914.cc: Remove explicit dg-do run. Index:

Re: [PATCH V3] Generalized predicate/condition for parameter reference in IPA (PR ipa/91088)

2019-09-14 Thread Jan Hubicka
> +/* Analyze EXPR if it represents a series of simple operations performed on > + a function parameter and return true if so. FBI, STMT, EXPR, INDEX_P and > + AGGPOS have the same meaning like in unmodified_parm_or_parm_agg_item. > + Type of the parameter or load from an aggregate via the

Re: [PATCH V2] Setup predicate for switch default case in IPA (PR ipa/91089)

2019-09-14 Thread Jan Hubicka
> It is somewhat hard to write a testcase to show role of range info only with > this patch. If another patch "Generalized predicate/condition for parameter > reference in IPA (PR ipa/91088)" is accepted, it will become easy and I will > update this testcase to show that. > > And this new version

Re: [patch, fortran] Improve error messages for mismatched arguments

2019-09-14 Thread Steve Kargl
On Sat, Sep 14, 2019 at 02:27:15PM +0200, Thomas Koenig wrote: > > the attached patch improves the rather hard to read error > messages for argument mismatches. With this patch, this reads > > argument_checking_21.f90:7:11: > > 6 | call foo(1.0) ! { dg-warning "Rank mismatch" } >

[PR target/85401] initialize the move cost table before using it

2019-09-14 Thread coypu
This seems to be the way the rest of ira-color.c does it. I hope it's OK. It does fix the segfault. 2019-09-10 Maya Rashish PR target/85401 * ira-color.c: (allocno_copy_cost_saving) Call ira_init_register_move_cost_if_necessary diff --git a/gcc/ira-color.c

[patch, fortran] Improve error messages for mismatched arguments

2019-09-14 Thread Thomas Koenig
Hello world, the attached patch improves the rather hard to read error messages for argument mismatches. With this patch, this reads argument_checking_21.f90:7:11: 6 | call foo(1.0) ! { dg-warning "Rank mismatch" } | 2 7 | call foo(b) ! { dg-warning "Rank

[patch,committed][og9][openacc-gcc-9-branch] Fix segfault with plugin-gcn under libgomp

2019-09-14 Thread Tobias Burnus
Hi all, exactly the same as for plugin-hsa on the trunk: https://gcc.gnu.org/ml/gcc-patches/2019-09/msg00718.html Only a different file (which is only in this branch). Tobias commit 392044a8db285d9aea0a280983ce7c5014a4e99c Author: Tobias Burnus Date: Thu Sep 12 18:07:53 2019 +0200

Re: [PATCH v6 3/3] PR80791 Consider doloop cmp use in ivopts

2019-09-14 Thread Kewen.Lin
on 2019/9/12 下午4:14, Richard Biener wrote: > On Wed, 11 Sep 2019, Kewen.Lin wrote: > >> Hi, >> >> Sorry for the late update. I've updated the words of target hooks part. >> >> Could someone help to review it? Thanks in advance! >> >> By the way, as previous emails in this thread, Bin has