Re: [PATCH v6] RISC-V:Optimize the MASK opt generation

2023-10-01 Thread Jan-Benedict Glaw
On Mon, 2023-10-02 10:55:25 +0800, Kito Cheng wrote: > Hi Gerald: > > Thanks for reporting this issue, I just realized multidimensional > arrays are gawk extensions, could you try the attached patch to see if > it can resolve the issue? With your new patch, it works for me again using `mawk`

Re: Improve -Wflex-array-member-not-at-end changes.html wording |Plus: and warning bug? (was: [V2][PATCH] gcc-14/changes.html: Deprecate a GCC C extension on flexible array members.)

2023-10-01 Thread Qing Zhao
Hi, Tobias, Sorry for the late reply. I has been on vacation after Cauldron, and will be back to work in the mid of Oct. will look at this issue at that time. Qing > On Sep 25, 2023, at 2:24 PM, Tobias Burnus wrote: > > Hi all, > > I stumbled over this as I found the wording in the release

Re: [PATCH v6] RISC-V:Optimize the MASK opt generation

2023-10-01 Thread Kito Cheng
Hi Gerald: Thanks for reporting this issue, I just realized multidimensional arrays are gawk extensions, could you try the attached patch to see if it can resolve the issue? On Mon, Oct 2, 2023 at 4:56 AM Gerald Pfeifer wrote: > > On Sun, 1 Oct 2023, Kito Cheng wrote: > > Committed to trunk,

[RISC-V]: Re: cpymem for RISCV with v extension

2023-10-01 Thread Joern Rennecke
On Tue, 15 Aug 2023 at 15:06, Jeff Law wrote: > > On 8/15/23 03:16, juzhe.zh...@rivai.ai wrote: > > The new patch looks reasonable to me now. Thanks for fixing it. > > > > Could you append testcase after finishing test infrastructure ? > > I prefer this patch with testcase after infrastructure.

[PATCH] C/C++: add hints for strerror

2023-10-01 Thread Oskari Pirhonen
Add proper hints for implicit declaration of strerror. The results could be confusing depending on the other included headers. These example messages are from compiling a trivial program to print the string for an errno value. It only includes stdio.h (cstdio for C++). Before: $

Committed: Fix typo in add_options_for_riscv_v, add_options_for_riscv_zfh, add_options_for_riscv_d .

2023-10-01 Thread Joern Rennecke
Committed as obvious (RE doesn't compile without patch, and I know what I meant when I wrote it). commit 5f3da480e7541a9c29d655dccb2463fc5f3cf2c4 Author: Joern Rennecke Date: Sun Oct 1 22:46:43 2023 +0100 Fix typo in add_options_for_riscv_v, add_options_for_riscv_zfh,

Re: [PATCH v6] RISC-V:Optimize the MASK opt generation

2023-10-01 Thread Gerald Pfeifer
On Sun, 1 Oct 2023, Kito Cheng wrote: > Committed to trunk, thanks Feng :) Hmm, my nightly FreeBSD 12 tester now fails as follows: nawk -f /scratch/tmp/gerald/GCC-HEAD/gcc/opt-functions.awk \ -f /scratch/tmp/gerald/GCC-HEAD/gcc/opt-read.awk \ -f

[COMMITTED/13] Fix PR 111331: wrong code for `a > 28 ? MIN : 29`

2023-10-01 Thread Andrew Pinski
From: Andrew Pinski The problem here is after r6-7425-ga9fee7cdc3c62d0e51730, the comparison to see if the transformation could be done was using the wrong value. Instead of see if the inner was LE (for MIN and GE for MAX) the outer value, it was comparing the inner to the value used in the

[WIP 2/4] OpenMP: Language-independent parts of loop transform support.

2023-10-01 Thread Sandra Loosemore
From: Frederik Harwath This patch adds support for the OMP_LOOP_TRANS tree node, internal OpenMP clauses representing loop transformations, and the omp_transform_loops pass to lower them. gcc/ChangeLog: * Makefile.in (OBJS): Add omp-transform-loops.o. * gimple-pretty-print.cc

[WIP 0/4] OpenMP: support for loop transformations

2023-10-01 Thread Sandra Loosemore
This series of patches is an update of Frederik's previous loop transformation patch set, previously posted here: https://gcc.gnu.org/pipermail/gcc-patches/2023-March/614564.html that has been updated to resolve conflicts with my set of imperfectly-nested loops patches and other changes on

[WIP 1/4] openacc: Rename OMP_CLAUSE_TILE to OMP_CLAUSE_OACC_TILE

2023-10-01 Thread Sandra Loosemore
From: Frederik Harwath OMP_CLAUSE_TILE will be used for the OpenMP 5.1 loop transformation construct "omp tile". gcc/ChangeLog: * tree-core.h (enum omp_clause_code): Rename OMP_CLAUSE_TILE. * tree.h (OMP_CLAUSE_TILE_LIST): Rename to ... (OMP_CLAUSE_OACC_TILE_LIST): ...

Re: [Fortran, Patch, Coarray, PR 37336] Fix crash in finalizer when derived type coarray is already freed.

2023-10-01 Thread Paul Richard Thomas
Hi Andre, All is well that ends well! Thanks for working on this. Regards Paul On Sat, 30 Sept 2023 at 14:16, Andre Vehreschild wrote: > > Hi all, > > back porting to gcc-13 unfortunately caused a regression due to > gfc_deallocate_with_status() having a different parameter count. This is

[PATCH v2] ipa-utils: avoid uninitialized probabilities on ICF [PR111559]

2023-10-01 Thread Sergei Trofimovich
From: Sergei Trofimovich r14-3459-g0c78240fd7d519 "Check that passes do not forget to define profile" exposed check failures in cases when gcc produces uninitialized profile probabilities. In case of PR/111559 uninitialized profile is generated by edges executed 0 times reported by IPA profile:

[COMMITTED/13] Fix PR 110386: backprop vs ABSU_EXPR

2023-10-01 Thread Andrew Pinski
From: Andrew Pinski The issue here is that when backprop tries to go and strip sign ops, it skips over ABSU_EXPR but ABSU_EXPR not only does an ABS, it also changes the type to unsigned. Since strip_sign_op_1 is only supposed to strip off sign changing operands and not ones that change types,

[PATCH v5] C, ObjC: Add -Wunterminated-string-initialization

2023-10-01 Thread Alejandro Colomar
Warn about the following: char s[3] = "foo"; Initializing a char array with a string literal of the same length as the size of the array is usually a mistake. Rarely is the case where one wants to create a non-terminated character sequence from a string literal. In some cases, for writing

Re: [PATCH] rtl-optimization/110939 Really fix narrow comparison of memory and constant

2023-10-01 Thread Jeff Law
On 10/1/23 08:26, Stefan Schulze Frielinghaus wrote: FWIW, I should definitely have caught this hunk earlier -- we've gone the rounds in this same space (GEN_INT vs gen_int_mode) elsewhere. Again, sorry for the long wait. jeff No worries at all. At least I have learned something new :)

RE: [ARC PATCH] Use rlc r0, 0 to implement scc_ltu (i.e. carry_flag ? 1 : 0)

2023-10-01 Thread Claudiu Zissulescu
I'll add it to our nightly. Just to be sure  I’ll let you know asap it's status. Roger, you can always use Synopsys free nsim simulator which you can find it on Synopsys website. Thanks, Claudiu -Original Message- From: Jeff Law Sent: Saturday, September 30, 2023 1:02 AM To: Roger

Re: [PATCH] rtl-optimization/110939 Really fix narrow comparison of memory and constant

2023-10-01 Thread Stefan Schulze Frielinghaus
On Fri, Sep 29, 2023 at 01:01:57PM -0600, Jeff Law wrote: > > > On 8/10/23 07:04, Stefan Schulze Frielinghaus via Gcc-patches wrote: > > In the former fix in commit 41ef5a34161356817807be3a2e51fbdbe575ae85 I > > completely missed the fact that the normal form of a generated constant for > > a >

[PATCH v4] C, ObjC: Add -Wunterminated-string-initialization

2023-10-01 Thread Alejandro Colomar
Warn about the following: char s[3] = "foo"; Initializing a char array with a string literal of the same length as the size of the array is usually a mistake. Rarely is the case where one wants to create a non-terminated character sequence from a string literal. In some cases, for writing

[PATCH v3] C, ObjC: Add -Wunterminated-string-initialization

2023-10-01 Thread Alejandro Colomar
From: Alejandro Colomar Warn about the following: char s[3] = "foo"; Initializing a char array with a string literal of the same length as the size of the array is usually a mistake. Rarely is the case where one wants to create a non-terminated character sequence from a string literal.

Re: [PATCH v2] C, ObjC: Add -Wunterminated-string-initialization

2023-10-01 Thread Alejandro Colomar
On Sun, Oct 01, 2023 at 09:37:59AM +0200, Martin Uecker wrote: > > (I shortened the recipient list) > > Am Sonntag, dem 01.10.2023 um 02:55 +0200 schrieb Alejandro Colomar: > > > > > ... > > I ran the tests, and get some unexpected failure. I used dg-warning, > > but maybe I used it wrong?

Re: [PATCH v6] RISC-V:Optimize the MASK opt generation

2023-10-01 Thread Kito Cheng
Committed to trunk, thanks Feng :) On Sat, Sep 30, 2023 at 3:34 AM Jeff Law wrote: > > > > On 9/12/23 03:18, Feng Wang wrote: > > New patch add some comments and update docs for this new usage. > > --- > > Accoring to Kito's advice, using "MASK(name) Var(other_flag_name)" > > to generate MASK

Re: [PATCH v2] C, ObjC: Add -Wunterminated-string-initialization

2023-10-01 Thread Martin Uecker
(I shortened the recipient list) Am Sonntag, dem 01.10.2023 um 02:55 +0200 schrieb Alejandro Colomar: > > ... > I ran the tests, and get some unexpected failure. I used dg-warning, > but maybe I used it wrong? Here's the output: > > ``` > output is: >