Re: [PATCH] PR target/112886, Add %S to print_operand for vector pair support

2024-01-11 Thread Michael Meissner
On Tue, Jan 09, 2024 at 04:35:22PM -0600, Peter Bergner wrote: > ...and this is really ugly and hard to read/understand. Can't we use > register variables to make it simpler? Something like the following > which tests having both FPR and Altivec reg numbers assigned? > > ... > void > test

Re: [PATCH] PR target/112886, Add %S to print_operand for vector pair support

2024-01-10 Thread Kewen.Lin
Hi Mike, on 2024/1/6 06:18, Michael Meissner wrote: > In looking at support for load vector pair and store vector pair for the > PowerPC in GCC, I noticed that we were missing a print_operand output modifier > if you are dealing with vector pairs to print the 2nd register in the vector > pair. >

Re: [PATCH] PR target/112886, Add %S to print_operand for vector pair support

2024-01-10 Thread Michael Meissner
On Tue, Jan 09, 2024 at 04:35:22PM -0600, Peter Bergner wrote: > On 1/5/24 4:18 PM, Michael Meissner wrote: > > @@ -14504,13 +14504,17 @@ print_operand (FILE *file, rtx x, int code) > > print_operand (file, x, 0); > >return; > > > > +case 'S': > > case 'x': > > - /* X

Re: [PATCH] PR target/112886, Add %S to print_operand for vector pair support

2024-01-09 Thread Peter Bergner
On 1/5/24 4:18 PM, Michael Meissner wrote: > @@ -14504,13 +14504,17 @@ print_operand (FILE *file, rtx x, int code) > print_operand (file, x, 0); >return; > > +case 'S': > case 'x': > - /* X is a FPR or Altivec register used in a VSX context. */ > + /* X is a FPR

[PATCH] PR target/112886, Add %S to print_operand for vector pair support

2024-01-05 Thread Michael Meissner
In looking at support for load vector pair and store vector pair for the PowerPC in GCC, I noticed that we were missing a print_operand output modifier if you are dealing with vector pairs to print the 2nd register in the vector pair. If the instruction inside of the asm used the Altivec