Re: [PATCH] system.h: rename vec_step to workaround powerpc/clang bug [PR114369]

2024-03-19 Thread Richard Biener
On Tue, 19 Mar 2024, Jakub Jelinek wrote: > On Tue, Mar 19, 2024 at 12:54:47PM +0100, Richard Biener wrote: > > Works for me, but would > > > > #undef vec_step > > > > work or is it really a keyword in the clang side? > > No, it is really keyword. > #undef vec_step > int > main () > { > int

Re: [PATCH] system.h: rename vec_step to workaround powerpc/clang bug [PR114369]

2024-03-19 Thread Jakub Jelinek
On Tue, Mar 19, 2024 at 12:54:47PM +0100, Richard Biener wrote: > Works for me, but would > > #undef vec_step > > work or is it really a keyword in the clang side? No, it is really keyword. #undef vec_step int main () { int vec_step = 0; return vec_step; } clang --target=powerpc64le-linux -o

Re: [PATCH] system.h: rename vec_step to workaround powerpc/clang bug [PR114369]

2024-03-19 Thread Richard Biener
On Tue, 19 Mar 2024, Jakub Jelinek wrote: > On Sat, Jul 20, 2019 at 05:26:57PM +0100, Richard Sandiford wrote: > > Gerald Pfeifer writes: > > > I have seen an increasing number of reports of GCC failing to > > > build with clang on powerpc (on FreeBSD, though that's probably > > > immaterial). >

[PATCH] system.h: rename vec_step to workaround powerpc/clang bug [PR114369]

2024-03-19 Thread Jakub Jelinek
On Sat, Jul 20, 2019 at 05:26:57PM +0100, Richard Sandiford wrote: > Gerald Pfeifer writes: > > I have seen an increasing number of reports of GCC failing to > > build with clang on powerpc (on FreeBSD, though that's probably > > immaterial). > > > > Turns out that clang has vec_step as a