Re: [wide-int] More optimisations

2013-10-30 Thread Richard Biener
On Tue, 29 Oct 2013, Mike Stump wrote: On Oct 29, 2013, at 5:43 AM, Richard Sandiford rsand...@linux.vnet.ibm.com wrote: Richard Biener rguent...@suse.de writes: I think the cases Mike added should only be enabled when we can figure them out at compile-time, too. Well, the idea

Re: [wide-int] More optimisations

2013-10-29 Thread Richard Biener
On Sun, 27 Oct 2013, Richard Sandiford wrote: This patch adds some more optimisations to the wi:: comparison functions. It uses the: #define CONSTANT(X) (__builtin_constant_p (X) (X)) idiom that was mentioned before, except that I thought CONSTANT would be too easily confused with

Re: [wide-int] More optimisations

2013-10-29 Thread Richard Sandiford
Richard Biener rguent...@suse.de writes: On Sun, 27 Oct 2013, Richard Sandiford wrote: This patch adds some more optimisations to the wi:: comparison functions. It uses the: #define CONSTANT(X) (__builtin_constant_p (X) (X)) idiom that was mentioned before, except that I thought

Re: [wide-int] More optimisations

2013-10-29 Thread Kenneth Zadeck
On 10/29/2013 08:43 AM, Richard Sandiford wrote: Richard Biener rguent...@suse.de writes: On Sun, 27 Oct 2013, Richard Sandiford wrote: This patch adds some more optimisations to the wi:: comparison functions. It uses the: #define CONSTANT(X) (__builtin_constant_p (X) (X)) idiom that was

Re: [wide-int] More optimisations

2013-10-29 Thread Kenneth Zadeck
On 10/29/2013 08:43 AM, Richard Sandiford wrote: Richard Biener rguent...@suse.de writes: On Sun, 27 Oct 2013, Richard Sandiford wrote: This patch adds some more optimisations to the wi:: comparison functions. It uses the: #define CONSTANT(X) (__builtin_constant_p (X) (X)) idiom that was

Re: [wide-int] More optimisations

2013-10-29 Thread Mike Stump
On Oct 29, 2013, at 5:43 AM, Richard Sandiford rsand...@linux.vnet.ibm.com wrote: Richard Biener rguent...@suse.de writes: I think the cases Mike added should only be enabled when we can figure them out at compile-time, too. Well, the idea with most of these functions was to handle the

[wide-int] More optimisations

2013-10-27 Thread Richard Sandiford
This patch adds some more optimisations to the wi:: comparison functions. It uses the: #define CONSTANT(X) (__builtin_constant_p (X) (X)) idiom that was mentioned before, except that I thought CONSTANT would be too easily confused with CONSTANT_P, so I went for CAN_TELL instead. Better names