Re: [PATCH, AArch64] Add vabs_s64 intrinsic

2013-07-13 Thread Marcus Shawcroft
On 12 Jul 2013, at 19:49, Ian Bolton ian.bol...@arm.com wrote: 2013-07-12 Ian Bolton ian.bol...@arm.com gcc/ * config/aarch64/arm_neon.h (vabs_s64): New function. testsuite/ * gcc.target/aarch64/scalar_intrinsics.c (test_vabs_s64): Added new

Re: Fix GCC bug causing bootstrap failure with vectorizer turned on

2013-07-13 Thread Richard Biener
Cong Hou co...@google.com wrote: GCC bootstrap failed with loop vectorizer turned on by default at O2. The symptom is that the comparison between stage23 compilers fails. The root cause is a bug in the file tree-vect-data-refs.c, where a qsort() function call is used to sort a group of data

Re: [c++-concepts] requires expressions

2013-07-13 Thread Andrew Sutton
This should be merged with pp_cxx_parameter_declaration_clause. +reqparms_to_string (tree p) And this should have a more generic name. I called this parms_to_string for symmetry with args_to_string. It calls pp_cxx_parameter_declaration_clause. + if (check_requirements (t, args)) +

RE: [ping] Re: [patch 0/4] reimplement -fstrict-volatile-bitfields, v3

2013-07-13 Thread Bernd Edlinger
Hi Sandra, On Fri, 5 Jul 2013, Hans-Peter Nilsson wrote Or - maybe more acceptable - an optional warning, say -Wportable-volatility, to warn about code for which separate incompatbile definitions on different platforms (or between C and C++) exist even within gcc.  It would be usable for

Re: vector conditional expression with scalar arguments

2013-07-13 Thread Marc Glisse
On Mon, 8 Jul 2013, Jason Merrill wrote: On 07/08/2013 05:28 PM, Marc Glisse wrote: Perhaps the most conservative rule would be to only accept the case where the sizes match and reject the others for now, so whatever is decided later for other cases is unlikely to require a breaking change.

Fix for UTF-16 string encoding

2013-07-13 Thread Jared Parsons
Hello everyone, Attached is a patch to fix bug 41698 (http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41698) and a second patch with extends test suite coverage for it. No unexpected failures on the g++ test suite. libcpp/Changelog: 2013-07-13 Jared Parsons jared...@gmail.com *

Re: [PATCH] Add command line parsing of -fsanitize

2013-07-13 Thread Jakub Jelinek
On Wed, Jun 19, 2013 at 10:17:15AM +0200, Jakub Jelinek wrote: While it would be possible to define say %:sanitize(thread LIBTSAN_EARLY) that would work roughly like %{fsanitize=thread:LIBTSAN_EARLY} worked until now (variable number of arguments that would be concatenated together if

Re: [c++-concepts] requires expressions

2013-07-13 Thread Jason Merrill
On 07/13/2013 05:37 AM, Andrew Sutton wrote: There are two instantiations on purpose. OK. A lot of the new code in pt.c doesn't seem like it needs to be there; let's put as much in constraint.cc as we can. Let's move some of the bits out of semantics.c as well. I think the

Re: vector conditional expression with scalar arguments

2013-07-13 Thread Jason Merrill
OK. Jason

PATCH (c,c++) for c++/57793

2013-07-13 Thread Jason Merrill
On 07/10/2013 01:24 AM, Eric Botcazou wrote: The idea behind the existing trick is that the reference is within the bounds of the base object, i.e. the global offset (offset3 + bitpos) is positive, but the bitpos part is negative, so we rearrange it into ((offset-c3)3 + (bitpos+c)). Here the

C++ PATCH to can_convert to support user-defined conversions

2013-07-13 Thread Jason Merrill
As came up in the review of the concepts lite code, can_convert currently doesn't allow user-defined conversions. This is surprising, so we've renamed it to can_convert_standard and made the can_convert name allow them. Users that could potentially call can_convert with arguments of class

Re: C++ PATCH for c++/57402 (ICE with VLA initialization)

2013-07-13 Thread Jason Merrill
Value-initialization isn't quite right, either; we need to use {} to initialize elements without an explicit initializer. Tested x86_64-pc-linux-gnu, applying to trunk. commit f1f87745de6be6cf23acfb6aa30f44cce9cbcff6 Author: Jason Merrill ja...@redhat.com Date: Fri Jul 12 16:58:58 2013 -0700

Re: Fwd: [PATCH] Attribute for unused warning for variables of non-trivial types

2013-07-13 Thread Jason Merrill
On 07/08/2013 10:32 AM, Jason Merrill wrote: Was it a deliberate decision to put this in the c-common attributes rather than the C++-specific ones? I'm not saying it's wrong, just interested in your thinking. I think it makes sense to leave it in c-common so that types shared between C and

Re: [gomp4] Fix up #pragma omp declare simd parsing

2013-07-13 Thread Jason Merrill
On 07/01/2013 05:18 AM, Jakub Jelinek wrote: (cp_finish_omp_declare_simd): Renamed to... (cp_finalize_omp_declare_simd): ... this. Adjust for ... (cp_finish_omp_declare_simd): New function. So now we have finish and finalize; please choose more distinct names.

Re: [patch] implement Cilk Plus simd loops on trunk

2013-07-13 Thread Jason Merrill
On 07/09/2013 09:09 AM, Aldy Hernandez wrote: + is the controlling variable. COND is the condition. INCRP is a + pointer the increment expression (in case, the increment needs to pointer to No comma after in case + error_at (loc, initialization variable must be of integral +

Re: Minor Cygwin patches

2013-07-13 Thread JonY
On 7/10/2013 20:43, JonY wrote: Hi, Attached are some minor patches, comments? Kai, ping? signature.asc Description: OpenPGP digital signature

Re: [gomp4] Fix up #pragma omp declare simd parsing

2013-07-13 Thread Jakub Jelinek
On Sat, Jul 13, 2013 at 05:33:15PM -0700, Jason Merrill wrote: On 07/01/2013 05:18 AM, Jakub Jelinek wrote: (cp_finish_omp_declare_simd): Renamed to... (cp_finalize_omp_declare_simd): ... this. Adjust for ... (cp_finish_omp_declare_simd): New function. So now we have finish

Re: [PATCH] Add command line parsing of -fsanitize

2013-07-13 Thread Marek Polacek
On Sat, Jul 13, 2013 at 11:47:29PM +0200, Jakub Jelinek wrote: On Wed, Jun 19, 2013 at 10:17:15AM +0200, Jakub Jelinek wrote: While it would be possible to define say %:sanitize(thread LIBTSAN_EARLY) that would work roughly like %{fsanitize=thread:LIBTSAN_EARLY} worked until now (variable

[ubsan] Instrument __builtin_unreachable

2013-07-13 Thread Marek Polacek
This patch implements sanitizing of the __builtin_unreachable call. A call to __builtin_unreachable only emits BARRIER, if we actually get to it, the behavior is undefined. So, we just replace the call with a call to the ubsan library, it then issues an error and dies. The patch is long because

Re: [ubsan] Instrument __builtin_unreachable

2013-07-13 Thread Marek Polacek
On Sun, Jul 14, 2013 at 07:39:38AM +0200, Marek Polacek wrote: This patch implements sanitizing of the __builtin_unreachable call. A call to __builtin_unreachable only emits BARRIER, if we actually get to it, the behavior is undefined. So, we just replace the call with a call to the ubsan