[ubsan] Don't always use NORETURN

2013-07-15 Thread Marek Polacek
Some libubsan functions aren't really noreturn, so don't mark them as such. This prevents failures with -O1+, since we don't generate any code after calling noreturn routines, thus segfault when we actually get there. Applying to ubsan branch. 2013-07-15 Marek Polacek pola...@redhat.com

Re: [testsuite] fix powerpc alignment tests for eabi

2013-07-15 Thread Sebastian Huber
On 07/08/2013 09:47 PM, Janis Johnson wrote: Tests gcc.target/powerpc/20020118-1.c and gcc.c-torture/execute/nest-align-1.c sometimes fail because they expect a stack alignment that is greater than that required for powerpc-eabi. This patch forces stack alignment to 128 bits by passing

[PATCH] [AArch64] -mcmodel=tiny -fPIC GOT support.

2013-07-15 Thread Marcus Shawcroft
Hi, Adding support for tiny model GOT access. Regressed, committed. /Marcus 2013-07-15 Marcus Shawcroft marcus.shawcr...@arm.com * config/aarch64/aarch64-protos.h (aarch64_symbol_type): Define SYMBOL_TINY_GOT, update comment. * config/aarch64/aarch64.c

Re: C++ PATCH to can_convert to support user-defined conversions

2013-07-15 Thread Gabriel Dos Reis
On Sat, Jul 13, 2013 at 6:02 PM, Jason Merrill ja...@redhat.com wrote: As came up in the review of the concepts lite code, can_convert currently doesn't allow user-defined conversions. This is surprising, so we've renamed it to can_convert_standard and made the can_convert name allow them.

ping: Re: [patch] fix cross building a native compiler

2013-07-15 Thread Matthias Klose
ping Am 12.06.2013 09:48, schrieb Matthias Klose: Trying to cross build a native compiler for arm-linux on x86_64 linux currently fails to build, if the libgmp development files are not available for the build system. This works with 4.7, but fails with 4.8. The build fails with:

[ping 2] Re: [ping] Re: [PATCH] Remove unnecessaily included limits.h in libgcc2.c

2013-07-15 Thread Matthias Klose
ping 2 Am 15.05.2013 13:46, schrieb Matthias Klose: ping? regenerated the patch for the trunk, check with builds on arm-linux-gnueabihf and x86_64-linux-gnu Matthias * libgcc2.c: Don't include limits.h. Am 14.01.2013 22:54, schrieb Matthias Klose: Am 04.01.2013 20:01,

Re: Call GNU ld with -O*

2013-07-15 Thread Michael Matz
Hi, On Fri, 12 Jul 2013, Ian Lance Taylor wrote: It was probably a mistake to have a linker -O option at all. Doesn't the linker produce something that is faster to link and/or smaller, with this flag? For gold I think it has two effects. If you use compressed debug sections, it

Re: [PATCH, rs6000, libitm] Enable Hardware Transactional Memory (HTM) support on Power

2013-07-15 Thread Peter Bergner
On Thu, 2013-07-04 at 12:02 -0400, David Edelsohn wrote: The expanders in htm.md should not include constraint letters. That's the way I had the code originally, since they're not needed for expand, but I added them later to improve the error message when someone uses a builtin that takes an

Re: [Patch, microblaze]: Add TARGET_ASM_OUTPUT_MI_THUNK to support varargs thunk

2013-07-15 Thread Michael Eager
On 07/14/13 21:37, David Holsgrove wrote: Hi Michael, -Original Message- From: Michael Eager [mailto:ea...@eagerm.com] Sent: Saturday, 13 July 2013 9:33 am To: David Holsgrove Cc: gcc-patches@gcc.gnu.org; Edgar Iglesias; John Williams; Vinod Kathail; Vidhumouli Hunsigida; Nagaraju

Re: [PATCH, rs6000, libitm] Enable Hardware Transactional Memory (HTM) support on Power

2013-07-15 Thread David Edelsohn
On Mon, Jul 15, 2013 at 11:23 AM, Peter Bergner berg...@vnet.ibm.com wrote: On Thu, 2013-07-04 at 12:02 -0400, David Edelsohn wrote: The expanders in htm.md should not include constraint letters. That's the way I had the code originally, since they're not needed for expand, but I added them

[Google 4.8] Fix up size of pubnames in the presence of pruned enumerators

2013-07-15 Thread Sterling Augustine
Hi Cary, Google 4.8 calculates the size of pubnames incorrectly in the presence of pruned enumerators. The logic in size_of_pubnames should match that in output_pubnames. The enclosed patch fixes that. OK for google 4.8? Sterling gcc/ChangeLog 2013-07-12 Sterling Augustine

[c++-concepts] Merge from trunk

2013-07-15 Thread Gabriel Dos Reis
Trunk was merged to the c++-concept branch at revision 200958. Andrew -- There aere a few conflicts surronding introduction of can_convert_standard, between your version and the one Jason committed. I resolved them in favour of Jason's because his version followed the GNU coding convention (when

Re: [PATCH, rs6000, libitm] Enable Hardware Transactional Memory (HTM) support on Power

2013-07-15 Thread Peter Bergner
On Mon, 2013-07-15 at 11:55 -0400, David Edelsohn wrote: Thanks for the explanation. Leave it in. Jakub was asking about the status of the HTM patch and support, so please check it in. Ok, committed to mainline (after another bootstrap) as revision 200960. Thanks! Peter

Re: Group static constructors and destructors in specific subsections

2013-07-15 Thread Cary Coutant
I am not sure how to update gold - I basically copied existing code in binutils for .text.unlikely group in GNU LD linker script, but I think gold is doing independent decisions somewhere. Ian committed this patch a few months ago, after a lengthy discussion around a patch originally

Re: [Google 4.8] Fix up size of pubnames in the presence of pruned enumerators

2013-07-15 Thread Sterling Augustine
On Mon, Jul 15, 2013 at 9:32 AM, Sterling Augustine saugust...@google.com wrote: Hi Cary, Google 4.8 calculates the size of pubnames incorrectly in the presence of pruned enumerators. The logic in size_of_pubnames should match that in output_pubnames. After some discussion off line, I have

[ubsan] Add testsuite

2013-07-15 Thread Marek Polacek
Ubsan testsuite is something we've been missing for some time now, so this patch adds it. Fortunately the dejagnu part was quite simple, since ubsan doesn't need similar tweaks as asan does. But I had to tweak gcc.c to include -lubsan. The tests are testing pretty basic stuff, however, in LLVM

Re: [ping 2] Re: [ping] Re: [PATCH] Remove unnecessaily included limits.h in libgcc2.c

2013-07-15 Thread Ian Lance Taylor
This patch is OK. Sorry for not looking at it earlier. Thanks. Ian On Mon, Jul 15, 2013 at 5:40 AM, Matthias Klose d...@ubuntu.com wrote: ping 2 Am 15.05.2013 13:46, schrieb Matthias Klose: ping? regenerated the patch for the trunk, check with builds on arm-linux-gnueabihf and

Re: [Google 4.8] Fix up size of pubnames in the presence of pruned enumerators

2013-07-15 Thread Cary Coutant
After some discussion off line, I have reworked this patch as below. This version is cleaner and ensures the logic is just in one place. OK for Google 4.7 and 4.8? Sterling 2013-07-15 Sterling Augustine saugust...@google.com * dwarf2out.c (output_pubnames): Rework assertion.

Re: Fix GCC bug causing bootstrap failure with vectorizer turned on

2013-07-15 Thread Richard Biener
Cong Hou co...@google.com wrote: Hi Richard Thank you for you reply. The code generation is affected when generating conditions for alias checks using the function static void vect_create_cond_for_alias_checks (loop_vec_info loop_vinfo, tree * cond_expr) from the file *tree-vect-loop-manip.c*

Re: Group static constructors and destructors in specific subsections

2013-07-15 Thread Jan Hubicka
I am not sure how to update gold - I basically copied existing code in binutils for .text.unlikely group in GNU LD linker script, but I think gold is doing independent decisions somewhere. Ian committed this patch a few months ago, after a lengthy discussion around a patch originally

Re: Group static constructors and destructors in specific subsections

2013-07-15 Thread Ian Lance Taylor
On Mon, Jul 15, 2013 at 11:05 AM, Jan Hubicka hubi...@ucw.cz wrote: The next thing is how to tell GNU LD/Gold the relative order of functions. I.e. my_function_section.order.125 or something like that? Gold has a --section-ordering-file option that lets you specify the order in which sections

Re: Group static constructors and destructors in specific subsections

2013-07-15 Thread Jan Hubicka
On Mon, Jul 15, 2013 at 11:05 AM, Jan Hubicka hubi...@ucw.cz wrote: The next thing is how to tell GNU LD/Gold the relative order of functions. I.e. my_function_section.order.125 or something like that? Gold has a --section-ordering-file option that lets you specify the order in which