Re: [patch] Unify bitmap interface.

2012-10-30 Thread Bin.Cheng
On Tue, Oct 30, 2012 at 8:23 AM, Lawrence Crowl cr...@googlers.com wrote: On 10/29/12, Diego Novillo dnovi...@google.com wrote: On Oct 29, 2012 Diego Novillo dnovi...@google.com wrote: Just to make sure. Testing on ppc should be fast, for example. And useless. Your patch does not touch

Re: [patch] Unify bitmap interface.

2012-10-30 Thread Diego Novillo
On Tue, Oct 30, 2012 at 2:17 AM, Bin.Cheng amker.ch...@gmail.com wrote: On Tue, Oct 30, 2012 at 8:23 AM, Lawrence Crowl cr...@googlers.com wrote: On 10/29/12, Diego Novillo dnovi...@google.com wrote: On Oct 29, 2012 Diego Novillo dnovi...@google.com wrote: Just to make sure. Testing on ppc

Re: [patch] Unify bitmap interface.

2012-10-30 Thread Diego Novillo
On Mon, Oct 29, 2012 at 4:25 PM, Steven Bosscher stevenb@gmail.com wrote: On Mon, Oct 29, 2012 at 7:54 PM, Diego Novillo wrote: Sure. But the point is not to add more. We should mechanically strip all the #if 0 code from the tree, btw. No point keeping all that garbage around. Please

Re: [patch] Unify bitmap interface.

2012-10-30 Thread Richard Biener
On Tue, Oct 30, 2012 at 12:53 PM, Diego Novillo dnovi...@google.com wrote: On Mon, Oct 29, 2012 at 4:25 PM, Steven Bosscher stevenb@gmail.com wrote: On Mon, Oct 29, 2012 at 7:54 PM, Diego Novillo wrote: Sure. But the point is not to add more. We should mechanically strip all the #if 0

Re: [patch] Unify bitmap interface.

2012-10-30 Thread Lawrence Crowl
On 10/30/12, Diego Novillo dnovi...@google.com wrote: On Oct 30, 2012 Bin.Cheng amker.ch...@gmail.com wrote: Just one question: Should we change the name of functions sbitmap_intersection_of_succs/sbitmap_intersection_of_preds/ sbitmap_union_of_succs/sbitmap_union_of_preds too? It might

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Diego Novillo
On Thu, Oct 25, 2012 at 6:39 PM, Lawrence Crowl cr...@googlers.com wrote: The sbitmap non-bool returning bitwise operations have been merged with the bool versions. Sometimes this merge involved modifying the non-bool version to compute the bool value, and sometimes modifying bool version to

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Richard Biener
On Mon, Oct 29, 2012 at 2:06 PM, Diego Novillo dnovi...@google.com wrote: On Thu, Oct 25, 2012 at 6:39 PM, Lawrence Crowl cr...@googlers.com wrote: The sbitmap non-bool returning bitwise operations have been merged with the bool versions. Sometimes this merge involved modifying the non-bool

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Lawrence Crowl
On 10/29/12, Richard Biener richard.guent...@gmail.com wrote: On Oct 29, 2012 Diego Novillo dnovi...@google.com wrote: On Oct 25, 2012 Lawrence Crowl cr...@googlers.com wrote: The sbitmap non-bool returning bitwise operations have been merged with the bool versions. Sometimes this merge

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Diego Novillo
On Mon, Oct 29, 2012 at 2:46 PM, Lawrence Crowl cr...@googlers.com wrote: Okay, but I point out that there is an awful lot of #if 0 code out there. I would rather have done such removal in a followup patch. Sure. But the point is not to add more. We should mechanically strip all the #if 0

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Lawrence Crowl
On 10/29/12, Diego Novillo dnovi...@google.com wrote: On Oct 29, 2012 Lawrence Crowl cr...@googlers.com wrote: The sbitmap popcount function is only used in ebitmap, which is itself not used. If we do anything, removing them might be the thing to do. Yes, please. Separate patch, please.

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Steven Bosscher
On Mon, Oct 29, 2012 at 7:54 PM, Diego Novillo wrote: Sure. But the point is not to add more. We should mechanically strip all the #if 0 code from the tree, btw. No point keeping all that garbage around. Please no. A lot (if not most) if the #if 0 code serves as good documentation for why

Re: [patch] Unify bitmap interface.

2012-10-29 Thread Diego Novillo
On Mon, Oct 29, 2012 at 2:54 PM, Diego Novillo dnovi...@google.com wrote: Just to make sure. Testing on ppc should be fast, for example. And useless. Your patch does not touch ppc. Diego.

Re: [patch] Unify bitmap interface.

2012-10-26 Thread Lawrence Crowl
On 10/25/12, Lawrence Crowl cr...@googlers.com wrote: This patch implements the unification of the *bitmap interfaces as discussed. Essentially, we rename ebitmap and sbitmap functions to use the same names as the bitmap functions. This rename works because we can now overload on the bitmap