Re: [WIP PATCH] Re: Inefficient end-of-loop value computation - missed optimization somewhere?

2012-03-15 Thread Ulrich Weigand
Richard Guenter wrote: On Thu, Mar 8, 2012 at 3:29 PM, Ulrich Weigand uweig...@de.ibm.com wrote: I'm wondering where to go from there: - Why are those special re-association cases handled only in forwprop, and not in fold-cost? I would have expected forwprop to just propagate

Re: [WIP PATCH] Re: Inefficient end-of-loop value computation - missed optimization somewhere?

2012-03-12 Thread Richard Guenther
On Thu, Mar 8, 2012 at 3:29 PM, Ulrich Weigand uweig...@de.ibm.com wrote: Richard Guenther wrote: On Tue, Feb 28, 2012 at 4:10 PM, Ulrich Weigand uweig...@de.ibm.com wrote: I'll still need to do proper testing and benchmarking, but I thought I'd post the patch anyway just as a heads-up ...

Re: [WIP PATCH] Re: Inefficient end-of-loop value computation - missed optimization somewhere?

2012-03-08 Thread Ulrich Weigand
Richard Guenther wrote: On Tue, Feb 28, 2012 at 4:10 PM, Ulrich Weigand uweig...@de.ibm.com wrote: I'll still need to do proper testing and benchmarking, but I thought I'd post the patch anyway just as a heads-up ... Does this look reasonable to you? Yes, that looks reasonable. Though

Re: [WIP PATCH] Re: Inefficient end-of-loop value computation - missed optimization somewhere?

2012-02-28 Thread Richard Guenther
On Tue, Feb 28, 2012 at 4:10 PM, Ulrich Weigand uweig...@de.ibm.com wrote: Richard Guenther wrote: On Mon, Feb 20, 2012 at 11:19 PM, Ulrich Weigand uweig...@de.ibm.com wrote: we've noticed that the loop optimizer sometimes inserts weirdly inefficient code to compute the value of an induction