[gem5-dev] Change in gem5/gem5[develop]: scons: Work around a scons bug when calling TryCompile.

2021-02-13 Thread Gabe Black (Gerrit) via gem5-dev
Gabe Black has submitted this change. (  
https://gem5-review.googlesource.com/c/public/gem5/+/41213 )


Change subject: scons: Work around a scons bug when calling TryCompile.
..

scons: Work around a scons bug when calling TryCompile.

When calling TryCompile with an empty string for the source, useful
when just testing a build flag, some versions of SCons will apparently
create some sort of equivalence between Value('') and Value(0). That
shows itself when creating config file headers, where Value(0) is
switched with Value(''), and the header defines a macro with which
expands to nothing rather than a macro which expands to 0. Later uses
of the macro of the form:

 #if CONFIG_VARIABLE

fail because CONFIG_VARIABLE expands to nothing. If it expanded to 0
like it's supposed to, then the guarded block of code would be excluded
correctly.

Change-Id: Ie324ec5f8dd307c65745b9326a11230e10caa0bd
Reviewed-on: https://gem5-review.googlesource.com/c/public/gem5/+/41213
Maintainer: Bobby R. Bruce 
Tested-by: kokoro 
Reviewed-by: Gabe Black 
---
M site_scons/gem5_scons/configure.py
1 file changed, 1 insertion(+), 1 deletion(-)

Approvals:
  Gabe Black: Looks good to me, approved
  Bobby R. Bruce: Looks good to me, approved
  kokoro: Regressions pass



diff --git a/site_scons/gem5_scons/configure.py  
b/site_scons/gem5_scons/configure.py

index 7bf97b2..35aa1a9 100644
--- a/site_scons/gem5_scons/configure.py
+++ b/site_scons/gem5_scons/configure.py
@@ -47,7 +47,7 @@
 context.Message("Checking for compiler %s support... " % flag)
 last_cxxflags = context.env['CXXFLAGS']
 context.env.Append(CXXFLAGS=[flag])
-ret = context.TryCompile('', '.cc')
+ret = context.TryCompile('// CheckCxxFlag DO NOTHING', '.cc')
 if not (ret and autoadd):
 context.env['CXXFLAGS'] = last_cxxflags
 context.Result(ret)

--
To view, visit https://gem5-review.googlesource.com/c/public/gem5/+/41213
To unsubscribe, or for help writing mail filters, visit  
https://gem5-review.googlesource.com/settings


Gerrit-Project: public/gem5
Gerrit-Branch: develop
Gerrit-Change-Id: Ie324ec5f8dd307c65745b9326a11230e10caa0bd
Gerrit-Change-Number: 41213
Gerrit-PatchSet: 2
Gerrit-Owner: Gabe Black 
Gerrit-Reviewer: Andreas Sandberg 
Gerrit-Reviewer: Bobby R. Bruce 
Gerrit-Reviewer: Gabe Black 
Gerrit-Reviewer: Giacomo Travaglini 
Gerrit-Reviewer: Jason Lowe-Power 
Gerrit-Reviewer: kokoro 
Gerrit-MessageType: merged
___
gem5-dev mailing list -- gem5-dev@gem5.org
To unsubscribe send an email to gem5-dev-le...@gem5.org
%(web_page_url)slistinfo%(cgiext)s/%(_internal_name)s

[gem5-dev] Build failed in Jenkins: Weekly #7

2021-02-13 Thread jenkins-no-reply--- via gem5-dev
See 

Changes:

[gabe.black] cpu: Factor MaxInst(SrcDest)Regs out of the trace CPU.

[gabe.black] cpu: Track flat register indices in the Minor CPU with a vector.

[gabe.black] cpu: Track misc regs in vectors in the O3 CPU instruction class.

[hoanguyen] base-stats: Add Units to Stats

[hoanguyen] mem: Fix/Improve stats in src/mem

[hoanguyen] cpu,mem: Converting stats to supported units

[hoanguyen] mem: Add Units to mem stats

[hoanguyen] sim: Add units to src/sim

[hoanguyen] dev,dev-arm: Add units to stats in /src/dev

[hoanguyen] arch-arm,arch-riscv,arch-x86: Add units to stats

[hoanguyen] learning-gem5: Add units to stats

[hoanguyen] cpu: Add Units to cpu stats

[hoanguyen] mem: Change warmupCycle stat to warmupTick

[hoanguyen] base-stats: Print Units in Stats dump

[hoanguyen] mem: Remove units from stats description

[hoanguyen] dev,dev-arm: Remove units from stats description

[hoanguyen] arch-riscv: Fixed the style of stats variable names in TlbStats

[hoanguyen] cpu: Remove units from stats description

[gabe.black] scons: Add support for debug info compression.

[Giacomo Travaglini] dev-arm: Add VRAM to VExpress_GEM5_Base

[gabe.black] cpu: Delete the empty, default off "nocpu".

[gabe.black] scons: Remove partial linking.

[gabe.black] scons: Update the Check(Cxx|Link)Flag checks to set their vars.

[gabe.black] scons: Remove "TIMEOUT" variable and checks.

[gabe.black] scons: Trim down a check for mac OS and arch setting flags.

[gabe.black] scons: Extract the gem5 specific Configure call to its own file.

[odanrc] base: Fix copyright of base/stats/SConscript

[gabe.black] scons: Pull Configure() to earlier in SConstruct so we can use it 
more.

[hoanguyen] mem: Initialize pendingWrites stat of NVMStats

[Giacomo Travaglini] arch-arm: Fix CPTR_EL2 writes

[tiago.muck] mem-ruby: warns on masked functional writes

[tiago.muck] mem-ruby: fixes for masked writes

[tiago.muck] mem-ruby: fix functional reads in abstract ctrl

[tiago.muck] mem-ruby: fix Sequencer latency reporting

[gabe.black] scons: In Check(Cxx|Link)Flag, only install the flag if it exists.

[gabe.black] scons: Use conf to determine if some flags are supported.

[gabe.black] scons: Move a displaced have_posix_clock check back where it goes.

[gabe.black] scons: Simplify check for have_posix_clock.

[gabe.black] scons: Simplify backtrace implementation detection.

[gabe.black] scons: Simplify the check for hdf5 support.

[gabe.black] scons: Create a Configure checker for pkg-config.

[gabe.black] scons: Simplify the check for protoc.

[gabe.black] scons: Merge redundant checks for the socket library.

[gabe.black] scons: Simplify kvm architecture compatibility check.

[kyleroarty1716] arch-gcn3: Fix sign extension for branches with multiplied 
offset

[tiago.muck] python: more readable Ruby dot topology

[tiago.muck] mem-ruby: add andMask to WriteMask


--
[...truncated 498.30 KB...]
MOESI_AMD_Base-L3cache.sm:196: Warning: Non-void return ignored, return type is 
'bool'
MOESI_AMD_Base-L3cache.sm:611: Warning: Non-void return ignored, return type is 
'Tick'
MOESI_AMD_Base-L3cache.sm:615: Warning: Non-void return ignored, return type is 
'Tick'
MOESI_AMD_Base-L3cache.sm:619: Warning: Non-void return ignored, return type is 
'Tick'
MOESI_AMD_Base-L3cache.sm:623: Warning: Non-void return ignored, return type is 
'Tick'
MOESI_AMD_Base-L3cache.sm:561: Warning: Unused action: rd_copyDataFromRequest, 
write data to L3
 [ CXX] GCN3_X86/gpu-compute/gpu_static_inst.cc -> .o
 [ TRACING]  -> GCN3_X86/debug/PseudoInst.hh
 [ TRACING]  -> GCN3_X86/debug/X86.hh
 [ CXX] GCN3_X86/gpu-compute/pool_manager.cc -> .o
 [ TRACING]  -> GCN3_X86/debug/GPURF.hh
 [ CXX] GCN3_X86/gpu-compute/register_manager.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/schedule_stage.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/scheduler.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/scalar_memory_pipeline.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/global_memory_pipeline.cc -> .o
 [SO PARAM] HSADriver -> GCN3_X86/params/HSADriver.hh
 [ CXX] GCN3_X86/gpu-compute/gpu_compute_driver.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/scalar_register_file.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/gpu_dyn_inst.cc -> .o
 [SO PARAM] SimpleMemory -> GCN3_X86/params/SimpleMemory.hh
 [ENUMDECL] MessageRandomization -> GCN3_X86/enums/MessageRandomization.hh
 [ CXX] GCN3_X86/gpu-compute/fetch_unit.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/gpu_tlb.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/compute_unit.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/lds_state.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/dispatcher.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/local_memory_pipeline.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/register_file.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/gpu_command_processor.cc -> .o
 [ CXX] GCN3_X86/gpu-compute/scoreboard_check_stage.cc -> .o
 [ TRACING]  -> 

[gem5-dev] Change in gem5/gem5[develop]: arch-x86: Use popCount from bitfields.hh.

2021-02-13 Thread Gabe Black (Gerrit) via gem5-dev
Gabe Black has submitted this change. (  
https://gem5-review.googlesource.com/c/public/gem5/+/41354 )


Change subject: arch-x86: Use popCount from bitfields.hh.
..

arch-x86: Use popCount from bitfields.hh.

Use popCount from bitfields.hh rather than call __builtin_popcountl
directly. That will ensure the instruction works whether or not that
builtin is available.

Change-Id: I947b35bb832b768936b489a58ee324adb8a90b5e
Reviewed-on: https://gem5-review.googlesource.com/c/public/gem5/+/41354
Reviewed-by: Jason Lowe-Power 
Maintainer: Jason Lowe-Power 
Tested-by: kokoro 
---
M src/arch/x86/isa/microops/regop.isa
1 file changed, 1 insertion(+), 4 deletions(-)

Approvals:
  Jason Lowe-Power: Looks good to me, approved; Looks good to me, approved
  kokoro: Regressions pass



diff --git a/src/arch/x86/isa/microops/regop.isa  
b/src/arch/x86/isa/microops/regop.isa

index 570c084..63a1683 100644
--- a/src/arch/x86/isa/microops/regop.isa
+++ b/src/arch/x86/isa/microops/regop.isa
@@ -1766,10 +1766,7 @@
 '''

 class Popcnt(RegOp):
-code = '''
-DestReg =
-merge(DestReg, __builtin_popcountl(psrc1), dataSize);
-'''
+code = 'DestReg = merge(DestReg, popCount(psrc1), dataSize);'
 flag_code = '''
 ccFlagBits = ccFlagBits & ~(SFBit | AFBit | ZFBit | PFBit);
 if (findZero(dataSize * 8, SrcReg1)) {

--
To view, visit https://gem5-review.googlesource.com/c/public/gem5/+/41354
To unsubscribe, or for help writing mail filters, visit  
https://gem5-review.googlesource.com/settings


Gerrit-Project: public/gem5
Gerrit-Branch: develop
Gerrit-Change-Id: I947b35bb832b768936b489a58ee324adb8a90b5e
Gerrit-Change-Number: 41354
Gerrit-PatchSet: 2
Gerrit-Owner: Gabe Black 
Gerrit-Reviewer: Bobby R. Bruce 
Gerrit-Reviewer: Gabe Black 
Gerrit-Reviewer: Jason Lowe-Power 
Gerrit-Reviewer: Jason Lowe-Power 
Gerrit-Reviewer: kokoro 
Gerrit-MessageType: merged
___
gem5-dev mailing list -- gem5-dev@gem5.org
To unsubscribe send an email to gem5-dev-le...@gem5.org
%(web_page_url)slistinfo%(cgiext)s/%(_internal_name)s

[gem5-dev] Change in gem5/gem5[develop]: arch: Stop including unnecessary FP headers.

2021-02-13 Thread Gabe Black (Gerrit) via gem5-dev
Gabe Black has submitted this change. (  
https://gem5-review.googlesource.com/c/public/gem5/+/41353 )


Change subject: arch: Stop including unnecessary FP headers.
..

arch: Stop including unnecessary FP headers.

Nothing is used from them. They're probably there as copy/paste from
other ISAs, or old code that's been replaced. This also gets rid of some
 #if guarded includes which is a nice cleanup.

Change-Id: Icd84300fb7531ec203ce4acbdae1d311e56cc873
Reviewed-on: https://gem5-review.googlesource.com/c/public/gem5/+/41353
Reviewed-by: Jason Lowe-Power 
Maintainer: Jason Lowe-Power 
Tested-by: kokoro 
---
M src/arch/mips/isa/includes.isa
M src/arch/power/isa/includes.isa
M src/arch/x86/isa/includes.isa
3 files changed, 9 insertions(+), 32 deletions(-)

Approvals:
  Jason Lowe-Power: Looks good to me, approved; Looks good to me, approved
  kokoro: Regressions pass



diff --git a/src/arch/mips/isa/includes.isa b/src/arch/mips/isa/includes.isa
index 34922e4..d17bcf6 100644
--- a/src/arch/mips/isa/includes.isa
+++ b/src/arch/mips/isa/includes.isa
@@ -41,6 +41,7 @@
 #include "arch/mips/pra_constants.hh"
 #include "cpu/static_inst.hh"
 #include "mem/packet.hh"
+
 }};

 output decoder {{
@@ -56,14 +57,11 @@
 #include "arch/mips/pra_constants.hh"
 #include "arch/mips/tlb.hh"
 #include "arch/mips/utility.hh"
-#include "base/loader/symtab.hh"
 #include "base/cprintf.hh"
+#include "base/loader/symtab.hh"
 #include "cpu/thread_context.hh"
 #include "mem/packet.hh"
 #include "sim/full_system.hh"
-#if defined(linux)
-#include 
-#endif

 using namespace MipsISA;
 }};
@@ -83,10 +81,6 @@
 #include "arch/mips/pra_constants.hh"
 #include "arch/mips/tlb.hh"
 #include "arch/mips/utility.hh"
-#if defined(linux)
-#include 
-#endif
-
 #include "base/condcodes.hh"
 #include "cpu/base.hh"
 #include "cpu/exetrace.hh"
diff --git a/src/arch/power/isa/includes.isa  
b/src/arch/power/isa/includes.isa

index ac7756c..c97aba9 100644
--- a/src/arch/power/isa/includes.isa
+++ b/src/arch/power/isa/includes.isa
@@ -52,9 +52,6 @@

 output decoder {{
 #include 
-#if defined(linux)
-#include 
-#endif

 #include "arch/power/decoder.hh"
 #include "arch/power/faults.hh"
@@ -69,9 +66,6 @@

 output exec {{
 #include 
-#if defined(linux)
-#include 
-#endif

 #include "arch/generic/memhelpers.hh"
 #include "arch/power/faults.hh"
diff --git a/src/arch/x86/isa/includes.isa b/src/arch/x86/isa/includes.isa
index 3bd7872..27ef988 100644
--- a/src/arch/x86/isa/includes.isa
+++ b/src/arch/x86/isa/includes.isa
@@ -53,13 +53,13 @@
 #include 

 #include "arch/generic/debugfaults.hh"
+#include "arch/x86/emulenv.hh"
 #include "arch/x86/insts/macroop.hh"
 #include "arch/x86/insts/microfpop.hh"
 #include "arch/x86/insts/microldstop.hh"
 #include "arch/x86/insts/micromediaop.hh"
 #include "arch/x86/insts/microregop.hh"
 #include "arch/x86/insts/static_inst.hh"
-#include "arch/x86/emulenv.hh"
 #include "arch/x86/isa_traits.hh"
 #include "arch/x86/registers.hh"
 #include "arch/x86/types.hh"
@@ -73,46 +73,35 @@
 }};

 output decoder {{
+#include 
+
 #include "arch/x86/decoder.hh"
+#include "arch/x86/faults.hh"
+#include "arch/x86/microcode_rom.hh"
 #include "arch/x86/regs/float.hh"
 #include "arch/x86/regs/misc.hh"
 #include "arch/x86/regs/segment.hh"
-#include "arch/x86/faults.hh"
-#include "arch/x86/microcode_rom.hh"
 #include "arch/x86/tlb.hh"
-#include "base/loader/symtab.hh"
 #include "base/cprintf.hh"
+#include "base/loader/symtab.hh"
 #include "base/logging.hh"
 #include "cpu/thread_context.hh"  // for Jump::branchTarget()
 #include "mem/packet.hh"
 #include "sim/full_system.hh"

-#if defined(linux) || defined(__APPLE__)
-#include 
-#endif
-#include 
-
 using namespace X86ISA;
 }};

 output exec {{
-#if defined(linux) || defined(__APPLE__)
-#include 
-#endif
-
-#if defined(__sun) || defined (__OpenBSD__)
-#include 
-#endif
-
 #include 
 #include 

 #include "arch/generic/debugfaults.hh"
-#include "arch/x86/regs/misc.hh"
 #include "arch/x86/cpuid.hh"
 #include "arch/x86/faults.hh"
 #include "arch/x86/memhelpers.hh"
 #include "arch/x86/pseudo_inst_abi.hh"
+#include "arch/x86/regs/misc.hh"
 #include "arch/x86/tlb.hh"
 #include "base/compiler.hh"
 #include "base/condcodes.hh"

--
To view, visit https://gem5-review.googlesource.com/c/public/gem5/+/41353
To unsubscribe, or for help writing mail filters, visit  
https://gem5-review.googlesource.com/settings


Gerrit-Project: public/gem5
Gerrit-Branch: develop
Gerrit-Change-Id: Icd84300fb7531ec203ce4acbdae1d311e56cc873
Gerrit-Change-Number: 41353
Gerrit-PatchSet: 2
Gerrit-Owner: Gabe Black 
Gerrit-Reviewer: Andreas Sandberg 
Gerrit-Reviewer: Daniel Carvalho 
Gerrit-Reviewer: Gabe Black 
Gerrit-Reviewer: Jason Lowe-Power 
Gerrit-Reviewer: kokoro 
Gerrit-MessageType: merged
___
gem5-dev mailing list -- gem5-dev@gem5.org
To unsubscribe send an email to gem5-dev-le...@gem5.org