zx2c4       14/04/13 15:44:38

  Modified:             ChangeLog
  Added:                pass-1.5.ebuild
  Log:
  Bump version.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
A5DE03AE)

Revision  Changes    Path
1.9                  app-admin/pass/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/ChangeLog?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/ChangeLog?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/ChangeLog?r1=1.8&r2=1.9

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/pass/ChangeLog,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- ChangeLog   22 Mar 2014 19:38:36 -0000      1.8
+++ ChangeLog   13 Apr 2014 15:44:38 -0000      1.9
@@ -1,6 +1,11 @@
 # ChangeLog for app-admin/pass
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/ChangeLog,v 1.8 2014/03/22 
19:38:36 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/ChangeLog,v 1.9 2014/04/13 
15:44:38 zx2c4 Exp $
+
+*pass-1.5 (13 Apr 2014)
+
+  13 Apr 2014; Jason A. Donenfeld <zx...@gentoo.org> +pass-1.5.ebuild:
+  Bump version.
 
   22 Mar 2014; Jason A. Donenfeld <zx...@gentoo.org> pass-9999.ebuild:
   Support darwin on livebuild.



1.1                  app-admin/pass/pass-1.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/pass-1.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/pass/pass-1.5.ebuild?rev=1.1&content-type=text/plain

Index: pass-1.5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/pass/pass-1.5.ebuild,v 1.1 
2014/04/13 15:44:38 zx2c4 Exp $

EAPI=4

inherit bash-completion-r1

DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely 
using gpg, pwgen, and git"
HOMEPAGE="http://zx2c4.com/projects/password-store/";
SRC_URI="http://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz";

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~x86-macos"
IUSE="+git X zsh-completion fish-completion elibc_Darwin"

RDEPEND="
        app-crypt/gnupg
        app-admin/pwgen
        app-text/tree
        git? ( dev-vcs/git )
        X? ( x11-misc/xclip )
        elibc_Darwin? ( app-misc/getopt )
        zsh-completion? ( app-shells/zsh )
        fish-completion? ( app-shells/fish )
"

S="${WORKDIR}/password-store-${PV}"

src_prepare() {
        use elibc_Darwin || return
        # use coreutils'
        sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
        # host getopt isn't cool, and we aren't brew (rip out brew reference)
        sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
        # make sure we can find "mount"
        sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
}

src_compile() {
        :;
}

src_install() {
        newbin src/password-store.sh pass
        doman man/pass.1
        dodoc README
        newbashcomp src/completion/pass.bash-completion ${PN}
        if use zsh-completion ; then
                insinto /usr/share/zsh/site-functions
                newins src/completion/pass.zsh-completion _pass
        fi
        if use fish-completion ; then
                insinto /usr/share/fish/completions
                newins src/completion/pass.fish-completion pass.fish
        fi
        if use elibc_Darwin ; then
                insinto /usr/share/pass
                newins src/platform/darwin.sh platform.sh
        fi

}




Reply via email to